You are not logged in.

#1 2013-04-12 01:41:38

Jindur
Member
Registered: 2011-09-29
Posts: 184

netctl fail

Quoted from netctl wiki, "Migrating from netcfg":

"Warning: netctl conflicts with netcfg so disable existing netcfg@<profile> service before installing netctl."
-> If you disable the profile service, you will be offline. So you obviously cannot install netctl.

"Rename variables therein according to netctl.profile(5) (most have only become UpperCamelCase i.e CONNECTION= becomes Connection=).
Unquote interface variables and other variables that don't strictly need quoting (this is mainly a style thing)."
-> Which are variables that "don't strictly need quoting"?
Anyway, I renamed everything/changed quoting/parentheses exactly as in the given example files and yet netctl does not work but just says that the interface wasn't working, followed by another line that claims that authentication failed. Which one is it, interface not working or authentication not working??

So I had to go back to netcfg, because netctl just doesn't work. sad


Here is the network profile file I copied over into the /etc/netctl folder when I replaced netcfg by netctl and edited so it matches the netcfg example files:

Interface=wlp5s0
Connection=wireless
Security=wpa-configsection
IP=dhcp
ESSID='JINDUR'
Hidden=yes
WPAConfigSection=(
    'ssid="JINDUR"'
    'psk=0123456789abc...and.so.on'
)

Last edited by Jindur (2013-04-12 01:50:16)

Offline

#2 2013-04-12 02:01:54

opt1mus
Member
From: UK
Registered: 2011-12-31
Posts: 197
Website

Re: netctl fail

The network block you've added seems a little odd to me, have you tried removing the ' from it, so as to appear thus;

WPAConfigSection=(
    ssid="JINDUR"
    psk=0123456789etcetera
)

-- edit below --

Alternatively have the network block separate so you may have a profile similar to this;

Description='WPA encrypted wireless connection'
Interface=wlp5s0
Connection=wireless
Security=wpa

IP=dhcp
TimeoutDHCP=30

ESSID=JINDUR
Hidden=yes
Key=\"0123456789etcetera

Last edited by opt1mus (2013-04-12 02:17:15)

Offline

#3 2013-04-12 09:21:14

Jindur
Member
Registered: 2011-09-29
Posts: 184

Re: netctl fail

Thanks for your suggestion!
That quoting with () and '' was exactly how it was given in some example files in netctl/exampl
I think the "psk" variable might no longer be valid, the wiki doesn't say anything about that unfortunately. However, the odd part was that it apparently didn't even find the adaptor according to "journal -xn".
I will try to change psk to key and I will try different quotings, I guess.
But before starting another attempt, to be on the *safe* side I will first give them a few weeks to correct the docs/examples in case they are incomplete/misleading, just to reduce the amount of random tinkering that I might have to do to figure out how it was meant to work.

About your "key=" line, isn't it missing \" quotes at the end too? It only has \" in the beginnig once.

Last edited by Jindur (2013-04-12 09:29:01)

Offline

#4 2013-04-12 16:19:45

opt1mus
Member
From: UK
Registered: 2011-12-31
Posts: 197
Website

Re: netctl fail

Jindur wrote:

About your "key=" line, isn't it missing \" quotes at the end too? It only has \" in the beginni(n)g once.

My Key= line is absolutely correct, this is known as a non-quoted string. You could also write it as;

Key="\"0123456789etcetera"

or

Key='"0123456789etcetera'

All three are equivalent, the syntax you were expecting is called a quoted string - where if you open with " you need to close with ". All of this is covered very well towards the foot of the netctl.profile(5) man page. It may look odd, but trust me; I use the same non-quoted string for my PSKs.

-- edited for my spelling --

Last edited by opt1mus (2013-04-12 16:20:52)

Offline

#5 2013-04-12 17:15:13

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,108

Re: netctl fail

Moderator:  Moving to Testing

Edit:  I am not on top of my game today.  I thought this was still in testing.  Moving (again) to networking

Last edited by ewaller (2013-04-12 17:36:33)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#6 2013-04-13 12:05:44

jouke
Member
Registered: 2009-10-14
Posts: 63

Re: netctl fail

As opt1mus said, the OP shouldn't use Security=wpa-configsection, but a regular Security=wpa profile.

Another thing wrong with the profile of the OP is that it uses Hidden=yes, while netctl.profile(5) tells you that this is ignored for Security=wpa-configsection. If the network is hidden, the WPAConfigSection should contain 'scan_ssid=1'. This is something netcfg used to do differently.

Offline

#7 2013-04-13 12:56:04

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: netctl fail

jouke wrote:

Another thing wrong with the profile of the OP is that it uses Hidden=yes, while netctl.profile(5) tells you that this is ignored for Security=wpa-configsection. If the network is hidden, the WPAConfigSection should contain 'scan_ssid=1'. This is something netcfg used to do differently.

Are you sure?

man netctl.profile | grep hidden -a3 wrote:

       Hidden=
           Whether or not the specified network is a hidden network. Defaults to ‘no’.

Offline

#8 2013-04-13 14:11:23

jouke
Member
Registered: 2009-10-14
Posts: 63

Re: netctl fail

WPAConfigSection=() [mandatory for Security=wpa-configsection]
           Array of lines that form a network block for wpa_supplicant. All of
           the above options will be ignored.

The Hidden= option is documented above this one wink.

Offline

#9 2013-04-13 14:55:47

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: netctl fail

Thanks! (seems to be my outdated git-mirror;)

Offline

Board footer

Powered by FluxBB