You are not logged in.

#1 2013-04-11 12:51:04

Ypnose
Member
From: Jailed in the shell
Registered: 2011-04-21
Posts: 353
Website

Netctl / Systemd output above login prompt

Hi Archers,
I switched from netcfg to netctl as many among us. Everything's fine except after the boot ends.
After my system boots, I'm on tty1 (username/password), but three seconds after, systemd prints messages about connection and target above username/password line.
Here a picture (it's hard to explain it)

I remember having this issue with netcfg, but I fixed it by adding @ before profile name, in netcfg config file:

NETWORKS=(@Madbox)

It starts profile on the background.

My profile:

Description='A wpa_supplicant configuration based wireless connection'
Interface=wlp0s19f2u2
Connection=wireless
Security=wpa-config
WPAConfigFile='/etc/wpa_supplicant.conf'
IP=dhcp
DNS=("8.8.8.8" "8.8.4.4")
# Uncomment this if your ssid is hidden
#HIDDEN=yes

Any ideas how can I fix this with netctl?

Last edited by Ypnose (2013-04-11 12:57:45)


Github -- My terminal font Envypn

Offline

#2 2013-04-11 21:45:26

StR@ng3r
Member
Registered: 2011-11-12
Posts: 61

Re: Netctl / Systemd output above login prompt

I think systemd targets should be helpful here: https://wiki.archlinux.org/index.php/Systemd#Targets

Also, you could just add "quiet" to your kernel boot line.

Offline

#3 2013-04-11 22:32:23

Ypnose
Member
From: Jailed in the shell
Registered: 2011-04-21
Posts: 353
Website

Re: Netctl / Systemd output above login prompt

I'm already with "multi-user.target" which it's not graphical (same as runlevel3) and adding quiet is just a workaround.
I need to see boot messages, adding quiet is dirty.


Github -- My terminal font Envypn

Offline

#4 2013-04-11 23:02:29

AdamCDunlap
Member
Registered: 2013-04-03
Posts: 11

Re: Netctl / Systemd output above login prompt

It seems like you should make a unit file that is After=multi-user.target that somehow suppresses systemd's output. I don't know what command to run from the unit file, though.

Offline

#5 2013-04-12 07:21:43

n125
Member
Registered: 2011-12-30
Posts: 38

Re: Netctl / Systemd output above login prompt

I hope you don't mind me asking, but how did you get your login screen to look like that? It looks really neat.

Offline

#6 2013-04-12 11:20:11

Ypnose
Member
From: Jailed in the shell
Registered: 2011-04-21
Posts: 353
Website

Re: Netctl / Systemd output above login prompt

AdamCDunlap wrote:

It seems like you should make a unit file that is After=multi-user.target that somehow suppresses systemd's output. I don't know what command to run from the unit file, though.

Modified service file from:

After=sys-subsystem-net-devices-wlp0s19f2u2.device

to

After=sys-subsystem-net-devices-wlp0s19f2u2.device multi-user.target

It seems to be better now.

n125 wrote:

I hope you don't mind me asking, but how did you get your login screen to look like that? It looks really neat.

I modified my /etc/issue smile . You can take a look here: https://bbs.archlinux.org/viewtopic.php?id=50845&p=1

EDIT => Reported the issue: https://bugs.archlinux.org/task/34747

Last edited by Ypnose (2013-04-12 13:03:02)


Github -- My terminal font Envypn

Offline

#7 2013-04-12 17:30:36

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,442

Re: Netctl / Systemd output above login prompt

Moderator.  Moving to testing

Edit:  More coffee for me sad  I thought this was still in testing.  Moving (again) to Networking

Last edited by ewaller (2013-04-12 17:35:23)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#8 2013-04-12 19:48:08

demaio
Member
From: Germany
Registered: 2012-09-02
Posts: 63
Website

Re: Netctl / Systemd output above login prompt

I solved the problem by putting the following line in /etc/systemd/system/getty.target.wants/getty@tty1.service (if it is a symlink, copy the source file and edit it instead of the original):

After=netctl@MYWIFIPROFILE.service

MYWIFIPROFILE is the name of the network profile enabled by netctl enable MYWIFIPROFILE. The downside is that you have to wait until the connection is up before you can login because the login prompt waits for the network profile which can cause delays in case of DHCP.

Offline

Board footer

Powered by FluxBB