You are not logged in.

#1 2013-04-12 20:10:58

Alain2
Member
Registered: 2009-11-06
Posts: 13

[SOLVED] netctl transition not working for me

Hi,

Following the latest news I tried to switch from netcfg to netctl but can't get it to work..

my netctl profile, similar to my netcfg one:

Description='A simple WPA encrypted wireless connection using a static IP'
Interface=wlan0
Connection=wireless
Security='wpa-config'
WPAConfigFile='/etc/wpa_supplicant.conf'

IP=static
Address='192.168.0.5'
Gateway='192.168.0.254'

result:

# netctl start wirelessHome
Job for netctl@wirelessHome.service failed. See 'systemctl status netctl@wirelessHome.service' and 'journalctl -xn' for details.

# journalctl -xn
-- Logs begin at Sun 2012-11-11 12:36:25 CET, end at Fri 2013-04-12 21:54:20 CEST. --
Apr 12 21:54:19 alainLaptop kernel: wlan0: associated
Apr 12 21:54:19 alainLaptop kernel: IPv6: ADDRCONF(NETDEV_CHANGE): wlan0: link becomes ready
Apr 12 21:54:20 alainLaptop network[1373]: RTNETLINK answers: Network is unreachable
Apr 12 21:54:20 alainLaptop network[1373]: Could not set gateway '192.168.0.254' on interface 'wlan0'
Apr 12 21:54:20 alainLaptop kernel: wlan0: deauthenticating from 00:24:d4:51:48:98 by local choice (reason=3)
Apr 12 21:54:20 alainLaptop kernel: cfg80211: Calling CRDA to update world regulatory domain
Apr 12 21:54:20 alainLaptop network[1373]: Failed to bring the network up for profile 'wirelessHome'
Apr 12 21:54:20 alainLaptop systemd[1]: netctl@wirelessHome.service: main process exited, code=exited, status=1/FAILURE
Apr 12 21:54:20 alainLaptop systemd[1]: Failed to start Networking for netctl profile wirelessHome.
-- Subject: Unit netctl@wirelessHome.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- Documentation: http://www.freedesktop.org/wiki/Software/systemd/catalog/be02cf6855d2428ba40df7e9d022f03d
-- 
-- Unit netctl@wirelessHome.service has failed.
-- 
-- The result is failed.
Apr 12 21:54:20 alainLaptop systemd[1]: Unit netctl@wirelessHome.service entered failed state

Any suggestion ?

Last edited by Alain2 (2013-04-12 22:37:20)

Offline

#2 2013-04-12 21:48:40

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED] netctl transition not working for me

Offline

#3 2013-04-12 22:36:45

Alain2
Member
Registered: 2009-11-06
Posts: 13

Re: [SOLVED] netctl transition not working for me

Thank you Strike0!

Indeed this was the issue, adding the /24 for netmask resolved this (for my defense the error message is not very clear on this)

Sorry I should have seen this topic... I guess it would be worth mentioning in the netctl wiki page as well.

Offline

#4 2013-04-13 07:23:17

Strike0
Member
From: Germany
Registered: 2011-09-05
Posts: 1,277

Re: [SOLVED] netctl transition not working for me

Good & no big deal, I have added a sentence for it in the wiki. The error message is not perfect but not too bad either in my view. It does point toward the gateway. Strange I find that the systemd journal references a documentation link that then leads to a 404 page which does not give much clue how to continue there. The feature with the message_ID itself is awesome, but I'm sure the too plain 404 template at freedesktop has a great hit count (not for netctl, but in general)..

Offline

Board footer

Powered by FluxBB