You are not logged in.

#1 2013-04-11 19:59:06

feboss
Member
Registered: 2013-04-11
Posts: 11

Internet download very slow

Hello,
First of all, sorry for my english but i'm still trying to learn

So, the problem:
With my internet connection i can download at 5 Mb/s but with archlinux the connection is very unstable.I start to download at 1 Mb/s and after a few second the connection drop at 100kb/s
I already disable ipv6 by grub way and tried both networkmanager and wifi-menu

ifconfig -a

wlo1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.1.9  netmask 255.255.255.0  broadcast 192.168.1.255
        ether f4:b7:e2:45:c5:a9  txqueuelen 1000  (Ethernet)
        RX packets 11982  bytes 13259672 (12.6 MiB)
        RX errors 0  dropped 24  overruns 0  frame 0
        TX packets 8799  bytes 1467896 (1.3 MiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

dmesg

[  122.107871] wlo1: authenticate with 68:7f:74:03:14:f8
[  122.120995] wlo1: send auth to 68:7f:74:03:14:f8 (try 1/3)
[  122.122547] wlo1: authenticated
[  122.123942] wlo1: associate with 68:7f:74:03:14:f8 (try 1/3)
[  122.127358] wlo1: RX AssocResp from 68:7f:74:03:14:f8 (capab=0x411 status=0 aid=2)
[  122.127468] wlo1: associated

sudo lspci | grep -i net

01:00.0 Network controller: Ralink corp. Device 539b
02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8101E/RTL8102E PCI Express Fast Ethernet controller (rev 05)

/boot/grub/grub.cfg

 linux   /vmlinuz-linux root=UUID=ffaa21ba-e3d0-49c3-8481-3a19d2d86907 ro  quiet ipv6.disable=1

cat /etc/resolv.conf   

                                                                                                                                                      
# Generated by NetworkManager                                                                                                                                                                   
nameserver 192.168.1.1                                                                                                                                                                          

                                                                                                                                                               
cat /etc/hosts

                                                                                                                                                      
#                                                                                                                                                                                               
# /etc/hosts: static lookup table for host names                                                                                                                                                
#                                                                                                                                                                                               
                                                                                                                                                                                                
#<ip-address>   <hostname.domain.org>   <hostname>                                                                                                                                              
127.0.0.1       localhost.localdomain   localhost                                                                                                                                               
#::1            localhost.localdomain   localhost                                                                                                                                               
                                                                                                                                                                                                
# End of file                                                                                                                                                                                   

                                                                                                                                                                                                                                                                                                                                       
                       
for test my download i use file on this website:
http://www.thinkbroadband.com/download.html

I want try to put original driver by ralink:
http://www.mediatek.com/_en/07_download … php?sn=501
Someone can explain me how to replace with this driver?

Last edited by feboss (2013-04-11 22:45:11)


I’m working on improving my English so please excuse any mistakes

Offline

#2 2013-04-12 04:46:38

jacobopantoja
Member
From: Madrid
Registered: 2011-03-16
Posts: 44

Re: Internet download very slow

May be your card is not still 100% supported. Check on the linux wireless page if you have not done yet.

Offline

#3 2013-04-13 12:59:06

Jasa
Member
Registered: 2011-08-05
Posts: 35

Re: Internet download very slow

From my own quick consideration of thing is that of where you have constant from single host to your machine transfer occurring and transfer becomes "stalled" as in those of older days in by Linux and informative side.

That of most possible cause of issue is where you are having stable internet connection without issues and slow hard drive write speed along with not too quick usage of either memory (or not enought of it) or cpu to handle events going on (laptop) and you want to use an compression capable filesystem like btrfs, on where contents are in memory side until whole content of writeable data has been formed to be supplied in to hard disk, gets to use your swap space to hold some contents and throw them up and forth where your hard drive might be doing on at write moment multiple times amount of work it is required compared to uncompressed smooth flow of from host to yours and final storage space.

That of previous would be noticeable on by trying to run other services that gets files from hard drive to end user and display those in some form of, where speeds and system would stay in at on-hold state until things in buffer would be released.

Also without any proper knowledge (just user) i would claim that attempts to disable ipv6 to speed up system boot time, comes fail when if your system would support it in side of hosts you are connect at, it would instead reduce your latency time to end hosts, meaning your web browsing speed takes longer with ipv4, what is that you are trying to use.

(Had few beers, hope content is readable.) = )

Last edited by Jasa (2013-04-13 13:00:33)

Offline

#4 2013-04-13 15:46:41

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,165

Re: Internet download very slow

What is the output of hostname  ??
What is the output of iwconfig  ??
What is the output of traceroute thiinkbroadband.com

ewaller$@$odin ~ 1002 %pacman -Qo $(which traceroute)
/usr/bin/traceroute is owned by traceroute 2.0.19-1
ewaller$@$odin ~ 1003 %

Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#5 2013-04-16 21:19:52

feboss
Member
Registered: 2013-04-11
Posts: 11

Re: Internet download very slow

ewaller wrote:

What is the output of hostname  ??
What is the output of iwconfig  ??
What is the output of traceroute thiinkbroadband.com

ewaller$@$odin ~ 1002 %pacman -Qo $(which traceroute)
/usr/bin/traceroute is owned by traceroute 2.0.19-1
ewaller$@$odin ~ 1003 %

[feboss@Archi7 pam.d]$ hostname && iwconfig && traceroute thinkbroadband.com

Archi7
eno1      no wireless extensions.

lo        no wireless extensions.

wlo1      IEEE 802.11bgn  ESSID:"feboss"  
          Mode:Managed  Frequency:2.462 GHz  Access Point: 68:7F:74:03:14:F8   
          Bit Rate=13 Mb/s   Tx-Power=20 dBm   
          Retry  long limit:7   RTS thr:off   Fragment thr:off
          Power Management:off
          Link Quality=45/70  Signal level=-65 dBm  
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:1312  Invalid misc:145   Missed beacon:0

traceroute to thinkbroadband.com (80.249.99.130), 30 hops max, 60 byte packets
 1  192.168.1.1 (192.168.1.1)  1.879 ms  2.890 ms  3.144 ms
 2  * * *
 3  217-168-63-57.static.cablecom.ch (217.168.63.57)  16.513 ms  17.218 ms  17.237 ms
 4  84.116.211.21 (84.116.211.21)  44.189 ms  44.476 ms  44.308 ms
 5  84.116.202.225 (84.116.202.225)  43.933 ms  44.024 ms  43.098 ms
 6  84.116.134.46 (84.116.134.46)  38.203 ms de-fra03a-rd1-xe-3-2-0.aorta.net (213.46.160.53)  31.992 ms de-fra03a-rd1-xe-2-2-0.aorta.net (213.46.160.45)  36.356 ms
 7  84.116.133.214 (84.116.133.214)  40.235 ms 84.116.134.17 (84.116.134.17)  37.147 ms 84.116.136.101 (84.116.136.101)  40.095 ms
 8  nl-ams09b-ri1-xe-9-0-0.aorta.net (84.116.130.10)  38.706 ms  41.923 ms  45.658 ms
 9  ge-2-1-0.mpr1.lhr2.uk.above.net (195.66.224.76)  50.382 ms * *
10  above-gw2.thdo.ncuk.net (213.152.254.53)  49.726 ms  46.031 ms  39.003 ms
11  gi0-24-10-star1.core-rs2.thdo.ncuk.net (80.249.97.9)  39.694 ms  43.328 ms  37.516 ms
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *

Last edited by feboss (2013-04-16 21:45:52)


I’m working on improving my English so please excuse any mistakes

Offline

#6 2013-04-17 23:15:51

feboss
Member
Registered: 2013-04-11
Posts: 11

Re: Internet download very slow

my Bit Rate change every second, is normal?

bash -c 'while [ 0 ]; do \
echo $(date +%H:%M:%S) ": " $(iwconfig wlo1 | grep -iE "rate|retries");sleep 3; done'

01:10:57 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:5788 Invalid misc:298 Missed beacon:0
01:11:00 :  Bit Rate=43.3 Mb/s Tx-Power=20 dBm Tx excessive retries:5806 Invalid misc:298 Missed beacon:0
01:11:03 :  Bit Rate=28.9 Mb/s Tx-Power=20 dBm Tx excessive retries:5840 Invalid misc:298 Missed beacon:0
01:11:06 :  Bit Rate=43.3 Mb/s Tx-Power=20 dBm Tx excessive retries:5871 Invalid misc:298 Missed beacon:0
01:11:09 :  Bit Rate=21.7 Mb/s Tx-Power=20 dBm Tx excessive retries:5914 Invalid misc:298 Missed beacon:0
01:11:12 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:5980 Invalid misc:298 Missed beacon:0
01:11:15 :  Bit Rate=21.7 Mb/s Tx-Power=20 dBm Tx excessive retries:6028 Invalid misc:298 Missed beacon:0
01:11:18 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6066 Invalid misc:298 Missed beacon:0
01:11:21 :  Bit Rate=21.7 Mb/s Tx-Power=20 dBm Tx excessive retries:6110 Invalid misc:298 Missed beacon:0
01:11:24 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6141 Invalid misc:298 Missed beacon:0
01:11:27 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6180 Invalid misc:298 Missed beacon:0
01:11:30 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6198 Invalid misc:298 Missed beacon:0
01:11:33 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6216 Invalid misc:298 Missed beacon:0
01:11:36 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6237 Invalid misc:298 Missed beacon:0
01:11:39 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6276 Invalid misc:298 Missed beacon:0
01:11:42 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6300 Invalid misc:298 Missed beacon:0
01:11:45 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6336 Invalid misc:298 Missed beacon:0
01:11:48 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6396 Invalid misc:298 Missed beacon:0
01:11:51 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6437 Invalid misc:298 Missed beacon:0
01:11:54 :  Bit Rate=21.7 Mb/s Tx-Power=20 dBm Tx excessive retries:6465 Invalid misc:298 Missed beacon:0
01:11:57 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6485 Invalid misc:298 Missed beacon:0
01:12:00 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6504 Invalid misc:299 Missed beacon:0
01:12:03 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6518 Invalid misc:300 Missed beacon:0
01:12:06 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6523 Invalid misc:300 Missed beacon:0
01:12:09 :  Bit Rate=13 Mb/s Tx-Power=20 dBm Tx excessive retries:6534 Invalid misc:300 Missed beacon:0
01:12:12 :  Bit Rate=14.4 Mb/s Tx-Power=20 dBm Tx excessive retries:6536 Invalid misc:300 Missed beacon:0
01:12:15 :  Bit Rate=19.5 Mb/s Tx-Power=20 dBm Tx excessive retries:6547 Invalid misc:300 Missed beacon:0
01:12:18 :  Bit Rate=57.8 Mb/s Tx-Power=20 dBm Tx excessive retries:6555 Invalid misc:300 Missed beacon:0
01:12:21 :  Bit Rate=19.5 Mb/s Tx-Power=20 dBm Tx excessive retries:6557 Invalid misc:300 Missed beacon:0

EDIT 1: i start to thinking that the problem is my wifi card. tomorrow i begin to test my wifi with windows and ndiswrapper.

EDIT 2: Ok the problem is the wifi card, not archlinux. with windows i have the same problem and every computer in my house can download without problem at 5MB/s.
I will call hp support

Last edited by feboss (2013-04-18 07:25:00)


I’m working on improving my English so please excuse any mistakes

Offline

#7 2013-04-26 00:40:00

feboss
Member
Registered: 2013-04-11
Posts: 11

Re: Internet download very slow

WTF i change my wireless card but i still have same problem... please help me sad


I’m working on improving my English so please excuse any mistakes

Offline

#8 2013-04-30 20:09:56

feboss
Member
Registered: 2013-04-11
Posts: 11

Re: Internet download very slow

Conclusion: i tried with 32bit, with fedora kde and fedora gnome. always same problem.
With windows i have no problem so the problem is the driver rt2800pci.


I’m working on improving my English so please excuse any mistakes

Offline

Board footer

Powered by FluxBB