You are not logged in.

#1 2005-11-22 20:27:47

becho4
Member
From: Galicia, Spain
Registered: 2004-12-09
Posts: 71

iptables doesn`t work after boot

I am using firehol to setup my firewall with NAT.

After generating the rules I save them to /etc/iptables/iptables.rules with /etc/rc.d/iptables save

also added iptables to the daemon array:
DAEMONS=(syslog-ng hotplug dbus hal !pcmcia network hplip cups alsa netfs crond xinetd sshd samba httpd iptables kdm)

after boot iptables is started but I do not have access to the internet in the other computers of the LAN (that use the arch server as a router).

Running 'iptables restart' manually after boot everything works fine again.

Any suggestions?
Thanks in advance

Offline

#2 2005-11-22 22:00:28

dojo
Member
Registered: 2005-11-02
Posts: 96

Re: iptables doesn`t work after boot

The solution for your problem is quiet simple. You just have to enable  "net.ipv4.ip_forward" in your /etc/sysctl.conf.

Greets

Sunnemer

Offline

#3 2005-11-23 15:29:28

lanrat
Member
From: Poland
Registered: 2003-10-28
Posts: 1,274

Re: iptables doesn`t work after boot

If you're using the standard /etc/rc.d/iptables script in rc.conf then check also your /etc/conf.d/iptables file. The script uses IPTABLES_FORWARD variable for setting forwarding (it probably overwrites /etc/sysctl.conf setting). The variable should be set to 1.

Offline

#4 2005-11-29 21:30:37

becho4
Member
From: Galicia, Spain
Registered: 2004-12-09
Posts: 71

Re: iptables doesn`t work after boot

You were absolutely right.
sunnemer and lanrat, many thanks for your help.

Alfonso

Offline

Board footer

Powered by FluxBB