You are not logged in.

#1 2013-04-15 15:28:14

felipense
Member
Registered: 2013-04-05
Posts: 62

Installing Catalyst from the official repository

I'm trying to install catalyst but i get

[root @ localhost felipe] # pacman-S catalyst catalyst-utils-dkms
resolving dependencies ...
Conflict checking ...
:: Catalyst-utils and mesa-libgl are in conflict. Remove? Mesa-libgl? [s / N] s
:: Catalyst-utils and xorg-server conflict. Remove xorg-server?? [s / N] s
Error: Failed to prepare transaction (could not satisfy dependencies)
:: Catalyst-utils:  requires xorg-server
:: Ati-dri: requiresmesa-libgl=9.1.1
Glamor-egl ::: requires mesa-libgl
PyPanel ::: need x-server

Last edited by felipense (2013-04-15 15:32:00)

Offline

#2 2013-04-15 15:33:06

mzneverdies
Member
Registered: 2012-02-04
Posts: 147

Re: Installing Catalyst from the official repository

According to https://wiki.archlinux.org/index.php/AM … positories

Catalyst doesn't support xorg-server 1.14.

Seems you need to install/downgrade xorg-server 1.13 (there's a repo on the link) or wait till catalyst supports 1.14.

I am a nvidia user by the way, so i'm not pretty sure about what I just said smile

Last edited by mzneverdies (2013-04-15 15:37:42)

Offline

#3 2013-04-15 16:05:38

hadrons123
Member
From: chennai
Registered: 2011-10-07
Posts: 1,249

Re: Installing Catalyst from the official repository


LENOVO Y 580 IVYBRIDGE 660M NVIDIA
Unix is user-friendly. It just isn't promiscuous about which users it's friendly with. - Steven King

Offline

#4 2013-04-15 16:07:53

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: Installing Catalyst from the official repository

Oks. Thanks. smile

I downgraded the xorg, xf86input, xf86-video ati   and installed catalyst, and dkms.

But i get a error installing catalyst

Creating symlink /var/lib/dkms/fglrx/13.1-2/source ->
                 /usr/src/fglrx-13.1-2

DKMS: add completed.
Error! echo
Your kernel headers for kernel 3.8.6-1-ARCH cannot be found at
/usr/lib/modules/3.8.6-1-ARCH/build or /usr/lib/modules/3.8.6-1-ARCH/source.
error: el comando falló al ejecutarse

It looks like i need to downgrade the Kernel to. But i don't have the linux-headers for that image anyways

Last edited by felipense (2013-04-15 17:04:35)

Offline

#5 2013-04-15 17:24:14

Radioactiveman
Member
From: Germany
Registered: 2010-05-13
Posts: 376

Re: Installing Catalyst from the official repository

There is no need to downgrade the kernel but the headers have to be installed.
Next time please post the output of commands in English (LANG=C pacman -…).

Offline

#6 2013-04-15 17:41:44

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: Installing Catalyst from the official repository

ok thanks. Have you the core/linux-headers 3.8.6-1 pkg?

Offline

#7 2013-04-15 18:07:07

mar04
Member
From: Poland
Registered: 2010-02-08
Posts: 117

Re: Installing Catalyst from the official repository

Kernel in core is now at version 3.8.7

Offline

#8 2013-04-15 19:35:00

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: Installing Catalyst from the official repository

edit: pacman says something about old linux headers. That suggest downgrade the kernel and downgrade the linux headers.

Thats why i'm aswering about the old linux-headers 3.8.6-1...

Last edited by felipense (2013-04-15 19:42:27)

Offline

#9 2013-04-15 20:01:27

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,073

Re: Installing Catalyst from the official repository

felipense wrote:

edit: pacman says something about old linux headers.

Tell us more.... what does it say??


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#10 2013-04-15 20:06:55

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: Installing Catalyst from the official repository

in #4 message XD.

Offline

#11 2013-04-15 20:07:52

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,073

Re: Installing Catalyst from the official repository

felipense wrote:

in #4 message XD.

ok. Read #5 XD


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#12 2013-04-15 20:14:43

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: Installing Catalyst from the official repository

ls /usr/lib/modules/
3.8.7-1-ARCH  extramodules-3.8-ARCH

==>


ln -s /usr/lib/modules/3.8.7-1-ARCH /usr/lib/modules/3.8.6-1-ARCH
ls -l /usr/lib/modules/
total 8
lrwxrwxrwx 1 root root   29 abr 15 17:15 3.8.6-1-ARCH -> /usr/lib/modules/3.8.7-1-ARCH
drwxr-xr-x 3 root root 4096 abr 15 12:34 3.8.7-1-ARCH
drwxr-xr-x 2 root root 4096 abr 15 11:35 extramodules-3.8-ARCH

?

Last edited by felipense (2013-04-15 20:17:48)

Offline

#13 2013-04-15 20:56:46

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: Installing Catalyst from the official repository

felipense wrote:
ln -s /usr/lib/modules/3.8.7-1-ARCH /usr/lib/modules/3.8.6-1-ARCH
ls -l /usr/lib/modules/
total 8
lrwxrwxrwx 1 root root   29 abr 15 17:15 3.8.6-1-ARCH -> /usr/lib/modules/3.8.7-1-ARCH
drwxr-xr-x 3 root root 4096 abr 15 12:34 3.8.7-1-ARCH
drwxr-xr-x 2 root root 4096 abr 15 11:35 extramodules-3.8-ARCH

?

Don't do that. I don't know what might happen, but I don't think its good.

After each kernel update you have to rebuild the fglrx module. You may try and use one of the tools listed in the wiki (https://wiki.archlinux.org/index.php/AMD_Catalyst#Tools) to automate the process. Or you can simply reboot after taking care of any .pacnew files and then simply reinstall catalyst-dkms which rebuilds and loads the fglrx module for you, too.

Offline

#14 2013-04-16 00:02:30

felipense
Member
Registered: 2013-04-05
Posts: 62

Re: Installing Catalyst from the official repository

-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by felipense (2013-04-16 15:39:11)

Offline

Board footer

Powered by FluxBB