You are not logged in.

#1 2012-04-11 00:22:33

LuckyStrike
Member
Registered: 2012-02-15
Posts: 13

Samba Broken After Updates

I had posted this thread awhile back about my Samba troubles.

https://bbs.archlinux.org/viewtopic.php?id=135807

But since this time it has been up and running perfectly.


Now when I try to open files on another computer I get various errors depending on the program but it is essentially, permission denied.

I have restart samba on each box, restart each computer, logged in as different users and rechecked that all of my settings are the same.  I'm at the end of my rope so I figured I'd take it to the gurus. 

Thanks in advance.

Offline

#2 2013-04-14 23:06:16

el_psycho
Member
From: Vancouver, Canada
Registered: 2012-04-30
Posts: 24

Re: Samba Broken After Updates

same problem here. samba 4.0.5-1
i rebooted today and got access denied everywhere. still looking around for a solution, for now i downgraded to samba 3.6.13-1 (remove /var/lib/samba dir after removing samba 4). will post back if i find something for samba 4.

Last edited by el_psycho (2013-04-14 23:16:44)

Offline

#3 2013-04-16 08:22:27

el_psycho
Member
From: Vancouver, Canada
Registered: 2012-04-30
Posts: 24

Re: Samba Broken After Updates

OK, found the solution. I have simple shares so basically after adding my shares the same way i had them before to the new smb.conf i had to add my user again to samba with the following command:

# smbpasswd -a <username>

after that restart the services like this:

# systemctl restart smbd.service nmbd.service

here is a dump of my service definitions from testparm for reference:

[global]
	server string = MediaServer
	log file = /var/log/samba/%m.log
	max log size = 50
	load printers = No
	printcap name = /dev/null
	dns proxy = No
	idmap config * : backend = tdb

[homes]
	comment = Home Directories
	read only = No
	browseable = No

[printers]
	comment = All Printers
	path = /var/spool/samba
	printable = Yes
	print ok = Yes
	browseable = No

[Media_1]
	path = /media/Media_1
	valid users = kevin
	read only = No
	create mask = 0664
	directory mask = 0775

[Media_2]
	path = /media/Media_2
	valid users = kevin
	read only = No
	create mask = 0664
	directory mask = 0775

EDIT:
LOL just noticed this is a 2012 threat! i thought it was this month's. anyways, hopefully someone finds this useful.

Last edited by el_psycho (2013-04-17 19:59:47)

Offline

#4 2013-04-16 11:52:00

Gordon
Member
From: Scotland
Registered: 2012-06-25
Posts: 14

Re: Samba Broken After Updates

Same problem
same fix
thanks

Offline

#5 2013-04-18 04:06:18

firenx
Member
From: Victoria, BC Canada
Registered: 2008-05-28
Posts: 11

Re: Samba Broken After Updates

Thanks! Worked perfectly smile

Offline

Board footer

Powered by FluxBB