You are not logged in.

#1 2013-04-15 19:13:20

igorcalabria
Member
Registered: 2013-04-15
Posts: 2

[SOLVED] Really weird resolution problem(Probably related to kms)

Hey guys, I've used arch on a couple machines before but I never seen something like this.

The problem is that the screen area is really strange, it's not even the same in every boot. Sometimes it's just black, but i can reboot just fine with ctrl + alt + del, sometimes the terminal is placed right on the middle of screen, so the right part is ok, but the left part acts like its continuation, kinda like a dual monitor setup, pic: http://i.imgur.com/zYmtlZq.jpg  . And sometimes(very rare) it's displayed correctly.

This is a fresh install, with just xorg and the open source ati drivers installed, but this thing also happens with the installation media.
nomodeset "solves" this, but startx doesn't work then.

Oh, and the machine is a sony vayo model SVE1712Z1EB with a Radeon HD 7650M.


Removed full size image -- Inxsible

Last edited by igorcalabria (2013-04-18 08:58:16)

Offline

#2 2013-04-16 16:05:24

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 4,054

Re: [SOLVED] Really weird resolution problem(Probably related to kms)

Does it also happen in console ?

With newer radeon cards it'soften worth it to try the proprietary catalyst driver, check the archwiki for details.


Booting with apg Openrc, NOT systemd.
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#3 2013-04-16 16:13:28

fr0z3d
Member
From: Venezuela
Registered: 2013-04-13
Posts: 8

Re: [SOLVED] Really weird resolution problem(Probably related to kms)

Did you try with the propietary drivers?

Offline

#4 2013-04-16 16:48:12

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: [SOLVED] Really weird resolution problem(Probably related to kms)

igorcalabria, Welcome to the forums.

Please read the forum etiquette as listed here, especially this section.

Please edit your post and make the necessary changes. @others, please report these kinds of violations via the Report link.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2013-04-17 20:41:17

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,059

Re: [SOLVED] Really weird resolution problem(Probably related to kms)

guess you haven't come to the boards, so I will delete the huge image in your post myself....


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#6 2013-04-18 08:57:37

igorcalabria
Member
Registered: 2013-04-15
Posts: 2

Re: [SOLVED] Really weird resolution problem(Probably related to kms)

Sorry about the image, next time I'll pay more attention.

The problem was fixed by using the proprietary drivers, it was pain to rollback the xorg stuff, but now everything
seems to be working just fine.

Thanks for the help.

Offline

Board footer

Powered by FluxBB