You are not logged in.

#1 2013-04-04 21:52:12

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 407
Website

[Request] Birdie Twitter Client

Id be happy if someone could create a package with the Birdie Twitter Client. smile

http://launchpad.net/~birdie-team

Offline

#2 2013-04-13 19:11:40

debsuvra
Member
From: India
Registered: 2008-08-07
Posts: 12
Website

Re: [Request] Birdie Twitter Client

Also looking forward to have it on AUR.

Offline

#3 2013-04-13 19:16:28

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

Re: [Request] Birdie Twitter Client

Why not try your hand at writing one first and we'll help you out with it? That's how the request section is meant to work, afterall.

All the best,

-HG

Last edited by HalosGhost (2013-04-13 19:19:36)


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

#4 2013-04-13 19:50:50

tdy
Member
From: Sacremende
Registered: 2008-12-14
Posts: 438

Re: [Request] Birdie Twitter Client

This thing has some major dependencies like unity.. that was the point where I stopped tinkering with this package.

Last edited by tdy (2013-04-13 19:52:12)

Offline

#5 2013-04-13 20:08:12

HalosGhost
Member
From: Twin Cities, MN
Registered: 2012-06-22
Posts: 1,486
Website

Re: [Request] Birdie Twitter Client

tdy wrote:

This thing has some major dependencies like unity.. that was the point where I stopped tinkering with this package.

I took a look at throwing together a PKGBUILD, and as soon as I stumbled on the unity dependency, I rather lost interest. Here is what I had so far. It may actually work as-is, but I'm not going to test it as I have no interest in installing Unity.

_bzrname=birdie
pkgname="${_bzrname}-lp-bzr"
pkgver=1.0
pkgrel=1
pkgdesc="A Twitter client"
arch=('any')
url="http://launchpad.net/~birdie-team"
license=('GPLv3')
depends=('vala' 'libwnck3' 'json-glib' 'rest' 'granite' 'unity' 'libcanberra' 'libnotify' 'gtk3' 'libindicate')
makedepends=('bzr' 'cmake')
source=("${_bzrname}::bzr+http://bazaar.launchpad.net/~${_bzrname}-team/${_bzrname}/trunk/")
sha256sums=('SKIP')

pkgver() {
  cd local_repo
  bzr revno
}

prepare() {
  cd "${srcdir}/${_bzrname}"
  mkdir -p build && cd build
  cmake .. -DCMAKE_INSTALL_PREFIX=/usr
}

package() {
  cd "${srcdir}/${_bzrname}"
  make DESTDIR="${pkgdir}" PREFIX=/usr install
  find "${pkgdir}" -type d -name .bzr -exec rm -r '{}' +
}

Best of luck in getting it to work. Seriously though, in the future, you should at least try making it first before requesting.

[Edit]: P.S., the above code isn't quite right. The package appears to check all its depends at build-time. So, technically, everything in the depends array should be in the makedepends array. Unity as a makedepends…

All the best,

-HG

Last edited by HalosGhost (2013-04-13 21:24:39)


"All errors are ᴘᴇʙᴋᴀᴄ errors—It's just a matter of narrowing down which keyboard and chair." -Trilby
\ldots

Offline

#6 2013-04-15 05:58:26

tdy
Member
From: Sacremende
Registered: 2008-12-14
Posts: 438

Re: [Request] Birdie Twitter Client

For those of you who actually want this app, I suggest bringing this app to the attention of Unity users in https://bbs.archlinux.org/viewtopic.php?id=125423

I'm not sure you'll get much interest from non-Unity packagers about figuring out how to get this to work. That's certainly the case with me, but I won't speak for everyone.

Last edited by tdy (2013-04-16 00:11:33)

Offline

#7 2013-04-18 08:46:15

Hund
Member
From: Sweden
Registered: 2010-03-22
Posts: 407
Website

Re: [Request] Birdie Twitter Client

Ouch, I didnt know you needed Unity. I lost interest of it as soon as I heard the word Unity. smile Thanks anyway!

Offline

Board footer

Powered by FluxBB