You are not logged in.

#1 2013-04-18 09:41:19

ArzhurB
Member
Registered: 2013-04-18
Posts: 6

ssh banner issue: no escape characters in /etc/issue [Solved]

Hello,

I’ve searched a bit, but could not find a proper solution to this issue.

I’ve done a fresh and minimal installation on an old computer, and just configured networking and SSH before hiding it in a closet, with power and ethernet.

While reading the SSH wiki page, I went through the line that explains how to add a custom banner, thought ‘how cool, let’s try it’, and added:

Banner /etc/issue

in my /etc/ssh/sshd_config file, letting the default content :

Welcome to \n
Arch Linux \r (\l)

But the result was quite unexpected, for I get exactly the same text when I connect through SSH.

Trailing characters remain as they are.

Thanks in advance for any advice!

Arzhur

Last edited by ArzhurB (2013-04-19 19:43:51)

Offline

#2 2013-04-18 18:16:37

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,075
Website

Re: ssh banner issue: no escape characters in /etc/issue [Solved]

man issue ?

Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-04-18 22:52:19

ArzhurB
Member
Registered: 2013-04-18
Posts: 6

Re: ssh banner issue: no escape characters in /etc/issue [Solved]

Thanks, I know how to RTFM before posting...

So, if anyone has an answer.

Offline

#4 2013-04-19 00:53:05

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,075
Website

Re: ssh banner issue: no escape characters in /etc/issue [Solved]

Then please reference it: we can't read your mind (or tell what getty you are using)...

Assuming it is agetty, then according to the LFS documentation, SSH won't interpret those escape characters
http://www.linuxfromscratch.org/blfs/vi … logon.html


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#5 2013-04-19 01:45:18

ArzhurB
Member
Registered: 2013-04-18
Posts: 6

Re: ssh banner issue: no escape characters in /etc/issue [Solved]

I thought telling it was a ‘minimal’ install would be enough, but you're right, I shoud have been clearer.

Thank you for the link, so I understand it is not a misbehaviour from my system, at least!

Offline

#6 2013-04-19 02:11:28

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,075
Website

Re: ssh banner issue: no escape characters in /etc/issue [Solved]

Cool. Please remember to mark your thread as [Solved] by editing your first post and prepending it to the title.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

Board footer

Powered by FluxBB