You are not logged in.

#1 2013-04-19 18:47:47

lothar_m
Member
From: Portugal
Registered: 2010-04-25
Posts: 28
Website

autostart profile with netctl

Hi guys.
I'm unable to auto connect to my home wifi at startup.
I've followed to wiki intructions at https://wiki.archlinux.org/index.php/Ne … e_Profiles:

1) migrated a bunch of my netcfg profiles to netctl format
2) successfully started and stopped netctl profiles (manually)
3) issued the following to setup autostart

# systemctl enable netctl-auto@wlan0.service 
# systemctl enable netctl-ifplugd@eth0.service

However, at startup my machine doesn't connect. Scratching under the surface reveals that:

[22:11:03]-[userX in ~]$ systemctl status netctl-auto@wlan0.service

netctl-auto@wlan0.service - Automatic wireless network connection using netctl profiles
   Loaded: loaded (/usr/lib/systemd/system/netctl-auto@.service; enabled)
   Active: failed (Result: exit-code) since Qui 2013-04-18 22:07:29 WEST; 6min ago
     Docs: man:netctl.special(7)
  Process: 205 ExecStart=/usr/bin/netctl-auto start %I (code=exited, status=1/FAILURE)

Guess i'm missing something.... but can't really put my finger on it.
Some advice would be appreciated.
Thanks


“Clearly, Field Marshal Haig is about to make yet another gargantuan effort to move his drinks cabinet six inches closer to Berlin.”
-----------------------------------------------------------------------------
GitHub

Offline

#2 2013-04-21 01:01:35

bananagranola
Member
From: US
Registered: 2011-08-07
Posts: 88
Website

Re: autostart profile with netctl

Have you enabled any netctl profiles?

netctl enable <profile>

If so, it might be fighting with netctl-auto.

Last edited by bananagranola (2013-04-21 01:04:23)

Offline

#3 2013-04-22 14:08:04

baitmaster
Member
Registered: 2013-04-18
Posts: 2

Re: autostart profile with netctl

The wiki says you need wpa_actiond installed for netctl-auto. Check that you do. My wired connection wouldn't start because I didn't have ifplugd installed.

Offline

#4 2013-04-22 14:55:43

cris9288
Member
Registered: 2013-01-07
Posts: 347

Re: autostart profile with netctl

what do dmesg and journalctl say? I was getting random failures to connect at boot, so increased the dhcp timeout to 30 and that did the trick. That may or may not work for you, but if you provide a little more information, we might be able to help you solve your problem.

Offline

Board footer

Powered by FluxBB