You are not logged in.

#1 2013-04-22 19:09:32

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Recent upgrade breaks GTK theming

An upgrade this morning seems to have broken theming for several applications. Normally on my setup, menus appear as such, and for most applications they still do:

http://i.imgur.com/qUk0r2M.png

http://i.imgur.com/GkWu3UL.png

but now on several applications (I've noticed it in the Network Manager applet and evince so far), a white background is incorrectly displayed:

http://i.imgur.com/c54uTXF.png

http://i.imgur.com/kE0zKuz.png

I'm using the Albatross theme in XFCE. Packages upgraded today are below (though I would guess it would be something related to one of the GTK packages):

glib2-2.36.1-1
at-spi2-core-2.8.0-1
atk-2.8.0-1
at-spi2-atk-2.8.1-1
dconf-0.16.0-1
pango-1.34.0-1
gtk3-3.8.1-1
gsettings-desktop-schemas-3.8.0-1
baobab-3.8.1-1
gdk-pixbuf2-2.28.1-1
cogl-1.14.0-2
clutter-1.14.2-2
clutter-gst-2.0.2-2
clutter-gtk-1.4.4-1
librsvg-2.37.0-1
gnome-desktop-1:3.8.1-1
nautilus-sendto-3.8.0-1
cheese-3.8.1-1
libksba-1.3.0-1
dirmngr-1.1.0-5
gnome-icon-theme-symbolic-3.8.0.1-1
gnome-icon-theme-3.8.0-1
libsecret-0.15-1
evince-3.8.0-1
file-roller-3.8.1-1
fontconfig-2.10.92-4
gnome-calculator-3.8.1-1
gcr-3.8.1-1
gtksourceview3-3.8.1-1
gobject-introspection-1.36.0-1
libpeas-1.8.0-2
python-cairo-1.10.0-2
pygobject-devel-3.8.1-1
python-gobject-3.8.1-1
gedit-3.8.1-1
gitg-0.2.7-1
glib-networking-2.36.1-1
libsigc++-2.3.1-1
glibmm-2.36.0-1
js185-1.0.0-2
polkit-0.110-2
udisks2-2.1.0-1
gnome-disk-utility-3.8.0-2
gnome-keyring-3.8.1-1
gnome-power-manager-3.8.1-1
vte-common-0.34.4-1
vte3-0.34.4-1
gnome-terminal-3.8.1-1
gnupg-2.0.19-7
gpgme-1.4.0-1
libsoup-2.42.1-1
gvfs-1.16.1-1
js-17.0.0-1
lib32-glib2-2.36.1-1
lib32-atk-2.8.0-1
lib32-fontconfig-2.10.92-1
lib32-gdk-pixbuf2-2.28.1-1
lib32-libgcrypt-1.5.2-1
lib32-pango-1.34.0-1
libgee-0.10.1-1
libgnome-keyring-3.8.0-1
libusbx-1.0.15-1
linux-3.8.8-1
linux-headers-3.8.8-1
lirc-utils-1:0.9.0-42
libqmi-1.2.0-2
modemmanager-0.7.990-3
networkmanager-0.9.8.0-3
network-manager-applet-0.9.8.0-2
p11-kit-0.18.1-1
perl-5.16.3-3
python2-gobject-3.8.1-1
qtwebkit-2.3.1-1
seahorse-3.8.1-1
texlive-core-2012.29661-1
texlive-latexextra-2012.29701-1
texlive-science-2012.29684-1
webkitgtk2-1.10.2-4
zenity-3.8.0-1

-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Last edited by slavik262 (2013-04-22 19:10:04)

Offline

#2 2013-04-22 19:19:16

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Recent upgrade breaks GTK theming

this is the second thread i have come across about this today (*unsurprisingly*); https://bbs.archlinux.org/viewtopic.php?id=161945

in the future you might want to search the forums before creating a new thread, since this is essentially the same as this previously created thread (linked to), regarding problems with menus in gtk-3.8.

BTW, Gtk3 themes typically break on every major release. (ie: 3.0 , 3.2, 3.4, 3.6, 3.8).

for now, you can either;

A) find a theme that is 3.8 compatible
B). report the theming issue to the author of the theme you are using 
C). see if you can fix it yourself.

Last edited by triplesquarednine (2013-04-22 19:20:08)

Offline

#3 2013-04-22 19:26:32

slavik262
Member
From: WA, USA
Registered: 2012-07-12
Posts: 46
Website

Re: Recent upgrade breaks GTK theming

Thanks for the info! Sorry I missed the other thread - I did run a search but apparently it was a poor one.

Offline

#4 2013-04-22 19:55:22

Jristz
Member
From: America/Santiago
Registered: 2011-06-11
Posts: 903

Re: Recent upgrade breaks GTK theming

Know issue by Uptream, the break on theming was probably intentional

Zukitwo support GTK3.8 if you want a theme

Now if you concider solved please add [solved] to you thread name


Well, I suppose that this is somekind of signature, no?

Offline

#5 2013-04-24 23:32:19

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Recent upgrade breaks GTK theming

just as an update to the OP (or anyone who may stumble here)

fixing this menu issue ended up being SUPER EASY.  For my theme all that was required was modifying gtk-widgets,css of my theme. eg:

/usr/share/themes/Blackbird/gtk-3.0/gtk-widgets.css

I opened gedit with gtk-widgets.css and searched for the 'menus', which led me to where all of hte code for menus was... I then changed every .menutitem entry that had "border-style: solid;" to "border-style: none;"

example code:

.menuitem:active {
	color: @selected_fg_color2;
        	padding: 3px 6px 3px 6px;
	border-width:  0px 1px 1px 0px;
	border-radius: 0px;
*	border-style: none;                                        <----- this line *
        border-color: alpha (#1c2931,0.8);
        background-color: #111;
	background-image: -gtk-gradient (linear, left top, left bottom,
		from (shade (#111, 1.2)),
		to (shade (#111, 1.1)));

	-unico-bullet-color: @selected_fg_color2;
	-unico-border-gradient: -gtk-gradient (linear, left top, left bottom,
		from (alpha (#111111, 0.6)),
		to (alpha (#111111, 0.7)));
	-unico-inner-stroke-style: none;
}

i had to repeat this 4 or 5 times. (for active, hover, etc). then of course saved it / test.

after that, menus look exactly how they should on my theme smile

Last edited by triplesquarednine (2013-04-24 23:48:50)

Offline

#6 2013-04-24 23:36:23

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 18,109
Website

Re: Recent upgrade breaks GTK theming

Nice work triplesquared...



Not a pacman issue, moving to Apps & DEs


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#7 2013-04-24 23:52:24

triplesquarednine
Member
Registered: 2011-04-12
Posts: 630

Re: Recent upgrade breaks GTK theming

jasonwryan wrote:

Nice work triplesquared...

thanks, man.

...i had to find a solution, since i am unwilling to drop my own gtk+ theme wink

obviously, i may not be the only archer in this kind of situation - so i thought it best to post.

Offline

Board footer

Powered by FluxBB