You are not logged in.

#1 2013-04-22 13:45:10

itti
Member
Registered: 2007-06-01
Posts: 74

media-keys no longer working

Hi,

today's updates brought gnome-3.8. After the update my multimedia keys don't work anymore. I'm not using gnome directly but rather launch awesome wm through slim and all I do is this in .xinitrc:

 /usr/lib/gnome-settings-daemon/gnome-settings-daemon &

The strange thing is that I can still use gnome-control-center to setup key combinations and that keys like "Audio mute" are perfectly recognized by the settings dialog. It's just that all Shortcuts stopped working after the update to 3.8. This means I basically lost the ability to control my the output volume of my sound card, as I'm sitting here with just headphones.

Offline

#2 2013-04-22 20:53:43

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: media-keys no longer working

I added the commands for audio control to globalkeys in the awesome wm config, works perfectly here. Check https://wiki.archlinux.org/index.php/Ex … board_Keys for more.

Offline

#3 2013-04-23 07:28:53

curson
Member
From: London
Registered: 2010-12-03
Posts: 32
Website

Re: media-keys no longer working

The volume FN keys and media control ones broke for me as well with Gnome 3.8. I don't use Gnome itself, I'm on Openbox, but I used to launch gnome-settings-daemon through the autostart.sh openbox file in ~/.config.

Anyone with an idea on how to fix this?

Last edited by curson (2013-04-23 07:45:17)

Offline

#4 2013-04-23 09:38:41

curson
Member
From: London
Registered: 2010-12-03
Posts: 32
Website

Re: media-keys no longer working

Update: it appears that gnome-settings-daemon isn't supposed to deal with media keys anymore, and that functionality now relies entirely on the fact that gnome-shell is running (which of course, being in a Openbox environment, isn't the case). I opened a BUG and received a clarification on this.

I have looked around and found volumeicon. It's sits in the tray notification area, which might not be for everyone, but it handles volume control through direct interaction with the icon or through the media keys that are now active and working again. If you use any kind of panel with such area available, it might be worth checking it out.

Offline

#5 2013-04-23 09:45:29

itti
Member
Registered: 2007-06-01
Posts: 74

Re: media-keys no longer working

Oh man... not cool but an understandable change from gnomes point of view. Thank you for escalating this. Will see whether volumeicon (had it in place years ago when I still used fluxbox) or an advanced awesome config turns out to be the deal.

Offline

#6 2013-04-23 17:32:09

cookies
Member
Registered: 2013-01-17
Posts: 253

Re: media-keys no longer working

The awesome wm config is not very advanced and works pretty well, I got my keys working with only 3 little lines in my config (4 lines if you count the comment, too). I simply added the following to the globalkeys list.

   -- Volume Controll
   , awful.key( {}, "#121", function() awful.util.spawn("amixer set Master toggle") end  )
   , awful.key( {}, "#122", function() awful.util.spawn("amixer set Master 5-") end  )
   , awful.key( {}, "#123", function() awful.util.spawn("amixer set Master 5+") end  )

You have to replace #121, #122 and #123 with the correct key codes for your keyboard and adjust the commands if you don't use alsa.

Offline

#7 2013-04-23 19:17:02

itti
Member
Registered: 2007-06-01
Posts: 74

Re: media-keys no longer working

I went with similar global hotkeys at first but the volume control on my keyboard fires "too fast" and this makes the left and right channels go out of sync every now and then. I remembered that vicious has a pulseaudio widget as a contrib module that adds commands for adjusting the volume levels of any given sink. I slapped a nice UTF-8 speaker symbol in front of that widget and now I can raise volume levels or toggle mute without channels going async and I have simple visual feedback in my awesome "tasklist". Fortunately clementine (my multimedia player) supports media keys directly if one turns off gnome integration, so now all keys I relied on are working again.

The widget

-- speaker widget
speakerwidget = wibox.widget.textbox()
speakerwidget:set_font("Symbola")
speakerwidget:set_text('?')

-- pulse widget
pulsewidget = awful.widget.progressbar()
pulsewidget:set_width(6)
pulsewidget:set_height(20)
pulsewidget:set_vertical(true)
pulsewidget:set_background_color("#222222")
pulsewidget:set_color("#3399FF")
vicious.register(pulsewidget, vicious.contrib.pulse, "$1", 2, "alsa_output.pci-0000_00_14.2.analog-stereo")

Note: the text for speakerwidget is supposed to be U+1F50A.

The hotkeys:

    awful.key({ }, "XF86AudioRaiseVolume", function () vicious.contrib.pulse.add(9, 2) end),
    awful.key({ }, "XF86AudioLowerVolume", function () vicious.contrib.pulse.add(-9, 2) end),
    awful.key({ }, "XF86AudioMute", function () vicious.contrib.pulse.toggle(2) end)

Obviously one has to adjust the index of the respective sink and it's name before use.

Last edited by itti (2013-04-23 19:25:39)

Offline

#8 2013-04-25 02:55:30

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: media-keys no longer working

Now you can use 'gnome-fallback-media-keys-helper' executable from the 'gnome-settings-daemon-compat' package (needs to be autostarted on login):
https://www.archlinux.org/packages/comm … on-compat/

Last edited by City-busz (2013-04-25 02:55:50)


My packages | My PGP Key: 0x0901C163

Offline

#9 2013-04-25 17:23:20

curson
Member
From: London
Registered: 2010-12-03
Posts: 32
Website

Re: media-keys no longer working

I personally have resolved by letting xfce4-settings handle what gnome-settings-daemon was handling. Coupled with 'volumeicon' and xfce4-notifyd, I have replicated the behaviour I had before. Thanks for the tip, City-busz, I'll keep it under consideration if things will break again!

Last edited by curson (2013-04-25 17:24:38)

Offline

#10 2014-04-29 18:47:49

Forger7
Member
Registered: 2013-11-15
Posts: 2

Re: media-keys no longer working

Any way to fix this in KDE4? My STOP-Mediakey is still working but Prev, Next and Play/Pause won't be recognized by the system.

Offline

#11 2014-05-05 17:46:35

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: media-keys no longer working

Forger7, the thread is a year old. Things change quite quickly in Arch. Start a new thread for your issue and link to this one in case you think its still relevant.

Closing...


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

Board footer

Powered by FluxBB