You are not logged in.

#1 2013-04-25 04:32:26

goodgrue
Member
From: CA, USA
Registered: 2008-11-19
Posts: 41

Some apps don't render properly after 3.8 update

I ran a major system update with all the Gnome 3.8 stuff. I didn't have any problems with GDM, and some apps seem fine (e.g. pidgin), but evince is completely unusable.

Symptoms:

1. Open evince. The window appears, looking as usual.
2. Click on a menu. The menu drops down, but never disappears even after I click away. Entries are not highlighted as I mouse over them.
3. Resize the window, shrinking it and then expanding it again. The portion of the window that was temporarily occluded never re-draws.
4. Try to open a "recent file". The window title changes, but nothing is rendered in the window.

I tried downgrading evince (by itself), and the problem persists, so it must be something else related to the massive update.

My setup:

- up-to-date system, not running [Testing].
- Running a plain Xmonad session launched from GDM.
- nouveau graphics driver

I'd appreciate any tips to help debug this. I've searched, but didn't find anyone describing a similar issue.

EDIT:

Apparently this affects other applications. I just ran gnome-tweak-tool and got the same behavior.

EDIT 2:

The issue is not theme-related. I have tried this with both Adwaita and Zukitwo and seen the same results. Some more relevant details:

- If I run Gnome Shell from GDM, evince works fine.
- If I run Gnome Classic from GDM, I get the frowny computer of death (this seems relevant...need to investigate).
- If I run Xmonad from GDM, I get the symptoms as originally described.
- If I run Xmonad from SLiM, evince works fine.

Last edited by goodgrue (2013-04-25 14:56:17)

Offline

#2 2013-04-25 04:40:56

jasonwryan
Forum & Wiki Admin
From: .nz
Registered: 2009-05-09
Posts: 19,075
Website

Re: Some apps don't render properly after 3.8 update

There are a heap of threads about this: use a gtk3 theme...


Closing -- for deletion


Reopened on appeal: apparently not theme-related.


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Offline

#3 2013-04-25 14:56:48

goodgrue
Member
From: CA, USA
Registered: 2008-11-19
Posts: 41

Re: Some apps don't render properly after 3.8 update

Thanks for re-opening, Jason. I've updated my original post with a few more details.

Offline

#4 2013-04-30 16:38:50

nobleach
Member
Registered: 2013-04-19
Posts: 6

Re: Some apps don't render properly after 3.8 update

I'm having similar issues.  The menu bar for gnome-terminal won't render the words File/Edit/View/Search etc. It's just a white box. I can click invoke the "active" state of the dropdown. The background of the dropdown is white though, so the text is not readable, unless I mouse over it. I've tried all kinds of GTK3 themes (including Adwaita) but the behavior is the same.

Offline

#5 2013-05-06 11:53:21

albertid
Member
Registered: 2013-05-06
Posts: 5

Re: Some apps don't render properly after 3.8 update

Same here,

- At least evince and nautilus show the same errorneus behaviour of not updating its screen after the first display.
- Other gtk apps like gimp work fine

Offline

#6 2013-05-06 17:31:35

luchoz
Member
Registered: 2013-05-06
Posts: 1
Website

Re: Some apps don't render properly after 3.8 update

the vast majority of problems were due to my particular theme issues, both gtk3 and the shell.
Try completely delete this directories:

~/.themes/

/usr/share/themes/

/usr/share/gnome-shell/theme/

and then reinstall the default theme packs and shell

Last edited by luchoz (2013-05-14 23:37:09)


sorry for my english

Offline

Board footer

Powered by FluxBB