You are not logged in.

#1951 2013-04-24 07:28:42

samuaz
Member
Registered: 2012-10-07
Posts: 32

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:

Hmm...I don't see anything wrong in there. Does Unity work fine other than needing workarounds?

I should be able to "fix" the media keys issue tomorrow smile

thanks great work

unity works good,, the only problems are that you mentioned and the lightdm (for my side) and if can anyone check if the globalmenu works with qt programs for me programas like q4wine or virtualbox have the menus in the applicatio , but the system are solid and with good performance

Last edited by samuaz (2013-04-24 07:29:16)

Offline

#1952 2013-04-24 08:18:15

hiob
Member
Registered: 2007-12-15
Posts: 19

Re: Progress on Unity under Arch Linux!

Unity is not working since gnome 3.8 on my laptop. Compiz and nautilus(-background) are starting. Going to tty1 and starting programs with "DISPLAY=:0 command" also works (this way I am able to post this).

I noticed the following things:

  • Unity was not enabled by default, I enabled it per ccsm (after a 'compiz.reset' and 'rm -rf .config/gtk-*'

  • In '.xsession-errors' is reported, that the opengl-plugin starts after unity is started, leading to fallback mode

  • Work-space switching does not work, desktop-size is 2x2, 'Desktop Wall' is enabled, worked before 3.8

My .xsession-errors:

** (gnome-session-check-accelerated:6802): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused

** (gnome-session:6760): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/at-spi-registryd.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/at-spi-registryd.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/bluetooth-applet.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/bluetooth-applet.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/gnome-do.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/gnome-do.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/xfconf-migration-4.6.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/xfconf-migration-4.6.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/gtk-kde4.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/gtk-kde4.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/Yakuake.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/Yakuake.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/dropbox.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/dropbox.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/docky.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/docky.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/magick-rotation.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/magick-rotation.desktop
gnome-session[6760]: WARNING: Could not parse desktop file /home/milan/.config/autostart/wicd-tray.desktop or it references a not found TryExec binary
gnome-session[6760]: WARNING: could not read /home/milan/.config/autostart/wicd-tray.desktop

** (gnome-settings-daemon:6830): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused
N: [pulseaudio] main.c: User-configured server at {a766bf07af2a49ab8068f632663ce345}unix:/run/user/1000/pulse/native, which appears to be local. Probing deeper.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
compiz (core) - Info: Loading plugin: core
compiz (core) - Info: Starting plugin: core

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Failed to create fallback wacom device for '/dev/input/event9': Device '/dev/input/event9' is not a tablet (2)

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.
compiz (core) - Info: Loading plugin: ccp
compiz (core) - Info: Starting plugin: ccp
+ dconf load /com/canonical/unity/
+ dconf dump /desktop/unity/
+ dconf reset -f /desktop/unity/
sleep: invalid time interval ‘10;’
sleep: invalid time interval ‘bash’
sleep: invalid time interval ‘/home/milan/.xprofile’
Try 'sleep --help' for more information.
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.

** (polkit-gnome-authentication-agent-1:6877): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused

** (gnome-screensaver:6858): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused

** (telepathy-indicator:6869): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused

** (nautilus:6859): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused

** (nm-applet:6863): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused

** (evolution-alarm-notify:6852): WARNING **: Couldn't connect to accessibility bus: Failed to connect to socket /tmp/dbus-gV776GSaFx: Connection refused
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
compiz (core) - Info: Loading plugin: composite
compiz (core) - Info: Starting plugin: composite
compiz (core) - Info: Loading plugin: opengl

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-application-handlers

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-command-line

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-log-out

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-print-setup

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-printing

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-save-to-disk

** (gnome-screensaver:6858): WARNING **: Config key not handled: user-administration-disabled

** (gnome-screensaver:6858): WARNING **: Config key not handled: color-shading-type

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-opacity

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-options

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-uri

** (gnome-screensaver:6858): WARNING **: Config key not handled: primary-color

** (gnome-screensaver:6858): WARNING **: Config key not handled: secondary-color

** (gnome-screensaver:6858): WARNING **: Config key not handled: show-full-name-in-top-bar

** (gnome-screensaver:6858): WARNING **: Config key not handled: show-notifications

** (gnome-screensaver:6858): WARNING **: Config key not handled: ubuntu-lock-on-suspend

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-application-handlers

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-command-line

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-log-out

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-print-setup

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-printing

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-save-to-disk

** (gnome-screensaver:6858): WARNING **: Config key not handled: user-administration-disabled

** (gnome-screensaver:6858): WARNING **: Config key not handled: color-shading-type

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-opacity

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-options

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-uri

** (gnome-screensaver:6858): WARNING **: Config key not handled: primary-color

** (gnome-screensaver:6858): WARNING **: Config key not handled: secondary-color

** (gnome-screensaver:6858): WARNING **: Config key not handled: show-full-name-in-top-bar

** (gnome-screensaver:6858): WARNING **: Config key not handled: show-notifications

** (gnome-screensaver:6858): WARNING **: Config key not handled: ubuntu-lock-on-suspend

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-application-handlers

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-command-line

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-log-out

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-print-setup

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-printing

** (gnome-screensaver:6858): WARNING **: Config key not handled: disable-save-to-disk

** (gnome-screensaver:6858): WARNING **: Config key not handled: user-administration-disabled

** (gnome-screensaver:6858): WARNING **: Config key not handled: color-shading-type

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-opacity

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-options

** (gnome-screensaver:6858): WARNING **: Config key not handled: picture-uri

** (gnome-screensaver:6858): WARNING **: Config key not handled: primary-color

** (gnome-screensaver:6858): WARNING **: Config key not handled: secondary-color

** (gnome-screensaver:6858): WARNING **: Config key not handled: show-full-name-in-top-bar

** (gnome-screensaver:6858): WARNING **: Config key not handled: show-notifications

** (gnome-screensaver:6858): WARNING **: Config key not handled: ubuntu-lock-on-suspend
compiz (core) - Info: Unity is fully supported by your hardware.
New PolkitAgentListener  0xc0af80 
Adding new listener  PolkitQt1::Agent::Listener(0x7ffff6603430) for  0xc0af80 

** (fingerprint-polkit-agent:6875): WARNING **: Unable to register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject
"Cannot register authentication agent: GDBus.Error:org.freedesktop.PolicyKit1.Error.Failed: An authentication agent already exists for the given subject" 
Destroying listener
Removing listener  PolkitQt1::Agent::Listener(0x7ffff6603430) 
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.

** (nm-applet:6863): WARNING **: Error connecting to ModemManager: Error calling StartServiceByName for org.freedesktop.ModemManager1: GDBus.Error:org.freedesktop.systemd1.LoadFailed: Unit dbus-org.freedesktop.ModemManager1.service failed to load: No such file or directory. See system logs and 'systemctl status dbus-org.freedesktop.ModemManager1.service' for details.
** Message: applet now removed from the notification area
compiz (core) - Info: Unity is not supported by your hardware. Enabling software rendering instead (slow).
compiz (core) - Info: Starting plugin: opengl
** Message: using fallback from indicator to GtkStatusIcon
compiz (core) - Info: Loading plugin: copytex
compiz (core) - Info: Starting plugin: copytex
compiz (core) - Info: Loading plugin: compiztoolbox
compiz (core) - Info: Starting plugin: compiztoolbox
compiz (core) - Info: Loading plugin: decor
compiz (core) - Info: Starting plugin: decor
compiz (core) - Info: Loading plugin: mousepoll
compiz (core) - Info: Starting plugin: mousepoll
compiz (core) - Info: Loading plugin: regex
compiz (core) - Info: Starting plugin: regex
compiz (core) - Info: Loading plugin: animation
compiz (core) - Info: Starting plugin: animation
compiz (core) - Info: Loading plugin: move
compiz (core) - Info: Starting plugin: move
compiz (core) - Info: Loading plugin: workarounds
compiz (core) - Info: Starting plugin: workarounds
compiz (core) - Info: Loading plugin: vpswitch
compiz (core) - Info: Starting plugin: vpswitch
compiz (core) - Info: Loading plugin: imgpng
compiz (core) - Info: Starting plugin: imgpng
compiz (core) - Info: Loading plugin: resize
compiz (core) - Info: Starting plugin: resize
compiz (core) - Info: Loading plugin: place
compiz (core) - Info: Starting plugin: place
compiz (core) - Info: Loading plugin: snap
compiz (core) - Info: Starting plugin: snap
compiz (core) - Info: Loading plugin: session
compiz (core) - Info: Starting plugin: session
I/O warning : failed to load external entity "/home/milan/.compiz/session/106928a78f5b892e6f136678950563171600000067600001"
compiz (core) - Info: Loading plugin: unitymtgrabhandles
compiz (core) - Info: Starting plugin: unitymtgrabhandles
compiz (core) - Info: Loading plugin: grid
compiz (core) - Info: Starting plugin: grid
compiz (core) - Info: Loading plugin: wall
compiz (core) - Info: Starting plugin: wall
compiz (core) - Info: Loading plugin: expo
compiz (core) - Info: Starting plugin: expo
compiz (core) - Info: Loading plugin: gnomecompat
compiz (core) - Info: Starting plugin: gnomecompat
compiz (core) - Info: Loading plugin: fade
compiz (core) - Info: Starting plugin: fade
compiz (core) - Info: Loading plugin: scale
compiz (core) - Info: Starting plugin: scale
compiz (core) - Info: Loading plugin: ezoom
compiz (core) - Info: Starting plugin: ezoom
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.

(process:6841): GLib-GIO-WARNING **: g_settings_set_value: value for key 'visual-bell-type' in schema 'org.gnome.desktop.wm.preferences' is outside of valid range
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated.
"sni-qt/6871" WARN  09:45:07.930 void StatusNotifierItemFactory::connectToSnw() Invalid interface to SNW_SERVICE 
No systemtrayicon available
/home/milan/.bashrc: line 51: bind: warning: line editing not enabled
sudo: no tty present and no askpass program specified

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gdk-CRITICAL **: gdk_device_get_source: assertion `GDK_IS_DEVICE (device)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Failed to create fallback wacom device for '/dev/input/event9': Device '/dev/input/event9' is not a tablet (2)

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gtk-CRITICAL **: gtk_widget_set_visible: assertion `GTK_IS_WIDGET (widget)' failed

(gnome-screensaver:6858): Gdk-CRITICAL **: gdk_device_get_source: assertion `GDK_IS_DEVICE (device)' failed
** Message: applet now embedded in the notification area
compiz (decor) - Warn: No default decoration found, placement will not be correct

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Failed to create fallback wacom device for '/dev/input/event9': Device '/dev/input/event9' is not a tablet (2)

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

(gnome-settings-daemon:6830): wacom-plugin-WARNING **: Automatically mapping tablet to heuristically-found display.

Edit: "not working" means, I see nothing from Unity, no launcher, no panel, no super-key-shortcuts.
Edit2: gnome (with gnome-shell) runs without errors.

Last edited by hiob (2013-04-24 08:29:15)

Offline

#1953 2013-04-24 08:44:42

samuaz
Member
Registered: 2012-10-07
Posts: 32

Re: Progress on Unity under Arch Linux!

hiob wrote:

Unity is not working since gnome 3.8 on my laptop. Compiz and nautilus(-background) are starting. Going to tty1 and starting programs with "DISPLAY=:0 command" also works (this way I am able to post this).

I noticed the following things:

  • Unity was not enabled by default, I enabled it per ccsm (after a 'compiz.reset' and 'rm -rf .config/gtk-*'

  • In '.xsession-errors' is reported, that the opengl-plugin starts after unity is started, leading to fallback mode

  • Work-space switching does not work, desktop-size is 2x2, 'Desktop Wall' is enabled, worked before 3.8

Edit: "not working" means, I see nothing from Unity, no launcher, no panel, no super-key-shortcuts.

if your using the "stable" repo change to chenxiaolong test repo but first unistall all unity and gnome in virtual console ctrl+alt+f1

sudo pacman -Rdd $(pacman -Slq unity unity-extra )
sudo pacman -Rsnc gnome gnome-extra
sudo pacman -Rsnc gtk3-ubuntu gtk2-ubuntu

next edit the pacman.conf and delete the repo unity

sudo nano /etc/pacman.conf

delete

[unity]
Server = http://unity.xe-xe.org/$arch

[unity-extra]
Server = http://unity.xe-xe.org/extra/$arch

save and exit

next

sudo pacman -Scc
sudo pacman -Syu
sudo pacman -S gnome gnome-extra

now add the chenxiaolong test repo

sudo nano /etc/pacman.conf

[Unity-for-Arch]
SigLevel = Optional TrustAll
Server = http://dl.dropbox.com/u/486665/Repos/Un … Arch/$arch

[Unity-for-Arch-Extra]
SigLevel = Optional TrustAll
Server = http://dl.dropbox.com/u/486665/Repos/Un … xtra/$arch

next
sudo pacman -Suy
sudo pacman -S $(pacman -Slq Unity-for-Arch) or for full installation sudo pacman -S $(pacman -Slq Unity-for-Arch Unity-for-Arch-Extra)

if you do a sudo pacman -S $(pacman -Slq Unity-for-Arch) you also need to install notify-osd signon-keyring-extension gnome-keyring zeitgeist zeitgeist-datahub  lightdm-ubuntu and lightdm-unity-greeter

so after pacman -S $(pacman -Slq Unity-for-Arch) do a

sudo pacman -S notify-osd signon-keyring-extension gnome-keyring zeitgeist zeitgeist-datahub  lightdm-ubuntu and lightdm-unity-greeter

next disable the gdm and enable lightdm

sudo systemctl -f disable gdm
sudo systemctl -f enable lightdm

reboot

sudo reboot

and try to start unity shouldbe work

but.....

if your lightdm not response, start again a virtual console (ctrl+alt+f1)

disable lightdm and renable gdm

sudo systemctl -f disable lightdm
sudo systemctl -f enable gdm

restart, sudo reboot

if your gdm not response only show the wallpaper wait a 5 sec and press f1, you get the login dialog so in this case first login with gnome session and if you get the same with gnome only show a wallpaper press f1 again, you get the ui start, next logout and login with unity session, unity should be work!

Last edited by samuaz (2013-04-24 08:45:36)

Offline

#1954 2013-04-24 08:45:49

gadelat
Member
Registered: 2013-03-11
Posts: 49

Re: Progress on Unity under Arch Linux!

@hiob: did you try compiz.reset? also, it's pretty fresh in repos, so if you built it yesterday maybe you installed some packages which were not updated yet, so do pacman -Syu

Last edited by gadelat (2013-04-24 08:46:40)

Offline

#1955 2013-04-24 08:52:04

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

@chenxiaolong,

Does nux still depend on ibus?
According to this https://bugs.launchpad.net/nux/+bug/983254, it seems that ibus is not required anymore.

Anyway, I'm testing it.

EDIT:
It seems that nothing breaks without ibus.

Last edited by qiuwei (2013-04-24 09:43:25)

Offline

#1956 2013-04-24 09:19:46

hiob
Member
Registered: 2007-12-15
Posts: 19

Re: Progress on Unity under Arch Linux!

samuaz wrote:

if your using the "stable" repo change to chenxiaolong test repo but first unistall all unity and gnome in virtual console ctrl+alt+f1

sorry, I didn't mention it: I installed unity via "s pacman -S --needed $(pacman -Sl Unity-for-Arch Unity-for-Arch-Extra | cut -f2 -d' ')", which replaced a bunch of gnome- and gtk-related packages.
lightdm seems not to be a problem, since compiz and any other proramm (except unity of cause) runs in the session started with the unity-entry (I start other programms via 'DISPLAY=:0 xfce4-panel' on console).

gadelat wrote:

did you try compiz.reset?

yes, I also removed everything matching "gtk-*" from .config and

:: Starting full system upgrade...
 there is nothing to do

Edit: Tested it with gdm, same thing.

*EDIT2:* Runnig 'DISPLAY=:0 compiz' brings up unity! Strange thing: with this command opengl-plugin is started before unity as expected. I'll try to fix it with a compiz-session-file for now.

Last edited by hiob (2013-04-24 09:33:26)

Offline

#1957 2013-04-24 09:37:51

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
oi_wtf wrote:

That's why I'm using nemo, a nautilus fork by linux mint, for quite a while now.
You'd need to use the nemo-git from aur though, as the version of nemo in [community] does not work well with gnome 3.8, yet.

Nemo is currently based on Nautilus 3.6. I wonder if they're going to merge changes from gnome-shell and nautilus 3.8 or if they're going to diverge even more. If they start drawing the desktop background with Cinnamon, then we'll end up in the same situation.

Btw, I just reverted the commits that removed background support in nautilus-ubuntu. If you prefer nautilus, that should be usable now.

Well, I pretty much don't care which nautilus nemo is currently based on, since it's, in my opinion, far much better than any nautilus, be it 3.6 or 3.8... big_smile
They re-added some features of nautilus, I wouldn't want to miss, so I'd only use nautilus if there's no other way. ^^

I'm also wondering what nemo-devs will do, but there'd always be the option of disabling desktop drawing of nemo
and use nautilus for that only instead or don't let any filemanager draw the desktop... I don't have any desktop-icons anyway, so I'd only be missing the right-click-menu. big_smile

Last edited by oi_wtf (2013-04-24 09:38:41)


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#1958 2013-04-24 13:11:21

mieLouk
Member
Registered: 2012-12-16
Posts: 36

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
mieLouk wrote:

Apparently I updated in the worst moment, earlier.

Now, I waited till your Repo had been finished. The update didn't really help to rescue my system. When I start up and login, I see the desktop for a splitsecond, then just a blinding whitescreen. Resetting compiz didn't help.

Any suggestions on how to save the installation? Is it save to update the other machine?

Could you post your ~/.xsession-errors file (while you're logged into the whitescreen)? I don't recommend updating your other computer until the first one works smile


After updating the packages which compiled a bit later, I just see the wallpaper and can rightclick on the background. This brings me into the control-center but there are no bars at all.

This is the .xsession-error from wallpaper-only-mode wink  http://paste.ubuntu.com/5598282/

EDIT: Don't bather. Third time's the charme with compiz.reset, everything works fine, except the issues you mentioned.

EDIT2: The earlier mentioned "stuttering" of the lenses on my laptop, has something to do with the background blur. When disabled via Unity Tweak Tool, no stuttering occurs.

Last edited by mieLouk (2013-04-24 13:38:57)

Offline

#1959 2013-04-24 23:04:49

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

samuaz wrote:
chenxiaolong wrote:

Hmm...I don't see anything wrong in there. Does Unity work fine other than needing workarounds?

I should be able to "fix" the media keys issue tomorrow smile

thanks great work

unity works good,, the only problems are that you mentioned and the lightdm (for my side) and if can anyone check if the globalmenu works with qt programs for me programas like q4wine or virtualbox have the menus in the applicatio , but the system are solid and with good performance

Unfortunately, I wasn't able to fix the issue without breaking gnome-shell. I think the Fedora developers will fix this soon because Cinnamon is an officially supported DE in Fedora and media keys are broken there too with GNOME 3.8.

For the Qt global menu, just install the appmenu-qt package smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1960 2013-04-24 23:07:44

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

oi_wtf wrote:

Well, I pretty much don't care which nautilus nemo is currently based on, since it's, in my opinion, far much better than any nautilus, be it 3.6 or 3.8... big_smile
They re-added some features of nautilus, I wouldn't want to miss, so I'd only use nautilus if there's no other way. ^^

I'm also wondering what nemo-devs will do, but there'd always be the option of disabling desktop drawing of nemo
and use nautilus for that only instead or don't let any filemanager draw the desktop... I don't have any desktop-icons anyway, so I'd only be missing the right-click-menu. big_smile

I'll have to check out nemo then. I can't stand nautilus either, which is why I currently use KDE's dolphin smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1961 2013-04-24 23:08:39

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

mieLouk wrote:

After updating the packages which compiled a bit later, I just see the wallpaper and can rightclick on the background. This brings me into the control-center but there are no bars at all.

This is the .xsession-error from wallpaper-only-mode wink  http://paste.ubuntu.com/5598282/

EDIT: Don't bather. Third time's the charme with compiz.reset, everything works fine, except the issues you mentioned.

EDIT2: The earlier mentioned "stuttering" of the lenses on my laptop, has something to do with the background blur. When disabled via Unity Tweak Tool, no stuttering occurs.

Awesome! Glad you got Unity working and the stuttering fixed smile


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1962 2013-04-24 23:50:29

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

Yeah, we're screwed. At least Cinnamon can merge upstream gnome-shell commits. Unfortunately, Unity won't benefit at all from any of that. I guess we can use xbindkeys or something like that for the media keys right now.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1963 2013-04-25 02:36:28

City-busz
Trusted User (TU)
From: Budapest, Hungary
Registered: 2010-12-27
Posts: 162
Website

Re: Progress on Unity under Arch Linux!

@chenxiaolong: check the gnome-settings-daemon-compat package:
https://www.archlinux.org/packages/comm … on-compat/

It contains the missing parts, including the media keys handling. You could add them as a required component in the gnome session file.


My packages | My PGP Key: 0x0901C163

Offline

#1964 2013-04-25 03:39:59

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

City-busz wrote:

@chenxiaolong: check the gnome-settings-daemon-compat package:
https://www.archlinux.org/packages/comm … on-compat/

It contains the missing parts, including the media keys handling. You could add them as a required component in the gnome session file.

Thank you very much for the package! I'll test it ASAP.

EDIT: Works great!

EDIT2: All notifications from gnome-settings-daemon-compat use the gnome-settings-daemon UI instead of notify-osd.

Last edited by chenxiaolong (2013-04-25 03:51:58)


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1965 2013-04-25 07:53:43

samuaz
Member
Registered: 2012-10-07
Posts: 32

Re: Progress on Unity under Arch Linux!

last update make media-keys works, thanks

screen https://dl.dropboxusercontent.com/u/590 … 0%3A11.png

observation system settings name and title are not traslated to spanish screen

https://dl.dropboxusercontent.com/u/590 … 8%3A48.png

thanks nice work

Last edited by samuaz (2013-04-25 07:55:25)

Offline

#1966 2013-04-25 20:24:25

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

I confirm media keys are working.
I have a problem with unity-lenses-files. Basically it is not giving me results.
Is it possible that I have to recompile libcolumbus or something else?
I tried already to remove zeitgeist cache...

Zeitgeist works because in gnome 3.8 the search engine is giving resuts. In Unity it seems that the files-folders is not working. Is there anybody else having the same problem?

Last edited by gianluca.pettinello (2013-04-27 12:23:38)

Offline

#1967 2013-04-28 09:10:08

roi.dm
Member
Registered: 2011-10-29
Posts: 22

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
City-busz wrote:

@chenxiaolong: check the gnome-settings-daemon-compat package:
https://www.archlinux.org/packages/comm … on-compat/

It contains the missing parts, including the media keys handling. You could add them as a required component in the gnome session file.

Thank you very much for the package! I'll test it ASAP.

EDIT: Works great!

EDIT2: All notifications from gnome-settings-daemon-compat use the gnome-settings-daemon UI instead of notify-osd.

there's no need for settings-daemon-compat the new gnome-settings-daemon_3.8.1-0ubuntu1~raring2.debian.tar.gz contains the patch "fix_media_keys_on_unity.patch"

Offline

#1968 2013-04-28 13:47:23

edmael
Member
From: Corte de' Frati, Italy
Registered: 2012-07-19
Posts: 54
Website

Re: Progress on Unity under Arch Linux!

Hi,
I'm using Gnome 3.8 from the stable repo and I want to (re-)try Unity.
Should I remove Gnome, add Unity-xe-xe repository and then install everything
OR
should I use GIT and compile everything
OR
should I use Unity-for-Arch repository?

Thanks wink

Offline

#1969 2013-04-28 15:56:39

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

edmael wrote:

Hi,
I'm using Gnome 3.8 from the stable repo and I want to (re-)try Unity.
Should I remove Gnome, add Unity-xe-xe repository and then install everything
OR
should I use GIT and compile everything
OR
should I use Unity-for-Arch repository?

Thanks wink

The packages in my repo (Unity-for-Arch) are built automatically so you'll always get the latest and greatest smile If you want to save yourself from an hour or two of compile time, just use the binary repo. The unity.xe-xe.org repo hasn't been updated for GNOME 3.8 yet.

Also, there's no need to remove GNOME. It should work properly even with Unity installed.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1970 2013-04-28 15:57:26

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

roi.dm wrote:
chenxiaolong wrote:
City-busz wrote:

@chenxiaolong: check the gnome-settings-daemon-compat package:
https://www.archlinux.org/packages/comm … on-compat/

It contains the missing parts, including the media keys handling. You could add them as a required component in the gnome session file.

Thank you very much for the package! I'll test it ASAP.

EDIT: Works great!

EDIT2: All notifications from gnome-settings-daemon-compat use the gnome-settings-daemon UI instead of notify-osd.

there's no need for settings-daemon-compat the new gnome-settings-daemon_3.8.1-0ubuntu1~raring2.debian.tar.gz contains the patch "fix_media_keys_on_unity.patch"

Thanks! I'll take a look at the patch and make sure that it doesn't break gnome-shell.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1971 2013-04-28 16:54:43

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

samuaz wrote:

last update make media-keys works, thanks

screen https://dl.dropboxusercontent.com/u/590 … 0%3A11.png

observation system settings name and title are not traslated to spanish screen

https://dl.dropboxusercontent.com/u/590 … 8%3A48.png

thanks nice work

The System Settings should now be translated now smile The issue was that "System Settings" was renamed to "Settings" in GNOME 3.8, so I just renamed it back.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1972 2013-04-28 17:01:41

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:

I confirm media keys are working.
I have a problem with unity-lenses-files. Basically it is not giving me results.
Is it possible that I have to recompile libcolumbus or something else?
I tried already to remove zeitgeist cache...

Zeitgeist works because in gnome 3.8 the search engine is giving resuts. In Unity it seems that the files-folders is nworking. Is there anybody else having the same problem?

Edit 2 I tried to recompile everything but no success. I'm lost. I type in the dash and the applications list readapts while I'm typing. But the files and folders list stays blocked. Is there anyone experiencing the same???

Offline

#1973 2013-04-28 17:21:43

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:
gianluca.pettinello wrote:

I confirm media keys are working.
I have a problem with unity-lenses-files. Basically it is not giving me results.
Is it possible that I have to recompile libcolumbus or something else?
I tried already to remove zeitgeist cache...

Zeitgeist works because in gnome 3.8 the search engine is giving resuts. In Unity it seems that the files-folders is nworking. Is there anybody else having the same problem?

Edit 2 I tried to recompile everything but no success. I'm lost. I type in the dash and the applications list readapts while I'm typing. But the files and folders list stays blocked. Is there anyone experiencing the same???

I'll check if it works here right now.

EDIT: It's broken here too sad

Btw, gnome-shell uses tracker, not zeitgeist, which is why it works properly.

EDIT2: I found the problem. Arch Linux upgraded to zeitgeist 0.9.12 recently, which is incompatible with unity-lens-files. You'll need to downgrade to version 0.9.5 to get things working again.

EDIT3: Nevermind, that doesn't work either. I don't know what's wrong.

Last edited by chenxiaolong (2013-04-28 17:52:56)


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#1974 2013-04-28 18:53:57

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
gianluca.pettinello wrote:
gianluca.pettinello wrote:

I confirm media keys are working.
I have a problem with unity-lenses-files. Basically it is not giving me results.
Is it possible that I have to recompile libcolumbus or something else?
I tried already to remove zeitgeist cache...

Zeitgeist works because in gnome 3.8 the search engine is giving resuts. In Unity it seems that the files-folders is nworking. Is there anybody else having the same problem?

Edit 2 I tried to recompile everything but no success. I'm lost. I type in the dash and the applications list readapts while I'm typing. But the files and folders list stays blocked. Is there anyone experiencing the same???

I'll check if it works here right now.

EDIT: It's broken here too sad

Btw, gnome-shell uses tracker, not zeitgeist, which is why it works properly.

EDIT2: I found the problem. Arch Linux upgraded to zeitgeist 0.9.12 recently, which is incompatible with unity-lens-files. You'll need to downgrade to version 0.9.5 to get things working again.

EDIT3: Nevermind, that doesn't work either. I don't know what's wrong.


unity-lens-files should use also locate. Could it be linked to dbus??

Offline

#1975 2013-04-28 19:22:36

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:

unity-lens-files should use also locate. Could it be linked to dbus??

Does locate work for files in /home? Also, locate only works if "sudo updatedb" is run. Arch currently runs "updatedb" once daily.

I don't think the problem is related to dbus. With the newer zeitgeist, there are dbus warnings about methods not being found, but these messages all disappear with the old zeitgeist 0.9.5 that Ubuntu uses.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

Board footer

Powered by FluxBB