You are not logged in.

#1 2013-04-29 11:48:03

toni
Member
Registered: 2011-10-15
Posts: 395

[SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

arch is showing incorrect time. For example, it shows 15h and it should be 13h. Anyway if I boot into Win8, it shows correct time. Also, if I set correct time in arch and I reboot, arch linux is showing the correct time once boot but not Win8. So, is there a way to set the time correctly independently of the OS? I want that the time be correctly shown independently if I boot into arch or win8.

Both OSes are set to use UTC.

I am using old initscripts, /etc/rc.conf:

DAEMON_LOCALE="no"
HARDWARECLOCK="UTC"
TIMEZONE="Europe/Madrid"

and hwclock in daemons.

Currently using kernel 3.8.8-2-ARCH

Thanks in advance.

Last edited by toni (2013-04-29 20:58:39)

Offline

#2 2013-04-29 12:19:45

cdrc
Member
From: France
Registered: 2013-04-16
Posts: 5

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

From the wiki:

It makes sense to disable time synchronization in Windows - otherwise it will mess up the hardware clock.

Worked for me, with win7.

If that’s not it, maybe cheating with the timezone?

Last edited by cdrc (2013-04-29 12:21:33)

Offline

#3 2013-04-29 12:22:48

illusionist
Member
From: localhost
Registered: 2012-04-03
Posts: 498

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Use ntpd. But I am not sure if ntpd still has rc.conf compatibility. I suggest you to migrate to systemd.


  Never argue with stupid people,They will drag you down to their level and then beat you with experience.--Mark Twain
@github

Offline

#4 2013-04-29 12:36:05

mich41
Member
Registered: 2012-06-22
Posts: 592

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Your hardware clock should be set to UTC (continental European summer time minus 2 hours). Set it using BIOS setup and then check which OS shows correct time and fix the other one. Considering that Arch shows 2 hours later than Windows, it's probably Windows that's broken.

Offline

#5 2013-04-29 18:11:51

toni
Member
Registered: 2011-10-15
Posts: 395

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

mich41 wrote:

Your hardware clock should be set to UTC (continental European summer time minus 2 hours). Set it using BIOS setup and then check which OS shows correct time and fix the other one. Considering that Arch shows 2 hours later than Windows, it's probably Windows that's broken.

I have set my hardware clock correctly in BIOS and then I perform following steps depending on scenario:

Scenario #1 Booting into Win8
1.- I check out the clock in BIOS to see that is correct previous to boot into Win8
2.- I boot into Win8 and I see that clock is correct

Scenario #2 Booting into arch
1.- I check out the clock in BIOS to see that is correct previous to boot into arch
2.- I boot into arch and I see that clock is incorrect +2 hours

so I think there is a problem in my arch linux, maybe something not configured correctly. Acrch show 2 hours later than W**** but W**** is showing the correct one so the issue is related to arch.

If I executed  "timedatectl status" it outputs below information. The correct hour is shown by UTC, so why arch is not showing it? and why is showing the incorrect one (local time) instead?

      Local time: lun 2013-04-29 22:13:57 CEST
  Universal time: lun 2013-04-29 20:13:57 UTC
        RTC time: lun 2013-04-29 20:13:57
        Timezone: Europe/Madrid (CEST, +0200)
     NTP enabled: n/a
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  dom 2013-03-31 01:59:59 CET
                  dom 2013-03-31 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dom 2013-10-27 02:59:59 CEST
                  dom 2013-10-27 02:00:00 CET

Last edited by toni (2013-04-29 18:19:44)

Offline

#6 2013-04-29 18:16:32

65kid
Member
From: Germany
Registered: 2011-01-26
Posts: 663

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

toni wrote:

so I think there is a problem in my arch linux

yes, there is, it's the fact that you are still using initscripts. Not saying that initscripts is definitively at fault here, but you can't really expect much help here if you still use an init system that has been deprecated for 6 months.

Offline

#7 2013-04-29 18:19:42

alphaniner
Member
From: Ancapistan
Registered: 2010-07-12
Posts: 2,653

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Windows expects the clock to be set to local time. Generally, Linux expects the clock to be set to UTC.

I check out the clock in BIOS to see that is correct previous to boot into Win8/arch

If you mean the clock is always the correct *local* time, then that explains why Windows time is correct and Arch time is not. You need to decide how to harmonize the conflicting expectations of the two OSs.

65kid wrote:
toni wrote:

so I think there is a problem in my arch linux

yes, there is, it's the fact that you are still using initscripts. Not saying that initscripts is definitively at fault here, but you can't really expect much help here if you still use an init system that has been deprecated for 6 months.

Also this.


But whether the Constitution really be one thing, or another, this much is certain - that it has either authorized such a government as we have had, or has been powerless to prevent it. In either case, it is unfit to exist.
-Lysander Spooner

Online

#8 2013-04-29 18:20:42

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,965

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Almost all serious operating systems assume that the BIOS clock is set to UTC.  A certain popular operating system that, (originally) was not designed to connect to the internet, assumes that the BIOS clock is set to local time.  This creates havoc whenever governments arbitrarily add seasonal offsets to local time, or when a system moves from one timezone to another. 

When you say the clock in BIOS is correct, does it reflect your local time, or is it set to UTC ?(as it should be)

Edit snaked by one minute by alphaniner big_smile

Last edited by ewaller (2013-04-29 21:57:57)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Online

#9 2013-04-29 18:22:21

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,978

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

toni wrote:

If I executed  "timedatectl status" it outputs below information. The correct hour is shown by UTC, so why arch is not showing it? and why is showing the incorrect one (local time) instead?

So your hardware clock is in localtime, yet you're specifically telling Arch that it's UTC. Read your first post.

Offline

#10 2013-04-29 18:25:36

toni
Member
Registered: 2011-10-15
Posts: 395

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

65kid wrote:
toni wrote:

so I think there is a problem in my arch linux

yes, there is, it's the fact that you are still using initscripts. Not saying that initscripts is definitively at fault here, but you can't really expect much help here if you still use an init system that has been deprecated for 6 months.

Some days ago I decided to migrate all the initscripts to systemd, so this is what I did, but only a few ones still remain using initscripts, and they are the following in /etc/rc.conf because I have not found any equivalence in systemd:

DAEMONS=(hwclock hal netfs)

Regarding to hwclock I have read in arch wiki that it is no longer used by systemd (it is not necessary) so I wonder If I can remove from daemons. Can I remove hwclock from daemons? If I remove it, is it necessary to do something else?

Regarding to the other (hal, netfs) what are the equivalence in systemd? I know I should open another thread but as we are talking about it....

Thanks.

Offline

#11 2013-04-29 18:41:08

dodo3773
Member
Registered: 2011-03-17
Posts: 798

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

I have found that having the correct time can be problematic in some cases. As previously stated you are supposed to use localtime and not utc on the gnu/linux side if you dual boot with windows. The solution for me (I never found the daemon initscript or .service file to be completely reliable) was this: Install ntp / ntpq  package(s). Make sure the time servers are correct in /etc/ntp.conf Here is an example (mine):

# Associate to public NTP pool servers; see http://www.pool.ntp.org/
server 0.us.pool.ntp.org
server 1.us.pool.ntp.org
server 2.us.pool.ntp.org

After that either set your /etc/rc.local or a .service file or add /usr/bin/ntpd to your sudo exceptions and setup something like this in your startup:

 
sleep 30 && /usr/bin/ntpd -qg &

or from a regular user startup script if you added it to your sudoers as an exception:

sleep 30 && sudo /usr/bin/ntpd -qg &

This is the only way I found for it to always work for me. The startup daemon or service may be better now but I will probably continue to do it this way.

Last edited by dodo3773 (2013-04-29 18:41:36)

Offline

#12 2013-04-29 18:48:54

mich41
Member
Registered: 2012-06-22
Posts: 592

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

toni wrote:

If I executed  "timedatectl status" it outputs below information. The correct hour is shown by UTC, so why arch is not showing it? and why is showing the incorrect one (local time) instead?

      Local time: lun 2013-04-29 22:13:57 CEST
  Universal time: lun 2013-04-29 20:13:57 UTC
        RTC time: lun 2013-04-29 20:13:57
        Timezone: Europe/Madrid (CEST, +0200)

Your Arch configuration is correct. You don't need to mess with rc.conf, init scripts, ntpd or anything else.

Your RTC needs to be set to UTC, not CEST. Adjust it by -2 and fix Windows.

Last edited by mich41 (2013-04-29 18:50:11)

Offline

#13 2013-04-29 18:54:46

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,978

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

toni wrote:

Regarding to hwclock I have read in arch wiki that it is no longer used by systemd (it is not necessary) so I wonder If I can remove from daemons. Can I remove hwclock from daemons? If I remove it, is it necessary to do something else?

You just need to set your configuration files up like you would in any install. Instructions here: https://wiki.archlinux.org/index.php/Be … ase_system

toni wrote:

Regarding to the other (hal, netfs) what are the equivalence in systemd? I know I should open another thread but as we are talking about it....

Are you actually using hal? It's been gone from Arch for a long time now (couple of years?).

netfs is handled automatically by systemd.

Offline

#14 2013-04-29 18:58:19

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,071

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Scimmia wrote:

Are you actually using hal? It's been gone from Arch for a long time now (couple of years?).

Question is, are you using Arch or a derivative of Arch ?


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#15 2013-04-29 19:30:32

toni
Member
Registered: 2011-10-15
Posts: 395

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Inxsible wrote:
Scimmia wrote:

Are you actually using hal? It's been gone from Arch for a long time now (couple of years?).

Question is, are you using Arch or a derivative of Arch ?

I am using original Arch. Not derivative.

Offline

#16 2013-04-29 19:31:52

toni
Member
Registered: 2011-10-15
Posts: 395

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Scimmia wrote:
toni wrote:

Regarding to hwclock I have read in arch wiki that it is no longer used by systemd (it is not necessary) so I wonder If I can remove from daemons. Can I remove hwclock from daemons? If I remove it, is it necessary to do something else?

You just need to set your configuration files up like you would in any install. Instructions here: https://wiki.archlinux.org/index.php/Be … ase_system

toni wrote:

Regarding to the other (hal, netfs) what are the equivalence in systemd? I know I should open another thread but as we are talking about it....

Are you actually using hal? It's been gone from Arch for a long time now (couple of years?).

netfs is handled automatically by systemd.

I have removed DAEMONS line from /etc/rc.conf and all continue working ok, so no hwclock, hal, netfs being used. Now they are completely migrated to systemd.

Offline

#17 2013-04-29 19:39:20

toni
Member
Registered: 2011-10-15
Posts: 395

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

mich41 wrote:
toni wrote:

If I executed  "timedatectl status" it outputs below information. The correct hour is shown by UTC, so why arch is not showing it? and why is showing the incorrect one (local time) instead?

      Local time: lun 2013-04-29 22:13:57 CEST
  Universal time: lun 2013-04-29 20:13:57 UTC
        RTC time: lun 2013-04-29 20:13:57
        Timezone: Europe/Madrid (CEST, +0200)

Your Arch configuration is correct. You don't need to mess with rc.conf, init scripts, ntpd or anything else.

Your RTC needs to be set to UTC, not CEST. Adjust it by -2 and fix Windows.

By RTC I understand the Real TIme Clock, that is, CMOS clock (that appears in BIOS). My RTC (from BIOS) is set to UTC, but once Arch boots it shows the local time CEST and I want to be shown the UTC which is the correct right now.

When you say my RTC needs to be set to UTC, I understand that below steps should be performed:

1.- Enter in BIOS
2.- Set the correct time in BIOS (the UTC time)
3.- Save changes

and finally boot up arch. Am I right? If not, could you please indicate me how to do it?

Thanks in advance.

Last edited by toni (2013-04-29 19:40:19)

Offline

#18 2013-04-29 19:52:55

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 4,978

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

toni wrote:

When you say my RTC needs to be set to UTC, I understand that below steps should be performed:

1.- Enter in BIOS
2.- Set the correct time in BIOS (the UTC time)
3.- Save changes

and finally boot up arch. Am I right? If not, could you please indicate me how to do it?

Thanks in advance.

Yes, that is how you do it, but:

toni wrote:

My RTC (from BIOS) is set to UTC, but once Arch boots it shows the local time CEST and I want to be shown the UTC which is the correct right now.

Is completely wrong. First, from what I can tell, your RTC is not set to UTC like you seem think it is, it's set to CEST. Second, you do not want linux to show UTC, you want the RTC to be the correct UTC, so that when linux applies the timezone correction, you end up with the correct CEST.

Note that in this configuration, you need to make a registry change in Windows so that it knows that the clock is UTC.

Last edited by Scimmia (2013-04-29 19:54:44)

Offline

#19 2013-04-29 19:56:20

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,965

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Can you please post the output of hwclock --debug   ??


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Online

#20 2013-04-29 20:04:06

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,812
Website

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

toni wrote:

but once Arch boots it shows the local time CEST and I want to be shown the UTC which is the correct right now.

So you want your local time to display time for a different timezone?  Then set your timezone to somewhere equivalent to UTC.  You've set your time zone to CEST, and you are suprised that your time is displayed in CEST??


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Online

#21 2013-04-29 20:30:06

toni
Member
Registered: 2011-10-15
Posts: 395

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Scimmia wrote:
toni wrote:

When you say my RTC needs to be set to UTC, I understand that below steps should be performed:

1.- Enter in BIOS
2.- Set the correct time in BIOS (the UTC time)
3.- Save changes

and finally boot up arch. Am I right? If not, could you please indicate me how to do it?

Thanks in advance.

Yes, that is how you do it, but:

toni wrote:

My RTC (from BIOS) is set to UTC, but once Arch boots it shows the local time CEST and I want to be shown the UTC which is the correct right now.

Is completely wrong. First, from what I can tell, your RTC is not set to UTC like you seem think it is, it's set to CEST. Second, you do not want linux to show UTC, you want the RTC to be the correct UTC, so that when linux applies the timezone correction, you end up with the correct CEST.

Note that in this configuration, you need to make a registry change in Windows so that it knows that the clock is UTC.

FInally I have solved by setting RTC in BIOS to -2 hours and creating the following registry key in Windows to indicate it is UTC:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
“RealTimeIsUniversal”=dword:00000001

so now it is working in dual boot, both OSes are shown the correct time right now because both are guessing that RTC is configured in UTC.

The output for "timedatectl status" is:

      Local time: lun 2013-04-29 22:31:21 CEST
  Universal time: lun 2013-04-29 20:31:21 UTC
        RTC time: lun 2013-04-29 20:31:21
        Timezone: Europe/Madrid (CEST, +0200)
     NTP enabled: n/a
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  dom 2013-03-31 01:59:59 CET
                  dom 2013-03-31 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dom 2013-10-27 02:59:59 CEST
                  dom 2013-10-27 02:00:00 CET

As I understand and after reading a lot of wikis, the problem was that arch (and linux distros and like MacOS) by default takes RTC as UTC and Win OSes as Localtime. So there are two options to solve it as I understand when dual boot is used:

1) Set RTC (hardware clock in BIOS) in localtime so it implies to tell linux it is set as local by doing "timedatectl set-local-rtc 1" and leave WIndows untouched as by default it suppose RTC is in Local and no need to create any registry key as above indicated.

2) Set RTC in UTC, in my case -2 hours, so it implies to leave linux untouched as by default linux interprets that RTC is in UTC, and to do some modifications in Windows, that is, create a registry key like above commented in order to indicate Windows that RTC has to be taken into account as UTC. CAUTION!!!! -> THIS METHOD IS NOT VALID AND NOT RECOMMENDED FOR  Windows Server 2008, Windows 7, and Windows Server 2008 R2 (See this link for more details and also what David Batson says in the post below: http://support.microsoft.com/kb/2687252).

In my case I have choosen option 2.


Thanks all for your support.

Last edited by toni (2013-05-05 09:20:34)

Offline

#22 2013-04-29 23:42:58

Trilby
Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 13,812
Website

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

*headdesk*

Yes, those are the very same options in the wiki and the ones you missed in many recommendations in this thread as you insisted your hwclock was in UTC, which apparently it was not.


InterrobangSlider
• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.

Online

#23 2013-05-05 07:29:38

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

toni wrote:

FInally I have solved by setting RTC in BIOS to -2 hours and creating the following registry key in Windows to indicate it is UTC:

[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\TimeZoneInformation]
“RealTimeIsUniversal”=dword:00000001

so now it is working in dual boot, both OSes are shown the correct time right now because both are guessing that RTC is configured in UTC.

The output for "timedatectl status" is:

      Local time: lun 2013-04-29 22:31:21 CEST
  Universal time: lun 2013-04-29 20:31:21 UTC
        RTC time: lun 2013-04-29 20:31:21
        Timezone: Europe/Madrid (CEST, +0200)
     NTP enabled: n/a
NTP synchronized: no
 RTC in local TZ: no
      DST active: yes
 Last DST change: DST began at
                  dom 2013-03-31 01:59:59 CET
                  dom 2013-03-31 03:00:00 CEST
 Next DST change: DST ends (the clock jumps one hour backwards) at
                  dom 2013-10-27 02:59:59 CEST
                  dom 2013-10-27 02:00:00 CET

As I understand and after reading a lot of wikis, the problem was that arch (and linux distros and like MacOS) by default takes RTC as UTC and Win OSes as Localtime. So there are two options to solve it as I understand when dual boot is used:

1) Set RTC (hardware clock in BIOS) in localtime so it implies to tell linux it is set as local by doing "timedatectl set-local-rtc 1" and leave WIndows untouched as by default it suppose RTC is in Local and no need to create any registry key as above indicated.

2) Set RTC in UTC, in my case -2 hours, so it implies to leave linux untouched as by default linux interprets that RTC is in UTC, and to do some modifications in Windows, that is, create a registry key like above commented in order to indicate Windows that RTC has to be taken into account as UTC.

In my case I have choosen option 2.


Thanks all for your support.

I have a similar setup with Archlinux, Fedora, Mageia, and Windows 7.  I used the registry fix in Windows 7 and it seemed to go alright.

I also have a second hard disk that I sometimes use with this laptop through an expansion bay.  This second hard drive has Bodhi Linux and Windows 8.  While researching to see if I could use this registry fix in Windows 8, I read that either it does not work, or causes problems.  The Archwiki on Time states (regarding this registry fix): "Note: The following method is not supported in Windows 8 and Windows Server 2012. Your only current option is to use localtime instead of UTC, as described above."
https://wiki.archlinux.org/index.php/Ti … in_Windows

Furthermore, I ran across the following information regarding Windows 7 and that registry hack.

Microsoft wrote:

Symptoms
Microsoft is aware of a potential system unresponsiveness issue that may be caused by using the RealTimeIsUniversal registry entry for the Daylight Saving Time (DST) changeover.

Resolution
A hotfix is available to resolve this issue in Windows Server 2008, Windows 7, and Windows Server 2008 R2.  For more information, click the following article number to view the article in the Microsoft Knowledge Base:
2800213 High CPU usage during DST changeover in Windows Server 2008, Windows 7, or Windows Server 2008 R2
We strongly recommend that you not use the RealTimeIsUniversal registry entry. This issue does not occur if you do not use this entry.

We recommend that you remove the RealTimeIsUniversal value from the registry or set its value to 0. This will prevent the system from becoming unresponsive during the DST changeover.

In light of this, I plan to have my Linux distros use local time instead of UTC time as in Option 1 above.
http://support.microsoft.com/kb/2687252

EDIT2: Nevermind.  Previous edit had incorrect info.

Last edited by David Batson (2013-05-05 09:09:39)

Offline

#24 2013-05-05 09:31:59

toni
Member
Registered: 2011-10-15
Posts: 395

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

David Batson wrote:

In light of this, I plan to have my Linux distros use local time instead of UTC time as in Option 1 above.
http://support.microsoft.com/kb/2687252

Good job David! I have corrected the information posted in post 2 by putting a warning for those OSes.
Anyway, if you choose option 1), the issue posted originally for Win8 is not solved and doing this arch linux does not change automatically to the correct hour when necessary (Your clock will not be adjusted automatically for DST if your hwclock is not set to use UTC.) so as I understand there is no solution in this case, right?

Offline

#25 2013-05-05 09:58:04

David Batson
Member
Registered: 2011-10-13
Posts: 640

Re: [SOLVED] HOWTO:Set correct time-Avoid UTC/LocalTime conflict Dual-Boot

Well, I've got all my OS's showing the current local time on their relevant clock applets.  The BIOS hardware clock is set to local time.  Not sure how DST will be affected when the time changes.

Offline

Board footer

Powered by FluxBB