You are not logged in.

#1 2013-04-29 19:06:00

georgi-it
Member
Registered: 2013-04-29
Posts: 14

[SOLVED] [KDE] Strange colors in applications

Hello, i am new to Arch Linux and KDE, i have been using Gnome on Mint 14 lately but today i switched to Arch. I have a very weird problem: after tuning the KDE's desktop settings to increase the performance i changed a few things, here's a screenshot of the current settings

pic3kg.jpg


I changed them a few times until i found the effect i was looking for but i stumbled into another problem - some of the applications started to have strange colors in the menus, and that happened only to external apllcations, not in dolphin or widgets or something like that. Here are the screenshots

pic2xaa.jpg
pic1xg.jpg

Can anyone please tell me what can the problem be or atleast give me some starting point because i don't know where to start looking from. I can uninstall and reinstall KDE completely but that takes about 40 minutes and i can't know if it will work.

Thank you all in advance i really appreciate it and i really love the distro smile.

P.S i am using Nvidia 9800GTX+ video card with nvidia drivers.

Last edited by georgi-it (2013-04-29 21:16:58)

Offline

#2 2013-04-29 19:54:03

genghizkhan91
Member
From: Kyoto, Japan
Registered: 2013-03-26
Posts: 32
Website

Re: [SOLVED] [KDE] Strange colors in applications

What other applications does this affect, apart from Aptana Studio and Sublime Text? Does it affect GTK applications (viz. Firefox and Deluge) as well? Does it also affect other (non kdebase) KDE applications like Amarok?


Dotfiles | Blog
ArchLinux 64 - Dell Studio 1458, Intel Nehalem i5 460M 2.54 GHz, 4GB RAM, ATI Radeon 5450

Offline

#3 2013-04-29 19:57:19

georgi-it
Member
Registered: 2013-04-29
Posts: 14

Re: [SOLVED] [KDE] Strange colors in applications

genghizkhan91 wrote:

What other applications does this affect, apart from Aptana Studio and Sublime Text? Does it affect GTK applications (viz. Firefox and Deluge) as well? Does it also affect other (non kdebase) KDE applications like Amarok?

It effects Chrome but does not effect Deluge and VLC

Basically i think it effects external applications but not KDE based ones :?

Last edited by georgi-it (2013-04-29 19:59:56)

Offline

#4 2013-04-29 20:00:32

Inxsible
Forum Fellow
From: Chicago
Registered: 2008-06-09
Posts: 9,079

Re: [SOLVED] [KDE] Strange colors in applications

georgi-it, welcome to the forums. Please read the forum rules and abide by them. You shouldn't be posting full size images. This is your 2nd thread today where I have removed images.


Forum Rules

There's no such thing as a stupid question, but there sure are a lot of inquisitive idiots !

Offline

#5 2013-04-29 20:02:18

genghizkhan91
Member
From: Kyoto, Japan
Registered: 2013-03-26
Posts: 32
Website

Re: [SOLVED] [KDE] Strange colors in applications

The fix I'm gonna suggest is pretty stop-gap (I don't know any better, honestly), but try removing your ~/.kde4 folder and restarting KDE. This should give you a brand new KDE to work with. Now don't change any settings, just keep them the way they are and see if Chrome still shows the same problems.


Dotfiles | Blog
ArchLinux 64 - Dell Studio 1458, Intel Nehalem i5 460M 2.54 GHz, 4GB RAM, ATI Radeon 5450

Offline

#6 2013-04-29 20:07:03

georgi-it
Member
Registered: 2013-04-29
Posts: 14

Re: [SOLVED] [KDE] Strange colors in applications

Inxsible wrote:

georgi-it, welcome to the forums. Please read the forum rules and abide by them. You shouldn't be posting full size images. This is your 2nd thread today where I have removed images.

I am really sorry they actually had to be resized on upload, it won't happen again.

genghizkhan91 wrote:

The fix I'm gonna suggest is pretty stop-gap (I don't know any better, honestly), but try removing your ~/.kde4 folder and restarting KDE. This should give you a brand new KDE to work with. Now don't change any settings, just keep them the way they are and see if Chrome still shows the same problems.

Yeah i was looking for a way to "clear" KDE, i am going to test that in a minute and get back to you.

Offline

#7 2013-04-29 20:16:14

georgi-it
Member
Registered: 2013-04-29
Posts: 14

Re: [SOLVED] [KDE] Strange colors in applications

genghizkhan91 wrote:

The fix I'm gonna suggest is pretty stop-gap (I don't know any better, honestly), but try removing your ~/.kde4 folder and restarting KDE. This should give you a brand new KDE to work with. Now don't change any settings, just keep them the way they are and see if Chrome still shows the same problems.

Cleared it, obviously kde is   brand new but the colors are still there. Maybe it has something to do with the drivers?

Offline

#8 2013-04-29 20:31:37

genghizkhan91
Member
From: Kyoto, Japan
Registered: 2013-03-26
Posts: 32
Website

Re: [SOLVED] [KDE] Strange colors in applications

Hmm... That seems doubtful. Try deleting your .gtkrc-2.0 and restarting KDE.


Dotfiles | Blog
ArchLinux 64 - Dell Studio 1458, Intel Nehalem i5 460M 2.54 GHz, 4GB RAM, ATI Radeon 5450

Offline

#9 2013-04-29 20:34:31

georgi-it
Member
Registered: 2013-04-29
Posts: 14

Re: [SOLVED] [KDE] Strange colors in applications

genghizkhan91 wrote:

Hmm... That seems doubtful. Try deleting your .gtkrc-2.0 and restarting KDE.

Well, that worked. Thank you a ton man smile

Offline

#10 2013-04-29 21:14:50

genghizkhan91
Member
From: Kyoto, Japan
Registered: 2013-03-26
Posts: 32
Website

Re: [SOLVED] [KDE] Strange colors in applications

Glad to help. smile Mark the thread as solved by editing the original post by clicking on the 'edit' button at the lower right corner of it and prepending [SOLVED] to the title.


Dotfiles | Blog
ArchLinux 64 - Dell Studio 1458, Intel Nehalem i5 460M 2.54 GHz, 4GB RAM, ATI Radeon 5450

Offline

Board footer

Powered by FluxBB