You are not logged in.

#1 2013-05-03 20:19:28

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

[solved] gtk-update-icon-cache: error while loading shared libraries

[2013-05-03 21:38] [PACMAN] Running 'pacman -Syu'
[2013-05-03 21:38] [PACMAN] synchronizing package lists
[2013-05-03 21:38] [PACMAN] starting full system upgrade
[2013-05-03 21:43] [PACMAN] upgraded avahi (0.6.31-6 -> 0.6.31-7)
[2013-05-03 21:43] [PACMAN] upgraded libpng (1.5.15-1 -> 1.6.2-2)
[2013-05-03 21:44] [PACMAN] upgraded cairo (1.12.14-3 -> 1.12.14-4)
[2013-05-03 21:44] [PACMAN] upgraded dbus (1.6.8-6 -> 1.6.10-1)
[2013-05-03 21:44] [PACMAN] upgraded dhcpcd (5.6.7-1 -> 5.6.8-1)
[2013-05-03 21:44] [PACMAN] upgraded gcc-libs (4.8.0-3 -> 4.8.0-4)
[2013-05-03 21:44] [PACMAN] upgraded dosbox (0.74-3 -> 0.74-5)
[2013-05-03 21:44] [ALPM-SCRIPTLET] gtk-update-icon-cache: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-03 21:44] [PACMAN] upgraded firefox (20.0.1-2 -> 20.0.1-4)
...

I think this is due to firefox' post_install

post_install() {
  update-desktop-database -q
  gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
}

post_upgrade() {
  post_install
}

post_remove() {
  post_install
}

Running the commands from post_install by hand worked fine.

Are things like this bound to happen after rebuilds (libpng 1.5 -> 1.6) or is it something that needs fixing?

Last edited by karol (2013-05-07 20:32:12)

Offline

#2 2013-05-03 22:01:28

brebs
Member
Registered: 2007-04-03
Posts: 3,466

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

karol wrote:

gtk-update-icon-cache: error while loading shared libraries: libpng15.so.15: cannot open shared object file: No such file or directory

gtk2 needs a rebuild, which provides gtk-update-icon-cache.

You'll see it better with:

$ ldd /usr/bin/gtk-update-icon-cache | grep png
	libpng15.so.15 => /usr/lib/libpng15.so.15 (0xb72f0000)

That's the sort of output you *should* see, rather than "missing" wink

Last edited by brebs (2013-05-03 22:03:19)

Offline

#3 2013-05-03 22:26:05

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

brebs wrote:

gtk2 needs a rebuild

Not gtk2, but gdk-pixbuf2. The thing is though, it *did* get rebuilt.

karol, did you maybe do a partial update? gdk-pixbuf2-2.28.1-2 should've gotten installed at the same time as libpng-1.6.2

Last edited by Gusar (2013-05-03 22:27:07)

Offline

#4 2013-05-03 22:29:48

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 20,081
Website

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

I got the same error; I suspect it was the order. I just pacman -S'ed pixbuf after the -Syu and it went fine...


Arch + dwm   •   Mercurial repos  •   Github

Registered Linux User #482438

Online

#5 2013-05-03 23:02:43

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

I did check gdk-pixbuf2, firefox etc. versions and they're all correct (according to http://www.archlinux.org/packages/ ) so this was a proper upgrade, not a partial one.
I should have posted the whole log instead of skipping the rest with '..' ;P

[2013-05-03 21:38] [PACMAN] Running 'pacman -Syu'
[2013-05-03 21:38] [PACMAN] synchronizing package lists
[2013-05-03 21:38] [PACMAN] starting full system upgrade
[2013-05-03 21:43] [PACMAN] upgraded avahi (0.6.31-6 -> 0.6.31-7)
[2013-05-03 21:43] [PACMAN] upgraded libpng (1.5.15-1 -> 1.6.2-2)
[2013-05-03 21:44] [PACMAN] upgraded cairo (1.12.14-3 -> 1.12.14-4)
[2013-05-03 21:44] [PACMAN] upgraded dbus (1.6.8-6 -> 1.6.10-1)
[2013-05-03 21:44] [PACMAN] upgraded dhcpcd (5.6.7-1 -> 5.6.8-1)
[2013-05-03 21:44] [PACMAN] upgraded gcc-libs (4.8.0-3 -> 4.8.0-4)
[2013-05-03 21:44] [PACMAN] upgraded dosbox (0.74-3 -> 0.74-5)
[2013-05-03 21:44] [ALPM-SCRIPTLET] gtk-update-icon-cache: error while loading shared libra
ries: libpng15.so.15: cannot open shared object file: No such file or directory
[2013-05-03 21:44] [PACMAN] upgraded firefox (20.0.1-2 -> 20.0.1-4)
[2013-05-03 21:44] [PACMAN] upgraded gcc (4.8.0-3 -> 4.8.0-4)
[2013-05-03 21:44] [PACMAN] upgraded gd (2.0.36RC1-5 -> 2.0.36RC1-6)
[2013-05-03 21:44] [PACMAN] upgraded gdk-pixbuf2 (2.28.1-1 -> 2.28.1-2)
[2013-05-03 21:44] [PACMAN] upgraded imlib2 (1.4.5-2 -> 1.4.5-4)
[2013-05-03 21:44] [PACMAN] upgraded libpipeline (1.2.2-1 -> 1.2.3-1)
[2013-05-03 21:44] [PACMAN] upgraded libpulse (3.0-3 -> 3.99.1-1)
[2013-05-03 21:44] [PACMAN] upgraded linux-firmware (20121118-1 -> 20130430-1)
[2013-05-03 21:44] [PACMAN] upgraded util-linux (2.22.2-2 -> 2.23-1)
[2013-05-03 21:44] [PACMAN] upgraded mkinitcpio (0.13.0-1 -> 0.14.0-1)
[2013-05-03 21:45] [ALPM-SCRIPTLET] >>> Updating module dependencies. Please wait ...

<snip>

[2013-05-03 21:45] [PACMAN] upgraded linux (3.8.10-1 -> 3.9-2)
[2013-05-03 21:45] [PACMAN] upgraded lirc-utils (1:0.9.0-43 -> 1:0.9.0-44)
[2013-05-03 21:45] [PACMAN] upgraded logrotate (3.8.3-1 -> 3.8.4-1)
[2013-05-03 21:45] [PACMAN] upgraded mplayer2 (20130309-1 -> 20130309-2)
[2013-05-03 21:45] [PACMAN] upgraded pciutils (3.1.10-1 -> 3.2.0-2)
[2013-05-03 21:45] [PACMAN] upgraded sdl_image (1.2.12-2 -> 1.2.12-3)
[2013-05-03 21:45] [PACMAN] upgraded sox (14.4.1-1 -> 14.4.1-2)
[2013-05-03 21:46] [PACMAN] upgraded webkitgtk2 (1.10.2-4 -> 1.10.2-5)

Last edited by karol (2013-05-03 23:03:36)

Offline

#6 2013-05-03 23:27:48

brebs
Member
Registered: 2007-04-03
Posts: 3,466

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

gdk-pixbuf2 should have been upgraded after libpng (which it was) but also *before* firefox wink

Offline

#7 2013-05-03 23:45:36

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

Yeah, like jasonwryan said, ordering issue. Icon cache update failed that one time because libpng got updated, but not yet gdk-pixbuf2. But later you did get the new gdk-pixbuf2, so everything is ok.

Offline

#8 2013-05-04 00:03:46

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

karol wrote:

Are things like this bound to happen after rebuilds (libpng 1.5 -> 1.6) or is it something that needs fixing?

Gusar wrote:

Icon cache update failed that one time because libpng got updated, but not yet gdk-pixbuf2. But later you did get the new gdk-pixbuf2, so everything is ok.

I meant should I fill a bug report about this?
Sorry if I was not clear, but hey, I've been on this forum for just 4 years ;P

Offline

#9 2013-05-06 09:23:19

wroobel
Member
From: Poland
Registered: 2010-03-27
Posts: 7

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

Is this somehow related or should I start a new thread?

[***@arch-desktop ~]$ firefox 
XPCOMGlueLoad error for file /usr/lib/firefox/libxpcom.so:
libpng15.so.15: cannot open shared object file: No such file or directory
Couldn't load XPCOM.
[***@arch-desktop ~]$ ldd /usr/bin/gtk-update-icon-cache | grep png
        libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007fd10743e000)
[***@arch-desktop ~]$ LC_ALL=C sudo pacman -Syu
:: Synchronizing package databases...
 testing is up to date
 core is up to date
 extra is up to date
 community-testing is up to date
 community is up to date
 multilib-testing is up to date
 multilib is up to date
:: Starting full system upgrade...
 there is nothing to do

Last edited by wroobel (2013-05-06 09:24:53)

Offline

#10 2013-05-06 11:19:09

Gusar
Member
Registered: 2009-08-25
Posts: 3,500

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

Looks different. And weird, because the latest Firefox (20.0.1-4) does not even use the system libpng, but it's internal version. Check that your Firefox package is at 20.0.1-4, and even if it is, re-install it.

Edit: 20.0.1-5 was just built, it uses system libpng again. This one should definitely work.

Last edited by Gusar (2013-05-06 12:11:16)

Offline

#11 2013-05-06 12:10:15

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

@wroobel
Are you using the stock cairo package from [testing]?
firefox is now at version 20.0.1-5.

Offline

#12 2013-05-06 12:14:41

wroobel
Member
From: Poland
Registered: 2010-03-27
Posts: 7

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

Gusar wrote:

Check that your Firefox package is at 20.0.1-4

Yes it is.

Gusar wrote:

and even if it is, re-install it.

I've tried, just before I wrote my previous post.

karol wrote:

Are you using the stock cairo package from [testing]?

This is it. I've just rebuild cairo-ubuntu.

Thank you guys for your replies.

Last edited by wroobel (2013-05-06 12:38:50)

Offline

#13 2013-05-06 22:21:34

flipper T
Member
Registered: 2012-09-14
Posts: 419

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

I think that I have run into the same issue in the non-testing repo.

I have posted here: https://bbs.archlinux.org/viewtopic.php … 0#p1268850

as I was not sure that it was exactly the same. Could a mod kindly merge the 2, if required.

Thanks


If I'm curt with you it's because time is a factor. I think fast, I talk fast and I need you guys to act fast if you wanna get out of this. So, pretty please... with sugar on top. Clean the [censored] car. -The Wolf

Offline

#14 2013-05-07 08:08:23

Edward.H
Member
Registered: 2009-10-26
Posts: 69
Website

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

i got exactly same problem and solved it by rebuild cairo-ubuntu via yaourt.

Offline

#15 2013-05-07 20:31:51

karol
Archivist
Registered: 2009-05-06
Posts: 25,433

Re: [solved] gtk-update-icon-cache: error while loading shared libraries

Somebody opened a bug report and it has been closed as "nothing terrible happened, just a package update ordering issue": https://bugs.archlinux.org/task/35133

I'm marking this thread as solved.

Offline

Board footer

Powered by FluxBB