You are not logged in.

#1 2013-05-09 01:22:32

K3fka
Member
From: Florida
Registered: 2011-12-04
Posts: 10

Trendnet TEW-643PI

Hi, I just bought a new wireless network card today, the Trendnet TEW-643PI. I got it working in Windows 7 with minimal trouble, but I can't get it working in Arch.

When I run iwconfig, the interface is listed as having "no wireless extensions."

Running lspci gives me this:

 05:00.0 Network controller: Realtek Semiconductor Co., Ltd. RTL8190 802.11n Wireless LAN

So where do I go from here?

Offline

#2 2013-05-09 01:42:32

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,829

Re: Trendnet TEW-643PI

Could you please run that again as lspci -nn   (that is two n's, not m)
Also, could you pastebin the output of dmesg and provide a link? (wgetpaste is a good tool for that)


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#3 2013-05-09 13:35:51

K3fka
Member
From: Florida
Registered: 2011-12-04
Posts: 10

Re: Trendnet TEW-643PI

Thanks for responding.
Alright, here is the output of lspci -nn.

And here is the dmesg output.

Also, I should probably note that I am just running the environment from the live usb, so I don't have X or anything up and running, just the good ol' ttys.

Offline

#4 2013-05-09 15:25:43

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 13,829

Re: Trendnet TEW-643PI

Can you please see if the module r8192e_pci is loaded into the kernel? lsmod | grep 8192
If is not there, what happens if you try a # modprobe r8192_pci   ??   If that is silent, does a wireless NIC appear? Does it add anything interesting to the end of dmesg output?


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
You assume people are rational and influenced by evidence.  You must not work with the public much. -- Trilby
----
How to Ask Questions the Smart Way

Offline

#5 2013-05-10 03:11:30

K3fka
Member
From: Florida
Registered: 2011-12-04
Posts: 10

Re: Trendnet TEW-643PI

Okay, so the module was not loaded, according to lsmod. I loaded it with modprobe, and there was no output. iwconfig still says there's no wireless extension of the interface.

Here is the dmesg output after the modprobe.

Offline

Board footer

Powered by FluxBB