You are not logged in.

#1 2013-05-12 13:54:08

Registered: 2013-05-12
Posts: 14

[Solved] Can't access tty (nor systemctl rescue)

Good afternoon

I just saw I have a little problem with my archlinux.
Indeed, while I wanted to use systemctl rescue to realloc with e4-rat, It appeared that I could'nt access the rescue mode.
It switches to a consoles screen, I guess, but i can't see anything ; the same thing happens when i try to use a tty (from 1 to 6, each one).
However, I am still able to go back to the desktop environment by typing Ctl+D in rescue mode, and goinb back to tty7.

Even if i don't use them often, it seems to me that it could be very dangerous if i have any problem.
I reaaly don't know what could have caused this, since i update my system daily, i don't modify any of important files (such as the ones in /etc that i don't know) and i noticed this only today.

Does anyone know how to fix this ?


P.S. : i'm not a native english speaker, so sorry if i make mistakes.

Last edited by nyddogghr (2013-05-12 15:46:40)


#2 2013-05-12 15:16:20

Forum Moderator
From: Massachusetts, USA
Registered: 2011-11-29
Posts: 15,108

Re: [Solved] Can't access tty (nor systemctl rescue)

What graphics card and driver do you use?  I've heard of such issues with some of the closed source drivers.

• How's my coding? See this page.
• How's my moderating? Feel free to email any concerns, complaints, or objections.


#3 2013-05-12 15:35:23

Registered: 2013-05-12
Posts: 14

Re: [Solved] Can't access tty (nor systemctl rescue)

Hum, it can indeed comes from that.
I've changed my drivers about a week ago.
I have an AMD HD Radeon 6500.
I use catalyst and catalyst-utils from Vi0l0's repository.
I have to mention that i had a little problem installing them, because i had these drivers from AUR also, and the only way i found to change was by forcing installation of those from Vi0l0.

//And now that i've checked, it appears that, according to yaourt, i have catalyst not installed Oo

//I install it and then reply again.

[Edit] In fact, as i have catalyst-hhok, i don't need catalyst, if i'm right.

Last edited by nyddogghr (2013-05-12 15:37:47)


#4 2013-05-12 15:45:51

Registered: 2013-05-12
Posts: 14

Re: [Solved] Can't access tty (nor systemctl rescue)

It was indeed the problem.
I checked on the catalyst page on the wiki (i didn't think of looking for a solution there, originally).
There was a solution for this problem.

And so i solved it as they say : putting vga=0x0323 on my kernel line.

Thanks a lot !


Board footer

Powered by FluxBB