You are not logged in.

#1 2013-05-14 21:32:56

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

LibreOffice Fonts are Glyphs

I recently installed LibreOffice 4.0.3.3 on a fresh install of Arch. When I launch it all of the text is represented as weird glyphs resembling []. This can be seen from the attached screenshot. Also when I launch it from the terminal "Lookup Table Format4: specific interpretation needed!" is displayed a bunch of times. I have spent a lot of time googling around for a solution but was only able to find a few artlices about OpenOffice. Although I know the two of them are very similar, the solutions I found were unsuccessful. I am sure this is probably an easy fix but any information would be much appreciated.

http://i.imgur.com/kzSzLd4.png

Last edited by Gr0t92 (2013-05-15 22:41:37)

Offline

#2 2013-05-14 23:39:13

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: LibreOffice Fonts are Glyphs

When you are installing LibreOffice, pacman asks you to choose a language pack, are you sure you chose your language? I believe index [1] in the list is Afrikans(though I could be wrong), Since it defaults to index[1], it will choose a incorrect language. If a language that xorg did not have a character file on chart for, it would produce odd symboles. I would recommend just reinstalling it. Use:

pacman -Rs libreoffice

And reinstall. I also found this on the arch wiki:

Note:
As the language pack for en-US is no longer included by default, you will need to install at least 1 language pack. The default language is Afrikaans (because it is alphabetically the first provider of libreoffice-langpack), while the previous default (en-US) is at number 24. A common mistake is to install libreoffice-uk, which is the Ukrainian language pack, instead of libreoffice-en-GB.
You need libreoffice-kde4 or libreoffice-gnome only if you care about qt or gtk visual integration - see the #Theme section below.

As a random side note, you may want to put your pictures on a image hosting service, many times your image will get nuked unless it is smaller than say 200x200, I've been told not everyone has unlimited bandwith. Also, what WindowManager and theme is that?

Last edited by Multimoon (2013-05-14 23:39:48)


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#3 2013-05-15 22:49:43

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

Re: LibreOffice Fonts are Glyphs

Thanks for the response Multimoon but unfortunately following your advice resulted in the same odd symbols. I noticed the same excerpt from the arch wiki before I initially installed it and am pretty sure I selected the en-US language pack but went ahead and retried it just to double check. I am not sure but could this be occuring because possibly I do not have the default font that LibreOffice uses? If so what font would that be?

Also I am using openbox for my WM and the theme is Jelloir's Zarp Neon GTK2 theme http://jelloir.deviantart.com/art/Zarp-Neon-280647195

Offline

#4 2013-05-15 23:31:18

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: LibreOffice Fonts are Glyphs

Libreoffice should pull down all the fonts it _needs_, could you give me a bit more detailed information about your system, and the output of the following.

pacman -Q libreoffice
cat /etc/pacman.conf 

It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#5 2013-05-16 03:08:12

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

Re: LibreOffice Fonts are Glyphs

For some strange reason running pacman -Q libreoffice results with "error: package 'libreoffice' was not found" even when ran with root privledges. However if I run libreoffice --version it prompts "LibreOffice 4.0.3.3"


And here are the contents of /etc/pacman.conf

#
# /etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
#CacheDir    = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
HoldPkg     = pacman glibc
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

# Pacman won't upgrade packages listed in IgnorePkg and members of IgnoreGroup
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#Color
#TotalDownload
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Arch Linux
# packagers with `pacman-key --populate archlinux`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

#[testing]
#Include = /etc/pacman.d/mirrorlist

[core]
Include = /etc/pacman.d/mirrorlist

[extra]
Include = /etc/pacman.d/mirrorlist

#[community-testing]
#Include = /etc/pacman.d/mirrorlist

[community]
Include = /etc/pacman.d/mirrorlist

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

Offline

#6 2013-05-16 08:47:16

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: LibreOffice Fonts are Glyphs

Gr0t92 wrote:

For some strange reason running pacman -Q libreoffice results with "error: package 'libreoffice' was not found" even when ran with root privledges. However if I run libreoffice --version it prompts "LibreOffice 4.0.3.3"

Yes you need pacman -Qs libreoffice to list the installed packages containing that name, since all the libreoffice packages are libreoffice-xxxx


Mike C

Offline

#7 2013-05-16 11:05:04

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: LibreOffice Fonts are Glyphs

mcloaked wrote:
Gr0t92 wrote:

For some strange reason running pacman -Q libreoffice results with "error: package 'libreoffice' was not found" even when ran with root privledges. However if I run libreoffice --version it prompts "LibreOffice 4.0.3.3"

Yes you need pacman -Qs libreoffice to list the installed packages containing that name, since all the libreoffice packages are libreoffice-xxxx

Ah Yes I forgot 'libreoffice' is a group package. When I am home later today I'll install Libreoffice with a similar setting to yours, and see if I can reproduce the issue.


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#8 2013-05-16 18:42:23

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

Re: LibreOffice Fonts are Glyphs

Alright thanks. When I get home I'll post the output of pacman -Qs.  I recently converted to arch so still getting used to pacman.

Offline

#9 2013-05-16 20:50:14

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

Re: LibreOffice Fonts are Glyphs

the output of pacman -Qs libreoffice:

local/libreoffice-base 4.0.3-1 (libreoffice)
    GUI database front-end for LibreOffice. Allows creation and management of databases through a GUI.
local/libreoffice-calc 4.0.3-1 (libreoffice)
    Spreadsheet application for LibreOffice.
local/libreoffice-common 4.0.3-1 (libreoffice)
    common files for LibreOffice - a productivity suite that is compatible with other major office suites
local/libreoffice-draw 4.0.3-1 (libreoffice)
    Drawing Application for LibreOffice.
local/libreoffice-en-US 4.0.3-1
    English (US) language pack for LibreOffice
local/libreoffice-gnome 4.0.3-1 (libreoffice)
    Plug-in for LibreOffice that enables integration into the Gnome and other gtk desktop environment.
local/libreoffice-impress 4.0.3-1 (libreoffice)
    Presentation Application for LibreOffice.
local/libreoffice-kde4 4.0.3-1 (libreoffice)
    Plug-in for LibreOffice that enables integration into the KDE4 desktop environment.
local/libreoffice-math 4.0.3-1 (libreoffice)
    Equation Editor Application for LibreOffice.
local/libreoffice-postgresql-connector 4.0.3-1 (libreoffice)
    A PostgreSQL connector for the database front-end for LibreOffice
local/libreoffice-sdk 4.0.3-1 (libreoffice)
    Software Development Kit for LibreOffice.
local/libreoffice-sdk-doc 4.0.3-1 (libreoffice)
    Software Development Kit documentation for LibreOffice
local/libreoffice-writer 4.0.3-1 (libreoffice)
    Word Processor Application for LibreOffice.

Offline

#10 2013-05-17 00:05:52

Multimoon
Member
From: /usr/share/zoneinfo/US/Eastern
Registered: 2012-09-30
Posts: 169

Re: LibreOffice Fonts are Glyphs

It is possible the specific repo you are using has a corrupt package, I was unable to reproduce the issue, try updating your mirrorlist here. https://www.archlinux.org/mirrorlist/


It always makes me laugh when people complain and rage over any distro's management ideal, when this is a linux community, and you could always make your own distro and experience the pains yourself.

Offline

#11 2013-05-17 01:15:07

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

Re: LibreOffice Fonts are Glyphs

To be honest anything is possible...  I'll try this soon

Offline

#12 2013-05-19 07:07:19

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

Re: LibreOffice Fonts are Glyphs

Alright so I updated my mirrorlist, and reinstalled libreoffice again with no luck. I managed to dig up a post where this sort of thing was happening to openoffice where they claimed all that was needed to fix the issue was to change a few options in what I assume is prefrences tab then prefrences>fonts and prefrences>view. Unfortunately I was unable to recreate their success. https://bbs.archlinux.org/viewtopic.php?id=111234 This makes me think libreoffice is trying to use a font that either I do not have installed or is intended to look like odd glyphs. I think its either my font idea or possibly my gtk2 theme could be conflicting (I will disable and report back)

Offline

#13 2013-05-19 07:47:37

Gr0t92
Member
Registered: 2013-05-12
Posts: 10

Re: LibreOffice Fonts are Glyphs

Well I disabled my theme and no luck. But looking at the post I mentioned last time about openoffice again(the link again), and looking at the OpenOffice wiki page I found this:

You may wish to set the Xorg server dots-per-inch in the KDM configuration.

Do not select "use my KDE style in GTK applications". Instead choose a native syle and font for GTK2 applications.

Use a program like gtk-chtheme to select a style (in general different from KDE) and a font (may be the same as your KDE general system font). There are also other GTK engine packages available.

There are two relevant parts of the OOo options dialog, View and Fonts:

    View
        set scale to 100%.
        set use system font OFF (otherwise replacement table will not be used).
        set antialiasing OFF. 

    Fonts
        select "Use replacement table".
        replace "Andale Sans UI" (you must type this in -- it is not in the drop down list) with another font (your KDE system font or another if this looks bad).
        Press the tick symbol to update the list.
        Select "always" and "screen only".
        Press OK. 

I was able to find the View and Fonts menus but besides that everything else is unreadable so I really cannot play with the settings.
http://i.imgur.com/EL0D1VO.png
http://i.imgur.com/BSiyCOU.png

Offline

Board footer

Powered by FluxBB