You are not logged in.

#1 2012-10-11 21:39:33

gamanakis
Member
Registered: 2012-10-11
Posts: 17

[Solved] No NAP tethering by Bluez

The default bluez package fails to tether with a mobile phone (e.g. iPhone, Galaxy Nexus).
journalctl shows

Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> Activation (XX:XX:XX:XX:XX:XX) Stage 1 of 5 (Device Prepare) started...
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> Activation (XX:XX:XX:XX:XX:XX) Stage 2 of 5 (Device Configure) scheduled...
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> Activation (XX:XX:XX:XX:XX:XX) Stage 1 of 5 (Device Prepare) complete.
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> Activation (XX:XX:XX:XX:XX:XX) Stage 2 of 5 (Device Configure) starting...
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> (XX:XX:XX:XX:XX:XX): device state change: prepare -> config (reason 'none') [40 50 0]
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> Activation (XX:XX:XX:XX:XX:XX) Stage 2 of 5 (Device Configure) complete.
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <warn> Error connecting with bluez: Method "Connect" with signature "s" on interface "org.bluez.Network" doesn't exist
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> (XX:XX:XX:XX:XX:XX): device state change: config -> failed (reason 'bluetooth-failed') [50 120 44]
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> Marking connection 'Galaxy Nexus Network' invalid.
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <warn> Activation (XX:XX:XX:XX:XX:XX) failed for connection 'Galaxy Nexus Network'
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> (XX:XX:XX:XX:XX:XX): device state change: failed -> disconnected (reason 'none') [120 30 0]
Oct 11 23:13:24 scythe-thinkpad NetworkManager[248]: <info> (XX:XX:XX:XX:XX:XX): deactivating device (reason 'none') [0]

The problem is solved as reported here: (patches bluez-4.101-network[1-4].patch)
http://sources.gentoo.org/cgi-bin/viewv … uez/files/

I updated the PKGBUILD and can report that afterwards with those patches enabled the tethering functions properly.

Last edited by gamanakis (2012-10-12 11:31:08)

Offline

#2 2013-03-11 20:49:15

Fedes
Member
From: Buenos Aires, Argentina
Registered: 2012-10-23
Posts: 36

Re: [Solved] No NAP tethering by Bluez

Hello, could you please clarify how to fix this? Where did you get the PKGBUILD from?

Thanks,

Offline

#3 2013-03-14 21:43:27

gamanakis
Member
Registered: 2012-10-11
Posts: 17

Re: [Solved] No NAP tethering by Bluez

Source files, patches and patched PKGBUILD here.

Offline

#4 2013-05-19 13:39:40

OlafLostViking
Member
From: Lost
Registered: 2013-01-30
Posts: 47

Re: [Solved] No NAP tethering by Bluez

Just passing by to say thank you smile

BTW: the Arch Bug is 33020

Offline

#5 2013-06-09 20:09:54

OlafLostViking
Member
From: Lost
Registered: 2013-01-30
Posts: 47

Re: [Solved] No NAP tethering by Bluez

There's a new bug report - the most important change is the renaming of the package from bluez to bluez4.

https://bugs.archlinux.org/task/35695

Offline

#6 2013-06-23 10:55:45

C@illou
Member
Registered: 2013-06-23
Posts: 2

Re: [Solved] No NAP tethering by Bluez

gamanakis wrote:

Source files, patches and patched PKGBUILD here.

Hey, just registered to thank you! Just installed your patched package, now my android phone works perfectly well in bluetooth internet tethering. I've had this problem for several weeks now.

Offline

Board footer

Powered by FluxBB