You are not logged in.

#1 2013-05-15 14:05:35

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

[SOLVED] ndiswrapper requires manual install

Hi all,

For some time now I found that, while the ndiswrapper package is up to date in the repository, pacman -S ndiswrapper and variants seem to sync to a less recent version of the package. Manual downloading the package from the archlinux website works, so it's a problem that can be bypassed. But of course, I'm curious what's going on.

I checked /etc/pacman.conf, and there's no entry of ndiswrapper there, so I don't think I accidentally fudged anything?

Thanks.

Last edited by dumas (2013-06-16 10:15:11)


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#2 2013-05-15 14:07:34

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] ndiswrapper requires manual install

The package has just been updated https://www.archlinux.org/packages/?sort=&q=ndiswrapper and the mirrors you're using haven't synced it yet.

Offline

#3 2013-05-19 12:36:04

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Haha thanks for the quick reply.

I tried pacman -Syu just now, it gives

warning: ndiswrapper: local (1.58-9) is newer than community (1.57-20)

?


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#4 2013-05-19 12:43:53

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] ndiswrapper requires manual install

https://www.archlinux.org/packages/?name=ndiswrapper : ndiswrapper 1.58-9
Seems you have the most up-to-date version installed.

Try running 'pacman -Syyu' to force redownloading package databases.

Offline

#5 2013-05-19 13:41:31

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Thanks for the suggestion, I never knew the Syyu argument.

Still gives exactly the same warning though?


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#6 2013-05-19 13:52:26

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] ndiswrapper requires manual install

dumas wrote:

Thanks for the suggestion, I never knew the Syyu argument.

It's all in the manpage :-)

dumas wrote:

Still gives exactly the same warning though?

You might be using a mirror that hasn't synced for some reason. Pick a different one and try again.
* https://www.archlinux.org/mirrorlist
* https://www.archlinux.org/mirrors/status/
* https://wiki.archlinux.org/index.php/Reflector

I've just installed ndiswrapper 1.58-9, so it has to be your mirror's fault.

Offline

#7 2013-05-22 12:51:35

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

That's the weird thing, the mirrors I use (from Australia) are in sync according from the status pages and reflector:

Server = http://mirror.aarnet.edu.au/pub/archlinux/$repo/os/$arch
Server = http://ftp.iinet.net.au/pub/archlinux/$repo/os/$arch
Server = http://mirror.internode.on.net/pub/archlinux/$repo/os/$arch
Server = http://mirror.optus.net/archlinux/$repo/os/$arch
Server = http://ftp.swin.edu.au/archlinux/$repo/os/$arch

"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#8 2013-05-22 13:24:25

karol
Archivist
Registered: 2009-05-06
Posts: 25,427

Re: [SOLVED] ndiswrapper requires manual install

I've just used the first mirror from your list to download ndiswrapper 1.58-9. Are you still having problems with downloading the latest version? If the mirrors are fine, 'pacman -Syyu' should fix it on your end.

Offline

#9 2013-05-22 13:49:30

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Just tried pacman -Syyu, still gives warning message

warning: ndiswrapper: local (1.58-9) is newer than community (1.57-20)

As I said, since I can manually upgrade it, that's a small problem. It's more convenience/curiosity? After all we are using Arch Linux.

I'm guessing maybe I messed up some config? I checked pacman.conf and there's no entry on ndiswrapper.


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#10 2013-05-25 08:23:16

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Anyone?

And it appears I have the same problem with mplayer2: pacman is synced to version 20120729-1, whereas 20130309-2 is the newest Arch package.


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#11 2013-05-29 09:12:16

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Anyone sad


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#12 2013-06-10 07:59:59

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

I survived system upgrade with moving the bin directories, as well as upgrading to syslinux from grub-legacy.

Just checked, ndiswrapper and mplayer2 are still out of sync.

One possibility is /var/lib/pacman/sync/extra.db.tar.gz does not contain entries of these 2 packages?


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#13 2013-06-13 12:26:14

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Another example of the problem:

https://bbs.archlinux.org/viewtopic.php … 2#p1285992

After manual upgrade of rxvt-unicode, pacman -Syyu gives

:: Synchronizing package databases...
 core                     103.4 KiB  44.3K/s 00:02 [#####################] 100%
 extra                   1506.6 KiB   300K/s 00:05 [#####################] 100%
 community               1794.7 KiB  76.2M/s 00:00 [#####################] 100%
:: Starting full system upgrade...
warning: mplayer2: local (20130428-1) is newer than community (20120729-1)
warning: ndiswrapper: local (1.58-11) is newer than community (1.57-20)
warning: reflector: local (2013-1) is newer than community (2012.7.26-1)
warning: rxvt-unicode: local (9.18-5) is newer than community (9.15-3)
 there is nothing to do

Irony with the reflector warning!


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#14 2013-06-14 23:52:12

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: [SOLVED] ndiswrapper requires manual install

This entry has multiple versions of packages in it:

Server = http://ftp.iinet.net.au/pub/archlinux/$repo/os/$arch

Try commenting that out and -Syyu again. If the problem goes away, yell at Xyne (err... report a possible bug in reflector).

Offline

#15 2013-06-15 03:16:17

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Yay! A reply!

I just tried that, but problem persists sad

Last edited by dumas (2013-06-15 03:17:03)


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#16 2013-06-15 03:28:56

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: [SOLVED] ndiswrapper requires manual install

Assuming that you have only those five mirrors enabled, one of those is your issue. Comment out all but one, then test with -Syyu. Just walk down the list until you find that problem mirror.

Offline

#17 2013-06-15 04:14:08

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

The servers I have are

Server = http://mirror.aarnet.edu.au/pub/archlinux/$repo/os/$arch
Server = http://ftp.iinet.net.au/pub/archlinux/$repo/os/$arch
Server = http://mirror.internode.on.net/pub/archlinux/$repo/os/$arch
Server = http://mirror.optus.net/archlinux/$repo/os/$arch
Server = http://ftp.swin.edu.au/archlinux/$repo/os/$arch

I tried them one at a time, each and all give the same result

warning: mplayer2: local (20130428-1) is newer than community (20120729-1)
warning: ndiswrapper: local (1.58-11) is newer than community (1.57-20)
warning: reflector: local (2013-1) is newer than community (2012.7.26-1)
warning: rxvt-unicode: local (9.18-5) is newer than community (9.15-3)

"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

#18 2013-06-15 04:37:44

skunktrader
Member
From: Brisbane, Australia
Registered: 2010-02-14
Posts: 1,320

Re: [SOLVED] ndiswrapper requires manual install

I don't have an answer to your specific problem but mirror.optus.net is no longer in the list of official mirrors

Offline

#19 2013-06-15 15:32:42

skottish
Forum Fellow
From: Here
Registered: 2006-06-16
Posts: 7,931

Re: [SOLVED] ndiswrapper requires manual install

I'm guessing that you either have more stuff in your mirrorlist file or there's something extra defined in pacman.conf. Please post the output of:

grep -v '^#' /etc/pacman.d/mirrorlist

and

grep '^Server' /etc/pacman.conf

Offline

#20 2013-06-15 15:53:53

dumas
Member
From: Sydney
Registered: 2007-09-01
Posts: 94

Re: [SOLVED] ndiswrapper requires manual install

Yes thanks I think that is it! It's this line in pacman.conf:

SigLevel = PackageRequired
Server = file:///var/lib/pacman/sync
Include = /etc/pacman.d/mirrorlist

Commenting out the Server line apparently synced things correctly.

Now just need to check rebooting (since kernel and other packages are updated...)

EDIT:

Yes all's good. Thanks folks smile

Last edited by dumas (2013-06-15 15:59:24)


"If you wish to make an apple pie from scratch, you must first invent the universe."
                                                                                                       - Carl Sagan, Cosmos

Offline

Board footer

Powered by FluxBB