You are not logged in.

#1 2013-05-22 21:21:35

arch2013
Member
From: Berlin
Registered: 2013-05-22
Posts: 11

DE saves session at systemctl poweroff

Hey guys!

Yesterday i updated my system with pacman -Syu for the first time after a while (about 2 months). Everything is fine so far, but i observed a difference, which annoys me. I use xfce4 with lxdm as graphical login.
I am used to the following:
When i shutdown my system with shutdown -h now or the xfce4-panel shutdown button, the system does not save the session/open applications. This is what i want.

After the update, the system saves the session/open applications when i shutdown the system with shutdown -h now or the xfce4-panel shutdown button. This seems to be an added feature, but it annoys me. I cannot find a way to inhibit this.

If i logout from xfce4, it does not save the session.

I know that this is a very common topic, so i googled it first, but i couldnt a solution which is working for me.
The stuff i tried until now:
-deleting cache rm -r ~/cache/sessions
-trying out kiosk mode with this explanation: http://askubuntu.com/questions/250630/h … ystem-wide
-checking the graphical configuration menu of xfce: at start&sessions and checking if it is still in the way it was before.
-add a new user
-several options for shutdown

But i couldnt change the behaviour: At logout, it does not save the session (fine), but at shutdown, it does.

Greetings and thanks in advance,

Daniel

Last edited by arch2013 (2013-05-27 18:48:59)

Offline

#2 2013-05-23 21:28:15

arch2013
Member
From: Berlin
Registered: 2013-05-22
Posts: 11

Re: DE saves session at systemctl poweroff

--News--
I downgraded three xfce4 packages:
extra/xfce4-session
extra/xfce4-settings
extra/xfce4-xkb-plugin

The downgraded versions are:
extra/xfce4-session    4.10.0-6
extra/xfce4-settings   4.10.0-3
extra/xfce4-xkb-plugin 0.5.4.3-3

The versions this trouble started with were:
extra/xfce4-session    4.10.1-1
extra/xfce4-settings  4.10.1-1
extra/xfce4-xkb-plugin 0.5.5-1

Downgrading these three packages could _not_ fix it.

Offline

#3 2013-05-23 21:36:45

jrussell
Member
From: Cape Town, South Africa
Registered: 2012-08-16
Posts: 510

Re: DE saves session at systemctl poweroff

Thats odd, try test by creating a new user

useradd -m -g users -s /bin/bash archie

and fiddle with the session options as the new user and see if you have the same problem

*Edit

I think upgrade eveything in the meantime, I think you can cross out package versions seeing as the old ones didnt solve this.

Last edited by jrussell (2013-05-23 21:39:43)


bitcoin: 1G62YGRFkMDwhGr5T5YGovfsxLx44eZo7U

Offline

#4 2013-05-25 15:42:16

arch2013
Member
From: Berlin
Registered: 2013-05-22
Posts: 11

Re: DE saves session at systemctl poweroff

Hello jrussell,

i tried this and i could reproduce exactly the same behaviour i had with my account on the new account.
And yes, i brought my system back to the latest update.

Thanks!

Offline

#5 2013-05-25 15:42:51

arch2013
Member
From: Berlin
Registered: 2013-05-22
Posts: 11

Re: DE saves session at systemctl poweroff

I could observe the following:
shutdown -h now: Computer saves session, then turns off.
shutdown -H now: Computer halts, i had to manually power off, session was not saved
shutdown -P now: Computer does not save the session and turns power off.
shutdown now: Computer does not save the session (but firefox does!) and turns power off.

poweroff showed similar behaviour than shutdown -P now.

Any data which is still written at the moment were doomed anyway (the only exception was -H), no matter which option i gave shutdown.

----

To come to an end:
I replaced 'shutdown -h now' by 'shutdown now'. I wasn't able to "repair" the xfce4-panel shutdown button, so i build my own panel button with shutdown now. This is fine for me.

Offline

#6 2013-05-27 19:05:30

arch2013
Member
From: Berlin
Registered: 2013-05-22
Posts: 11

Re: DE saves session at systemctl poweroff

Hello!

It seems that the reason for this relies on the switch to systemd's logind service.

Replacing shutdown -h now by systemctl poweroff had the following effect:
-Applications do not "plop up" on login.

Things that are still unsolved:
-While opening firefox, it reminds the last session and reopens all last tabs.
-setting logind to kill processes.

What i learned:
shutdown, reboot, poweroff, etc. are deprecated, the new commands are:
systemctl poweroff (etc.)

lxdm does not correctly kills user processes at logout, one may want to edit /etc/lxdm/PostLogout:
--------------------------------
# Close processes on logout Bug 8209
#Find current session number
session=$(loginctl -p Sessions show-user $USER | cut -f2 -d"=" | cut -f1 -d" ")

#Terminate session
loginctl terminate-session $session
--------------------------------

https://wiki.archlinux.org/index.php/Sy … emd-logind
The given command:
loginctl show-session $XDG_SESSION_ID
says:
Id=1
Timestamp=Mo 2013-05-27 20:42:23 CEST
TimestampMonotonic=44355419
DefaultControlGroup=systemd:/user/1000.user/1.session
VTNr=7
TTY=tty7
Display=:0
Remote=no
Service=lxdm
Leader=984
Audit=1
Type=x11
Class=user
Active=yes
State=active
KillProcesses=no
IdleHint=no
IdleSinceHint=0
IdleSinceHintMonotonic=0

-I was not able to set:
KillProcesses= to yes, through
cat /etc/systemd/logind.conf says:
KillUserProcesses=yes


Greetings

Offline

#7 2013-05-27 23:08:31

nuc
Member
Registered: 2012-04-26
Posts: 115

Re: DE saves session at systemctl poweroff

I have also the problem that xfce4 saves session, but it happens on logout via xfce GUI, too.

This causes my system with compiz to be rendered useless https://bbs.archlinux.org/viewtopic.php … 0#p1273690

Offline

#8 2013-06-08 16:58:20

arch2013
Member
From: Berlin
Registered: 2013-05-22
Posts: 11

Re: DE saves session at systemctl poweroff

bump

Offline

Board footer

Powered by FluxBB