You are not logged in.

#101 2013-05-02 12:09:16

kevdog
Member
Registered: 2013-01-26
Posts: 46

Re: Gnome 3.8 not working (upgrade from 3.6)

Am I totally wrong -- but the 20-intel.conf trick is only going to work if you have intel graphics right?  So if you have NVIDIA or ATI graphics, this file really shouldn't matter correct?  Possibly the reason it works for some but not others.

Offline

#102 2013-05-02 13:15:18

lmello
Member
From: Brazil
Registered: 2012-11-06
Posts: 287
Website

Re: Gnome 3.8 not working (upgrade from 3.6)

kevdog wrote:

Am I totally wrong -- but the 20-intel.conf trick is only going to work if you have intel graphics right?  So if you have NVIDIA or ATI graphics, this file really shouldn't matter correct?  Possibly the reason it works for some but not others.

Yes, the Shell is not compatible with the intel's driver default acceleration mode. Don't have a clue about other cards.


Fundamental Axiom of the Universe (aka Murphy's Law): Whatever can go wrong, will go wrong.
First Digital Deduction: Nothing obeys Murphy's Law so well as computers.
Second Digital Deduction: Everything go wrong at least once.
Third Digital Deduction: Things go wrong even when there's absolutely no possibility of anything go wrong.

Offline

#103 2013-05-07 14:46:43

Macdelaney
Member
Registered: 2008-11-24
Posts: 24

Re: Gnome 3.8 not working (upgrade from 3.6)

@ilio wrote:
@ilio wrote:

Hello,

I am having a lot of troubles with my gnome 3.8 installation. In the following, I paste the output of the interesting part of journalctl -b:

Apr 24 12:28:25 myhost gdm[413]: GdmSessionWorker: username is 'sickboy'
Apr 24 12:28:25 myhost gdm[413]: GdmSessionWorker: old-username='sickboy' new-username='sickboy'
Apr 24 12:28:25 myhost gdm[413]: GdmSessionWorker: received pam message of type 1 with payload 'Password: '
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: JS ERROR: !!!   Exception in callback for signal: release
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: JS ERROR: !!!     message = '"can't convert this._frame to an integer"'
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: JS ERROR: !!!     fileName = '"/usr/share/gnome-shell/js/ui/panel.js"'
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: JS ERROR: !!!     lineNumber = '121'
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: JS ERROR: !!!     stack = '"Animation<._showFrame@/usr/share/gnome-shell/js/ui/panel.js:121
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: Animation<.play@/usr/share/gnome-shell/js/ui/panel.js:97
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: LoginDialog<._setWorking@/usr/share/gnome-shell/js/gdm/loginDialog.js:874
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: LoginDialog<._askQuestion/tasks<@/usr/share/gnome-shell/js/gdm/loginDialog.js:909
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: Task<.run@/usr/share/gnome-shell/js/gdm/batch.js:38
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: Batch<.runTask@/usr/share/gnome-shell/js/gdm/batch.js:120
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: ConsecutiveBatch<.process@/usr/share/gnome-shell/js/gdm/batch.js:186
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: Batch<.nextTask@/usr/share/gnome-shell/js/gdm/batch.js:137
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: ConsecutiveBatch<.process/signalId<@/usr/share/gnome-shell/js/gdm/batch.js:194
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: _emit@/usr/share/gjs-1.0/signals.js:124
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: Hold<.release@/usr/share/gnome-shell/js/gdm/batch.js:78
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: Hold<.acquireUntilAfter/signalId<@/usr/share/gnome-shell/js/gdm/batch.js:70
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: _emit@/usr/share/gjs-1.0/signals.js:124
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: Hold<.release@/usr/share/gnome-shell/js/gdm/batch.js:78
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: wrapper@/usr/share/gjs-1.0/lang.js:213
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: @/usr/share/gnome-shell/js/gdm/loginDialog.js:821
Apr 24 12:28:26 myhost /usr/bin/dbus-launch[476]: "'

Basically, I insert my password in GDM and nothing happens and the system doesn't freeze.

Thanks in advance


Oh gosh! Obviously it was a problem with the gtk theme!!! Sorry!

I'm having this exact same problem and can't figure out how to solve it, anyone knows what to do?

Offline

#104 2013-05-07 16:22:21

ricardofunke
Member
Registered: 2009-11-03
Posts: 41

Re: Gnome 3.8 not working (upgrade from 3.6)

I was able to solve reinstalling librsvg

pacman -Sy librsvg

Offline

#105 2013-05-08 13:47:51

robrigo
Member
Registered: 2013-05-02
Posts: 2

Re: Gnome 3.8 not working (upgrade from 3.6)

ricardofunke wrote:

I was able to solve reinstalling librsvg

pacman -Sy librsvg

I did a system upgrade (pacman -Syu) yesterday and had this issue upon boot today. Didn't reinstall gnome-extra or anything, just this package, and then rebooted. gdm logged me in smoothly afterwards instead of hanging.

Thanks ricardofunke!

Offline

#106 2013-05-08 18:13:13

MarcusMoeller
Member
Registered: 2012-05-29
Posts: 6

Re: Gnome 3.8 not working (upgrade from 3.6)

I am curious if the problem has something to do with the new gnome-initial-setup that has been introduced lately. I got several error messages while trying to start GDM, saying 'Could not find user: gnome-initial-setup'.

At least this problem also occurs on nouveau and on older Intel cards which do not support SNA.

A 'workaround' is to switch to lightdm (you need to install a greeter, too - e.g. lightdm-gtk3-greeter) and to disable gdm using systemctl disable gdm.service.

PS: Also the thread topic might be changed to GDM 3.8 not working, as GNOME itself works correctly.

Last edited by MarcusMoeller (2013-05-08 18:14:38)

Offline

#107 2013-05-09 12:30:01

PS
Member
Registered: 2011-08-07
Posts: 6

Re: Gnome 3.8 not working (upgrade from 3.6)

This works for me fine.

ricardofunke wrote:

I was able to solve reinstalling librsvg

pacman -Sy librsvg

Offline

#108 2013-05-19 12:45:52

hoobastank
Member
Registered: 2010-03-30
Posts: 86

Re: Gnome 3.8 not working (upgrade from 3.6)

I was started a new topic about this problem yesterday.
https://bbs.archlinux.org/viewtopic.php?id=163603

But it was closed because it was thought that as if "personal topic". According to forum etiquette "Public posts should be open, productive and inviting to all members" Yes, I want to invite to all member to discuss the general problems of Linux and also Arch Linux coz I criticize some aspects of it. You can see my posts in the first page of this topic, one months have passed since then that day. There havent been specific solution yet, I'm not young computer nerd, I cant lose time at every turn when I update my system because of that silly problems. Linux community and especially Arch Linux community should think about this subject. Yes it is a rolling distro but I didnt do any mistake. I've just update exactly 360 package approximately 900 mb, and it was successfully updated, there is no error or no warning, no conflict error etc. But then I rebooted it and what I saw, the problem is same and waiting for me, look the same as the previous one month. This must be definitely criticized!!! and be told as a public posts in here not at a personel blogs or website.

By the way I've been using archlinux for four years on my laptop everyday, and I'll keep going to use it as much as possible but day by day it's getting harder.

Offline

#109 2013-05-19 13:33:36

vic
Member
Registered: 2011-10-27
Posts: 11

Re: Gnome 3.8 not working (upgrade from 3.6)

i am using the latest gnome 3.8 update due to fresh installation

my cd-rom drive is not automounting.

here is the result of lsblk:

 NAME              MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
 sr0                11:0    1   696M  0 rom

can someone help?

Offline

#110 2013-05-19 20:45:58

gbc921
Member
From: Brazil
Registered: 2011-08-05
Posts: 62
Website

Re: Gnome 3.8 not working (upgrade from 3.6)

vic wrote:

i am using the latest gnome 3.8 update due to fresh installation

my cd-rom drive is not automounting.

here is the result of lsblk:

 NAME              MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINT
 sr0                11:0    1   696M  0 rom

can someone help?

Are you sure that this is related to Gnome 3.8 update?

Anyway, try to check the

/etc/fstab

Also, do you have installed "udisks" and "udisks2" ?

Finally check the options at the auto-mount options in the "gnome-control-center" or something nearby (Removable Media).


"Nothing is impossible, impossible just takes longer"

Offline

#111 2013-05-20 08:10:36

sentinelAlpha
Member
Registered: 2013-05-13
Posts: 4

Re: Gnome 3.8 not working (upgrade from 3.6)

I fixed this issue. However it seems there are a few fixes where the symptoms are perhaps the same.

Symptoms (in order):
1. Upgrade using pacman -Syu (3.6->3.8)
2. Log in to GDM
3. No log in. Receive blank wallpaper, cursor and nothing else.

Fix:

I basically reset my locale settings. I’m based in Australia so I edited

/etc/locale.gen

and enabled

en_GB.UTF-8 UTF-8
en_GB ISO-8859-1

and the entries for en_AU and en_US.

Next I created /etc/locale.conf and put in the following;

LANG="en_AU.UTF-8"

Also, see here for more info.

Offline

#112 2013-05-21 16:54:31

Chowchilla
Member
Registered: 2011-11-13
Posts: 46

Re: Gnome 3.8 not working (upgrade from 3.6)

I'm having the same issue with gdm remaining on a screen with only a cursor and gdm's grey background. Downgrading libsoup fixes the issue. I've tried the locale fix (only enabling UTF-8 lang) with the latest libsoup, and at first it seemed to work, but it turns out that it does still happen *sometimes*.

Anyone any idea where libsoup comes into this (in terms of its use by gdm, I have no idea)? Or what could be causing the issue to only appear on occasion?

My original bug report/thread:

https://bugs.archlinux.org/task/34987?project=1&cat[0]=2&string=libsoup
https://bbs.archlinux.org/viewtopic.php?id=162232

Offline

#113 2013-05-23 01:37:12

sentinelAlpha
Member
Registered: 2013-05-13
Posts: 4

Re: Gnome 3.8 not working (upgrade from 3.6)

I would say the issue is not related to GDM but the Gnome Desktop Environment. You could probably start using Slim as your Login Manager/Display Manager and the problem would be the same; that the DE fails to start and GDM cannot pass off to GDE. It would be a good exercise to narrow the problem to the DM or the DE.

GDM is Gnome dependent and probably uses libsoup, but I probably know as much as you on this. Have you been looking at your logs after the occasion?

Offline

#114 2013-06-04 03:53:33

bhadotia
Member
From: Karnal, India
Registered: 2008-12-09
Posts: 87

Re: Gnome 3.8 not working (upgrade from 3.6)

wclpat wrote:

it worked for my Laptop (Thinkpad x220) after I turned on the SNA (previously I used UXA).

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
    Identifier "Card0"
    Driver       "intel"
    Option       "AccelMethod" "sna"
EndSection


No need to to do this now. I'm on a sandy bridge machine and after a recent update gdm works without the need to enable sna. I think it was an update to the intel driver that solved it.

Here is the relevant portion from pacman.log:

[2013-05-28 06:26] [PACMAN] upgraded xf86-video-intel (2.21.7-1 -> 2.21.8-1)

Last edited by bhadotia (2013-06-04 04:38:20)

Offline

#115 2013-06-06 02:41:18

lmello
Member
From: Brazil
Registered: 2012-11-06
Posts: 287
Website

Re: Gnome 3.8 not working (upgrade from 3.6)

bhadotia wrote:
wclpat wrote:

it worked for my Laptop (Thinkpad x220) after I turned on the SNA (previously I used UXA).

$ cat /etc/X11/xorg.conf.d/20-intel.conf
Section "Device"
    Identifier "Card0"
    Driver       "intel"
    Option       "AccelMethod" "sna"
EndSection


No need to to do this now. I'm on a sandy bridge machine and after a recent update gdm works without the need to enable sna. I think it was an update to the intel driver that solved it.

Here is the relevant portion from pacman.log:

[2013-05-28 06:26] [PACMAN] upgraded xf86-video-intel (2.21.7-1 -> 2.21.8-1)

Thank you for the info, I removed the config file and sna acceleration is no longer required smile


Fundamental Axiom of the Universe (aka Murphy's Law): Whatever can go wrong, will go wrong.
First Digital Deduction: Nothing obeys Murphy's Law so well as computers.
Second Digital Deduction: Everything go wrong at least once.
Third Digital Deduction: Things go wrong even when there's absolutely no possibility of anything go wrong.

Offline

#116 2013-06-19 06:28:16

karantani
Member
From: Texas
Registered: 2010-08-15
Posts: 36

Re: Gnome 3.8 not working (upgrade from 3.6)

To me resetting my local settings worked like a charm

/etc/locale.gen

and enabled

en_GB.UTF-8 UTF-8
en_GB ISO-8859-1

I created /etc/locale.conf

LANG="en_AU.UTF-8"

smile

Thank you "sentinelAlpha"  smile

Offline

Board footer

Powered by FluxBB