You are not logged in.

#1 2013-07-23 00:39:22

oskar.einstein
Member
From: Poland
Registered: 2009-10-23
Posts: 29

Logitech K350 (Unifying) doesn't work after update to linux 3.10

After update to linux 3.10 my wireless keyboard stopped working. It is properly recognized by solaar

https://dl.dropboxusercontent.com/s/z3l … u9wog&dl=1

lspci

00:00.0 Host bridge: Intel Corporation 4th Gen Core Processor DRAM Controller (rev 06)
00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v3/4th Gen Core Processor PCI Express x16 Controller (rev 06)
00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 04)
00:16.0 Communication controller: Intel Corporation 8 Series/C220 Series Chipset Family MEI Controller #1 (rev 04)
00:1a.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #2 (rev 04)
00:1b.0 Audio device: Intel Corporation 8 Series/C220 Series Chipset High Definition Audio Controller (rev 04)
00:1c.0 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #1 (rev d4)
00:1c.1 PCI bridge: Intel Corporation 8 Series/C220 Series Chipset Family PCI Express Root Port #2 (rev d4)
00:1c.3 PCI bridge: Intel Corporation 82801 PCI Bridge (rev d4)
00:1d.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB EHCI #1 (rev 04)
00:1f.0 ISA bridge: Intel Corporation Z87 Express LPC Controller (rev 04)
00:1f.2 SATA controller: Intel Corporation 8 Series/C220 Series Chipset Family 6-port SATA Controller 1 [AHCI mode] (rev 04)
00:1f.3 SMBus: Intel Corporation 8 Series/C220 Series Chipset Family SMBus Controller (rev 04)
01:00.0 VGA compatible controller: NVIDIA Corporation GK106 [GeForce GTX 650 Ti] (rev a1)
01:00.1 Audio device: NVIDIA Corporation Device 0e0b (rev a1)
03:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 06)
04:00.0 PCI bridge: ASMedia Technology Inc. ASM1083/1085 PCIe to PCI Bridge (rev 03)

I couldn't find any related bug in arch bugs.



-- mod edit: read the Forum Etiquette and only post thumbnails http://wiki.archlinux.org/index.php/For … s_and_Code [jwr] --

Offline

#2 2013-07-23 07:47:55

Anarconda
Member
Registered: 2002-12-23
Posts: 77

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

It's working here with kernel 3.10.2-1-ARCH.


Scientia et sapientia patrimonium humanitatis sunt.

Offline

#3 2013-07-23 11:20:56

oskar.einstein
Member
From: Poland
Registered: 2009-10-23
Posts: 29

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

It doesn't work for me.

I've found similar problem reported here. Like author, I have also Z87 based motheboard (MSI z87-g43), I don't know is this related.

Offline

#4 2013-07-23 15:08:52

Anarconda
Member
Registered: 2002-12-23
Posts: 77

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

Can you find a line like this:

Bus 007 Device 002: ID 046d:c52b Logitech, Inc. Unifying Receiver

using lsusb?


Scientia et sapientia patrimonium humanitatis sunt.

Offline

#5 2013-07-23 16:49:38

misc
Member
From: Bavaria, Germany
Registered: 2010-03-22
Posts: 112

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

See here.

Last edited by misc (2013-07-23 16:49:59)

Offline

#6 2013-07-25 18:08:21

oskar.einstein
Member
From: Poland
Registered: 2009-10-23
Posts: 29

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

@Anarconda

Yes, I can find such line

@misc

I've tried this patch but it doesn't work.

Offline

#7 2013-07-25 18:23:42

Anarconda
Member
Registered: 2002-12-23
Posts: 77

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

and can you find a line like this one:

 "XINPUT: Adding extended input device "Logitech Unifying Device. Wireless PID:4011" (type: KEYBOARD, id 9)"

in your /var/log/Xorg.0.log ?


Scientia et sapientia patrimonium humanitatis sunt.

Offline

#8 2013-07-25 22:30:49

oskar.einstein
Member
From: Poland
Registered: 2009-10-23
Posts: 29

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

[     6.153] 
X.Org X Server 1.14.2
Release Date: 2013-06-25
[     6.153] X Protocol Version 11, Revision 0
[     6.153] Build Operating System: Linux 3.9.7-1-ARCH x86_64 
[     6.153] Current Operating System: Linux Enkelados 3.10.2-1-ARCH #1 SMP PREEMPT Mon Jul 22 08:47:24 CEST 2013 x86_64
[     6.153] Kernel command line: initrd=\initramfs-linux.img root=/dev/sda4 rw
[     6.153] Build Date: 01 July 2013  10:48:42AM
[     6.153]  
[     6.153] Current version of pixman: 0.30.0
[     6.153]    Before reporting problems, check http://wiki.x.org
        to make sure that you have the latest version.
[     6.153] Markers: (--) probed, (**) from config file, (==) default setting,
        (++) from command line, (!!) notice, (II) informational,
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
[     6.153] (==) Log file: "/var/log/Xorg.0.log", Time: Fri Jul 26 00:22:32 2013
[     6.227] (==) Using config file: "/etc/X11/xorg.conf"
[     6.227] (==) Using config directory: "/etc/X11/xorg.conf.d"
[     6.227] (==) Using system config directory "/usr/share/X11/xorg.conf.d"
[     6.304] (==) ServerLayout "Layout0"
[     6.304] (**) |-->Screen "Screen0" (0)
[     6.304] (**) |   |-->Monitor "Monitor0"
[     6.304] (**) |   |-->Device "Device0"
[     6.304] (**) |-->Input Device "Keyboard0"
[     6.304] (**) |-->Input Device "Mouse0"
[     6.304] (==) Automatically adding devices
[     6.304] (==) Automatically enabling devices
[     6.304] (==) Automatically adding GPU devices
[     6.317] (WW) The directory "/usr/share/fonts/OTF/" does not exist.
[     6.317]    Entry deleted from font path.
[     6.332] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/100dpi/".
[     6.332]    Entry deleted from font path.
[     6.332]    (Run 'mkfontdir' on "/usr/share/fonts/100dpi/").
[     6.332] (WW) `fonts.dir' not found (or not valid) in "/usr/share/fonts/75dpi/".
[     6.332]    Entry deleted from font path.
[     6.332]    (Run 'mkfontdir' on "/usr/share/fonts/75dpi/").
[     6.332] (==) FontPath set to:
        /usr/share/fonts/misc/,
        /usr/share/fonts/TTF/,
        /usr/share/fonts/Type1/                                                                                                                                                    
[     6.332] (==) ModulePath set to "/usr/lib/xorg/modules"                                                                                                                        
[     6.332] (WW) Hotplugging is on, devices using drivers 'kbd', 'mouse' or 'vmmouse' will be disabled.                                                                           
[     6.332] (WW) Disabling Keyboard0                                                                                                                                              
[     6.332] (WW) Disabling Mouse0                                                                                                                                                 
[     6.349] (II) Loader magic: 0x7fdc20                                                                                                                                           
[     6.349] (II) Module ABI versions:                                                                                                                                             
[     6.349]    X.Org ANSI C Emulation: 0.4
[     6.349]    X.Org Video Driver: 14.1
[     6.349]    X.Org XInput driver : 19.1
[     6.349]    X.Org Server Extension : 7.0
[     6.349] (II) xfree86: Adding drm device (/dev/dri/card0)
[     6.350] (--) PCI:*(0:1:0:0) 10de:11c6:1458:3557 rev 161, Mem @ 0xf6000000/16777216, 0xe8000000/134217728, 0xf0000000/33554432, I/O @ 0x0000e000/128, BIOS @ 0x????????/524288
[     6.351] Initializing built-in extension Generic Event Extension
[     6.351] Initializing built-in extension SHAPE
[     6.351] Initializing built-in extension MIT-SHM
[     6.351] Initializing built-in extension XInputExtension
[     6.351] Initializing built-in extension XTEST
[     6.351] Initializing built-in extension BIG-REQUESTS
[     6.351] Initializing built-in extension SYNC
[     6.351] Initializing built-in extension XKEYBOARD
[     6.351] Initializing built-in extension XC-MISC
[     6.351] Initializing built-in extension SECURITY
[     6.351] Initializing built-in extension XINERAMA
[     6.351] Initializing built-in extension XFIXES
[     6.351] Initializing built-in extension RENDER
[     6.351] Initializing built-in extension RANDR
[     6.351] Initializing built-in extension COMPOSITE
[     6.351] Initializing built-in extension DAMAGE
[     6.351] Initializing built-in extension MIT-SCREEN-SAVER
[     6.351] Initializing built-in extension DOUBLE-BUFFER
[     6.351] Initializing built-in extension RECORD
[     6.351] Initializing built-in extension DPMS
[     6.351] Initializing built-in extension X-Resource
[     6.351] Initializing built-in extension XVideo
[     6.351] Initializing built-in extension XVideo-MotionCompensation
[     6.351] Initializing built-in extension XFree86-VidModeExtension
[     6.351] Initializing built-in extension XFree86-DGA
[     6.351] Initializing built-in extension XFree86-DRI
[     6.351] Initializing built-in extension DRI2
[     6.351] (II) LoadModule: "glx"
[     6.433] (II) Loading /usr/lib/xorg/modules/extensions/libglx.so
[     7.274] (II) Module glx: vendor="NVIDIA Corporation"
[     7.274]    compiled for 4.0.2, module version = 1.0.0
[     7.274]    Module class: X.Org Server Extension
[     7.274] (II) NVIDIA GLX Module  319.32  Wed Jun 19 14:55:38 PDT 2013
[     7.286] Loading extension GLX
[     7.286] (II) LoadModule: "nvidia"
[     7.286] (II) Loading /usr/lib/xorg/modules/drivers/nvidia_drv.so
[     7.479] (II) Module nvidia: vendor="NVIDIA Corporation"
[     7.479]    compiled for 4.0.2, module version = 1.0.0
[     7.479]    Module class: X.Org Video Driver
[     7.540] (II) NVIDIA dlloader X Driver  319.32  Wed Jun 19 14:34:12 PDT 2013
[     7.540] (II) NVIDIA Unified Driver for all Supported NVIDIA GPUs
[     7.551] (++) using VT number 7

[     7.557] (II) Loading sub module "fb"
[     7.557] (II) LoadModule: "fb"
[     7.557] (II) Loading /usr/lib/xorg/modules/libfb.so
[     7.589] (II) Module fb: vendor="X.Org Foundation"
[     7.589]    compiled for 1.14.2, module version = 1.0.0
[     7.589]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.589] (WW) Unresolved symbol: fbGetGCPrivateKey
[     7.589] (II) Loading sub module "wfb"
[     7.589] (II) LoadModule: "wfb"
[     7.589] (II) Loading /usr/lib/xorg/modules/libwfb.so
[     7.606] (II) Module wfb: vendor="X.Org Foundation"
[     7.606]    compiled for 1.14.2, module version = 1.0.0
[     7.606]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.606] (II) Loading sub module "shadow"
[     7.606] (II) LoadModule: "shadow"
[     7.606] (II) Loading /usr/lib/xorg/modules/libshadow.so
[     7.623] (II) Module shadow: vendor="X.Org Foundation"
[     7.623]    compiled for 1.14.2, module version = 1.1.0
[     7.623]    ABI class: X.Org ANSI C Emulation, version 0.4
[     7.623] (II) Loading sub module "ramdac"
[     7.623] (II) LoadModule: "ramdac"
[     7.623] (II) Module "ramdac" already built-in
[     7.623] (**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
[     7.623] (==) NVIDIA(0): RGB weight 888
[     7.623] (==) NVIDIA(0): Default visual is TrueColor
[     7.623] (==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
[     7.623] (**) NVIDIA(0): Enabling 2D acceleration
[     8.247] (II) NVIDIA(GPU-0): Display (BenQ BL2400 (DFP-0)) does not support NVIDIA 3D
[     8.247] (II) NVIDIA(GPU-0):     Vision stereo.
[     8.248] (II) NVIDIA(0): NVIDIA GPU GeForce GTX 650 Ti (GK106) at PCI:1:0:0 (GPU-0)
[     8.248] (--) NVIDIA(0): Memory: 1048576 kBytes
[     8.248] (--) NVIDIA(0): VideoBIOS: 80.06.3c.00.5d
[     8.248] (II) NVIDIA(0): Detected PCI Express Link width: 16X
[     8.250] (--) NVIDIA(0): Valid display device(s) on GeForce GTX 650 Ti at PCI:1:0:0
[     8.250] (--) NVIDIA(0):     CRT-0
[     8.250] (--) NVIDIA(0):     BenQ BL2400 (DFP-0) (boot, connected)
[     8.250] (--) NVIDIA(0):     DFP-1
[     8.250] (--) NVIDIA(0):     DFP-2
[     8.250] (--) NVIDIA(0): CRT-0: 400.0 MHz maximum pixel clock
[     8.250] (--) NVIDIA(0): BenQ BL2400 (DFP-0): 330.0 MHz maximum pixel clock
[     8.250] (--) NVIDIA(0): BenQ BL2400 (DFP-0): Internal Dual Link TMDS
[     8.250] (--) NVIDIA(0): DFP-1: 165.0 MHz maximum pixel clock
[     8.250] (--) NVIDIA(0): DFP-1: Internal Single Link TMDS
[     8.250] (--) NVIDIA(0): DFP-2: 330.0 MHz maximum pixel clock
[     8.250] (--) NVIDIA(0): DFP-2: Internal Single Link TMDS
[     8.250] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[     8.250] (**) NVIDIA(0):     device BenQ BL2400 (DFP-0) (Using EDID frequencies has
[     8.250] (**) NVIDIA(0):     been enabled on all display devices.)
[     8.250] (==) NVIDIA(0): 
[     8.250] (==) NVIDIA(0): No modes were requested; the default mode "nvidia-auto-select"
[     8.250] (==) NVIDIA(0):     will be used as the requested mode.
[     8.250] (==) NVIDIA(0): 
[     8.250] (II) NVIDIA(0): Validated MetaModes:
[     8.250] (II) NVIDIA(0):     "DFP-0:nvidia-auto-select{}"
[     8.250] (II) NVIDIA(0): Virtual screen size determined to be 1920 x 1080
[     8.311] (--) NVIDIA(0): DPI set to (92, 91); computed from "UseEdidDpi" X config
[     8.311] (--) NVIDIA(0):     option
[     8.311] (--) Depth 24 pixmap format is 32 bpp
[     8.311] (II) NVIDIA: Using 3072.00 MB of virtual memory for indirect memory
[     8.311] (II) NVIDIA:     access.
[     8.313] (II) NVIDIA(0): ACPI: failed to connect to the ACPI event daemon; the daemon
[     8.313] (II) NVIDIA(0):     may not be running or the "AcpidSocketPath" X
[     8.313] (II) NVIDIA(0):     configuration option may not be set correctly.  When the
[     8.313] (II) NVIDIA(0):     ACPI event daemon is available, the NVIDIA X driver will
[     8.313] (II) NVIDIA(0):     try to use it to receive ACPI event notifications.  For
[     8.313] (II) NVIDIA(0):     details, please see the "ConnectToAcpid" and
[     8.313] (II) NVIDIA(0):     "AcpidSocketPath" X configuration options in Appendix B: X
[     8.313] (II) NVIDIA(0):     Config Options in the README.
[     8.314] (II) NVIDIA(0): Setting mode "DFP-0:nvidia-auto-select{}"
[     8.376] Loading extension NV-GLX
[     8.416] (==) NVIDIA(0): Disabling shared memory pixmaps
[     8.416] (==) NVIDIA(0): Backing store disabled
[     8.416] (==) NVIDIA(0): Silken mouse enabled
[     8.416] (**) NVIDIA(0): DPMS enabled
[     8.416] Loading extension NV-CONTROL
[     8.418] Loading extension XINERAMA
[     8.418] (II) Loading sub module "dri2"
[     8.418] (II) LoadModule: "dri2"
[     8.418] (II) Module "dri2" already built-in
[     8.418] (II) NVIDIA(0): [DRI2] Setup complete
[     8.418] (II) NVIDIA(0): [DRI2]   VDPAU driver: nvidia
[     8.418] (--) RandR disabled
[     8.421] (II) Initializing extension GLX
[     8.775] (II) config/udev: Adding input device Power Button (/dev/input/event2)
[     8.775] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     8.775] (II) LoadModule: "evdev"
[     8.775] (II) Loading /usr/lib/xorg/modules/input/evdev_drv.so
[     8.797] (II) Module evdev: vendor="X.Org Foundation"
[     8.797]    compiled for 1.14.2, module version = 2.8.1
[     8.797]    Module class: X.Org XInput Driver
[     8.797]    ABI class: X.Org XInput driver, version 19.1
[     8.797] (II) Using input driver 'evdev' for 'Power Button'
[     8.797] (**) Power Button: always reports core events
[     8.797] (**) evdev: Power Button: Device: "/dev/input/event2"
[     8.797] (--) evdev: Power Button: Vendor 0 Product 0x1
[     8.797] (--) evdev: Power Button: Found keys
[     8.797] (II) evdev: Power Button: Configuring as keyboard
[     8.797] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/LNXPWRBN:00/input/input2/event2"
[     8.797] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 6)
[     8.797] (**) Option "xkb_rules" "evdev"
[     8.797] (**) Option "xkb_model" "pc104"
[     8.797] (**) Option "xkb_layout" "us"
[     8.808] (II) config/udev: Adding input device Power Button (/dev/input/event1)
[     8.808] (**) Power Button: Applying InputClass "evdev keyboard catchall"
[     8.808] (II) Using input driver 'evdev' for 'Power Button'
[     8.808] (**) Power Button: always reports core events
[     8.808] (**) evdev: Power Button: Device: "/dev/input/event1"
[     8.808] (--) evdev: Power Button: Vendor 0 Product 0x1
[     8.808] (--) evdev: Power Button: Found keys
[     8.808] (II) evdev: Power Button: Configuring as keyboard
[     8.808] (**) Option "config_info" "udev:/sys/devices/LNXSYSTM:00/device:00/PNP0C0C:00/input/input1/event1"
[     8.808] (II) XINPUT: Adding extended input device "Power Button" (type: KEYBOARD, id 7)
[     8.808] (**) Option "xkb_rules" "evdev"
[     8.808] (**) Option "xkb_model" "pc104"
[     8.808] (**) Option "xkb_layout" "us"
[     8.808] (II) config/udev: Adding drm device (/dev/dri/card0)
[     8.809] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=8 (/dev/input/event12)
[     8.809] (II) No input driver specified, ignoring this device.
[     8.809] (II) This device may have been added with another device file.
[     8.809] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=7 (/dev/input/event13)
[     8.809] (II) No input driver specified, ignoring this device.
[     8.809] (II) This device may have been added with another device file.
[     8.809] (II) config/udev: Adding input device HDA NVidia HDMI/DP,pcm=3 (/dev/input/event14)
[     8.809] (II) No input driver specified, ignoring this device.
[     8.809] (II) This device may have been added with another device file.
[     8.809] (II) config/udev: Adding input device USB OPTICAL MOUSE (/dev/input/event0)
[     8.809] (**) USB OPTICAL MOUSE: Applying InputClass "evdev pointer catchall"
[     8.809] (II) Using input driver 'evdev' for 'USB OPTICAL MOUSE'
[     8.809] (**) USB OPTICAL MOUSE: always reports core events
[     8.809] (**) evdev: USB OPTICAL MOUSE: Device: "/dev/input/event0"
[     8.809] (--) evdev: USB OPTICAL MOUSE: Vendor 0x93a Product 0x2521
[     8.809] (--) evdev: USB OPTICAL MOUSE: Found 9 mouse buttons
[     8.809] (--) evdev: USB OPTICAL MOUSE: Found scroll wheel(s)
[     8.809] (--) evdev: USB OPTICAL MOUSE: Found relative axes
[     8.809] (--) evdev: USB OPTICAL MOUSE: Found x and y relative axes
[     8.809] (II) evdev: USB OPTICAL MOUSE: Configuring as mouse
[     8.809] (II) evdev: USB OPTICAL MOUSE: Adding scrollwheel support
[     8.809] (**) evdev: USB OPTICAL MOUSE: YAxisMapping: buttons 4 and 5
[     8.809] (**) evdev: USB OPTICAL MOUSE: EmulateWheelButton: 4, EmulateWheelInertia: 10, EmulateWheelTimeout: 200
[     8.809] (**) Option "config_info" "udev:/sys/devices/pci0000:00/0000:00:14.0/usb1/1-5/1-5:1.0/input/input0/event0"
[     8.809] (II) XINPUT: Adding extended input device "USB OPTICAL MOUSE" (type: MOUSE, id 8)
[     8.809] (II) evdev: USB OPTICAL MOUSE: initialized for relative axes.
[     8.809] (**) USB OPTICAL MOUSE: (accel) keeping acceleration scheme 1
[     8.809] (**) USB OPTICAL MOUSE: (accel) acceleration profile 0
[     8.809] (**) USB OPTICAL MOUSE: (accel) acceleration factor: 2.000
[     8.809] (**) USB OPTICAL MOUSE: (accel) acceleration threshold: 4
[     8.809] (II) config/udev: Adding input device USB OPTICAL MOUSE (/dev/input/mouse0)
[     8.809] (II) No input driver specified, ignoring this device.
[     8.809] (II) This device may have been added with another device file.
[     8.809] (II) config/udev: Adding input device HDA Intel PCH Rear Mic (/dev/input/event10)
[     8.809] (II) No input driver specified, ignoring this device.
[     8.809] (II) This device may have been added with another device file.
[     8.809] (II) config/udev: Adding input device HDA Intel PCH Front Mic (/dev/input/event11)
[     8.809] (II) No input driver specified, ignoring this device.
[     8.809] (II) This device may have been added with another device file.
[     8.809] (II) config/udev: Adding input device HDA Intel PCH Front Headphone (/dev/input/event4)
[     8.809] (II) No input driver specified, ignoring this device.
[     8.809] (II) This device may have been added with another device file.
[     8.810] (II) config/udev: Adding input device HDA Intel PCH Line Out Side (/dev/input/event5)
[     8.810] (II) No input driver specified, ignoring this device.
[     8.810] (II) This device may have been added with another device file.
[     8.810] (II) config/udev: Adding input device HDA Intel PCH Line Out CLFE (/dev/input/event6)
[     8.810] (II) No input driver specified, ignoring this device.
[     8.810] (II) This device may have been added with another device file.
[     8.810] (II) config/udev: Adding input device HDA Intel PCH Line Out Surround (/dev/input/event7)
[     8.810] (II) No input driver specified, ignoring this device.
[     8.810] (II) This device may have been added with another device file.
[     8.810] (II) config/udev: Adding input device HDA Intel PCH Line Out Front (/dev/input/event8)
[     8.810] (II) No input driver specified, ignoring this device.
[     8.810] (II) This device may have been added with another device file.
[     8.810] (II) config/udev: Adding input device HDA Intel PCH Line (/dev/input/event9)
[     8.810] (II) No input driver specified, ignoring this device.
[     8.810] (II) This device may have been added with another device file.
[     8.810] (II) config/udev: Adding input device PC Speaker (/dev/input/event3)
[     8.810] (II) No input driver specified, ignoring this device.
[     8.810] (II) This device may have been added with another device file.
[    74.529] (II) config/udev: Adding input device AT Translated Set 2 keyboard (/dev/input/event15)
[    74.529] (**) AT Translated Set 2 keyboard: Applying InputClass "evdev keyboard catchall"
[    74.529] (II) Using input driver 'evdev' for 'AT Translated Set 2 keyboard'
[    74.529] (**) AT Translated Set 2 keyboard: always reports core events
[    74.529] (**) evdev: AT Translated Set 2 keyboard: Device: "/dev/input/event15"
[    74.529] (--) evdev: AT Translated Set 2 keyboard: Vendor 0x1 Product 0x1
[    74.529] (--) evdev: AT Translated Set 2 keyboard: Found keys
[    74.529] (II) evdev: AT Translated Set 2 keyboard: Configuring as keyboard
[    74.530] (**) Option "config_info" "udev:/sys/devices/platform/i8042/serio0/input/input15/event15"
[    74.530] (II) XINPUT: Adding extended input device "AT Translated Set 2 keyboard" (type: KEYBOARD, id 9)
[    74.530] (**) Option "xkb_rules" "evdev"
[    74.530] (**) Option "xkb_model" "pc104"
[    74.530] (**) Option "xkb_layout" "us"
[   102.547] (II) NVIDIA(GPU-0): Display (BenQ BL2400 (DFP-0)) does not support NVIDIA 3D
[   102.547] (II) NVIDIA(GPU-0):     Vision stereo.
[   102.547] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   102.547] (**) NVIDIA(0):     device BenQ BL2400 (DFP-0) (Using EDID frequencies has
[   102.547] (**) NVIDIA(0):     been enabled on all display devices.)
[   108.766] (II) NVIDIA(GPU-0): Display (BenQ BL2400 (DFP-0)) does not support NVIDIA 3D
[   108.766] (II) NVIDIA(GPU-0):     Vision stereo.
[   108.766] (**) NVIDIA(0): Using HorizSync/VertRefresh ranges from the EDID for display
[   108.766] (**) NVIDIA(0):     device BenQ BL2400 (DFP-0) (Using EDID frequencies has
[   108.766] (**) NVIDIA(0):     been enabled on all display devices.)

No sad

...and now 3.10 is in core -.-

Last edited by oskar.einstein (2013-07-25 22:36:27)

Offline

#9 2013-07-26 01:09:18

Anarconda
Member
Registered: 2002-12-23
Posts: 77

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

Do you have any custom udev rule? What version of systemd are you using?


Scientia et sapientia patrimonium humanitatis sunt.

Offline

#10 2013-07-26 04:42:47

juanp_1982
Member
From: Toronto, Ontario
Registered: 2012-09-02
Posts: 42

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

I have the same problem. lsusb shows the "Logitech, Inc. Unifying Receiver" properly the "hid_logitech_dj" and "hid_generic" modules are loaded and still the mouse and keyboard are not responding :-(

Offline

#11 2013-07-26 07:54:28

kokoko3k
Member
Registered: 2008-11-14
Posts: 1,472

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

The bug is in the upstream kernel and has been submitted.
There's nothing you can do, unfortunately, apart from downgrade temporally or manually reverting the git commit that broke unify by recompiling linux.
look:
https://bugs.archlinux.org/task/35991
https://bugzilla.kernel.org/show_bug.cgi?id=60507
They are working on it: https://lkml.org/lkml/2013/7/18/262

I'd just downgrade for a while.

Offline

#12 2013-10-10 09:42:47

sphakka
Member
Registered: 2013-09-09
Posts: 3

Re: Logitech K350 (Unifying) doesn't work after update to linux 3.10

Good news: back in business with kernel 3.11.4-1 :-)

Linux urvogel 3.11.4-1-ARCH #1 SMP PREEMPT Sat Oct 5 21:22:51 CEST 2013 x86_64 GNU/Linux

My combo mk330 keyboard + Wireless Touchpad are working nicely:

$ solaar-cli -V
solaar-cli 0.9.2
$ solaar-cli show
Unifying Receiver [/dev/hidraw2:BF0096E4] with 3 devices
1: M215 2nd Gen [M215 2nd Gen:15B51B34] offline
2: Wireless Keyboard K330 [K330:8AE18D6A] 
3: Wireless Touchpad [Wireless Touch:B00807AD] 

Offline

Board footer

Powered by FluxBB