You are not logged in.

#26 2013-09-11 22:47:25

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Linux Working on Razer blade 14 (2013)

Hi guys, I'm happily using linux on a razer blade 14 as the only OS as my main machine. I'm no linux/OS expert, so apologies if I use wrong terminology.

Here's my notes on getting everything to work. As you guys know, only issue is the touchpad doesn't have a synaptics driver. I have not seen the "missed keys" issue on the keyboard on my machine.

Link to my post about getting everything to work. Had to use majaro linux for that kernel patch until the graphics driver connector issue gets fixed in the main kernel, it didn't work in vanilla 3.11 when I tried it.

http://forums.linuxmint.com/viewtopic.p … 93#p762793

Best,
Richard

Offline

#27 2013-09-12 19:02:19

labotsirc
Member
Registered: 2013-08-21
Posts: 81

Re: Razer Blade [Gen 1]

riveale wrote:

Linux Working on Razer blade 14 (2013)

Hi guys, I'm happily using linux on a razer blade 14 as the only OS as my main machine. I'm no linux/OS expert, so apologies if I use wrong terminology.

Here's my notes on getting everything to work. As you guys know, only issue is the touchpad doesn't have a synaptics driver. I have not seen the "missed keys" issue on the keyboard on my machine.

Link to my post about getting everything to work. Had to use majaro linux for that kernel patch until the graphics driver connector issue gets fixed in the main kernel, it didn't work in vanilla 3.11 when I tried it.

http://forums.linuxmint.com/viewtopic.p … 93#p762793

Best,
Richard


Great to see that the blade 14" works very good. At the moment our main problem with the Razer Blade 17 (R1 R2 or R3), is the keyboard issue. It seems as if the SBUI + keyboard is giving headaches to the kernel driver

Last edited by labotsirc (2013-09-12 19:02:45)

Offline

#28 2013-09-13 01:57:07

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

FxChiP wrote:

I have a Razer Blade R2 myself and have written some details up at http://fxchip.net/RazerBlade/ if this helps anyone.

As far as the keyboard issues go, I find it strange that it doesn't happen in Windows. Even stranger is that, occasionally, the keyboard and mouse will flake out and crash. This eventually happens in Windows as well at times -- but at least it doesn't miss keystrokes (and recovery time is thankfully low). I always seem to find these errors when it happens:

[ 1199.070868] ehci-pci 0000:00:1a.0: detected XactErr len 0/64 retry 7

These indicate that the USB hardware found some fault going on in communicating directly with the hardware device. Unfortunately, there doesn't seem to be any way to upgrade firmware or anything.

By the way, what you're seeing with regards to the pointer: in my experience, when the system first boots, both keyboard and mouse remain in compatibility modes, presenting as standard USB HID devices (interestingly, the mouse implements pinch-to-zoom in hardware in this mode). This changes when the interface corresponding to the trackpad is told to use alternate setting 1 -- but not only does the trackpad start operating under those conditions, the keyboard will start sending HID reports on its other input interface, too. The neat thing about some of those is that the keyboard is able to report more characters than it would under the Boot USB Keyboard standard, which probably accounts for some of the anti-ghosting. However, in my tests, I haven't yet been able to catch the keyboard misbehaving. I almost want to say there's a good chance stuff is being ignored by the kernel, but... can't prove it.

Also, my synaptics driver (on that site) is still being developed and tested. Use at your own risk. Although the biggest problem you'll probably run into is an insane amount of jitter. Sometimes the multitouch won't work properly, either (or it might take a second). The damn thing samples way too quickly. smile


FxChip: much appreciation/respect for your work, I enjoyed reading your notes. Do you think I should try your synaptics kernel patch on the RB 14 (or are there hardcoded hardware locations for the RB17 that I would need to change in your code, etc. before I try?). I'm a bit busy with other things at the moment, but I really want to get this touchpad issue solved! Also, as mentioned, I'm an absolute hardware interface novice so I might ask some silly questions (apologies in advance).

Offline

#29 2013-09-24 13:53:21

labotsirc
Member
Registered: 2013-08-21
Posts: 81

Re: Razer Blade [Gen 1]

FxChip's fix for the keyboard has finally worked for me.
I had to use the default configuration of the kernel

make defconfig

plus some other modules for booting, ethernet, and wifi.

For some strange reason, i cannot use ARCH's ".config" and have the fix at the same time. Some option in ARCH LINUX is wiping out the usbhid patch. Im not even using PKGBUILD neither makepkg, this happens at the level of traditional kernel compilation.
I Guess i will have to invest a good amount of hours trying to find that option from ARCH's ".config" that is messing with the usbhid patch...and disable it.
My basic kernel is far from being fully operational (im missing so many modules).

Last edited by labotsirc (2013-09-24 13:56:04)

Offline

#30 2013-10-01 09:40:27

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Hm, maybe I'm running into similar problems then. I've been trying to apply his patch, (naively?) thinking that I could simply compile that kernel module and slip it into my current kernel without recompiling the whole thing. Remember, I'm doing this for the synaptics mouse thing (not the keyboard)

My way of doing this was (I have no idea what I'm doing -- online guides were absolutely useless so I was just guessing...):

1) download source of kernel (3.9.11) to e.g. ~/kernelsource/linux-3911
2) apply patch (patch -p1 < patchname.patch) from inside ~/kernelsource/linux-3911
3) copy the .config file from /usr/src/linux-3.9.11/.config to ~/kernelsource/linux-3911
4) compile just the kernel module thingy "make M=drivers/input/mouse"
(this produces drivers/input/mouse/synaptics_usb.ko)
5) copy that .ko into /lib/modules/kernel/drivers/input/mouse/synaptics_usb.ko.gz
(not clear to me why the old one is a .gz? I backed it up)

Turns out (of course) that even the OLD synaptics-usb driver/module thing wasn't being loaded, so I add it manually "modprobe --force-vermagic synaptics-usb" (needed the force since I never compiled the whole kernel and was missing some kind of thingy).

Aaaaaand...nothing changes wink Of course, I guess...why would it automatically associate the hardware with that new driver code. Something tells me I'm missing a lot of steps (esp. between 3 and 4).

Anyone who knows how to do this...any help would be much appreciated!

Best,
Richard

labotsirc wrote:

FxChip's fix for the keyboard has finally worked for me.
I had to use the default configuration of the kernel

make defconfig

plus some other modules for booting, ethernet, and wifi.

For some strange reason, i cannot use ARCH's ".config" and have the fix at the same time. Some option in ARCH LINUX is wiping out the usbhid patch. Im not even using PKGBUILD neither makepkg, this happens at the level of traditional kernel compilation.
I Guess i will have to invest a good amount of hours trying to find that option from ARCH's ".config" that is messing with the usbhid patch...and disable it.
My basic kernel is far from being fully operational (im missing so many modules).

Offline

#31 2013-10-01 15:28:52

skualito
Member
Registered: 2008-11-19
Posts: 184

Re: Razer Blade [Gen 1]

Offline

#32 2013-10-02 01:30:32

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Hi skualito, thank you for the link!

Yes, I saw that page, but I don't have the source for the patch of my current kernel (the bbsfix kernel), I only have the binary, so I unfortunately can't use that method. I need a method of inserting the module into my current kernel I guess, if it's possible...

Much appreciated,
Richard

Offline

#33 2013-10-02 04:38:20

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

OK, a small amount of progress(?)

I realized that I think the touchpad on the RB14 is a different device ID than the one FxChip had in his patch. lsusb returns
Bus 001 Device 002: ID 1532:011d Razer USA, Ltd

I.e. vendor number is 0x1531 (same as FxChip), but device (product?) ID is 0x011d (FxChip had it as 0x0116).

So, I recompiled that kernel module synaptics_usb.ko, and renamed it to /lib/modules/<kernelversion>/extramodules/synaptics_usb.ko.gz

now, I get

[riveale@manjaro ~]$ modinfo synaptics_usb
filename:       /lib/modules/3.9.11-1-MANJARO-bbswitchfix/extramodules/synaptics_usb.ko.gz
license:        GPL
description:    Synaptics USB device driver
author:         Rob Miller <rob@inpharmatica.co.uk>, Ron Lee <ron@debian.org>, Jan Steinhoff <cpad@jan-steinhoff.de>
alias:          usb:v1532p011Dd*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0013d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0010d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0009d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0008d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0007d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0006d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0003d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0002d*dc*dsc*dp*ic*isc*ip*in*
alias:          usb:v06CBp0001d*dc*dsc*dp*ic*isc*ip*in*
depends:        usbcore
vermagic:       3.9.11-MANJARO-bbswitchfix SMP preempt mod_unload modversions 

I have no idea what those "alias" things are, but the first one is pointing to 1532 (razer blade vendor ID), and 011D (the device ID of my touchpad). So...something is getting recognized somewhere? (it means that it should know that this module can be responsible for that device, right?).

However, lsmod | grep synap returns nothing (i.e. the module is not loaded...)

Furthermore, if I forcefully load the module,  "modprobe -f synaptics-usb"

[riveale@manjaro ~]$ lsmod | grep synap
synaptics_usb           6239  0 
usbcore               177091  8 ath3k,btusb,uvcvideo,ehci_hcd,ehci_pci,synaptics_usb,usbhid,xhci_hcd

So...it's loaded (not used by any other modules it seems though)

Furthermore, if I lspci -v, then I get some entries like this (see the kernel modules only show xhci etc., they don't show synaptics_usb, which should be another
driver available to control this device). But, I guess these things are determined by udev or whatever at boot, and since the synaptics-usb module isn't loaded at
boot, it doesn't have them listed there?

00:14.0 USB controller: Intel Corporation 8 Series/C220 Series Chipset Family USB xHCI (rev 05) (prog-if 30 [XHCI])
	Subsystem: Razer USA Ltd. Device 6746
	Flags: bus master, medium devsel, latency 0, IRQ 43
	Memory at f7900000 (64-bit, non-prefetchable) [size=64K]
	Capabilities: <access denied>
	Kernel driver in use: xhci_hcd
	Kernel modules: xhci_hcd

Anyway, so I guess what I need to do is:
1) forcefully load the synaptics-usb module at boot before udev...? (/etc/rc.local is too late I think?).
2) tell it to use the synaptics-usb driver for that device.

Does anyone know how to do this? I can't find anywhere how to tell it to (at runtime) switch which driver module controls which hardware device. In /dev/input/by-id/ there
are synlinks to the various razer hardware keybard/mouse etc. (event things).

Any help much appreciated smile
Richard

Offline

#34 2013-11-20 05:37:00

FxChiP
Member
Registered: 2013-08-26
Posts: 10

Re: Razer Blade [Gen 1]

It looks like the Razer Blade 14" actually remaps the input device interfaces slightly -- interface 0 is probably the synaptics touchpad, but since it no longer has an altsetting, it won't report (and the alternate/expanded keyboard won't work either) until the functionality switch is performed in a different way (probably something to do with that outbound USB endpoint it has).

Offline

#35 2013-12-02 01:07:41

FxChiP
Member
Registered: 2013-08-26
Posts: 10

Re: Razer Blade [Gen 1]

Actually, it looks like the Razer Blade 14" may not even use a Synaptics touchpad -- instead, whatever touchpad input protocol it does use, it multiplexes (sort of) over the first interface (0 or 1, depending on Linux or Windows) using the HID protocol with reportID 0x0c. (Someone sent me some dumps and HID descriptor reports, and I just made the connection today). I'm not sure what they're doing with it here.

Offline

#36 2014-01-04 09:20:30

FxChiP
Member
Registered: 2013-08-26
Posts: 10

Re: Razer Blade [Gen 1]

Incidentally if anyone is interested, check out http://i.imgur.com/E2K550e.jpg . Source code at http://github.com/FxChiP/rzswitchblade/ .

Watch out: if you're not using the synaptics patch I wrote, the blit test *will* lock your keyboard and mouse. If you use the harness and are able to rebind your keyboard, things get a *little* better (you get keyboard back, anyway).

Offline

#37 2014-01-15 21:09:46

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Cool! Still can't imagine what I'd use that switchblade thing for, though smile I'd keep it off to save battery haha.

Still haven't had time to look into the RB14 driver any more. Crossing my fingers that some of the (other) problems will be fixed in 3.13 so that I can focus on the touchpad as the only remaining problem.

Offline

#38 2014-01-24 22:52:03

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Yo, just a heads up, It would be really nice if razer could contribute help or a patch for their hardware. I pinged them on facebook (https://www.facebook.com/razer/posts/10 … tif_t=like) and submitted a support request on their site (who knows where that will end up...:D). If a business case can be made for contributing a patch, I don't see why they wouldn't have someone spend a few days doing it. But then, there's a reason I'm not in business smile

Best,R

Offline

#39 2014-04-29 20:37:33

labotsirc
Member
Registered: 2013-08-21
Posts: 81

Re: Razer Blade [Gen 1]

FxChiP wrote:

Incidentally if anyone is interested, check out http://i.imgur.com/E2K550e.jpg . Source code at http://github.com/FxChiP/rzswitchblade/ .

Watch out: if you're not using the synaptics patch I wrote, the blit test *will* lock your keyboard and mouse. If you use the harness and are able to rebind your keyboard, things get a *little* better (you get keyboard back, anyway).

Amazing job man. Long time since i last posted.

About the picture, great progress!.
Do you think it could be possible to put a terminal window in there?

Offline

#40 2014-04-30 01:57:31

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Looks like something might be happening on the kernel side for the touchpad on the RB14 at least (although he says RB17 has different type of touchpad so this might not apply).

https://bbs.archlinux.org/viewtopic.php … 2#p1410412

Offline

#41 2014-04-30 03:26:45

labotsirc
Member
Registered: 2013-08-21
Posts: 81

Re: Razer Blade [Gen 1]

riveale wrote:

Yo, just a heads up, It would be really nice if razer could contribute help or a patch for their hardware. I pinged them on facebook (https://www.facebook.com/razer/posts/10 … tif_t=like) and submitted a support request on their site (who knows where that will end up...:D). If a business case can be made for contributing a patch, I don't see why they wouldn't have someone spend a few days doing it. But then, there's a reason I'm not in business smile

Best,R


We should join forces and make a petition to the CEO he seems a guy that can listen to his users

Offline

#42 2014-04-30 03:36:59

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Haha, yea, we got shot down trying to go through support and through their marketing (facebook?) team.

R

Offline

#43 2014-04-30 04:09:57

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 12,740

Re: Razer Blade [Gen 1]

Guys, do what you will, but please... do not organize it here.
As a moderator, I would appreciate it.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Like you, I have no idea what you are doing, but I am pretty sure it is wrong...Jasonwryan
----
How to Ask Questions the Smart Way

Offline

#44 2014-05-01 03:41:15

riveale
Member
Registered: 2013-09-10
Posts: 49
Website

Re: Razer Blade [Gen 1]

Keeping this thread updated in case anyone has a lightbulb in their head.

https://bbs.archlinux.org/viewtopic.php?pid=1410745

Some progress being made on the RB14 side (?). As you noted a while ago FxChip, the thing is an HID multiplexing thing. Apparently there is a new synaptics HID driver being developed (that will be mainlined in 3.16) that should work for the touchpad to get multitouch etc., but the problem right now is that it tries to load that driver for that whole device, which includes the keyboard as well as touchpad, and thus it locks up the keyboard.

Note that this is for RB14, RB17 unfortunately (?) has a different thing...

Offline

#45 2014-05-01 15:56:25

labotsirc
Member
Registered: 2013-08-21
Posts: 81

Re: Razer Blade [Gen 1]

Very good news

A contributor of the USB 3.0 module (xhci) was very kind on taking care of the keyboard problem of RB17 machines. We have been working together and she already made a patch that works for the RB17 2013 which uses USB 3.0 module, which in fact i am using right now.
We will probably keep testing things to make sure it can be proposed to the community. Hopefully, this patch could make its way into a future kernel version and finally have Arch Linux work out of the box for the RB17 regarding basic functionality. That would be the first step for then focusing on the SBUI and led buttons where FxChip is doing an amazing job.

I will keep updating these news as we make more progress.

Last edited by labotsirc (2014-05-01 16:00:16)

Offline

#46 2014-05-07 01:37:21

aintaer
Member
Registered: 2013-04-17
Posts: 6

Re: Razer Blade [Gen 1]

Glad to hear about the progress! I also volunteer my Blade (Gen 1, dualbooting) for testing.

Offline

#47 2014-11-21 00:12:29

Gryaniy
Member
From: USA,UKRAINE,MEXICO
Registered: 2013-02-15
Posts: 46

Re: Razer Blade [Gen 1]

@Labotsirc - did you ever get that patch for the keyboard?

Offline

Board footer

Powered by FluxBB