You are not logged in.

#1 2013-10-09 11:52:31

kryta
Member
Registered: 2012-11-07
Posts: 31

[SOLVED] upgrade problem, bluez and obexd-client are in conflict

Hello guys.

When I execute "pacman -Syu" I get this problem with bluez and obexd-client packages:

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace gvfs-obexftp with extra/gvfs? [Y/n] Y
resolving dependencies...
looking for intern-conflicts...
:: bluez and obexd-client are in conflict. Remove obexd-client? [y/N] y
error: detect a conflict package impossible to resolve
error: failed to prepare transaction (could not satisfy dependencies)
:: bluez and obexd-client are in conflict

Any suggestion? Thank you and regards.

Last edited by kryta (2013-10-10 12:16:49)

Offline

#2 2013-10-09 12:07:39

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

There are some threads about bluez already.
Have you tried removing either bluez or obexd-client by hand? Are they dependencies for any package?

When posting configs, code or command output, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this

Offline

#3 2013-10-09 13:45:22

kryta
Member
Registered: 2012-11-07
Posts: 31

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

karol wrote:

There are some threads about bluez already.
Have you tried removing either bluez or obexd-client by hand? Are they dependencies for any package?

When posting configs, code or command output, please use [ code ] tags, not [ quote ] tags https://bbs.archlinux.org/help.php#bbcode

like this

Hi karol.

I have removed obexd-client without any problem but now when execute

 pacman -Syu 

system says:

:: Synchronizing package databases...
core is up to date
extra is up to date
community is up to date
multilib is up to date
archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace gvfs-obexftp with extra/gvfs? [Y/n] Y
resolving dependencies...
looking for intern-conflicts...
:: bluez and bluez4 are in conflict. Remove obexd-client? [y/N] y
error: detect a conflict package impossible to resolve
error: failed to prepare transaction (could not satisfy dependencies)
:: bluez and bluez4 are in conflict

I try to remove bluez4 and system says:

:: gnome-bluetooth: requires bluez4
:: gvfs-obexftp: requires bluez4

and I try to remove gnome-bluetooth and gvfs-obexftp

 sudo pacman -Rns gnome-bluetooth gvfs-obexftp 

and system says:

:: gnome-control-center: requires gnome-bluetooth
:: gnome-shell: requires gnome-bluetooth

Any idea?

Thank you and regards!

Last edited by kryta (2013-10-09 13:46:46)

Offline

#4 2013-10-09 13:51:46

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

See https://bbs.archlinux.org/viewtopic.php?id=170968 and other threads.
I know nothing about either gnome or bluetooth, but since posting on the forums like https://bbs.archlinux.org/viewtopic.php?id=170582 didn't change anything, I suggest asking on the mailing list or opening a bug report.

Offline

#5 2013-10-09 23:05:40

Pse
Member
Registered: 2008-03-15
Posts: 383

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

Remove gvfs-obexftp and obexd-client first. Do not remove gnome-bluetooth. Then attempt an upgrade.

Offline

#6 2013-10-09 23:07:46

kryta
Member
Registered: 2012-11-07
Posts: 31

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

Pse wrote:

Remove gvfs-obexftp and obexd-client first. Do not remove gnome-bluetooth. Then attempt an upgrade.

Hi Pse.

I try it, but when I execute

pacman -Syu

pacman says:

:: bluez and bluez4 are in conflict. Remove bluez4? [y/N] y
error: detect a conflict package impossible to resolve
error: failed to prepare transaction (could not satisfy dependencies)
:: bluez and bluez4 are in conflict

and N

:: bluez and bluez4 are in conflict. Remove bluez4? [y/N] N
error: detect a conflict package impossible to resolve
error: failed to prepare transaction (could not satisfy dependencies)
:: bluez and bluez4 are in conflict

I don't know what happen.

I don't use bluetooth and I think to force pacman upgrade....

What is your opinion? I don't want to break system.

Thank you and regards.

Last edited by kryta (2013-10-09 23:14:47)

Offline

#7 2013-10-09 23:30:03

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

I've never seen

error: detect a conflict package impossible to resolve

before. Why does it error out? Is this proper English even?

https://projects.archlinux.org/svntogit … c09a1d567d
changed gnome-bluetooth dependency from bluez4 to bluez, so let's get rid of bluez4.

kryta, run 'pacman -Rdd bluez4' and then try updating again with 'pacman -Syu'.

Offline

#8 2013-10-10 00:21:14

kryta
Member
Registered: 2012-11-07
Posts: 31

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

karol wrote:

I've never seen

error: detect a conflict package impossible to resolve

before. Why does it error out? Is this proper English even?

https://projects.archlinux.org/svntogit … c09a1d567d
changed gnome-bluetooth dependency from bluez4 to bluez, so let's get rid of bluez4.

kryta, run 'pacman -Rdd bluez4' and then try updating again with 'pacman -Syu'.

Hi karol.

Sorry for my English, I need to improve English.

Thank you, now I have upgraded my system and all is fine.

Regards!

Offline

#9 2013-10-10 00:35:28

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

kryta wrote:

Sorry for my English, I need to improve English.

Are you saying that you translated these messages yourself?

If so, next time please run

LC_ALL=C <command>

to get output in English e.g. 'LC_ALL=C pacman -Syu'. It's important to get the exact output.

Offline

#10 2013-10-10 03:04:05

soul916
Member
Registered: 2009-01-31
Posts: 7

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

kryta wrote:
karol wrote:

I've never seen

error: detect a conflict package impossible to resolve

before. Why does it error out? Is this proper English even?

https://projects.archlinux.org/svntogit … c09a1d567d
changed gnome-bluetooth dependency from bluez4 to bluez, so let's get rid of bluez4.

kryta, run 'pacman -Rdd bluez4' and then try updating again with 'pacman -Syu'.

Hi karol.

Sorry for my English, I need to improve English.

Thank you, now I have upgraded my system and all is fine.

Regards!

Thanks, I have resolved the problem use information from this post.

I use 'pacman -S  gnome-bluetooth' first update the gnome-bluetooth and the update will remove the bluez4

Offline

#11 2013-10-10 12:01:43

kryta
Member
Registered: 2012-11-07
Posts: 31

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

karol wrote:
kryta wrote:

Sorry for my English, I need to improve English.

Are you saying that you translated these messages yourself?

Yes

karol wrote:

to get output in English e.g. 'LC_ALL=C pacman -Syu'. It's important to get the exact output.

Ok. I didn't know how make it.

Thank you and regards.

Offline

#12 2013-10-10 12:07:27

karol
Archivist
Registered: 2009-05-06
Posts: 25,428

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

Your English is not perfect, but it's OK.
I was surprised that pacman would print a new and weird-sounding message, one that I never saw before. I didn't know it was you, not pacman :-)


Please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309

Offline

#13 2013-10-10 12:19:28

kryta
Member
Registered: 2012-11-07
Posts: 31

Re: [SOLVED] upgrade problem, bluez and obexd-client are in conflict

karol wrote:

Your English is not perfect, but it's OK.
I was surprised that pacman would print a new and weird-sounding message, one that I never saw before. I didn't know it was you, not pacman :-)

Ok wink

karol wrote:

Please remember to mark the thread as solved https://bbs.archlinux.org/viewtopic.php?id=130309

I have marked the thread as solved.

Regards!

Offline

Board footer

Powered by FluxBB