You are not logged in.

#2376 2013-11-02 05:28:29

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:
chenxiaolong wrote:
divansantana wrote:

Chen - you are being missed! Hopefully some updated packages soon? smile

I'm not gone and definitely not giving up on Unity yet big_smile I just have other priorities right now, mainly practicing for the ACM programming competition.

Maybe I'll try to fix my build server tomorrow. A bug in the chroot tool (systemd-nspawn) stops me from building multiple packages at the same time, so I can't really merge pull requests yet. They'd all just fail to build. If I can merge pull requests, at least other people can help me update the packages.

I saw that GTK 3.10 in the Ubuntu GNOME PPA was updated to 3.10.2 recently. Unfortunately, the patch to make indicators work properly still isn't fixed sad

Chen which patch are you referring to? I think there is trace in the patches from ubuntu package

I'm referring to ubuntu_gtk_custom_menu_items.patch. The patch allows custom GTK widgets to be used in menus, so things like the calendar in the datetime indicator will work. For now, they added a ubuntu_gtk_custom_menu_items-dummy.patch, which only makes the indicators compile. Nothing will work though sad


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2377 2013-11-02 07:34:43

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
gianluca.pettinello wrote:
chenxiaolong wrote:

I'm not gone and definitely not giving up on Unity yet big_smile I just have other priorities right now, mainly practicing for the ACM programming competition.

Maybe I'll try to fix my build server tomorrow. A bug in the chroot tool (systemd-nspawn) stops me from building multiple packages at the same time, so I can't really merge pull requests yet. They'd all just fail to build. If I can merge pull requests, at least other people can help me update the packages.

I saw that GTK 3.10 in the Ubuntu GNOME PPA was updated to 3.10.2 recently. Unfortunately, the patch to make indicators work properly still isn't fixed sad

Chen which patch are you referring to? I think there is trace in the patches from ubuntu package

I'm referring to ubuntu_gtk_custom_menu_items.patch. The patch allows custom GTK widgets to be used in menus, so things like the calendar in the datetime indicator will work. For now, they added a ubuntu_gtk_custom_menu_items-dummy.patch, which only makes the indicators compile. Nothing will work though sad

Thanks Chen! And do you know why unity lens application doesn't work. I get a unity-scope-loader segmentation fault? Anybody else having the same problem with gnome 3.10?
By the way I upgraded most of the packages to the last version, even though this didn't sole my problems. Vala0.18 and libgee06 for me are not necessary any more. If you want I have the tree structure with pkgbuilds and in some cases I added not phone patch

Offline

#2378 2013-11-03 18:02:35

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

For anyone who hasn't upgraded to GNOME 3.8 yet, you must switch to these repos:

[Unity-for-Arch]
SigLevel = Optional TrustAll
Server = http://dl.dropbox.com/u/486665/Repos/Unity-for-Arch-GNOME-3.8/$arch

[Unity-for-Arch-Extra]
SigLevel = Optional TrustAll
Server = http://dl.dropbox.com/u/486665/Repos/Unity-for-Arch-Extra-GNOME-3.8/$arch

GNOME 3.10 packages will be pushed to the main repos later today.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2379 2013-11-03 22:55:04

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

Unity with GNOME 3.10 is now available! Just run "pacman -Syu" to upgrade.

There are a couple things that do not work:

  1. Advanced indicator widgets, like the calendar and volume sliders, do not work.

  2. The global appmenu is broken for some apps, so it is disabled by default. To enable it, create an empty file: ~/.config/enable-gtk-appmenu

IPsk9On.png


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2380 2013-11-04 22:02:55

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

Hi Chen, is unity lens application working for you? I still get segmentation fault while trying to run unity-scope-loader commands.scope.
In addition unity-lens-files works only if I copy zeitgeist-fts and org.gnome.zeitgeist-fts from ubuntu package. Is my system messed up??
Thanks for your help

Offline

#2381 2013-11-04 22:59:56

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

gianluca.pettinello wrote:

Hi Chen, is unity lens application working for you? I still get segmentation fault while trying to run unity-scope-loader commands.scope.
In addition unity-lens-files works only if I copy zeitgeist-fts and org.gnome.zeitgeist-fts from ubuntu package. Is my system messed up??
Thanks for your help

Actually, unity-lens-applications is working fine for me. Maybe some packages need to be recompiled? You're right about unity-lens-files not working. I didn't even notice because I never use it. I'll see if I can bundle zeitgeist-fts with the unity-lens-files package.


Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2382 2013-11-05 01:20:58

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:

Unity with GNOME 3.10 is now available! Just run "pacman -Syu" to upgrade.

There are a couple things that do not work:

  1. Advanced indicator widgets, like the calendar and volume sliders, do not work.

  2. The global appmenu is broken for some apps, so it is disabled by default. To enable it, create an empty file: ~/.config/enable-gtk-appmenu

Some other stuff doesn't work for me

  1. Nautilus doesn't have proper window decoration

  2. Indicator-messages doesn't work(but it stopped working long ago. Previously I was using 13.10.1.13.10.20130822.5-100 which is the latest version that works properly) 

Anyway, thanks a lot. @chenxiaolong. Today I was able to install 472 updates which were long overdue.:)

Offline

#2383 2013-11-05 09:26:25

tydell
Member
From: actually: Hannover, DE
Registered: 2009-07-26
Posts: 102
Website

Re: Progress on Unity under Arch Linux!

What do you mean - proper window decoration ?
Something like this ?
554QmO2l.png
It's Gnome 3.10 with CSD (client side decorations) and it's normal

Last edited by tydell (2013-11-05 10:09:36)

Offline

#2384 2013-11-05 09:31:26

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

tydell wrote:

What do you mean - proper window decoration ?
Something like this ?

It's Gnome 3.10 with CSD (client side decorations) and it's normal

Yes, exactly. So it's a feature of nautilus in Gnome 3.10? I can understand that they remove the titlebar. But now it doesn't even have a normal shadow.

Offline

#2385 2013-11-06 05:40:25

divansantana
Member
Registered: 2011-01-21
Posts: 117

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:

For anyone who hasn't upgraded to GNOME 3.8 yet, you must switch to these repos:

[Unity-for-Arch]
SigLevel = Optional TrustAll
Server = http://dl.dropbox.com/u/486665/Repos/Unity-for-Arch-GNOME-3.8/$arch

[Unity-for-Arch-Extra]
SigLevel = Optional TrustAll
Server = http://dl.dropbox.com/u/486665/Repos/Unity-for-Arch-Extra-GNOME-3.8/$arch

GNOME 3.10 packages will be pushed to the main repos later today.

So are we supposed to just use the Unity-for-Arch-GNOME-3.8 repos or the standard Unity-for-Arch repos?
Because when trying the latter I get:
  error: failed to prepare transaction (unexpected error)

Offline

#2386 2013-11-06 08:38:54

divansantana
Member
Registered: 2011-01-21
Posts: 117

Re: Progress on Unity under Arch Linux!

Ok I have a dependency issue which I resolved.

Now I've got these issues:
Panel and desktop get cut off and duplicate itself like so:
https://dl.dropboxusercontent.com/u/7043306/1.png


The new unity-tweak-tool doesn't work and contains nothing.
% ll /var/cache/pacman/pkg/unity-tweak-tool-0.0.*
-rw-r--r-- 1 root root 357304 Oct  2 18:22 /var/cache/pacman/pkg/unity-tweak-tool-0.0.4.ubuntu0.1-1-any.pkg.tar.xz
-rw-r--r-- 1 root root   1024 Nov  6 08:27 /var/cache/pacman/pkg/unity-tweak-tool-0.0.6-4-any.pkg.tar.xz

% pacman -Ql unity-tweak-tool
%

gnome-tweak-tool doesn't work as an alternative to unity-tweak-tool
% gnome-tweak-tool   
WARNING : Shell not installed or running

ctrl+alt+l no longer locks desktop so far.

gnome-control-center menus looks pretty messed up.
https://dl.dropboxusercontent.com/u/7043306/2.png

Maybe some of the above is because I customized unity?

Offline

#2387 2013-11-06 08:48:23

divansantana
Member
Registered: 2011-01-21
Posts: 117

Re: Progress on Unity under Arch Linux!

how does one enable multiple workspaces/virtual desktops again?
unity-tweak-tool and gnome-tweak-tool aren't working.
Can't seem to find it in CCSM

Offline

#2388 2013-11-07 01:32:07

GermanyChris
Member
From: Southern Germany
Registered: 2013-10-14
Posts: 60

Re: Progress on Unity under Arch Linux!

How is this project going to go forward when Canonical brings Mir out? In slow kid terms

Last edited by GermanyChris (2013-11-07 01:34:49)


Don't scab for the bosses Don't listen to their lies Poor folks ain't got a chance Unless they organize --Florence Reece

Offline

#2389 2013-11-07 01:38:08

oi_wtf
Member
From: /home/wtf
Registered: 2012-03-11
Posts: 190

Re: Progress on Unity under Arch Linux!

divansantana wrote:

how does one enable multiple workspaces/virtual desktops again?
unity-tweak-tool and gnome-tweak-tool aren't working.
Can't seem to find it in CCSM

in ccsm:  General Settings -> Desktop Size

Last edited by oi_wtf (2013-11-07 01:38:35)


Laptop:   Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-3630QM @ 2.40GHz, 8 GiB RAM, NViDiA GeForce GT 650M 2 GiB
Desktop: Arch Linux (x86_64) and Win8.1 (x86_64);  Intel Core i7-4771  @ 3.50GHz, 8 GiB RAM, NViDiA GeForce GTX 660 Ti 2GiB

Offline

#2390 2013-11-07 05:27:05

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

Okay, this is screwball... I'm trying to install Unity now that Chen's got 3.10 working. I'm getting unresolved dependencies of libdbusmenu-gtk2 and libindicate. I'm fairly sure that the reason why it's telling me this is that according to the code below, Arch wants to downgrade my libdusmenu-glib package to an older version, instead of the required version.

[mikearch1@mikearchlaptop ~]$ sudo pacman -S $(pacman -Slq Unity-for-Arch)
[sudo] password for mikearch1: 
warning: libappindicator-12.10.1daily13.09.20-101 is up to date -- reinstalling
warning: downgrading package libdbusmenu-glib (12.10.3daily13.09.13-103 => 12.10.2-3)
warning: libdbusmenu-gtk2-12.10.3daily13.09.13-103 is up to date -- reinstalling
warning: libindicate-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk2-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk3-12.10.1-110 is up to date -- reinstalling
warning: libindicate-qt-0.2.5.91.5-106 is up to date -- reinstalling
warning: libindicator-12.10.2daily13.09.13-101 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...
warning: removing 'dee' from target list because it conflicts with 'dee-ubuntu'
:: gtk2-ubuntu and gtk2 are in conflict. Remove gtk2? [y/N] y
:: gsettings-desktop-schemas-ubuntu and gsettings-desktop-schemas are in conflict. Remove gsettings-desktop-schemas? [y/N] y
:: gtk3-ubuntu and gtk3 are in conflict. Remove gtk3? [y/N] y
:: gnome-settings-daemon-ubuntu and gnome-settings-daemon are in conflict. Remove gnome-settings-daemon? [y/N] y
:: network-manager-applet-ubuntu and network-manager-applet are in conflict. Remove network-manager-applet? [y/N] y
:: gnome-control-center-ubuntu and gnome-control-center are in conflict. Remove gnome-control-center? [y/N] y
:: gnome-session-ubuntu and gnome-session are in conflict. Remove gnome-session? [y/N] y
:: qt4-ubuntu and qt4 are in conflict. Remove qt4? [y/N] y
:: libnautilus-extension-ubuntu and libnautilus-extension are in conflict. Remove libnautilus-extension? [y/N] y
:: nautilus-ubuntu and nautilus are in conflict. Remove nautilus? [y/N] y
:: zeitgeist-ubuntu and zeitgeist are in conflict (zeitgeist-datahub). Remove zeitgeist? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: libdbusmenu-gtk2: requires libdbusmenu-glib=12.10.3daily13.09.13
:: libindicate: requires libdbusmenu

So, just to be sure, I try installing the packages listed after the error message:

[mikearch1@mikearchlaptop ~]$ sudo pacman -S libdbusmenu-gtk2
warning: libdbusmenu-gtk2-12.10.3daily13.09.13-103 is up to date -- reinstalling

[mikearch1@mikearchlaptop ~]$ sudo pacman -S libdbusmenu
warning: libdbusmenu-glib-12.10.3daily13.09.13-103 is up to date -- reinstalling

sudo pacman -S libindicate
warning: libindicate-12.10.1-110 is up to date -- reinstalling

What's going on? Am I just doing something wrong?

Offline

#2391 2013-11-07 06:38:44

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:

Okay, this is screwball... I'm trying to install Unity now that Chen's got 3.10 working. I'm getting unresolved dependencies of libdbusmenu-gtk2 and libindicate. I'm fairly sure that the reason why it's telling me this is that according to the code below, Arch wants to downgrade my libdusmenu-glib package to an older version, instead of the required version.

[mikearch1@mikearchlaptop ~]$ sudo pacman -S $(pacman -Slq Unity-for-Arch)
[sudo] password for mikearch1: 
warning: libappindicator-12.10.1daily13.09.20-101 is up to date -- reinstalling
warning: downgrading package libdbusmenu-glib (12.10.3daily13.09.13-103 => 12.10.2-3)
warning: libdbusmenu-gtk2-12.10.3daily13.09.13-103 is up to date -- reinstalling
warning: libindicate-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk2-12.10.1-110 is up to date -- reinstalling
warning: libindicate-gtk3-12.10.1-110 is up to date -- reinstalling
warning: libindicate-qt-0.2.5.91.5-106 is up to date -- reinstalling
warning: libindicator-12.10.2daily13.09.13-101 is up to date -- reinstalling
resolving dependencies...
looking for inter-conflicts...
warning: removing 'dee' from target list because it conflicts with 'dee-ubuntu'
:: gtk2-ubuntu and gtk2 are in conflict. Remove gtk2? [y/N] y
:: gsettings-desktop-schemas-ubuntu and gsettings-desktop-schemas are in conflict. Remove gsettings-desktop-schemas? [y/N] y
:: gtk3-ubuntu and gtk3 are in conflict. Remove gtk3? [y/N] y
:: gnome-settings-daemon-ubuntu and gnome-settings-daemon are in conflict. Remove gnome-settings-daemon? [y/N] y
:: network-manager-applet-ubuntu and network-manager-applet are in conflict. Remove network-manager-applet? [y/N] y
:: gnome-control-center-ubuntu and gnome-control-center are in conflict. Remove gnome-control-center? [y/N] y
:: gnome-session-ubuntu and gnome-session are in conflict. Remove gnome-session? [y/N] y
:: qt4-ubuntu and qt4 are in conflict. Remove qt4? [y/N] y
:: libnautilus-extension-ubuntu and libnautilus-extension are in conflict. Remove libnautilus-extension? [y/N] y
:: nautilus-ubuntu and nautilus are in conflict. Remove nautilus? [y/N] y
:: zeitgeist-ubuntu and zeitgeist are in conflict (zeitgeist-datahub). Remove zeitgeist? [y/N] y
error: failed to prepare transaction (could not satisfy dependencies)
:: libdbusmenu-gtk2: requires libdbusmenu-glib=12.10.3daily13.09.13
:: libindicate: requires libdbusmenu

So, just to be sure, I try installing the packages listed after the error message:

[mikearch1@mikearchlaptop ~]$ sudo pacman -S libdbusmenu-gtk2
warning: libdbusmenu-gtk2-12.10.3daily13.09.13-103 is up to date -- reinstalling

[mikearch1@mikearchlaptop ~]$ sudo pacman -S libdbusmenu
warning: libdbusmenu-glib-12.10.3daily13.09.13-103 is up to date -- reinstalling

sudo pacman -S libindicate
warning: libindicate-12.10.1-110 is up to date -- reinstalling

What's going on? Am I just doing something wrong?

After some exploring, I found that a package (libdbusmenu) needed for Unity resides in two different places- the community repo and the Unity-for-Arch/Unity-for-Arch-Extra repo. Unfortunately, Arch uses the community repo first, and tells pacman to downgrade libdbusmenu to the current version, which is 12.10.2-3. That results in the unsatisfied dependencies. I worked my way around the problem by uncommenting the community repo in /etc/pacman.conf, which resulted in a large number of failed dependencies. I then re-enabled the community repo, installed the missing dependencies (which were packagekit, bamf, xapian-core, libxdg-basedir, python-httplib2, python-oauthlib, and lsb-release), then disabled the community repo again and ran the install command for Unity-for-Arch. I now have Unity re-installed on my system... now off to see if it works!!!

Offline

#2392 2013-11-07 16:04:44

josephk
Member
Registered: 2011-01-09
Posts: 97
Website

Re: Progress on Unity under Arch Linux!

hi

does anyone know why there isn't libdbusmenu-gtk2 package in [community]?

Offline

#2393 2013-11-07 16:30:56

qiuwei
Member
Registered: 2009-12-18
Posts: 245

Re: Progress on Unity under Arch Linux!

@chenxiaolong

Today I just found that glib-ubuntu is not required by Unity-for-Arch any more, and it's not automatically replaced by the official version.
And it leads to that some other programs don't work normally.
My question is how I can get notified when some packages are removed from your repo?
Pacman seems to not be able to handle this automatically.

Offline

#2394 2013-11-09 16:04:51

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
gianluca.pettinello wrote:

Hi Chen, is unity lens application working for you? I still get segmentation fault while trying to run unity-scope-loader commands.scope.
In addition unity-lens-files works only if I copy zeitgeist-fts and org.gnome.zeitgeist-fts from ubuntu package. Is my system messed up??
Thanks for your help

Actually, unity-lens-applications is working fine for me. Maybe some packages need to be recompiled? You're right about unity-lens-files not working. I didn't even notice because I never use it. I'll see if I can bundle zeitgeist-fts with the unity-lens-files package.

I recompiled all packages but unfortunately not solved. No one having my problem in the known universe?

Offline

#2395 2013-11-12 21:35:36

mieLouk
Member
Registered: 2012-12-16
Posts: 36

Re: Progress on Unity under Arch Linux!

Got the same issues with libdbus* and my pulseaudio isn't starting anymore on my desktop, as a result of that. I've tried really hard (within my capabilites)

Offline

#2396 2013-11-13 05:39:53

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
gianluca.pettinello wrote:

Hi Chen, is unity lens application working for you? I still get segmentation fault while trying to run unity-scope-loader commands.scope.
In addition unity-lens-files works only if I copy zeitgeist-fts and org.gnome.zeitgeist-fts from ubuntu package. Is my system messed up??
Thanks for your help

Actually, unity-lens-applications is working fine for me. Maybe some packages need to be recompiled? You're right about unity-lens-files not working. I didn't even notice because I never use it. I'll see if I can bundle zeitgeist-fts with the unity-lens-files package.

Chen, I see here that you say unity-lens-applications is working for you. Any ideas as to why would mine be empty? There is nothing in my applications lens, even when I type in what I want. What's strange is my unity-lens-files that the two of you say is not working is working fine for me. BTW, I'm having a segmentation fault the same as gianluca.pettinello. Here's the code:

[mikearch1@mikearchlaptop ~]$ unity-scope-loader commands.scope
Error loading package indexes: Couldn't stat '/var/cache/software-center/xapian'

(unity-scope-loader:3064): unity-applications-daemon-CRITICAL **: daemon.vala:144: Failed to load Software Center 
index. 'Apps Available for Download' will not be listed

(unity-scope-loader:3064): GLib-CRITICAL **: g_path_get_basename: assertion 'file_name != NULL' failed
Segmentation fault (core dumped)

Just checked my /var/cache files... there is no software-center file. Is there a file that I've not downloaded?

Last edited by horsemanoffaith (2013-11-13 05:48:18)

Offline

#2397 2013-11-13 06:17:34

chenxiaolong
Member
From: /home/chenxiaolong
Registered: 2010-11-03
Posts: 779

Re: Progress on Unity under Arch Linux!

horsemanoffaith wrote:
chenxiaolong wrote:
gianluca.pettinello wrote:

Hi Chen, is unity lens application working for you? I still get segmentation fault while trying to run unity-scope-loader commands.scope.
In addition unity-lens-files works only if I copy zeitgeist-fts and org.gnome.zeitgeist-fts from ubuntu package. Is my system messed up??
Thanks for your help

Actually, unity-lens-applications is working fine for me. Maybe some packages need to be recompiled? You're right about unity-lens-files not working. I didn't even notice because I never use it. I'll see if I can bundle zeitgeist-fts with the unity-lens-files package.

Chen, I see here that you say unity-lens-applications is working for you. Any ideas as to why would mine be empty? There is nothing in my applications lens, even when I type in what I want. What's strange is my unity-lens-files that the two of you say is not working is working fine for me. BTW, I'm having a segmentation fault the same as gianluca.pettinello. Here's the code:

[mikearch1@mikearchlaptop ~]$ unity-scope-loader commands.scope
Error loading package indexes: Couldn't stat '/var/cache/software-center/xapian'

(unity-scope-loader:3064): unity-applications-daemon-CRITICAL **: daemon.vala:144: Failed to load Software Center 
index. 'Apps Available for Download' will not be listed

(unity-scope-loader:3064): GLib-CRITICAL **: g_path_get_basename: assertion 'file_name != NULL' failed
Segmentation fault (core dumped)

Just checked my /var/cache files... there is no software-center file. Is there a file that I've not downloaded?

I'll probably do a clean install of Arch this weekend. I have messed with so many packages that it could be something that I installed that keeps things working. By the way, here is my output. I don't think the missing files are the issue:

WARNING: ~/.zshrc differs from /stuff/chenxiaolong/Configuration/zshrc
[jf-common] unity-scope-loader commands.scope                       1:16:41  ☁  d4c40b9 ☀
Error loading package indexes: Couldn't stat '/var/cache/software-center/xapian'

(unity-scope-loader:31117): unity-applications-daemon-CRITICAL **: daemon.vala:144: Failed to load Software Center index. 'Apps Available for Download' will not be listed

Current system: Lenovo W520
Unity-for-Arch repos' build statuses and old packages: https://jenkins.noobdev.io/

Offline

#2398 2013-11-13 19:17:33

gianluca.pettinello
Member
Registered: 2013-04-16
Posts: 57

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
horsemanoffaith wrote:
chenxiaolong wrote:

Actually, unity-lens-applications is working fine for me. Maybe some packages need to be recompiled? You're right about unity-lens-files not working. I didn't even notice because I never use it. I'll see if I can bundle zeitgeist-fts with the unity-lens-files package.

Chen, I see here that you say unity-lens-applications is working for you. Any ideas as to why would mine be empty? There is nothing in my applications lens, even when I type in what I want. What's strange is my unity-lens-files that the two of you say is not working is working fine for me. BTW, I'm having a segmentation fault the same as gianluca.pettinello. Here's the code:

[mikearch1@mikearchlaptop ~]$ unity-scope-loader commands.scope
Error loading package indexes: Couldn't stat '/var/cache/software-center/xapian'

(unity-scope-loader:3064): unity-applications-daemon-CRITICAL **: daemon.vala:144: Failed to load Software Center 
index. 'Apps Available for Download' will not be listed

(unity-scope-loader:3064): GLib-CRITICAL **: g_path_get_basename: assertion 'file_name != NULL' failed
Segmentation fault (core dumped)

Just checked my /var/cache files... there is no software-center file. Is there a file that I've not downloaded?

I'll probably do a clean install of Arch this weekend. I have messed with so many packages that it could be something that I installed that keeps things working. By the way, here is my output. I don't think the missing files are the issue:

WARNING: ~/.zshrc differs from /stuff/chenxiaolong/Configuration/zshrc
[jf-common] unity-scope-loader commands.scope                       1:16:41  ☁  d4c40b9 ☀
Error loading package indexes: Couldn't stat '/var/cache/software-center/xapian'

(unity-scope-loader:31117): unity-applications-daemon-CRITICAL **: daemon.vala:144: Failed to load Software Center index. 'Apps Available for Download' will not be listed

Just to be clear my unity-lens-files works after I copied zeitgeist-fts. Unity-lens-applications doesn't work and gives me segmentation fault

Offline

#2399 2013-11-16 05:02:01

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

chenxiaolong wrote:
horsemanoffaith wrote:
chenxiaolong wrote:

Actually, unity-lens-applications is working fine for me. Maybe some packages need to be recompiled? You're right about unity-lens-files not working. I didn't even notice because I never use it. I'll see if I can bundle zeitgeist-fts with the unity-lens-files package.

Chen, I see here that you say unity-lens-applications is working for you. Any ideas as to why would mine be empty? There is nothing in my applications lens, even when I type in what I want. What's strange is my unity-lens-files that the two of you say is not working is working fine for me. BTW, I'm having a segmentation fault the same as gianluca.pettinello. Here's the code:

[mikearch1@mikearchlaptop ~]$ unity-scope-loader commands.scope
Error loading package indexes: Couldn't stat '/var/cache/software-center/xapian'

(unity-scope-loader:3064): unity-applications-daemon-CRITICAL **: daemon.vala:144: Failed to load Software Center 
index. 'Apps Available for Download' will not be listed

(unity-scope-loader:3064): GLib-CRITICAL **: g_path_get_basename: assertion 'file_name != NULL' failed
Segmentation fault (core dumped)

Just checked my /var/cache files... there is no software-center file. Is there a file that I've not downloaded?

I'll probably do a clean install of Arch this weekend. I have messed with so many packages that it could be something that I installed that keeps things working. By the way, here is my output. I don't think the missing files are the issue:

WARNING: ~/.zshrc differs from /stuff/chenxiaolong/Configuration/zshrc
[jf-common] unity-scope-loader commands.scope                       1:16:41  ☁  d4c40b9 ☀
Error loading package indexes: Couldn't stat '/var/cache/software-center/xapian'

(unity-scope-loader:31117): unity-applications-daemon-CRITICAL **: daemon.vala:144: Failed to load Software Center index. 'Apps Available for Download' will not be listed

Thanks for getting back to me, Chen! I appreciate it... looks like we're all having the same problem!

Offline

#2400 2013-11-16 05:08:47

horsemanoffaith
Member
Registered: 2013-05-10
Posts: 137

Re: Progress on Unity under Arch Linux!

Okay, I have another issue. When I first log in to Unity my gnome-tweak-tool settings are loaded and everything looks exactly the way that I want it (at least until Unity-tweak-tool is fixed). I have it set to Radiance for both the window setting and GTK+ and the Icons set to Ubuntu-mono-light. About 5 minutes or so into my session, Unity reverts to the default Gnome 3.10 settings (which are okay, but not what I want). When I run gnome-tweak-tool to change the settings, I get the following error:

[mikearch1@mikearchlaptop ~]$ gnome-tweak-tool
WARNING : Shell not installed or running
WARNING : Error detecting shell
Traceback (most recent call last):
  File "/usr/lib/python2.7/site-packages/gtweak/tweaks/tweak_group_shell_extensions.py", line 284, in __init__
    raise Exception("Shell not running or DBus service not available")
Exception: Shell not running or DBus service not available
WARNING : Shell not running
None
INFO    : GSettings missing key org.gnome.nautilus.desktop (key computer-icon-visible)

Obviously the shell isn't running... I would assume this would be the gnome-shell that Unity runs on. Any recommendations to fix it?

Offline

Board footer

Powered by FluxBB