You are not logged in.

#1 2006-01-19 21:36:02

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

[arch64] Qt (>= Qt 3.0) (library qt-mt) not found

I'm having problems with several packages getting this error message:

checking for Qt... configure: error: Qt (>= Qt 3.0) (library qt-mt) not found. Please check your installation!
For more details about this problem, look at the end of config.log.
Make sure that you have compiled Qt with thread support!
make: *** Keine Targets angegeben und keine »make«-Steuerdatei gefunden.  Schluss.
==> ERROR: Build Failed.  Aborting...

But all seems to bee there:

[root@workstation64 termcap-compat]# slocate qt-mt
/opt/qt/lib/libqt-mt.so.3
/opt/qt/lib/pkgconfig/qt-mt.pc
/opt/qt/lib/libqt-mt.prl
/opt/qt/lib/libqt-mt.so
/opt/qt/lib/libqt-mt.so.3.3.5
/opt/qt/lib/libqt-mt.so.3.3

Thread support seems to be enabled:

http://arch64.org/svn/trunk/extra/lib/q … iew=markup

from qt pkgbuild:

./configure -prefix /opt/qt -platform linux-g++ 
    -system-zlib -qt-gif -release -shared -sm -nis -thread -stl 
    -{system-lib,plugin-imgfmt-}{png,jpeg,mng} 
    -no-g++-exceptions -plugin-sql-{mysql,psql,sqlite,odbc}

Any idea?

Offline

#2 2006-01-19 21:53:53

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: [arch64] Qt (>= Qt 3.0) (library qt-mt) not found

I guess the qt pkg needs to be rebuild with a symlink /opt/qt/lib -> /opt/qt/lib64. I'll try that.

Offline

#3 2006-01-19 22:39:58

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: [arch64] Qt (>= Qt 3.0) (library qt-mt) not found

Yeah. That's the reason. Got it fixed. A new qt pkg is on the way.

Offline

#4 2006-01-19 22:47:06

AndyRTR
Developer
From: Magdeburg/Germany
Registered: 2005-10-07
Posts: 1,637

Re: [arch64] Qt (>= Qt 3.0) (library qt-mt) not found

I'm not sure if this only occurs on my system:

For updating qt I had to

pacman -Rd qt
rm /opt/qt/lib/*
rmdir /opt/qt/lib
pacman -U(or for you -S) qt

I hope it will cleanly update when next update will be released. Sorry. But I have no time for writing an execellent qt.install script.

Offline

Board footer

Powered by FluxBB