You are not logged in.

#1 2014-01-10 00:54:35

kaos77
Member
Registered: 2013-04-26
Posts: 6

[Mostly Solved] Copy *to* tftp server fails

I setup tftp-hpa server as directed in the wiki.  I can copy files *from* tftp to my Cisco router just fine.  Obviously the tftp service is up and running.  I haven't set up any firewall rules yet, default policy is still set to ALLOW.  I am just unable to tftp *to* my Arch box.  I Google'd this issue till I couldn't think of what to Google next.  I've searched the forums here, but haven't found anything specific to things working in only one direction.

tftpd.* files:

[root@wrangler system]# cat tftpd.service 
[Unit]
Description=hpa's original TFTP daemon

[Service]
ExecStart=/usr/bin/in.tftpd -s /srv/tftp/
StandardInput=socket
StandardOutput=inherit
StandardError=journal
[root@wrangler system]# 
[root@wrangler system]# 
[root@wrangler system]# 
[root@wrangler system]# cat tftpd.socket
[Socket]
ListenDatagram=69

[Install]
WantedBy=sockets.target
[root@wrangler system]# 

It is running:

[root@wrangler system]# ps aux|grep tftp
root      1549  0.0  0.0   6576   636 ?        Ss   18:47   0:00 /usr/bin/in.tftpd -s /srv/tftp/
root      1551  0.0  0.0  10664  1060 pts/1    S+   18:47   0:00 grep tftp
[root@wrangler system]# 

Firewall is not the issue:

[root@wrangler system]# iptables --list
Chain INPUT (policy ACCEPT)
target     prot opt source               destination         

Chain FORWARD (policy ACCEPT)
target     prot opt source               destination         

Chain OUTPUT (policy ACCEPT)
target     prot opt source               destination         
[root@wrangler system]# 

It's listening:

[root@wrangler system]# netstat -nap |grep 69
udp6       0      0 :::69                   :::*                                1/init              
unix  2      [ ]         DGRAM                    13150    642/systemd          @/org/freedesktop/systemd1/notify/11027632113387699407
unix  3      [ ]         STREAM     CONNECTED     11769    435/dbus-daemon      /run/dbus/system_bus_socket
unix  3      [ ]         STREAM     CONNECTED     7369     515/-:0              
unix  3      [ ]         STREAM     CONNECTED     11669    487/X                @/tmp/.X11-unix/X0
unix  3      [ ]         STREAM     CONNECTED     13869    806/akonadiserver    

The default installed permissions on the tftp  folder:

[root@wrangler system]# ls -l /srv
total 16
dr-xr-xr-x 2 root ftp  4096 May 31  2013 ftp
dr-xr-xr-x 2 root root 4096 May 31  2013 http
drwxr-xr-x 2 root root 4096 Jan  9 18:01 tftp
drwxr-xr-x 2 root root 4096 Jan  9 16:12 tftp.bak
[root@wrangler system]# 

It feels like a permissions problem (unable to write to directory, but able to read from it).  I had changed the permissions but it didn't seem to make any difference.

Any assistance would be appreciated.

Last edited by kaos77 (2014-01-10 04:37:12)

Offline

#2 2014-01-10 04:36:39

kaos77
Member
Registered: 2013-04-26
Posts: 6

Re: [Mostly Solved] Copy *to* tftp server fails

Partially solved.  Added a "-c"  to the command line args in tftpd.service.  Also changed the permissions to the /srv/tftp folder to 777.  I eventually want to get  tftpd to start as a tftp user and have everything owned by the tftp user, but this will work for my setup for now.

Offline

Board footer

Powered by FluxBB