You are not logged in.

#1 2014-02-02 18:47:30

Registered: 2014-02-02
Posts: 1

How to disable GnuPG agent?

When I log in gpg-agent is running. I have no idea what starts it. I use XFCE. I start OpenSSH's ssh-agent by having "eval $(ssh-agent)" in my ~/.bash_profile. I don't want to use gpg-agent. How can I disable it from starting automatically?


#2 2014-02-10 14:48:50

Registered: 2013-12-23
Posts: 784

Re: How to disable GnuPG agent?

I have it too. Some Googling took me here and here.

This command did the trick for me:

xfconf-query -c xfce4-session -p /startup/ssh-agent/enabled -n -t bool -s false

GPG agent is a key manager used for signing/verifying entities like mail and packages (pacman!). But for pacman, you don't need the user session.

Last edited by Rexilion (2014-02-10 14:51:54)

fs/super.c : "Self-destruct in 5 seconds.  Have a nice day...\n",


Board footer

Powered by FluxBB