You are not logged in.

#1 2013-12-06 23:06:43

sra
Member
Registered: 2013-12-06
Posts: 8

Unable to boot with recent archlinux ISO (> 2013-10)

I've spent hours to try to boot archlinux ISO (from CD or USB drives) , looking for UEFI problems, BIOS settings and so on, only to find recent images (2013-11, 2013-12) doesn't boot on my Toshiba laptop.

It seems these images are using a new version of syslinux which left my computer with a blinking cursor at boot time.

Offline

#2 2013-12-07 03:51:16

dazemc
Member
From: Seattle, Washington, USA
Registered: 2013-03-02
Posts: 45

Re: Unable to boot with recent archlinux ISO (> 2013-10)

What operating system are you trying to create the CD or USB?

Offline

#3 2013-12-07 13:06:27

CarlD
Member
From: London
Registered: 2013-11-23
Posts: 128

Re: Unable to boot with recent archlinux ISO (> 2013-10)

This issue may be related to Syslinux 6.02, which has been identified and fix in the latest ISO. See https://bbs.archlinux.org/viewtopic.php?id=173665 and https://bbs.archlinux.org/viewtopic.php?id=172588 for further information.

Offline

#4 2013-12-07 19:18:46

sra
Member
Registered: 2013-12-06
Posts: 8

Re: Unable to boot with recent archlinux ISO (> 2013-10)

dazemc I used Arch and dd, alternate method and unetbootin... I'm pretty sure it's a Syslinux 6.02 issue..

Offline

#5 2013-12-08 02:17:48

dazemc
Member
From: Seattle, Washington, USA
Registered: 2013-03-02
Posts: 45

Re: Unable to boot with recent archlinux ISO (> 2013-10)

I'm sorry I can't be more helpful...I'm literally racking my brain because I was having the same problem and I can't remember what I did to get it fixed...ok looking at my usb I'm pretty sure I used the https://wiki.archlinux.org/index.php/US … _Windows_2 method....mostly because I only had windows available and I was trying everything I could to make it work...and I have used the usb twice today on two different computers successfully even though neither of them uses UEFI...I'm sorry I couldn't be more help

Offline

#6 2013-12-09 13:01:17

sra
Member
Registered: 2013-12-06
Posts: 8

Re: Unable to boot with recent archlinux ISO (> 2013-10)

I've solved the problem by booting with Archlinux live ISO 2013-10-01 and installing syslinux 4.07 (downgrade and manual install of *.c32 files) in chrooted installation.
I've also added syslinux to IgnorePkg in /etc/pacman.conf...

Offline

#7 2013-12-09 13:04:17

sra
Member
Registered: 2013-12-06
Posts: 8

Re: Unable to boot with recent archlinux ISO (> 2013-10)

CarlD wrote:

This issue may be related to Syslinux 6.02, which has been identified and fix in the latest ISO. See https://bbs.archlinux.org/viewtopic.php?id=173665 and https://bbs.archlinux.org/viewtopic.php?id=172588 for further information.

Nope the issue is not fixed in syslinux 6.02-8 package.

Offline

#8 2014-01-20 09:07:52

sra
Member
Registered: 2013-12-06
Posts: 8

Re: Unable to boot with recent archlinux ISO (> 2013-10)

The syslinux bug report is http://bugzilla.syslinux.org/show_bug.cgi?id=45

The problem exist with newer Toshiba R940 models too.

Offline

#9 2014-03-08 22:19:42

the.ridikulus.rat
Member
From: Indiana, USA
Registered: 2011-10-04
Posts: 765

Re: Unable to boot with recent archlinux ISO (> 2013-10)

sra wrote:

The syslinux bug report is http://bugzilla.syslinux.org/show_bug.cgi?id=45

The problem exist with newer Toshiba R940 models too.

Please report this issue in Arch bug tracker. Otherwise the pkg maintainer may not be aware about this bug. and even if the issue is fixed upstream, the relevant patch will not be part of Arch's syslinux pkg unless a new stable version is released by upstream or the pkg maintainer is alerted to the existence of the bug and the patch to fix it (by linking to upstream bug report in Arch's bug report).

That is how issues are fixed. User may respond to forum posts with links to fixes or workarounds to the issue but the pkg maintainer may not even be aware of the post in the 1st place. And this is applicable not only to syslinux but to any pkg in general.

Offline

#10 2014-03-26 21:18:15

sra
Member
Registered: 2013-12-06
Posts: 8

Re: Unable to boot with recent archlinux ISO (> 2013-10)

You're right, the bug is now fixed (upstream) and I sent a mail to Archlinux maintainer to inform him.

Offline

#11 2014-06-25 21:20:11

sra
Member
Registered: 2013-12-06
Posts: 8

Re: Unable to boot with recent archlinux ISO (> 2013-10)

The problem is fixed in recent syslinux packages for Archlinux.

Offline

Board footer

Powered by FluxBB