You are not logged in.

#1 2014-05-06 14:05:28

cyrxi
Member
Registered: 2013-11-12
Posts: 5

[SOLVED] ATI (open source) Graphics Issue due to Upgrade

Shadowrun Returns finally loaded (after ages) but performance was abysmal whereas I was playing it with the same settings flawlessly yesterday. L4D2 was "laggy" while clicking in the interface and on the opening video, and then I got sound with a black screen and had to kill the process.

I believe it is related to a recent update in one of the following packages (at least I did not have this problem yesterday, and I updated first thing this morning):

[2014-05-06 08:32] [PACMAN] starting full system upgrade
[2014-05-06 08:32] [PACMAN] upgraded mesa (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded mesa-libgl (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded ati-dri (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded x265 (0.9-1 -> 1.0-1)
[2014-05-06 08:32] [PACMAN] upgraded ffmpeg (1:2.2.1-1 -> 1:2.2.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-mesa (10.1.1-1 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-mesa-libgl (10.1.1-1 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-ati-dri (10.1.1-1 -> 10.1.2-1)

There doesn't seem to be much useful output when starting Steam from the command line here's the beginning output:

Running Steam on arch rolling 64-bit
STEAM_RUNTIME is enabled automatically
Installing breakpad exception handler for appid(steam)/version(1398287272_client)
libGL error: dlopen /usr/lib32/xorg/modules/dri/r600_dri.so failed (/home/username/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6: version `GLIBCXX_3.4.20' not found (required by /usr/lib32/xorg/modules/dri/r600_dri.so))
libGL error: unable to load driver: r600_dri.so
libGL error: driver pointer missing
libGL error: failed to load driver: r600
Installing breakpad exception handler for appid(steam)/version(1398287272_client)
(steam:1501): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
(steam:1501): Gtk-WARNING **: Unable to locate theme engine in module_path: "adwaita",
/usr/share/themes/Adwaita/gtk-2.0/gtkrc:1137: error: unexpected identifier `direction', expected character `}'
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig error: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 70: non-double matrix element
Fontconfig warning: "/etc/fonts/conf.d/10-scale-bitmap-fonts.conf", line 78: saw unknown, expected number

My card shouldn't be using the r600 driver (mine is a Radeon HD 5770) and it's quite possible those errors have always been there.

Any help would be greatly appreciated.

Last edited by cyrxi (2014-05-06 15:03:55)

Offline

#2 2014-05-06 15:06:23

cyrxi
Member
Registered: 2013-11-12
Posts: 5

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

Downgraded from the following updates:

[2014-05-06 08:32] [PACMAN] upgraded mesa (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded mesa-libgl (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded ati-dri (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-mesa (10.1.1-1 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-mesa-libgl (10.1.1-1 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-ati-dri (10.1.1-1 -> 10.1.2-1)

And everything works as expected.

Offline

#3 2014-05-06 22:25:00

HarlemSquirrel
Member
From: New York, NY
Registered: 2014-01-22
Posts: 119
Website

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

I am having the same issue with my AMD 6670 on Dota 2 and L4D2. All 6 of my CPU cores are 85%+ just while in the main menu of either of these games. I am going to try downgrading now. Does anyone have any idea what is causing this? I thought mesa 10.1.2 was supposed to be a bug fix release!?


"Melody reigns supreme!"
    -J. J. Johnson

Offline

#4 2014-05-06 22:34:42

HarlemSquirrel
Member
From: New York, NY
Registered: 2014-01-22
Posts: 119
Website

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

cyrxi wrote:

Downgraded from the following updates:

[2014-05-06 08:32] [PACMAN] upgraded mesa (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded mesa-libgl (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded ati-dri (10.1.1-2 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-mesa (10.1.1-1 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-mesa-libgl (10.1.1-1 -> 10.1.2-1)
[2014-05-06 08:32] [PACMAN] upgraded lib32-ati-dri (10.1.1-1 -> 10.1.2-1)

And everything works as expected.

This worked for me as well. Have you posted a bug report?


"Melody reigns supreme!"
    -J. J. Johnson

Offline

#5 2014-05-06 23:55:45

andrewd18
Member
From: Wisconsin, USA
Registered: 2007-08-02
Posts: 34

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

I experienced the same issue on my HD 6850. Downgrading also fixed this for me. I reported the bug here: https://bugs.archlinux.org/task/40253

Offline

#6 2014-05-07 03:00:20

Ziusudra
Member
Registered: 2014-04-19
Posts: 119

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

cyrxi wrote:

My card shouldn't be using the r600 driver (mine is a Radeon HD 5770)

Actually, yes it should be loading that. r600_dri.so drives everything from the r600 to the NI based cards. See: https://wiki.gentoo.org/wiki/Radeon#Feature_support

This why you get such poor performance, it can't load the 32bit driver for the card so it has to use the 32bit software rasterizer.

Have you checked your boot messages to see if it can load the 64bit driver? Have you tried running any 64bit OpenGL apps?

Last edited by Ziusudra (2014-05-07 03:01:52)

Offline

#7 2014-05-07 03:48:27

bonaqua322
Member
Registered: 2014-05-07
Posts: 1

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

After upgrade, the Radeon HD 6850 gives an error "OpenGL GLX Context is not using direct rendering, which may cause performance problems.", downgrade does not help. Instructions given here, do not help.

Last edited by bonaqua322 (2014-05-07 03:51:32)

Offline

#8 2014-05-07 06:48:59

lordheavy
Developer
From: France
Registered: 2010-04-01
Posts: 284

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Offline

#9 2014-05-07 13:59:58

cyrxi
Member
Registered: 2013-11-12
Posts: 5

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

Glad my post could help at least a couple people. I had not posted a bug report because it appeared to be an upstream bug and I didn't have time to figure out where to sign-up/report the bug (I was just trying to play a game for 20-30 minutes to take a break from working on my term paper, ended up having to troubleshoot/fix instead).

Turns out it was a good thing too because I would have reported it to the mesa project, but it appears to be a Steam issue (thanks lordheavy). Curious that it worked fine before the upgrade though; I'm guessing that the lib32-ati-dri changed where/how it looks for the driver.

I'll play with it again this weekend sometime (still stuck in term paper land until then) and report back if I find anything useful.

Offline

#10 2014-05-07 20:58:11

HarlemSquirrel
Member
From: New York, NY
Registered: 2014-01-22
Posts: 119
Website

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

This worked perfectly for me! Now things are working just swimmingly! I think L4D2 is even smoother now with my HD6670! I just bought an R7 260X and I hope to have that working shortly.


"Melody reigns supreme!"
    -J. J. Johnson

Offline

#11 2014-05-08 10:23:39

dcc24
Member
Registered: 2009-10-31
Posts: 728

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Worked great for me as well, no need to downgrade any packages.

Edit: It seems that linking gcc 4.9 compiled c++ libs to older libstdc++ causes this.

Last edited by dcc24 (2014-05-08 10:26:46)


It is better to keep your mouth shut and be thought a fool than to open it and remove all doubt. (Mark Twain)

My AUR packages

Offline

#12 2014-05-09 13:57:45

Nowaker
Member
From: Gdańsk, Poland
Registered: 2011-10-26
Posts: 17
Website

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

I've got a bigger problem here. Whenever I start HipChat, X crashes. I also use open source Radeon driver on my Radeon 7870 card. The output you posted is almost the same (the difference is radeonsi_dri.so).

I had to remove libstdc++ they provide from HipChat. https://aur.archlinux.org/packages/hipchat/

Surprisingly, I haven't encountered any problems with Steam games. I just ran HL2 and L2D2 and they worked fine.
EDIT: Well, it broke soon after.

Last edited by Nowaker (2014-06-09 11:09:20)

Offline

#13 2014-05-10 16:13:52

cyrxi
Member
Registered: 2013-11-12
Posts: 5

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

Just updated again (to the 10.1.3 set of packages) and the problem re-emerged as expected.

Followed lordheavy's solution and am now fully upgraded without any problems (at least until Steam updates again). Thanks again for providing a better solution!

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Offline

#14 2014-05-10 19:32:13

fenuks
Member
Registered: 2013-05-31
Posts: 5

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

I have similar problem. I have removed steam-runtime libstdc++ libraries (I could not start game with them), but performance is very low. I use open source ati drivers (lib32-ati-dri also installed) and have Radeon 7770. Some time ago I could play Super Meat Boy with good performance, but now even intro is like 5 FPS which is obviously now what I expected. I am rather casual player so I can't say when (after which update as I presume) performance were redused. System is up-to-date.

I noticed that if I use AccelMethod "EXA" hardware acceleration do not work, with "GLAMOR" I have artefacts (e.g. with title bar and context menu) in KDE, but it run at normal SMB at normal speed. According to Arch Wiki there is a bug in X11 related to GLAMOR.

Last edited by fenuks (2014-05-10 21:27:11)

Offline

#15 2014-05-11 16:30:29

herangr
Member
Registered: 2011-07-31
Posts: 11

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Thank you.

5770 / dota2 / cs16  - no problems after update anymore.

Offline

#16 2014-05-13 13:09:51

drelyn86
Member
From: Indianapolis, IN
Registered: 2009-04-10
Posts: 80

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Care to explain how you reached this conclusion? I had the same issue last night with the 10.1.3 upgrade. This fixed it. Thanks!

Offline

#17 2014-05-16 12:48:03

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 7,436

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

drelyn86,
A few weeks ago a problem with xcb & steam was discussed here : https://bbs.archlinux.org/viewtopic.php … 5#p1391785
The cause turned out to be that steam ships it's own versions of some libraries, and they sometimes are to old to work with archlinux system libraries.
removing the library supplied by steam means steam HAS to use the newer arch-specific version.


Multi-init booting with apg Openrc and systemd coexisting
Automounting : not needed, i prefer pmount
Aur helpers : makepkg + my own local repo === rarely need them

Offline

#18 2014-05-22 04:46:41

badbytes
Member
Registered: 2011-05-23
Posts: 2

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Works for me as well.

Offline

#19 2014-05-23 12:59:06

agihr
Member
Registered: 2009-01-14
Posts: 23

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Didn't work for me. I'm still getting the error message

Offline

#20 2014-05-23 13:07:48

agihr
Member
Registered: 2009-01-14
Posts: 23

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

I solved it by removing ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1.

Offline

#21 2014-05-23 19:48:47

mclang
Member
From: Finland
Registered: 2005-10-24
Posts: 79

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

lordheavy wrote:

rm ~/.local/share/Steam/ubuntu12_32/steam-runtime/i386/usr/lib/i386-linux-gnu/libstdc++.so.6 will fix your problem

Fixed also mine problem that was:
OpenGL GLX context is not using direct rendering, which may cause performance problems.

Thanks!


Duettaeánn aef cirrán Cáerme Gláeddyv. Yn á esseáth.

Offline

#22 2014-05-31 18:21:55

frosth
Member
Registered: 2010-02-13
Posts: 15

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

i need #8 tip
and
'rm .local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1'

and now steam works again.

Offline

#23 2014-06-10 18:14:25

mclang
Member
From: Finland
Registered: 2005-10-24
Posts: 79

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

frosth wrote:

i need #8 tip
and
'rm .local/share/Steam/ubuntu12_32/steam-runtime/i386/lib/i386-linux-gnu/libgcc_s.so.1'

and now steam works again.

Me too... Thanks for the tip!

By the way how do you find out what to delete?


Duettaeánn aef cirrán Cáerme Gláeddyv. Yn á esseáth.

Offline

#24 2014-11-29 15:23:00

torf
Member
Registered: 2014-11-29
Posts: 1

Re: [SOLVED] ATI (open source) Graphics Issue due to Upgrade

i have a problem which is similiar this problem.
steam detect my card as "ATI technologies 256 mb" instead 2gb
but everything seems normal and fglrx drivers work normally

Last edited by torf (2014-11-29 15:23:29)

Offline

Board footer

Powered by FluxBB