You are not logged in.

#1 2006-02-11 06:13:25

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

not getting proper resolution from xorg.conf [solved]

hey everyone.

i just installed arch about an hour ago and have been tinkering with some things, mainly my resolution. i have a widescreen laptop which should be at 1440x900, and i have this set in my xorg.conf file. i came from ubuntu and had a succesful run with 1440x900 there, and took some parts from my old xorg file there to get this going. the resolution i am getting right now is 1152x768 according to the little gui tool in Desktop > Preferences > Screen Resolution.

i searched around a little but couldnt find anything concrete. i apologize if this has been covered recently, feel free to refer me to a solution if i missed one in my searches.

if it helps, here is my xorg.conf: http://briancurtin.com/xorg.conf.txt (couldnt get it to show up any other way)

thanks to anyone who can help

Offline

#2 2006-02-11 08:30:37

luca
Member
From: Rome
Registered: 2005-10-30
Posts: 280

Re: not getting proper resolution from xorg.conf [solved]

Hi briancurtin,
try to disbale the horizontal e vertical sync in this way (in the xorg.conf):

# HorizSync    28-72
# VertRefresh    43-60

Then exit X and start again.

Offline

#3 2006-02-11 09:04:38

xaos5
Member
Registered: 2005-12-30
Posts: 75

Re: not getting proper resolution from xorg.conf [solved]

you can try backing up your config file and do this: xorgcfg -textonly to generate a new config file.

Offline

#4 2006-02-11 16:34:08

Lone_Wolf
Member
From: Netherlands, Europe
Registered: 2005-10-04
Posts: 11,585

Re: not getting proper resolution from xorg.conf [solved]

luca wrote:

Hi briancurtin,
try to disbale the horizontal e vertical sync in this way (in the xorg.conf):

# HorizSync    28-72
# VertRefresh    43-60

Then exit X and start again.

I have done the same thing on my desktop with an 17" LCD on 1280x1024 res attached, and it works fine.


Disliking systemd intensely, but not satisfied with alternatives so focusing on taming systemd.


(A works at time B)  && (time C > time B ) ≠  (A works at time C)

Online

#5 2006-02-11 17:48:02

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: not getting proper resolution from xorg.conf [solved]

thanks for the replies guys. i commented out those two lines but that gave me like a 640x480 resolution or something

anything else i might be missing?

Offline

#6 2006-02-11 18:27:21

luca
Member
From: Rome
Registered: 2005-10-30
Posts: 280

Re: not getting proper resolution from xorg.conf [solved]

From your xorg.conf I suppose that your video card is an Nvidia, try to install the nvidia drivers. Follow the wiki:

http://wiki.archlinux.org/index.php/How_to_install_NVIDIA_driver

Offline

#7 2006-02-11 19:01:34

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: not getting proper resolution from xorg.conf [solved]

you are correct, it is nvidia, so i will try out those drivers. i got by without them before, but i will run through that and see how it works. thanks for the tip.

Offline

#8 2006-02-12 03:16:00

briancurtin
Member
From: Chicago, IL
Registered: 2006-02-11
Posts: 132
Website

Re: not getting proper resolution from xorg.conf [solved]

thanks a lot luca, i got it going on the first try with the proper resolution (1440x900). looks very nice now, the nvidia drivers were the last thing i had to get going to get this distro running just like i want it.

thanks a lot to everyone else too

Offline

Board footer

Powered by FluxBB