You are not logged in.

#1 2014-07-19 04:00:12

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

[SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Here's the error message from terminal:

└─ compton -b --config ~/.config/compton.conf
zsh: segmentation fault  compton -b --config ~/.config/compton.conf

Any compton user can confirm this with Xorg 1.16?

Edit: mpv too.

Last edited by serdotlinecho (2014-07-22 02:26:54)

Offline

#2 2014-07-19 05:26:51

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

You should probably specify what version of compton you are using.  I have the git version and it seems to have started just fine.

Edit: mpv seems to be working fine for me as well...

Last edited by WonderWoofy (2014-07-19 05:27:56)

Offline

#3 2014-07-19 05:57:24

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

X server is start from virtual console tty1, i3wm.

pacman -Q xorg-server intel-dri
xorg-server 1.16.0-2
intel-dri 10.2.3-2
compton --version
git-v0.1_beta2-35-g4e8ccea-2014-07-13

And compton is start from i3 config

exec --no-startup-id compton

using ~/.config/compton.conf

And my xinitrc

#!/bin/sh

if [ -d /etc/X11/xinit/xinitrc.d ]; then
    for f in /etc/X11/xinit/xinitrc.d/*; do
        [ -x "$f" ] && . "$f"
    done
    unset f
fi

xset +fp /usr/share/fonts/local
xset +fp $HOME/.local/share/fonts
xset fp rehash

# load up Xresources
xrdb -merge $HOME/.Xresources

# start some nice program
urxvtd -q -o -f &

# start gnome Keyring
eval $(/usr/bin/gnome-keyring-daemon --start --components=gpg,pkcs11,secrets,ssh)
export GPG_AGENT_INFO SSH_AUTH_SOCK

case $1 in
    cinnamon)
        exec cinnamon-session
        ;;
    gnome)
        exec gnome-session
        ;;
    i3)
        xautolock &
        exec i3
        ;;
esac

Last edited by serdotlinecho (2014-07-19 12:23:15)

Offline

#4 2014-07-19 08:30:26

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 809

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

I'm having this problem too, with glxgears too, or llpp or mpv.
Only on an intel integrated video card (on the other laptop with an ati card everything is fine).

Offline

#5 2014-07-19 09:32:11

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 139

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

hi, for me is fine too, I use mpv-git and I have an ATI RadeonHD with radeonsi driver.  Probably you need to rebuild mpv and compton ?


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#6 2014-07-19 09:35:03

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 809

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Nope...as I said, on my laptop with ati card everything is fine. While on the netbook with intel integrated card, it doesn't work. Btw i tried to build llpp again, but it doesn't work.

Offline

#7 2014-07-19 11:11:29

kinodont
Member
Registered: 2014-07-19
Posts: 1

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

If you're using the Intel i915 driver, then have a look at this bug report:
https://bugs.archlinux.org/task/41264

Offline

#8 2014-07-19 11:24:53

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 809

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Thank you very much kinodont. Added my vote to the bug report!

Offline

#9 2014-07-19 12:16:14

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Thanks, kinodont. Right now, I've downgraded back to xorg 1.15. I'll wait for the patches.

Offline

#10 2014-07-19 18:52:10

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Okay, so while compton, mpv, and everything else seems to run on my machine, 1.16 makes everything have a kind of brief delay.  It kind of makes it feel like I am back on rotational drives.

I have a machine with an Intel IVB processor/graphics.  Hopefully this gets worked out soon.

Offline

#11 2014-07-19 20:47:46

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

mpv runs fine on my machine. Also nothing seems to be delayed. Everything works as expected. That's with nvidia-304xx and Gnome 3.12.

Offline

#12 2014-07-20 15:50:00

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

After the mesa update, things seem to be running normally now for me.  Yay!

Offline

#13 2014-07-21 02:44:41

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

@WonderWoofy, on your Intel IVB machine? I have latest compton-git and mesa 10.2.4-1 and still cannot run. mpv cannot play video on my netbook Intel i915 driver, only audio.

Offline

#14 2014-07-21 02:47:24

WonderWoofy
Member
From: Los Gatos, CA
Registered: 2012-05-19
Posts: 8,412

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Yeah, my machine is a Thinkpad E430 with a 3210-M.  Things seem to work just fine.

Offline

#15 2014-07-21 02:55:03

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

@nierro can you confirm this on your netbook?

Last edited by serdotlinecho (2014-07-21 03:21:29)

Offline

#16 2014-07-21 08:12:14

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 809

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

I'm on latest mesa and mpv /glxgears etc etc, still won't run...

Offline

#17 2014-07-21 17:46:19

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

nierro wrote:

I'm on latest mesa and mpv /glxgears etc etc, still won't run...

What card are you on? Do you use radeon, intel or nouveau? I'm having no such problem with nouveau and nvidia blob. Have tried backtracing these applications?

Offline

#18 2014-07-21 17:53:12

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 809

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

As i said before, the netbook with intel card (i915) isn't working, while on the main laptop (radeon) everything is fine.

Offline

#19 2014-07-22 02:25:02

serdotlinecho
Member
Registered: 2013-01-26
Posts: 100

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Solved. @nierro, upgrade to xf86-video-intel 2.99.912-4.

[2014-07-22 10:22] [PACMAN] upgraded xf86-video-intel (2.99.912-2 -> 2.99.912-4)

Last edited by serdotlinecho (2014-07-22 02:25:28)

Offline

#20 2014-07-22 08:35:31

nierro
Member
From: Milan, Italy
Registered: 2011-09-02
Posts: 809

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

Yes, I've seen! Thank you!
And thanks devs!

Offline

#21 2014-07-22 18:12:46

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

serdotlinecho wrote:

Solved. @nierro, upgrade to xf86-video-intel 2.99.912-4.

[2014-07-22 10:22] [PACMAN] upgraded xf86-video-intel (2.99.912-2 -> 2.99.912-4)

Interesting that xf86-video-intel needs a "disable dri3" patch to work correctly with xorg-server 1.16.0. 
https://projects.archlinux.org/svntogit … d538e35b42

With so many Intel people working on X and other devs using Intel graphics you'd think they'd catch something like this before releasing 1.16.0.

Offline

#22 2014-07-22 22:22:09

desaparecido
Member
From: Liège, Belgium
Registered: 2010-03-14
Posts: 139

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

blackout23 wrote:

With so many Intel people working on X and other devs using Intel graphics you'd think they'd catch something like this before releasing 1.16.0.

is still in [testing] repo and is exactly for that than [testing] exist, I though.... to report if a specific config have problems smile


KF5 & Plasma5 (git versions) - Awesome WM
ASUS Sabertooth 990FX - AMD FX8350 - ATI Radeon HD 7970
[testing] repo

Offline

#23 2014-07-23 03:46:12

blackout23
Member
Registered: 2011-11-16
Posts: 780

Re: [SOLVED] Compton doesn't start with Xorg 1.16, intel i915 driver.

desaparecido wrote:
blackout23 wrote:

With so many Intel people working on X and other devs using Intel graphics you'd think they'd catch something like this before releasing 1.16.0.

is still in [testing] repo and is exactly for that than [testing] exist, I though.... to report if a specific config have problems smile

I was talking about upstream. For them Intel Graphics wasn't just some exotic config it probably was their main development plattform.

Last edited by blackout23 (2014-07-23 04:01:46)

Offline

Board footer

Powered by FluxBB