You are not logged in.

#1 2003-10-18 21:26:48

bOOyah
Member
Registered: 2003-10-18
Posts: 18

DSL

Hello,

i've installed arch linux for the frist time (0.5 iso) and everything went very will (i'm very impressed).

unfortunately I can't get my dsl running.

I've installed a Realtek 8139 and add it to the modul.conf.

Furthermore I've completed the following steps:

-adsl-setup
- removed the gateway

when i start with adsl-start I get a time-out.  when I cat the /var/log/messages I get two ip-adresses (remote and something a can't remember) even if I plug-off the network cable.

I won't call me a linux-newbie, cause I installed already several distros (mandrake, suse, redhat, debian), but with these distros the dsl-configuration went quite well so i'm at a loss, what to do.

Can you please help me?

Thanks a lot for your help!


arch 0.6 -- kernel-2.6.X -- KDE 3.2 @ P4-2,5 -- Geforce 5900XT

Offline

#2 2003-10-18 21:46:04

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: DSL

well did you install the rp-pppoe package or did you install rp-pppoe form source?

if you installed the package from arch i think all that you need to do is do your adsl-setup then start the daemon via (as root):

/etc/rc.d/adsl start

if you still have trouble please post any errors here.


AKA uknowme

I am not your friend

Offline

#3 2003-10-18 22:19:45

bOOyah
Member
Registered: 2003-10-18
Posts: 18

Re: DSL

Hi sahra31,

i did install rp-pppoe from package.

I configured my connection with adsl-setup and started the demon, but it doesn't work.

but here are the outputs form ifconfig, route, rc.conf, etc. Maybe it will help to find the failure....

Furthermore i configure my connection with the options server (dns) and 0 (question about masquarading/firewall)

-------------------------------------------------------------------------------------

---------------------------------------------------------------
ifconfig
---------------------------------------------------------------
eth0      Link encap:Ethernet  HWaddr 00:30:84:40:13:2D 
          inet addr:192.168.0.0  Bcast:192.168.0.255  Mask:255.255.255.0
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:12 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:100
          RX bytes:0 (0.0 b)  TX bytes:920 (920.0 b)
          Interrupt:18 Base address:0xc400

lo        Link encap:Local Loopback 
          inet addr:127.0.0.1  Mask:255.0.0.0
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:48 errors:0 dropped:0 overruns:0 frame:0
          TX packets:48 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0
          RX bytes:3628 (3.5 Kb)  TX bytes:3628 (3.5 Kb)

ppp1      Link encap:Point-to-Point Protocol 
          inet addr:10.64.64.65  P-t-P:10.112.112.113  Mask:255.255.255.255
          UP POINTOPOINT RUNNING NOARP MULTICAST  MTU:1492  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:3
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

---------------------------------------------------------------
route
---------------------------------------------------------------
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
10.112.112.113  *               255.255.255.255 UH    0      0        0 ppp1
192.168.0.0     *               255.255.255.0   U     0      0        0 eth0
default         10.112.112.113  0.0.0.0         UG    0      0        0 ppp1

---------------------------------------------------------------
/etc/rc.conf
---------------------------------------------------------------

#
# /etc/rc.conf - Main Configuration for Arch Linux
#

#
# Localization
#
# Note: HARDWARECLOCK is either "UTC" or "localtime"
#
KEYMAP=de
TIMEZONE=Europe/Berlin
HARDWARECLOCK="localtime"

#
# Networking
#
HOSTNAME="bOObOx"

#
# Module to load at boot-up (in this order)
#   (prefix a module with a ! to disable it)
#
MODULES=(!usbserial !ide-scsi)

#
# Interfaces to start at boot-up (in this order)
# Declare each interface then list in INTERFACES
#   (prefix an interface in INTERFACES with a ! to disable it)
#
# Note: to use DHCP, set your interface to be "dhcp" (eth0="dhcp")
#
lo="lo 127.0.0.1"
eth0="eth0 192.168.0.0 netmask 255.255.255.0 broadcast 192.168.0.255"
INTERFACES=(lo eth0)

#
# Routes to start at boot-up (in this order)
# Declare each route then list in ROUTES
#   (prefix a route in ROUTES with a ! to disable it)
#
# gateway="default gw 192.168.0.1"
ROUTES=(!gateway)

#
# Daemons to start at boot-up (in this order)
#   (prefix a daemon with a ! to disable it)
#
DAEMONS=(!pcmcia network crond inetd)

# End of file

---------------------------------------------------------------
adsl-start
---------------------------------------------------------------

Using interface ppp1
not replacing existing default route to ppp0 [10.112.112.112]
local  IP address 10.64.64.65
remote IP address 10.112.112.113
Terminating on signal 15. -->>>>>> I press strg+c
-------------------------------------------------------------------------------------[/list]


arch 0.6 -- kernel-2.6.X -- KDE 3.2 @ P4-2,5 -- Geforce 5900XT

Offline

#4 2003-10-18 23:09:51

orelien
Forum Fellow
From: France
Registered: 2002-12-05
Posts: 220
Website

Re: DSL

Try to check /etc/ppp/options. You should have at least something like:

user XXXXXXXXXX
usepeerdns
noipdefault
defaultroute
noauth

What outputs do you get in /var/log/messages?

Offline

#5 2003-10-19 17:07:43

bOOyah
Member
Registered: 2003-10-18
Posts: 18

Re: DSL

Hi,

here are my configuration files.  I don't know, why it doesn't work.

Do I really need the ppp/options and the pppoe.conf file?

Furthermore I always get the same local ip (10.64.64.64) and remote ip (10.112.112.112).

Thanks for you help in advance.
------------------------------------------------------------------------------------
----------------------------------
/var/log/messages
----------------------------------
Oct 19 20:47:15 bOObOx pppd[152]: Plugin /usr/lib/pppd/2.4.1/pppoe.so loaded.
Oct 19 20:47:15 bOObOx pppd[152]: PPPoE Plugin Initialized
Oct 19 20:47:15 bOObOx pppd[152]: pppd 2.4.1 started by root, uid 0
Oct 19 20:47:15 bOObOx pppd[152]: Using interface ppp0
Oct 19 20:47:15 bOObOx pppd[152]: local  IP address 10.64.64.64
Oct 19 20:47:15 bOObOx pppd[152]: remote IP address 10.112.112.112

----------------------------------
/etc/ppp/options
----------------------------------
#
# /etc/ppp/options
#

# uncomment the line below this if you use PPPoE
plugin /usr/lib/pppd/2.4.1/pppoe.so

demand
connect /bin/true
ipcp-accept-remote
ipcp-accept-local

# the idle time in seconds -- you might want to adjust this
idle 600
noipdefault
defaultroute
user ar0126764277
hide-password
noaccomp
nopcomp
nocrtscts
lcp-echo-interval 10
lcp-echo-failure 3
lock
nodetach
noauth
usepeerdns

----------------------------------
/etc/ppp/options
----------------------------------
#***********************************************************************
#
# pppoe.conf
#
# Configuration file for rp-pppoe.  Edit as appropriate and install in
# /etc/ppp/pppoe.conf
#
# NOTE: This file is used by the adsl-start, adsl-stop, adsl-connect and
#       adsl-status shell scripts.  It is *not* used in any way by the
#       "pppoe" executable.
#
# Copyright (C) 2000 Roaring Penguin Software Inc.
#
# This file may be distributed under the terms of the GNU General
# Public License.
#
# LIC: GPL
# $Id: pppoe.conf,v 1.10 2002/04/09 17:28:38 dfs Exp $
#***********************************************************************

# When you configure a variable, DO NOT leave spaces around the "=" sign.

# Ethernet card connected to ADSL modem
ETH='eth0'

# ADSL user name.  You may have to supply "@provider.com"  Sympatico
# users in Canada do need to include "@sympatico.ca"
# Sympatico uses PAP authentication.  Make sure /etc/ppp/pap-secrets
# contains the right username/password combination.
# For Magma, use xxyyzz@magma.ca
USER='xxxxxxxxxxx'

# Bring link up on demand?  Default is to leave link up all the time.
# If you want the link to come up on demand, set DEMAND to a number indicating
# the idle time after which the link is brought down.
DEMAND=no
#DEMAND=300

# DNS type: SERVER=obtain from server; SPECIFY=use DNS1 and DNS2;
# NOCHANGE=do not adjust.
DNSTYPE=SERVER

# Obtain DNS server addresses from the peer (recent versions of pppd only)
# In old config files, this used to be called USEPEERDNS.  Changed to
# PEERDNS for better Red Hat compatibility
PEERDNS=yes

DNS1=
DNS2=

# Make the PPPoE connection your default route.  Set to
# DEFAULTROUTE=no if you don't want this.
DEFAULTROUTE=yes

### ONLY TOUCH THE FOLLOWING SETTINGS IF YOU'RE AN EXPERT

# How long adsl-start waits for a new PPP interface to appear before
# concluding something went wrong.  If you use 0, then adsl-start
# exits immediately with a successful status and does not wait for the
# link to come up.  Time is in seconds.
#
# WARNING WARNING WARNING:
#
# If you are using rp-pppoe on a physically-inaccessible host, set
# CONNECT_TIMEOUT to 0.  This makes SURE that the machine keeps trying
# to connect forever after adsl-start is called.  Otherwise, it will
# give out after CONNECT_TIMEOUT seconds and will not attempt to
# connect again, making it impossible to reach.
CONNECT_TIMEOUT=30

# How often in seconds adsl-start polls to check if link is up
CONNECT_POLL=2

# Specific desired AC Name
ACNAME=

# Specific desired service name
SERVICENAME=

# Character to echo at each poll.  Use PING="" if you don't want
# anything echoed
PING="."

# File where the adsl-connect script writes its process-ID.
# Three files are actually used:
#   $PIDFILE       contains PID of adsl-connect script
#   $PIDFILE.pppoe contains PID of pppoe process
#   $PIDFILE.pppd  contains PID of pppd process
CF_BASE=`basename $CONFIG`
PIDFILE="/var/run/$CF_BASE-adsl.pid"

# Do you want to use synchronous PPP?  "yes" or "no".  "yes" is much
# easier on CPU usage, but may not work for you.  It is safer to use
# "no", but you may want to experiment with "yes".  "yes" is generally
# safe on Linux machines with the n_hdlc line discipline; unsafe on others.
SYNCHRONOUS=no

# Do you want to clamp the MSS?  Here's how to decide:
# - If you have only a SINGLE computer connected to the ADSL modem, choose
#   "no".
# - If you have a computer acting as a gateway for a LAN, choose "1412".
#   The setting of 1412 is safe for either setup, but uses slightly more
#   CPU power.
CLAMPMSS=1412
#CLAMPMSS=no

# LCP echo interval and failure count.
LCP_INTERVAL=20
LCP_FAILURE=3

# PPPOE_TIMEOUT should be about 4*LCP_INTERVAL
PPPOE_TIMEOUT=80

# Firewalling: One of NONE, STANDALONE or MASQUERADE
FIREWALL=NONE

# Linux kernel-mode plugin for pppd.  If you want to try the kernel-mode
# plugin, use LINUX_PLUGIN=/etc/ppp/plugins/rp-pppoe.so
LINUX_PLUGIN=

# Any extra arguments to pass to pppoe.  Normally, use a blank string
# like this:
PPPOE_EXTRA=""

# Rumour has it that "Citizen's Communications" with a 3Com
# HomeConnect ADSL Modem DualLink requires these extra options:
# PPPOE_EXTRA="-f 3c12:3c13 -S ISP"

# Any extra arguments to pass to pppd.  Normally, use a blank string
# like this:
PPPD_EXTRA=""


########## DON'T CHANGE BELOW UNLESS YOU KNOW WHAT YOU ARE DOING
# If you wish to COMPLETELY overrride the pppd invocation:
# Example:
# OVERRIDE_PPPD_COMMAND="pppd call dsl"

# If you want adsl-connect to exit when connection drops:
# RETRY_ON_FAILURE=no


arch 0.6 -- kernel-2.6.X -- KDE 3.2 @ P4-2,5 -- Geforce 5900XT

Offline

#6 2003-10-19 17:10:38

dp
Member
From: Zürich, Switzerland
Registered: 2003-05-27
Posts: 3,363
Website

Re: DSL

what adsl hardware do you have?

if you have something like this:
--------------------------------
[computer]-[network-card]-[hub/switch or crossed cable]-[adsl-router/+modem]->[internet]

then you do not have to specify anything on your computer for adsl: just set in rc.conf

eth0="dhcp"

the gateway you should keep removed

if you have something like this:
--------------------------------
[computer]-[adsl-router/+modem]->[internet]

then then you have to play around with adsl-config on the computer

--- but as you said, you activated a network-card in modules.conf, i think you have the first case


The impossible missions are the only ones which succeed.

Offline

#7 2003-10-19 17:23:23

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: DSL

i see a fews possible issues.

first is your userid it is not in standard userid format for dsl. normally userids are <userid>@yourisp.com (for example)

Second, you have not entered any nameservers. even if you were connecting your would have issues there.

your eth0 ips are wrong. you should either have none or they should reflect the ipd provided by your isp.

if your adsl is providing your info via dhcp then you rc.conf is wrong.

again i state these may be possible issues not for sure issues as the only dsl service i really know is my own and what works with it.


AKA uknowme

I am not your friend

Offline

#8 2003-10-19 20:08:38

orelien
Forum Fellow
From: France
Registered: 2002-12-05
Posts: 220
Website

Re: DSL

There's something curious with your ppp interfaces.
Kernel routing tables mentions ppp1 as the default route, whereas /var/log/messages are showing ppp is using ppp0...

From /var/log/messages, it seems the problem is related with the default route used to access the server (the server should have sent 2 DNS addresses during the negociation).

When I'm running pppd, I've got some additional lines than in yours:

Oct 19 18:46:23 pokemon pppd[200]: Remote message: CHAP authentication success, unit 1165
Oct 19 18:46:23 pokemon pppd[200]: local  IP address A.B.C.D
Oct 19 18:46:23 pokemon pppd[200]: remote IP address E.F.G.H
Oct 19 18:46:23 pokemon pppd[200]: primary   DNS address I.J.K.L
Oct 19 18:46:23 pokemon pppd[200]: secondary DNS address M.N.O.P

Did you correctly filled /etc/ppp/chap-secrets or /etc/ppp/pap-secrets (pap or chap: it depends on your ISP)?

You could also try to run adsl-start in debug mode, by issuing:

export DEBUG=1

before running adsl-start. It will generate a /tmp/pppoe-debug file.

From my point of view, the configuration looks fine but, you could try to use a minimalistic one, as for example:

#
# /etc/ppp/options
#
user XYZ
usepeerdns
noipdefault
defaultroute
noauth

Offline

#9 2003-10-20 05:33:22

bOOyah
Member
Registered: 2003-10-18
Posts: 18

Re: DSL

Hi,

I finally got dsl running.

I've changed two things:

1. changed the ip-address from eth0

2. I added a blank option file to /etc/ppp. I've read that somewhere else.

I just have to figure out, where the problem was, I suppose it is the empty option file.

@orelien the mention ppp1 results of a second start of pppoe.

Thanks @all, for your help....


arch 0.6 -- kernel-2.6.X -- KDE 3.2 @ P4-2,5 -- Geforce 5900XT

Offline

#10 2004-02-12 18:17:20

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: DSL

jong357 wrote:
bOOyah wrote:

Hi,

I finally got dsl running.


2. I added a blank option file to /etc/ppp. I've read that somewhere else.


You rock!!! I've been trying to get online with Arch for EVER.... That does the trick... I never have this prob with any other distro.... I'm stumped still..... Oh well...... It works and I don't care now...  :twisted:

Thanks again!!!

because by default  arch's ppp/options file is not empty. in most other distros it is and in most cases dsl connection do not like this file to be populated.


AKA uknowme

I am not your friend

Offline

#11 2004-02-13 05:32:41

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: DSL

fwiw i do think that commenting/erasing uncommneted entries in options is mentioned on the rp-pppoe web site. i know i saw it somewhere before. i seem to remember having this problem before with debain or libranet and this worked. i had completely forgotten about this though when i commented earlier in this thread.


AKA uknowme

I am not your friend

Offline

Board footer

Powered by FluxBB