You are not logged in.

#1 2006-02-21 05:45:31

danns
Member
Registered: 2006-02-12
Posts: 13
Website

xorg7 xfce4 issues

I had some issues with XFCE4 after upgarding to xorg 7.  Xfce was very slow to start and would not quit without a hard kill (ctrl-alt-backspace).  I noticed an error regarding ICE Authentication when XFCE was starting and learned that it could not find iceauth which was hardcoded in xfce4 to /usr/X11R6/bin/iceauth.  I created a symlink to the new location /usr/bin/iceauth and all is working well now.  I suspect this will be fixed in the next release of xfce4.

Offline

#2 2006-02-21 06:25:42

emma
Member
Registered: 2006-02-19
Posts: 64

Re: xorg7 xfce4 issues

Actually, it is already fixed in Xfce4-svn. big_smile

Offline

#3 2006-02-21 07:16:41

Snowman
Developer/Forum Fellow
From: Montreal, Canada
Registered: 2004-08-20
Posts: 5,212

Re: xorg7 xfce4 issues

Are you using xfce4-session 4.2.3-2 ?

Offline

#4 2006-02-21 07:42:28

mindbreaker
Member
Registered: 2006-01-23
Posts: 15

Re: xorg7 xfce4 issues

jep same problem here with xfce 4.2.3-2

it takes a long time to start and shutdown the xfce session


Arch 0.7.2
gnome 2.14
Athlon64 3700+

Offline

#5 2006-02-21 08:32:27

Cotton
Member
From: Cornwall, UK
Registered: 2004-09-17
Posts: 549

Re: xorg7 xfce4 issues

pacman -Sy xfce4-session gives:

xfce4-session-4.2.3-1: is up to date

I'm using ftp.heanet.ie which was sync'd with ftp.archlinux.org on Tue Feb 21 02:03:00 2006, according to checkmirror.py

I will try and download -2 manually later to see if fixes the problem.

Offline

#6 2006-02-21 08:45:26

syd
Member
From: Auckland, NZ
Registered: 2006-01-22
Posts: 155

Re: xorg7 xfce4 issues

Try the svn version from shadowhands repo.

[shadowhand]
Server = http://archpkg.wgilk.com/shadowhand

I just installed it 1/2 hr ago and it is running great.

There doesnt seem to a vast improvements.
But it does include thunar!!!!!

Offline

#7 2006-02-21 09:29:53

polarrr
Member
Registered: 2004-09-12
Posts: 91

Re: xorg7 xfce4 issues

xfce4-svn gives me some problems now. xfce4 from extra repo works fine, but xfce4-svn is acting really wacky for me. For example, mouse cursor is big fat X, like the original X server cursor, plus right click on desktop doesn't work. So it seems like only parts of xfce4-svn are working for me. I don't know what the issue is, I tinkered around for a bit, but I couldn't figure out, so I just said screw it and now using stock xfce4 from extra. I think I'll leave it at that for now. It does the job, minus a few fancy stuff, but least it's stable. Hopefully things get gradually resolved soon.

*edit* Found it... I was missing libxdamage. Too many components to keep up with now  :?

Offline

#8 2006-02-21 14:22:48

tomk
Forum Fellow
From: Ireland
Registered: 2004-07-21
Posts: 9,839

Re: xorg7 xfce4 issues

danns (or anyone else) - go svn if you want to, but there's no need if you just want to fix your iceauth problem. Just get hold of xfce4-session 4.2.3-2, as advised.

Re heanet (my local mirror) the package is actually there, but extra.db.tar.gz does not include it yet - that's why pacman does not know about it. Use the link above to download and install it.

Offline

#9 2006-02-21 15:06:28

T-Dawg
Forum Fellow
From: Wilmington, NC
Registered: 2005-01-29
Posts: 2,734

Re: xorg7 xfce4 issues

just run abs and rebuild xfce4-session...

Offline

#10 2006-02-24 21:06:23

drakosha
Member
Registered: 2006-01-03
Posts: 253
Website

Re: xorg7 xfce4 issues

New issue.
After upgrading to xorg7 i have the following problem: XKB layout switcher does not display correct flag (i.e. flag is not relevant to current language). It used to work correctly before.
Situation now:
Real lang -> Icon
EN -> "PC"
RU -> American flag
HEBREW -> Russian Flag

Any ideas how to fix it?
My xorg conf:
Section "InputDevice"
        Identifier  "Keyboard0"
        Driver      "kbd"
        Driver "keyboard"
        Option "XkbModel" "pc104"
        Option "XkbLayout" "us,ru,il"
        Option "XkbOptions" "compose:rwin,grp:alt_shift_toggle"
        Option "XkbVariant" ",winkeys,"
        Option "XkbRules" "xorg"
EndSection

10x!

Offline

#11 2006-02-25 16:02:32

Romashka
Forum Fellow
Registered: 2005-12-07
Posts: 1,054

Re: xorg7 xfce4 issues

I have the same problem. Already reported it as bug #4004 (http://bugs.archlinux.org/task/4004)


to live is to die

Offline

Board footer

Powered by FluxBB