You are not logged in.

#1 2014-12-19 18:49:10

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

[SOLVED]packagekit: requires pacman<4.2.0

sudo pacman -Syu
:: Synchronizing package databases...
testing is up to date
core is up to date
extra                   1806.5 KiB   775K/s 00:02 [----------------------] 100%
community-testing is up to date
community is up to date
multilib is up to date
:: Starting full system upgrade...
resolving dependencies...
looking for inter-conflicts...
error: failed to prepare transaction (could not satisfy dependencies)
:: packagekit: requires pacman<4.2.0

Last edited by Dmitrii (2014-12-19 23:46:45)

Offline

#2 2014-12-19 19:00:26

karol
Archivist
Registered: 2009-05-06
Posts: 25,440

Re: [SOLVED]packagekit: requires pacman<4.2.0

"Works" for me on my 32-bit Arch with [testing] repos enabled. pacman automatically got downgraded back to 4.1.2-7:

$ sudo pacman -S packagekit
resolving dependencies...
looking for conflicting packages...

Package (2)           Old Version  New Version  Net Change  Download Size

core/pacman           4.2.0-1      4.1.2-7       -0.53 MiB
community/packagekit               0.7.6-12       6.90 MiB       0.87 MiB

Total Download Size:    0.87 MiB
Total Installed Size:  10.60 MiB
Net Upgrade Size:       6.37 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages ...
 packagekit-0.7.6-12-i686              894.8 KiB  1916K/s 00:00 [###################################] 100%
(2/2) checking keys in keyring                                  [###################################] 100%
(2/2) checking package integrity                                [###################################] 100%
(2/2) loading package files                                     [###################################] 100%
(2/2) checking for file conflicts                               [###################################] 100%
(2/2) checking available disk space                             [###################################] 100%
(1/2) downgrading pacman                                        [###################################] 100%
(2/2) installing packagekit                                     [###################################] 100%
Optional dependencies for packagekit
    networkmanager

It has been flagged out-of-date for almost exactly a year: https://www.archlinux.org/packages/comm … ackagekit/ :-)

Offline

#3 2014-12-19 19:59:10

antsunrise
Member
Registered: 2014-12-19
Posts: 26

Re: [SOLVED]packagekit: requires pacman<4.2.0

I am getting same exact thing as OP. On both my computers.

Offline

#4 2014-12-19 21:01:39

bstaletic
Member
Registered: 2014-02-02
Posts: 658

Re: [SOLVED]packagekit: requires pacman<4.2.0

On my computer, it just downgraded pacman, as kerol has shown in his post above.

Offline

#5 2014-12-19 22:43:14

apg
Developer
Registered: 2012-11-10
Posts: 197

Re: [SOLVED]packagekit: requires pacman<4.2.0

Dmitrii wrote:
sudo pacman -Syu
karol wrote:

"Works" for me on my 32-bit Arch with [testing] repos enabled. pacman automatically got downgraded back to 4.1.2-7:

$ sudo pacman -S packagekit

OP is trying to update his system, not install packagekit.

Obviously you are not going to be able to update to pacman4.2 while you have packages installed that depend on pacman4.1.  Either uninstall packagekit or wait for an updated version that depends on pacman4.2.

Offline

#6 2014-12-19 22:45:03

Dmitrii
Member
Registered: 2014-10-16
Posts: 19

Re: [SOLVED]packagekit: requires pacman<4.2.0

Workaround

pacman -R python-packagekit packagekit

Offline

#7 2014-12-19 23:19:32

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,757

Re: [SOLVED]packagekit: requires pacman<4.2.0

Why does this come up every single time pacman has an update? Obviously if packagekit requires pacman < 4.2, you won't be able to install pacman 4.2 while packagekit is installed. Not rocket science.

Edit, ok, I was thinking of package-query, which causes problems every time.

Last edited by Scimmia (2014-12-19 23:27:49)

Offline

#8 2014-12-19 23:22:42

antsunrise
Member
Registered: 2014-12-19
Posts: 26

Re: [SOLVED]packagekit: requires pacman<4.2.0

No workaround on my part yet. Removed both and still a no go.But I'm just going to uncomment Testing for now and downgrade. That should be the safer and better route for I myself.

Offline

#9 2014-12-20 12:53:27

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: [SOLVED]packagekit: requires pacman<4.2.0

It's marked as SOLVED.. but I wonder, where is the solution?

Offline

#10 2014-12-20 13:02:19

fsckd
Forum Fellow
Registered: 2009-06-15
Posts: 4,173

Re: [SOLVED]packagekit: requires pacman<4.2.0

Solution is to either wait for a new version of packagekit to appear before upgrading or uninstall packagekit and upgrade without it.


aur S & M :: forum rules :: Community Ethos
Resources for Women, POC, LGBT*, and allies

Offline

#11 2014-12-20 13:13:25

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: [SOLVED]packagekit: requires pacman<4.2.0

fsckd wrote:

Solution is to either wait for a new version of packagekit to appear before upgrading or uninstall packagekit and upgrade without it.

Thanks a lot.
What I did and worked for me is to remove yaourt and package-query. After that Syu that will automatically install latest pacman. Now Syu gonna work but I lost yaourt for now..

Offline

#12 2014-12-21 23:04:47

WinterSoldier53
Member
From: Costa Rica
Registered: 2014-04-20
Posts: 19
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

erickwill wrote:
fsckd wrote:

Solution is to either wait for a new version of packagekit to appear before upgrading or uninstall packagekit and upgrade without it.

Thanks a lot.
What I did and worked for me is to remove yaourt and package-query. After that Syu that will automatically install latest pacman. Now Syu gonna work but I lost yaourt for now..

Just run pacman-db-upgrade and then pacman -S yaourt package-query.

Last edited by WinterSoldier53 (2014-12-21 23:04:59)

Offline

#13 2014-12-23 05:28:19

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 122

Re: [SOLVED]packagekit: requires pacman<4.2.0

Why is this marked as solved? It is far from solved

Last edited by gps1539 (2014-12-23 05:28:33)

Offline

#14 2014-12-23 05:32:55

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,006
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#15 2014-12-23 06:49:58

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 122

Re: [SOLVED]packagekit: requires pacman<4.2.0

A fix/workaround (you decide) for me was to uninstall yaourt and packagekit, then run pacman -Syuu to upgrade

As an alternative aur helper I installed pacaur, which is working well so far.

Offline

#16 2014-12-23 06:53:19

gps1539
Member
From: Los Gatos, CA
Registered: 2013-11-06
Posts: 122

Re: [SOLVED]packagekit: requires pacman<4.2.0

fsckd wrote:

Solution is to either wait for a new version of packagekit to appear before upgrading or uninstall packagekit and upgrade without it.

per the link in jasonwryan's post, that may be a very long wait.

Offline

#17 2014-12-23 07:29:04

Scimmia
Bug Wrangler
Registered: 2012-09-01
Posts: 7,757

Re: [SOLVED]packagekit: requires pacman<4.2.0

gps1539 wrote:

A fix/workaround (you decide) for me was to uninstall yaourt and packagekit, then run pacman -Syuu to upgrade

As an alternative aur helper I installed pacaur, which is working well so far.

You're making the same mistake I made earlier in this thread. Packagekit has nothing to do with yaourt, that's package-query.

Offline

#18 2014-12-23 09:10:54

Awebb
Member
Registered: 2010-05-06
Posts: 5,512

Re: [SOLVED]packagekit: requires pacman<4.2.0

Why is this not in the testing area? The 4.2.0 pacman is still in testing. No wonder there are conflicts.

Offline

#19 2014-12-23 15:47:33

ewaller
Administrator
From: Pasadena, CA
Registered: 2009-07-13
Posts: 17,336

Re: [SOLVED]packagekit: requires pacman<4.2.0

Awebb wrote:

Why is this not in the testing area? The 4.2.0 pacman is still in testing. No wonder there are conflicts.

Apparently the moderators are collectively overindulging in holiday cheer.  Nice catch.
Moving to Testing.


Nothing is too wonderful to be true, if it be consistent with the laws of nature -- Michael Faraday
Sometimes it is the people no one can imagine anything of who do the things no one can imagine. -- Alan Turing
---
How to Ask Questions the Smart Way

Offline

#20 2014-12-23 17:49:19

Awebb
Member
Registered: 2010-05-06
Posts: 5,512

Re: [SOLVED]packagekit: requires pacman<4.2.0

ewaller wrote:
Awebb wrote:

Why is this not in the testing area? The 4.2.0 pacman is still in testing. No wonder there are conflicts.

Apparently the moderators are collectively overindulging in holiday cheer.  Nice catch.
Moving to Testing.

Heh, I was rather aiming at the OP, who could have solved his urge to create a thread by understanding that testing is involved.

Happy holidays!

Offline

#21 2014-12-24 19:37:59

gururise
Member
Registered: 2011-11-03
Posts: 25

Re: [SOLVED]packagekit: requires pacman<4.2.0

It seems package-query requires pacman <4.2, but this can be changed so that package-query uses pacman 4.2.

Here is the real solution:

https://translate.googleusercontent.com … JLImgg1XYQ

Last edited by gururise (2014-12-24 19:45:39)

Offline

#22 2014-12-24 20:05:13

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,006
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

The "real" solution is the same thing that applies to every AUR package that depends on an official package: rebuild it.

Also, package-query is not packagekit, which is what this thread is actually about...


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#23 2014-12-24 20:23:59

helix
Member
Registered: 2013-02-17
Posts: 174

Re: [SOLVED]packagekit: requires pacman<4.2.0

Also package-query has been updated in the last couple of days to support pacman 4.2

Offline

#24 2014-12-26 11:47:44

piernov
Member
Registered: 2014-12-26
Posts: 1

Re: [SOLVED]packagekit: requires pacman<4.2.0

Tried to make packagekit work with pacman 4.2 : https://github.com/piernov/PackageKit/tree/pacman-4.2
It compiles, can list packages and updates, can install packages but cannot do updates. I don't know if it worked before.
I'm not a good programmer and I don't know how GLib, PackageKit, Pacman work so don't put too much hope there. (for example I don't know where I should use g_return_if_fail() )

Offline

#25 2014-12-26 13:08:30

stefanwilkens
Member
From: Enschede, the Netherlands
Registered: 2008-12-10
Posts: 624

Re: [SOLVED]packagekit: requires pacman<4.2.0

it's likely the arch backend for packagekit broke over the past year, might be fun having a look.


Arch i686 on Phenom X4 | GTX760

Offline

Board footer

Powered by FluxBB