You are not logged in.

#26 2014-12-27 17:29:29

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 914

Re: [SOLVED]packagekit: requires pacman<4.2.0

Can packagekit and python-packagekit sensibly be uninstalled without any consequences for most users? Since packagekit has just been dropped it would seem that there will be a need to do so? On the arch mailing list Ike Devolder sent a post today "I just dropped packagekit and its dependencies."

Last edited by mcloaked (2014-12-27 17:29:57)


Mike C

Offline

#27 2014-12-27 18:10:54

progandy
Member
Registered: 2012-05-17
Posts: 3,882

Re: [SOLVED]packagekit: requires pacman<4.2.0

mcloaked wrote:

Can packagekit and python-packagekit sensibly be uninstalled without any consequences for most users?

packagekit is only required for the integrated package managers of e.g. gnome, mate and qt (apper). It may force useres of those desktop environments to use pacman directly instead of a nice GUI, but that should be all.


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#28 2014-12-27 21:02:19

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 914

Re: [SOLVED]packagekit: requires pacman<4.2.0

Thanks progandy - I have deleted the two packagekit packages I had from my machine - I can't even remember installing them so I doubt I'd ever have needed them!


Mike C

Offline

#29 2014-12-29 12:49:57

kristoffer.paulsson
Member
Registered: 2014-05-26
Posts: 2

Re: [SOLVED]packagekit: requires pacman<4.2.0

My solution to the problem was:

pacman -R packagekit gnome-packagekit
pacman -Syu

Offline

#30 2014-12-29 13:01:25

Morn
Member
Registered: 2012-09-02
Posts: 619

Re: [SOLVED]packagekit: requires pacman<4.2.0

And my solution is

IgnorePkg = pacman

I love my gnome-packagekit updater thingymajig.  Plus PkgBrowser hasn't been updated yet and I need that too.

Offline

#31 2014-12-29 18:16:19

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,049
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

No longer a [testing] issue, moving to AUR Issues...


Stickying until this blows over.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#32 2014-12-30 12:34:17

lucacerone
Member
From: Spain
Registered: 2012-05-04
Posts: 144
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

Hi, I am having the same issue but I haven't properly understood what is going on. How do the two solutions differ?

Also, the error message says:

error: failed to prepare transaction (could not satisfy dependencies)
:: packagekit: requires pacman<4.2.0

but

$ pacman --version

 .--.                  Pacman v4.1.2 - libalpm v8.0.2
/ _.-' .-.  .-.  .-.   Copyright (C) 2006-2013 Pacman Development Team
\  '-. '-'  '-'  '-'   Copyright (C) 2002-2006 Judd Vinet
 '--'
                       This program may be freely redistributed under
                       the terms of the GNU General Public License.

so it seems I have an appropriate version of pacman installed.

Thanks a lot in advance for the help!

Last edited by lucacerone (2014-12-30 12:36:10)

Offline

#33 2014-12-30 13:14:32

Allan
Member
From: Brisbane, AU
Registered: 2007-06-09
Posts: 10,953
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

You are trying to update to a new pacman version.  packagekit is not compatible with it and has been removed from the repos.  You should remove it from your system then update.

Offline

#34 2014-12-30 13:42:12

lucacerone
Member
From: Spain
Registered: 2012-05-04
Posts: 144
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

Thanks Allan,
I didn't notice that there is a page 1 in the thread, reading it it is much clearer now!
(as mentioned in other post uninstalling packagekit and gnome-packagekit fixed the issue for me)

Offline

#35 2014-12-31 14:16:51

eworm
Trusted User (TU)
From: Oberhausen, Germany
Registered: 2010-01-30
Posts: 102
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

piernov wrote:

Tried to make packagekit work with pacman 4.2 : https://github.com/piernov/PackageKit/tree/pacman-4.2
It compiles, can list packages and updates, can install packages but cannot do updates. I don't know if it worked before.
I'm not a good programmer and I don't know how GLib, PackageKit, Pacman work so don't put too much hope there. (for example I don't know where I should use g_return_if_fail() )

I did prepare a similar patch and sent it to the mailing list:
http://lists.freedesktop.org/archives/p … 26342.html

Same issues, though...


ArchLinux - make it simple & lightweight

Offline

#36 2015-01-01 12:21:38

JKAbrams
Member
From: Sweden
Registered: 2011-11-07
Posts: 81

Re: [SOLVED]packagekit: requires pacman<4.2.0

Morn wrote:

Plus PkgBrowser hasn't been updated yet and I need that too.

PkgBrowser is now updated, has to be rebuilt while having Pacman 4.2 installed.

Offline

#37 2015-01-01 13:04:02

Musa
Member
Registered: 2014-07-11
Posts: 3

Re: [SOLVED]packagekit: requires pacman<4.2.0

For any KDE users having problems, do the following:

Remove apper, packagekit-qt2 & packagekit.

 sudo pacman -R apper packagekit-qt2 packagekit 

Then you can upgrade with:

 sudo pacman -Syu 

Then update the pacman database like so:

 sudo pacman-db-upgrade 

done.

Offline

#38 2015-01-01 13:24:26

Morn
Member
Registered: 2012-09-02
Posts: 619

Re: [SOLVED]packagekit: requires pacman<4.2.0

JKAbrams wrote:

PkgBrowser is now updated, has to be rebuilt while having Pacman 4.2 installed.

Yes, I've already noticed and updated pacman and pkgbrowser two days ago. Now I'm using kalu instead of gnome-packagekit, seems to work nicely so far.

Offline

#39 2015-01-01 18:29:44

dwillar
Member
Registered: 2012-08-10
Posts: 10

Re: [SOLVED]packagekit: requires pacman<4.2.0

I found three orphaned packages (packagekit, python-packagekit, python2-dbus ) and removed them.

pacman-db-upgrade

System back to normal now.

Last edited by dwillar (2015-01-01 18:40:12)

Offline

#40 2015-01-03 18:08:07

Verocheque
Member
Registered: 2015-01-03
Posts: 1

Re: [SOLVED]packagekit: requires pacman<4.2.0

Check this page, where I found the solution and sorted it out.
https://forum.manjaro.org/index.php?topic=19287.0

In the terminal as root I entered the following and now it works fine for me:


# pacman -Sdd pacman
Maybe you'll have to run an upgrade of the DB

# pacman-db-upgrade

and then enter th etwo lines below

# Pacman -Syy

# pacman Syu


Hope this helps you as well.

Cheers

Last edited by Verocheque (2015-01-03 19:50:34)

Offline

#41 2015-01-03 18:14:57

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 3,963

Re: [SOLVED]packagekit: requires pacman<4.2.0

Verocheque wrote:

Check this page, where I found the solution and sorted it out.
https://forum.manjaro.org/index.php?topic=19287.0

As root I entered the following in the terminal and now it works fine for me:


# pacman -Sdd pacman

# Pacman -Syy

# pacman Syu


Hope this helps you as well.

Cheers

This really isn't a good solution as you now have packagekit installed without its dependencies.
As stated earlier in this thread the solution is to remove packagekit from your system.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#42 2015-01-08 16:59:55

isank
Member
Registered: 2015-01-08
Posts: 6

Re: [SOLVED]packagekit: requires pacman<4.2.0

For the time being, this can be a workaround :

Just edit your "pacman.conf" and ignore the "pacman" update.

Steps to accomplish the above:

1. sudo nano /etc/pacman.conf [Return]
2. Go to the line which says "IgnorePkg"
3. Add IgnorePkg = pacman
4. Ctrl + X >> Y >> [Return]

Done.

Last edited by isank (2015-01-08 17:59:50)

Offline

#43 2015-01-08 17:17:04

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,049
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

isank wrote:

For the time being, this can be a solution :

Just edit your "pacman.conf" and ignore the "pacman" update.

Steps to accomplish the above:

1. sudo nano /etc/pacman.conf [Return]
2. Go to the line which says "IgnorePkg"
3. Add IgnorePkg = pacman
4. Ctrl + X >> Y >> [Return]

Done.


Not a solution at all; a "workaround" and an ill-advised one at that.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#44 2015-01-08 18:01:13

isank
Member
Registered: 2015-01-08
Posts: 6

Re: [SOLVED]packagekit: requires pacman<4.2.0

jasonwryan wrote:
isank wrote:

For the time being, this can be a solution :

Just edit your "pacman.conf" and ignore the "pacman" update.

Steps to accomplish the above:

1. sudo nano /etc/pacman.conf [Return]
2. Go to the line which says "IgnorePkg"
3. Add IgnorePkg = pacman
4. Ctrl + X >> Y >> [Return]

Done.


Not a solution at all; a "workaround" and an ill-advised one at that.

Sir, can you please tell me that why do you think it is ill-advised?
Because I have mentioned "for the time being", that means till packagekit gets an update or so, and till then ignoring the update of pacman is not harmful.

Last edited by isank (2015-01-08 18:03:21)

Offline

#45 2015-01-08 18:05:38

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,049
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

Where to start? First, partial upgrades are unsupported, and holding back the single most important package on your system makes no sense anyway. Secondly, to do so for an unsupported package (packagekit) is just arse backwards. Third, packagekit has been updated so none of this is necessary anyway.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#46 2015-01-08 18:07:11

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,404
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

isank wrote:

... "for the time being", that means till packagekit gets an update or so.

It has been updated.  It was updated over a week ago.  This nonsense is not needed.  This thread is solved.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#47 2015-01-08 18:14:57

isank
Member
Registered: 2015-01-08
Posts: 6

Re: [SOLVED]packagekit: requires pacman<4.2.0

jasonwryan wrote:

Where to start? First, partial upgrades are unsupported, and holding back the single most important package on your system makes no sense anyway. Secondly, to do so for an unsupported package (packagekit) is just arse backwards. Third, packagekit has been updated so none of this is necessary anyway.

Point taken, but then why the error is still the same when firing the command

sudo pacman -Syu

Offline

#48 2015-01-08 18:18:07

isank
Member
Registered: 2015-01-08
Posts: 6

Re: [SOLVED]packagekit: requires pacman<4.2.0

Trilby wrote:
isank wrote:

... "for the time being", that means till packagekit gets an update or so.

It has been updated.  It was updated over a week ago.  This nonsense is not needed.  This thread is solved.

Point taken, but then why the error is still the same when firing the command

sudo pacman -Syu

Offline

#49 2015-01-08 18:35:33

Trilby
Inspector Parrot
Registered: 2011-11-29
Posts: 24,404
Website

Re: [SOLVED]packagekit: requires pacman<4.2.0

Pacman does not update AUR packages, that's why.  Remove the old packagekit, upgrade your system, then rebuild/install the new packagekit.


"UNIX is simple and coherent..." - Dennis Ritchie, "GNU's Not UNIX" -  Richard Stallman

Offline

#50 2015-01-08 18:44:26

isank
Member
Registered: 2015-01-08
Posts: 6

Re: [SOLVED]packagekit: requires pacman<4.2.0

Trilby wrote:

Pacman does not update AUR packages, that's why.  Remove the old packagekit, upgrade your system, then rebuild/install the new packagekit.

Okay, thanks for the help.

But guys do you seriously think this is the way to tell that a post is wrong or not worth (nonsense/ill-advised etc), actually I am saying this because I am a newbie wanting to start my contribution to open source community, and on my very first post I get this, well this might be the way you guys are big players of this field, I don't know.

Offline

Board footer

Powered by FluxBB