You are not logged in.

#1 2004-02-17 10:38:42

Comete
Member
From: France
Registered: 2003-08-03
Posts: 46

pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

hi,

just to say that i've found a problem with the last release of flashplugin 6.0r79-8, the flash plugin doesn't work anymore with mozilla or mozilla-firefox. A patch is available here

http://wintrmute.net/software/flashfix-1.0.tar.gz

and it works very well for me smile

so if someone could modify the PKGBUILD to patch flashplugin...

Thank you


Comete

Offline

#2 2004-02-17 11:28:55

robot5x
Member
Registered: 2004-01-26
Posts: 266

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

I don't know exactly what that problem is - I'm using flashplugin 6.0r79-8 on mozilla-firefox 0.8-2 and flash works fine...

Offline

#3 2004-02-17 12:49:38

Comete
Member
From: France
Registered: 2003-08-03
Posts: 46

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

in fact, when i started mozilla-firebox or mozilla in an xterm, it returned an error about  libstdc++-libc6.2-2.so.3 that wasn't found for flashplugin. It seems that this error is known on
http://plugindoc.mozdev.org/linux.html#Flash

"If Flash Player does not work, make sure you have a compatible version of libstdc++ present (libstdc++-libc6.2-2.so.3). On RedHat based systems, install the package "compat-libstdc++" (Package "compat" on SuSE, "libstdc++2.10" on Mandrake 9.2). Alternatively, you can try Flashfix, which patches the Flash plugin to get around this requirement. "

if my problem could help someone else... smile

Comete

Offline

#4 2004-02-17 13:01:08

sarah31
Member
From: Middle of Canada
Registered: 2002-08-20
Posts: 2,975
Website

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

the problem for you comete is that the post install file that makes that link did not work for you ... if you uninstall and reinstall it should work without patching.


AKA uknowme

I am not your friend

Offline

#5 2004-02-18 08:53:13

sweiss
Member
Registered: 2004-02-16
Posts: 635

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

Well Comete, you helped me, so thanks a bunch smile

Offline

#6 2004-02-18 14:33:26

skparkes
Member
Registered: 2003-12-11
Posts: 52

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

On a similar subject, I've noticed the mplayer-plugin and the flashplugin packagers have done a good job of trying to get everything to work off the bat.  Unfortunately, at least for me, they missed the plugins directory for firefox.  The only directory that seems to like the plug-ins is:

/opt/mozilla-firefox/lib/mozilla-1.6/plugins

Once I drop the syms in there it seems to be okay.  Except for the flash, but I assume that has to do with the above error.

Later,

Ismoor

Offline

#7 2004-02-18 15:53:35

Xentac
Forum Fellow
From: Victoria, BC
Registered: 2003-01-17
Posts: 1,797
Website

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

It's a bug.  If you install flashplugin then mozilla-firebird, the directory is a directory, which is bad.  If you install mazilla-firebird then flashplugin, the directory is a symlink.  The easiest thing to do is move those symlinks over and create a symlink for the mozilla directory.  The most braindead thing to do is remave both packages and install them, one at a time, again.


I have discovered that all of mans unhappiness derives from only one source, not being able to sit quietly in a room
- Blaise Pascal

Offline

#8 2004-02-18 15:59:36

Mr Green
Forum Fellow
From: U.K.
Registered: 2003-12-21
Posts: 5,745

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

Mr X

Am I the Braindead one you speak of  lol

I rm flash & then reinstalled no problem 8)

Mr Green

Lookin for a Brain donor :?


Mr Green

Online

#9 2004-02-21 01:36:29

scottro
Member
From: NYC
Registered: 2002-10-11
Posts: 452
Website

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

I also had problems--I played around with symlinking and copying over flash here and there.   I should have been more systematic so my solution could help others.

In the end, I downloaded that missing libstdc (as I've had problems with it before with Arch, I actually have a bzipped copy of it on my ArchLinux page so just got it off there.  After that, everything worked (and didn't before hand) but as I said, I wasn't systematic with it.

=================================================

UPDATE

After looking at this thread, I tried doing it on another box.  I think the problem was, last time,
I did pacman -Syu and it put in the flashplugin first.  This time, I first upgraded firefox.  I then checked and flash still worked.


I then upgraded flashplugin.  When it went to install the plugin, it found the conflict that firefox already had the flashplayer.xpt and libflashplayer.so in /opt/mozilla-firefox/lib/mozilla/plugins.

So, I removed them, and after that, it worked without problem.

I think the key ~might~ be, at least in part, to do as was said and install firefox first.

Offline

#10 2004-02-22 04:35:41

tsykoduk
Member
From: A Chair
Registered: 2003-10-31
Posts: 48
Website

Re: pb with flashplugin 6.0r79-8 and mozilla/mozilla-firefox

Thanks Xentac - the symlinks did the trick!

Offline

Board footer

Powered by FluxBB