You are not logged in.

#1 2016-01-15 10:05:25

Registered: 2016-01-12
Posts: 1

Qualcomm Atheros AR9285: DMA failed to stop in 10 ms

I would like to run Arch Linux x86_64 on an ASUS EEE 1001PXD netbook, which uses an Atheros AR9285 mini-PCIe Wi-Fi card to connect to the Internet.

The driver which comes installed with the Arch Linux live CD loads and the card is detected properly. 'wifi-menu' finds Wi-Fi networks perfectly fine and connects to them without issue, however, after a minute of accessing the Internet over Wi-Fi, the following kernel message is printed to the framebuffer many times:

ath: phy0: DMA failed to stop in 10 ms AR_CR=0x00000024 AR_DIAG_SW=0x0002804 DMADBG_7=<changes every time the message appears>

and the access to the network is lost for a short period of time.

This obviously not only stops me from installing Arch Linux without the use of an Ethernet cable, but using a wired connection is not appropriate for what I want to use the netbook for.

I've tried setting the ath9k module's settings (and reloading the module) to:


as per other forum threads' solutions, but it does nothing. The message still is printed to the console, and the network access is still unreliable.

I've taken a picture of my screen here, which shows the messages along with the output of lspci: … sp=sharing

Is there a fix? Only recently have I started experiencing this issue (and I believe only in Arch Linux). I don't think I have opened this netbook up before, either.

EDIT: I've now tried connecting it to two Wi-Fi routers, one running the latest OpenWRT, and the other a Cisco Linksys router running a stock system. Both have the same issue.

Last edited by georgewhite (2016-01-24 16:25:00)


Board footer

Powered by FluxBB