You are not logged in.

#1 2016-01-12 18:26:45

Malakin
Member
From: Santiago, Chile
Registered: 2007-04-29
Posts: 34
Website

[SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

Is anyone else having this problem?

I'm getting some UI flicker after the last qt5-base package update (qt5-base-5.5.1-8). When moving the cursor over some UI elements some regions of the screen or other UI elements flicker. It happens in KDE and also in the SDDM login screen and the KDE loading screen when logging in.

It happens in both a laptop and a desktop computer, both with intel graphics (laptop also has an unused nvidia optimus) but the regions affected are not exactly the same. For example in my laptop I get a vertical bar to the left of the screen, where the background flickers, when I move the cursor over the SDDM login textbox, but on the desktop the whole background flickers.

If I downgrade to qt5-base-5.5.1-7 the problem goes away.

EDIT: It seems the problem is no longer present in the last update: 5.5.1-9.

Last edited by Malakin (2016-01-17 06:11:59)

Offline

#2 2016-01-12 19:43:21

archlinux20130905
Member
Registered: 2013-09-05
Posts: 17

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

I can confirm this bug. This problem started after the following updates:

[2016-01-11 20:27] [ALPM] upgraded device-mapper (2.02.137-1 -> 2.02.138-1)
[2016-01-11 20:27] [ALPM] upgraded dhcpcd (6.9.4-1 -> 6.10.0-1)
[2016-01-11 20:27] [ALPM] upgraded lvm2 (2.02.137-1 -> 2.02.138-1)
[2016-01-11 20:27] [ALPM] upgraded qt5-base (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-xmlpatterns (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-declarative (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-graphicaleffects (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-imageformats (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-location (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-multimedia (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-quickcontrols (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-script (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-sensors (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-svg (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-webchannel (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-webkit (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-translations (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-tools (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded qt5-x11extras (5.5.1-7 -> 5.5.1-8)
[2016-01-11 20:27] [ALPM] upgraded xorg-server-common (1.18.0-3 -> 1.18.0-4)
[2016-01-11 20:27] [ALPM] upgraded xorg-server (1.18.0-3 -> 1.18.0-4)

I didn't have time to narrow it down to one (or more) specific packages, so thank you for narrowing it down. However on my computer (Dell Inspiron 580) I only get the flickering at the login screen and only if I move the cursor over the pictures of the user or if I click on the left and right arrows. (I also use SDDM with KDE.)

During each flicker the screen goes white for a fraction of a second.

Offline

#3 2016-01-12 23:03:33

max kaspar
Member
Registered: 2013-04-11
Posts: 35

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

These updates made my Plasma 5 desktop unusable because it crashes every time  i click on a panel (application menu, system tray, network widget...). Flickering on sddm top panel also. I'm using nouveau driver

Last edited by max kaspar (2016-01-12 23:05:55)

Offline

#4 2016-01-13 03:00:38

sl1pkn07
Member
From: Spanishtán
Registered: 2010-03-30
Posts: 312

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

reverse related (?)

https://bugs.archlinux.org/task/47703
https://devtalk.nvidia.com/default/topi … th-361-16/

Last edited by sl1pkn07 (2016-01-13 03:43:56)

Offline

#5 2016-01-13 03:20:30

Malakin
Member
From: Santiago, Chile
Registered: 2007-04-29
Posts: 34
Website

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

I don't think the crashes are related. In my case everything works just fine except for the flickering of the UI.

Last edited by Malakin (2016-01-13 21:47:22)

Offline

#6 2016-01-13 07:38:38

lula
Member
Registered: 2009-07-16
Posts: 29

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

Same problem here on Lenovo Laptop with Intel HD4000 Graphic, flickering and black vertical bar on the left in sddm

Offline

#7 2016-01-13 09:12:52

hoerbert
Member
Registered: 2013-04-03
Posts: 36

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

No, not for me. I'm using Intel Card (HD Graphics 4000) without nvidia-driver tongue

Here [0] someone "solved" this, by switching from SNA to UXA. Did not test this, because that is not a real solution, but a temporary workaround. I think this is a problem in qt and/or X, so we will have to wait for a patch. Or first report this upstream. But to who?

[0]: https://bbs.archlinux.org/viewtopic.php … 9#p1594649

Greets,

Torben

Offline

#8 2016-01-13 10:10:38

smirky
Member
From: Bulgaria
Registered: 2013-02-23
Posts: 217
Website

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

Would be great if you guys made a video with ffmpeg or something else so we can see it.


Personal spot  ::  https://www.smirky.net/  ::  Try not to get lost!

Offline

#9 2016-01-13 10:59:03

hoerbert
Member
Registered: 2013-04-03
Posts: 36

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

For me, this mostly occurs in SDDM. See this videos taken with my Smartphone
https://vid.me/n3jX
https://vid.me/NYu1

When logged in, this only happens, when hovering the icons (icon-only starters) in the panel. But also only on the left side and only on the panel (not the whole height of the screen).

Torben

Last edited by hoerbert (2016-01-13 10:59:32)

Offline

#10 2016-01-13 15:20:38

smirky
Member
From: Bulgaria
Registered: 2013-02-23
Posts: 217
Website

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

I think you should report this in bugs.kde.org
Sadly, I'm unable to point out the proper section for this, but if you ask in #plasma on IRC, they'll surely help you out in reporting this bug (if not already reported or fixed in the 5.6).
Trust me, the best thing you can do is report it, otherwise it won't get much attention here.


Personal spot  ::  https://www.smirky.net/  ::  Try not to get lost!

Offline

#11 2016-01-13 15:30:35

V1del
Member
Registered: 2012-10-16
Posts: 1,115

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

The issue is in QT and/or the graphics driver. Arch currently uses a patch that hasn't been released yet, I doubt the KDE people will be of help here. The relation posted earlier is there. It is a fix for a peculiarity with the properietary driver, that lead to a fix in QT that leads to weird behaviour in FLOSS drivers.

Last edited by V1del (2016-01-13 15:32:08)

Online

#12 2016-01-13 22:09:15

AntAntAnt
Member
Registered: 2012-12-28
Posts: 10

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

It is freezing sddm entirely for me. I am using the nouveau driver.
Downgrading to 5.5.1-7 fixes the issue.
Did anyone open a bug report somewhere?

Offline

#13 2016-01-13 22:12:29

Daniel-HD
Member
Registered: 2015-11-27
Posts: 11

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

Offline

#14 2016-01-14 16:26:22

6ng4n
Member
Registered: 2012-02-07
Posts: 74

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

I'm using i915 and xorg-video-intel. It shows same behavior with nouveau that @hoerbert sent.

Offline

#15 2016-01-14 17:38:02

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

The solution at https://bbs.archlinux.org/viewtopic.php … 6#p1595276 works for me to work around this problem until the qt5 / mesa packages have this bug fixed upstream.


Mike C

Offline

#16 2016-01-15 12:44:40

bartki
Member
Registered: 2015-12-01
Posts: 3

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

For me it was sufficient to create the file /etc/X11/xorg.conf.d/20-intel.conf and add the following lines:

Section "Device"
        Identifier "Intel Graphics"
        Driver     "intel"
        Option     "DRI" "3"
EndSection

Options like TearFree did not solve the problem.

Offline

#17 2016-01-15 16:06:35

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

In my case on four different machines having the xorg set to both dri3 and tearfree, as well as using OpenGL 3.1 with EGL set in the plasma settings for Compositor in Display and Monitor, is now giving flawless behaviour for graphics - all machines are using Intel integrated graphics even though two laptops do have discrete graphics cards that are both set to not have drivers loaded.


Mike C

Offline

#18 2016-01-15 16:15:05

V1del
Member
Registered: 2012-10-16
Posts: 1,115

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

If I read it correctly, the QT patch addresses a GLX peculiarity, switching to EGL will therefore not trigger the behaviour

Online

#19 2016-01-16 23:17:11

McKlain
Member
Registered: 2013-06-23
Posts: 12

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

Seems to be fixed for qt5-base (5.5.1-9) package.

Offline

#20 2016-01-17 14:12:02

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 694

Re: [SOLVED] UI flickering after last qt5-base package update (5.5.1-8)

McKlain wrote:

Seems to be fixed for qt5-base (5.5.1-9) package.

For me it is better though ui freezes are still occurring with this version on all my machines periodically.


Mike C

Offline

Board footer

Powered by FluxBB