You are not logged in.

#1 2016-01-18 20:23:36

loredan13
Member
Registered: 2016-01-18
Posts: 2

wpa_supplicant sometimes failes to authenticate

The problem started after reinstaling Archlinux on my laptop. When a laptop is connected to my wireless router, after some time it disconnects and absolutely refuses to connect back. Reboot sometimes helps, sometimes it doesn't. Sometimes, I think, problem is solved by

sudo systemctl restart netctl-auto@wlp5s0

but it doesn't work most of the time. Sometimes it just comes back up, but I never figured out the time frame. This time I tried to follow a manual wireless networking guide here: https://wiki.archlinux.org/index.php/Wi … nual_setup and it worked the first time:

[root@laptop loredan13]# wpa_supplicant -D nl80211,wext -i wlp5s0 -c <(wpa_passphrase "AsusNET" "********")
Successfully initialized wpa_supplicant
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Associated with c8:60:00:93:30:a8
wlp5s0: WPA: Key negotiation completed with c8:60:00:93:30:a8 [PTK=CCMP GTK=CCMP]
wlp5s0: CTRL-EVENT-CONNECTED - Connection to c8:60:00:93:30:a8 completed [id=0 id_str=]
^Cwlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
nl80211: deinit ifname=wlp5s0 disabled_11b_rates=0
wlp5s0: CTRL-EVENT-TERMINATING

I exited it to try and get log output in journalctl somehow, and I did it with dhcpcd daemon still running. I tried to do the same with sudo, but it did not work:

[loredan13@laptop ~]$ sudo wpa_supplicant -D nl80211,wext -i wlp5s0 -c <(wpa_passphrase "AsusNET" "********")
[sudo] пароль для loredan13: 
Successfully initialized wpa_supplicant
Failed to open config file '/dev/fd/63', error: No such file or directory
Failed to read or parse configuration '/dev/fd/63'.

So I logged back as root and tried to launch it again, dhcpcd was still runnung, I think:

[root@laptop loredan13]# wpa_supplicant -D nl80211,wext -i wlp5s0 -c <(wpa_passphrase "AsusNET" "********")
Successfully initialized wpa_supplicant
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=1 duration=10 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=2 duration=23 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=3 duration=46 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=4 duration=77 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=5 duration=75 reason=CONN_FAILED
^Cnl80211: deinit ifname=wlp5s0 disabled_11b_rates=0
wlp5s0: CTRL-EVENT-TERMINATING 
[root@laptop loredan13]# wpa_supplicant -D nl80211,wext -i wlp5s0 -c <(wpa_passphrase "AsusNET" "********")
Successfully initialized wpa_supplicant
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=1 duration=10 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=2 duration=23 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=3 duration=46 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=4 duration=77 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=5 duration=75 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=6 duration=143 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=7 duration=135 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=8 duration=116 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=9 duration=102 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=10 duration=139 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=11 duration=121 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=12 duration=122 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Authentication with c8:60:00:93:30:a8 timed out.
wlp5s0: CTRL-EVENT-DISCONNECTED bssid=c8:60:00:93:30:a8 reason=3 locally_generated=1
wlp5s0: CTRL-EVENT-SSID-TEMP-DISABLED id=0 ssid="AsusNET" auth_failures=13 duration=227 reason=CONN_FAILED
wlp5s0: CTRL-EVENT-SSID-REENABLED id=0 ssid="AsusNET"
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Associated with c8:60:00:93:30:a8
wlp5s0: WPA: Key negotiation completed with c8:60:00:93:30:a8 [PTK=CCMP GTK=CCMP]
wlp5s0: CTRL-EVENT-CONNECTED - Connection to c8:60:00:93:30:a8 completed [id=0 id_str=]

So authentication failed 13 times, giving either CTRL-EVENT-ASSOC-REJECT or time out, and then authenticated normally. I repeated the same exiting wpa_supplicant with running dhcpcd again and this time it was faster:

[root@laptop loredan13]# wpa_supplicant -D nl80211,wext -i wlp5s0 -c <(wpa_passphrase "AsusNET" "********")
Successfully initialized wpa_supplicant
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: CTRL-EVENT-ASSOC-REJECT bssid=c8:60:00:93:30:a8 status_code=16
wlp5s0: Trying to associate with c8:60:00:93:30:a8 (SSID='AsusNET' freq=2437 MHz)
wlp5s0: Associated with c8:60:00:93:30:a8
wlp5s0: WPA: Key negotiation completed with c8:60:00:93:30:a8 [PTK=CCMP GTK=CCMP]
wlp5s0: CTRL-EVENT-CONNECTED - Connection to c8:60:00:93:30:a8 completed [id=0 id_str=]

As of hardware, it's Lenovo G560, network controller is Broadcom BCM4313 with broadcom-wl driver. The problem initially existed on brcm80211, I switched to broadcom-wl in hopes that it would fix the problem.
I did not manage to find any pattern in the occurence of the problem, and I can't find the conditions under which problem occurs. Did anybody encounter something similar?

Thanks

Offline

#2 2016-01-18 22:51:45

Head_on_a_Stick
Member
From: Asteroid B-612
Registered: 2014-02-20
Posts: 3,844
Website

Re: wpa_supplicant sometimes failes to authenticate

You need to use the "-B" flag to daemonise wpa_supplicant and return the command prompt wink

Do you have conflicting networking services?

systemctl list-unit-files|grep enabled

_0_
__0
000

Offline

#3 2016-01-18 22:55:59

loredan13
Member
Registered: 2016-01-18
Posts: 2

Re: wpa_supplicant sometimes failes to authenticate

[loredan13@laptop ~]$ systemctl list-unit-files | grep enabled
org.cups.cupsd.path                        enabled 
autovt@.service                            enabled 
display-manager.service                    enabled 
getty@.service                             enabled 
iptables.service                           enabled 
lightdm.service                            enabled 
netctl-ifplugd@.service                    enabled 
org.cups.cupsd.service                     enabled 
org.cups.cupsd.socket                      enabled 
remote-fs.target                           enabled 

Usually there is also netctl-auto@wlp5s0, but I turned it off for manual connection test. And I didn't put -B for testing purposes, I don't intend to make it a permanent solution

Offline

Board footer

Powered by FluxBB