You are not logged in.

#1 2016-01-22 02:27:52

retogenes
Member
Registered: 2016-01-21
Posts: 8

Network manager stops working when installing gvfs

I have installed Arch+xfce in a fairly old (32bits, 512MB RAM) laptop computer. I could not get my wifi working with wicd, but Network Manager worked like a charm until I tried to install gvfs (which also installs gcr-3.18.0-1 libatasmart-0.19-3  libbluray-0.9.2-1 libcddb-1.3.2-4  libcdio-0.93-3  libcdio-paranoia-10.2+0.93+1-1 udisks2-2.1.6-1  gvfs-1.26.2-1).

After that install, Network manager started to refuse to connect to wifi. "systemctl status NetworkManager" showed that when connecting to a secured wifi, NetworkManager was trying to do it without security, so it was rejected. When trying to connect to an unsecured wifi, the error was of wpa supplicant timeout. This was not solved by rebooting.

After uninstalling gvfs with its dependencies, NetworkManager started working again. Any idea on how can I install gvfs while keeping NetworkManager working?

Here are some outputs:

$ uname -r
4.3.3-3-ARCH
$ lspci | grep Wireless
01:02.0 Network controller: Intel Corporation PRO/Wireless 2200BG [Calexico2] Network Connection (rev 05)
$ systemctl status NetworkManager 
● NetworkManager.service - Network Manager
   Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disabled)
   Active: active (running) since vie 2016-01-22 04:40:56 CET; 16min ago
 Main PID: 230 (NetworkManager)
    Tasks: 4 (limit: 512)
   CGroup: /system.slice/NetworkManager.service
           ├─230 /usr/bin/NetworkManager --no-daemon
           └─288 /usr/bin/dhclient -d -q -sf /usr/lib/networkmanager/nm-dhcp-helper -pf /var/run/dhclient-wlp1s2.pid -lf /var/lib/NetworkManager/dhclient-da7dbe31-03b2-4288-9a8b-b0cdf23af138-wlp1s2.lease -cf /var/lib/NetworkManager/dhclient-wlp1s2.conf wlp1s2

Last edited by retogenes (2016-01-22 02:29:21)

Offline

#2 2016-01-22 02:35:57

Docbroke
Member
From: India
Registered: 2015-06-13
Posts: 527

Re: Network manager stops working when installing gvfs

Try manually editing your password for wireless-network, by right clicking on the icons of network manager.


Arch is home!
i3 rofi w3m mc vim mutt pass
w3m-dmenu

Offline

#3 2016-02-03 15:19:06

retogenes
Member
Registered: 2016-01-21
Posts: 8

Re: Network manager stops working when installing gvfs

After having other problems, I run a memtest and found some errors. I guess this caused also this problem.

Offline

Board footer

Powered by FluxBB