You are not logged in.

#2001 2016-05-24 03:39:11

zanny
Member
Registered: 2012-10-05
Posts: 78

Re: KF 5 & Plasma

If anyone else is having problems with kwallet, 5.22.0-2 seems to have broken something with PAM and my wallet was not unlocking on signin like usual. Reverting to -1 fixed it.

Offline

#2002 2016-05-24 05:46:04

misiunt
Member
Registered: 2015-08-28
Posts: 7

Re: KF 5 & Plasma

zanny wrote:

If anyone else is having problems with kwallet, 5.22.0-2 seems to have broken something with PAM and my wallet was not unlocking on signin like usual. Reverting to -1 fixed it.

I had the same issue after upgrading kwallet to 5.22.0-2. Downgrading back to 5.22.0-1 fixed it.

Offline

#2003 2016-05-24 07:55:14

midixinga
Member
Registered: 2014-01-18
Posts: 187

Re: KF 5 & Plasma

yes I'm also not able to open my wallet; it asks for a password; but I don't have a password?! I don't need it because my home is encrypted


[Desktop | Intel i4570 CPU |  Internal Graphics HD4600 |  ASRock H87M Pro4 | 8 GB RAM | UEFI/GPT | Samsung SSD 850 | Single-Boot Arch 64 Bit | sytemd-boot | KDE 4 xfce Plasma5]

Offline

#2004 2016-05-24 08:06:02

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 330
Website

Re: KF 5 & Plasma

I had the same issue. I've just rebuild kwallet 5.22.0-2 localy and it works again smile

Offline

#2005 2016-05-24 08:19:02

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,645

Re: KF 5 & Plasma

pb wrote:

I had the same issue. I've just rebuild kwallet 5.22.0-2 localy and it works again smile

Does your build include the patch for FS#47474? Can you attach the .BUILDINFO file from your build?

Online

#2006 2016-05-24 08:45:30

Tromzy
Member
Registered: 2015-02-15
Posts: 162

Re: KF 5 & Plasma

Deleting the wallet fixed the problem for me ; no need to downgrade.

Offline

#2007 2016-05-24 09:10:50

OdinEidolon
Member
From: Belluno - Italy
Registered: 2011-01-31
Posts: 489

Re: KF 5 & Plasma

Tromzy wrote:

Deleting the wallet fixed the problem for me ; no need to downgrade.

Thanks!


Hardware: 2016 Dell XPS15 - matte FullHD - i5-6300HQ - 32GB DDR4 - Nvidia GTX960M - Samsung 840EVO 250GB SSD - 56Wh
Software: Plasma 5 - rEFInd - linux-ck - preload - prelink - verynice - psd - bumblebee

Offline

#2008 2016-05-24 14:21:22

pb
Member
From: Krakow, PL
Registered: 2014-12-26
Posts: 330
Website

Re: KF 5 & Plasma

arojas wrote:
pb wrote:

I had the same issue. I've just rebuild kwallet 5.22.0-2 localy and it works again smile

Does your build include the patch for FS#47474? Can you attach the .BUILDINFO file from your build?

Yes, it's build with this patch. It's build using your's PKGBUILD for 5.22.0-2. Only one thing, I change, is update sums, because those in your's PKGBUILD for kwallet is not valid.

.BUILDINFO: http://pastebin.com/Lr79Jx7B

My Plasma 5.6.4 version has 3 packages with some patches from anongit: kwin, plasma-desktop and plasma-workspace. If you want, I can attach PKGBUILD for it, but my friend do this same - only build kwallet localy and it works.

Last edited by pb (2016-05-24 14:36:56)

Offline

#2009 2016-05-24 14:47:23

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,645

Re: KF 5 & Plasma

pb wrote:
arojas wrote:
pb wrote:

I had the same issue. I've just rebuild kwallet 5.22.0-2 localy and it works again smile

Does your build include the patch for FS#47474? Can you attach the .BUILDINFO file from your build?

Yes, it's build with this patch. It's build using your's PKGBUILD for 5.22.0-2. Only one thing, I change, is update sums, because those in your's PKGBUILD for kwallet is not valid.

.BUILDINFO: http://pastebin.com/Lr79Jx7B

My Plasma 5.6.4 version has 3 packages with some patches from anongit: kwin, plasma-desktop and plasma-workspace. If you want, I can attach PKGBUILD for it, but my friend do this same - only build kwallet localy and it works.

Oh crap, now I know what happened - fix coming up.

Online

#2010 2016-05-25 05:43:10

mabl
Member
Registered: 2012-11-20
Posts: 20

Re: KF 5 & Plasma

Tromzy wrote:
mabl wrote:

You are having issues with multiple monitors? You fear to undock your laptop because you just now Plasma will mess up spectacularly? You don't even think of going to standby in the dock and then undock? At work you let others connect their laptop to the projector, because you know they will only make fun of you? The time of constants horrors is over! I present to you:

https://git.reviewboard.kde.org/r/125451/

This little gem applies neatly to plasma-workspace 5.6.4. Just apply and rebuild your plasma-workspace. Your salvation is near!

Thanks for the info ; can you give information as to how to patch plasma-workspace with this ?

Yes, I simply added the patch to the current PKGBUILD file:

# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Antonio Rojas
# Contributor: Alexey D. <lq07829icatm at rambler.ru>

pkgbase=plasma-workspace
pkgname=('plasma-workspace' 'drkonqi' 'kuiserver' 'plasma-wayland-session')
pkgver=5.6.4
pkgrel=1
pkgdesc='KDE Plasma Workspace'
arch=('i686' 'x86_64')
url='https://www.kde.org/workspaces/plasmadesktop/'
license=('LGPL')
# note on libxdamage:
# not detected by namcap because libgl depends on it
# but nvidia providing libgl does not depend on libxdamage
depends=('kjsembed' 'knotifyconfig' 'libxdamage' 'libksysguard' 'libkscreen' 'ktexteditor' 'libqalculate'
         'qt5-tools' 'kde-cli-tools' 'xorg-xrdb' 'xorg-xsetroot' 'iso-codes' 'kactivitymanagerd'
         'xorg-xmessage' 'xorg-xprop' 'milou' 'breeze' 'prison-frameworks' 'kwin' 'plasma-integration')
makedepends=('extra-cmake-modules' 'kdoctools' 'gpsd' 'baloo'
             'krunner' 'kxmlrpcclient' 'networkmanager-qt')
groups=('plasma')
source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgbase}-${pkgver}.tar.xz" 'kde.pam' 'kdevelop_u30524.patch::https://git.reviewboard.kde.org/r/125451/diff/raw/')
md5sums=('9a1dec8b5961ee33faff91258f617ff6'
         '378ee33a9ec2870a1a899f2e05ee00d4' 'SKIP')

prepare() {
  mkdir -p build

  cd $pkgbase-${pkgver}
  # be sure to use the Qt5 version of qtpaths
  sed -e 's:qtpaths:qtpaths-qt5:' -i startkde/start*.cmake
  patch -p1 < ../kdevelop_u30524.patch
  
}

build() {
  cd build
  cmake ../$pkgbase-${pkgver} \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_BUILD_TYPE=Release \
    -DKDE_INSTALL_LIBDIR=lib \
    -DKDE_INSTALL_LIBEXECDIR=lib \
    -DBUILD_TESTING=OFF
  make
}

package_plasma-workspace() {
  depends+=('kuiserver')
  optdepends=('plasma-workspace-wallpapers: additional wallpapers'
              'gpsd: GPS based geolocation' 'networkmanager-qt: IP based geolocation')
  conflicts=('kdebase-workspace')

  cd build
  make DESTDIR="$pkgdir" install

  install -Dm644 "$srcdir"/kde.pam "$pkgdir"/etc/pam.d/kde

  # Remove conflicts with drkonqi
  rm "$pkgdir"/usr/lib/drkonqi
  rm -r "$pkgdir"/usr/share/drkonqi

  # Remove conflicts with kuiserver
  rm "$pkgdir"/usr/bin/kuiserver5
  rm "$pkgdir"/usr/lib/libkdeinit5_kuiserver5.so
  rm "$pkgdir"/usr/share/dbus-1/services/kf5_org.kde.kuiserver.service
  rm "$pkgdir"/usr/share/kservices5/kuiserver.desktop

  # Split plasma-wayland scripts
  rm -r "$pkgdir"/usr/share/wayland-sessions
}

package_drkonqi() {
  pkgdesc='KDE crash handler'
  depends=('kxmlrpcclient' 'kidletime' 'gdb')

  cd build/drkonqi
  make DESTDIR="$pkgdir" install
}

package_kuiserver() {
  pkgdesc='KDE Progress Info UI server'
  depends=('kxmlgui')
  groups=()

  cd build/kuiserver
  make DESTDIR="$pkgdir" install
}

package_plasma-wayland-session() {
  pkgdesc='Plasma Wayland session'
  depends=('plasma-workspace' 'qt5-wayland' 'kwayland-integration' 'xorg-server-xwayland')
  groups=()

  install -Dm644 build/plasmawayland.desktop "$pkgdir"/usr/share/wayland-sessions/plasmawayland.desktop
}

That file worked well for me, but somehow now I get build errors like

By not providing "FindKF5DesignerPlugin.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "KF5DesignerPlugin", but CMake did not find one.

But maybe it still works for you?

Offline

#2011 2016-05-25 18:03:26

hamelg
Member
From: France
Registered: 2008-06-19
Posts: 116

Re: KF 5 & Plasma

arojas wrote:

Oh crap, now I know what happened - fix coming up.

kwallet 5.22.0-3 has fixed the issue smile
thanks

Offline

#2012 2016-05-26 09:36:49

Tromzy
Member
Registered: 2015-02-15
Posts: 162

Re: KF 5 & Plasma

mabl wrote:
Tromzy wrote:
mabl wrote:

You are having issues with multiple monitors? You fear to undock your laptop because you just now Plasma will mess up spectacularly? You don't even think of going to standby in the dock and then undock? At work you let others connect their laptop to the projector, because you know they will only make fun of you? The time of constants horrors is over! I present to you:

https://git.reviewboard.kde.org/r/125451/

This little gem applies neatly to plasma-workspace 5.6.4. Just apply and rebuild your plasma-workspace. Your salvation is near!

Thanks for the info ; can you give information as to how to patch plasma-workspace with this ?

Yes, I simply added the patch to the current PKGBUILD file:

# $Id$
# Maintainer: Felix Yan <felixonmars@archlinux.org>
# Contributor: Andrea Scarpino <andrea@archlinux.org>
# Contributor: Antonio Rojas
# Contributor: Alexey D. <lq07829icatm at rambler.ru>

pkgbase=plasma-workspace
pkgname=('plasma-workspace' 'drkonqi' 'kuiserver' 'plasma-wayland-session')
pkgver=5.6.4
pkgrel=1
pkgdesc='KDE Plasma Workspace'
arch=('i686' 'x86_64')
url='https://www.kde.org/workspaces/plasmadesktop/'
license=('LGPL')
# note on libxdamage:
# not detected by namcap because libgl depends on it
# but nvidia providing libgl does not depend on libxdamage
depends=('kjsembed' 'knotifyconfig' 'libxdamage' 'libksysguard' 'libkscreen' 'ktexteditor' 'libqalculate'
         'qt5-tools' 'kde-cli-tools' 'xorg-xrdb' 'xorg-xsetroot' 'iso-codes' 'kactivitymanagerd'
         'xorg-xmessage' 'xorg-xprop' 'milou' 'breeze' 'prison-frameworks' 'kwin' 'plasma-integration')
makedepends=('extra-cmake-modules' 'kdoctools' 'gpsd' 'baloo'
             'krunner' 'kxmlrpcclient' 'networkmanager-qt')
groups=('plasma')
source=("http://download.kde.org/stable/plasma/${pkgver}/${pkgbase}-${pkgver}.tar.xz" 'kde.pam' 'kdevelop_u30524.patch::https://git.reviewboard.kde.org/r/125451/diff/raw/')
md5sums=('9a1dec8b5961ee33faff91258f617ff6'
         '378ee33a9ec2870a1a899f2e05ee00d4' 'SKIP')

prepare() {
  mkdir -p build

  cd $pkgbase-${pkgver}
  # be sure to use the Qt5 version of qtpaths
  sed -e 's:qtpaths:qtpaths-qt5:' -i startkde/start*.cmake
  patch -p1 < ../kdevelop_u30524.patch
  
}

build() {
  cd build
  cmake ../$pkgbase-${pkgver} \
    -DCMAKE_INSTALL_PREFIX=/usr \
    -DCMAKE_BUILD_TYPE=Release \
    -DKDE_INSTALL_LIBDIR=lib \
    -DKDE_INSTALL_LIBEXECDIR=lib \
    -DBUILD_TESTING=OFF
  make
}

package_plasma-workspace() {
  depends+=('kuiserver')
  optdepends=('plasma-workspace-wallpapers: additional wallpapers'
              'gpsd: GPS based geolocation' 'networkmanager-qt: IP based geolocation')
  conflicts=('kdebase-workspace')

  cd build
  make DESTDIR="$pkgdir" install

  install -Dm644 "$srcdir"/kde.pam "$pkgdir"/etc/pam.d/kde

  # Remove conflicts with drkonqi
  rm "$pkgdir"/usr/lib/drkonqi
  rm -r "$pkgdir"/usr/share/drkonqi

  # Remove conflicts with kuiserver
  rm "$pkgdir"/usr/bin/kuiserver5
  rm "$pkgdir"/usr/lib/libkdeinit5_kuiserver5.so
  rm "$pkgdir"/usr/share/dbus-1/services/kf5_org.kde.kuiserver.service
  rm "$pkgdir"/usr/share/kservices5/kuiserver.desktop

  # Split plasma-wayland scripts
  rm -r "$pkgdir"/usr/share/wayland-sessions
}

package_drkonqi() {
  pkgdesc='KDE crash handler'
  depends=('kxmlrpcclient' 'kidletime' 'gdb')

  cd build/drkonqi
  make DESTDIR="$pkgdir" install
}

package_kuiserver() {
  pkgdesc='KDE Progress Info UI server'
  depends=('kxmlgui')
  groups=()

  cd build/kuiserver
  make DESTDIR="$pkgdir" install
}

package_plasma-wayland-session() {
  pkgdesc='Plasma Wayland session'
  depends=('plasma-workspace' 'qt5-wayland' 'kwayland-integration' 'xorg-server-xwayland')
  groups=()

  install -Dm644 build/plasmawayland.desktop "$pkgdir"/usr/share/wayland-sessions/plasmawayland.desktop
}

That file worked well for me, but somehow now I get build errors like

By not providing "FindKF5DesignerPlugin.cmake" in CMAKE_MODULE_PATH this
  project has asked CMake to find a package configuration file provided by
  "KF5DesignerPlugin", but CMake did not find one.

But maybe it still works for you?

Thanks. I installed the patched version, but it did not fix the problem that if I unplug my external monitor, and then plug it back in, Plasma does not detect the monitor. So, it's kind of a disappointment.

Offline

#2013 2016-05-26 13:35:43

mabl
Member
Registered: 2012-11-20
Posts: 20

Re: KF 5 & Plasma

Tromzy wrote:

Thanks. I installed the patched version, but it did not fix the problem that if I unplug my external monitor, and then plug it back in, Plasma does not detect the monitor. So, it's kind of a disappointment.

If kscreen does not detect that change properly, the fix will indeed not help. It helps that plasma does not mess up once the screen change happens. Does it detect the monitor change once you just run "xrandr"? If so, this bug should probably be reported to the kscreen developers. It might also be a driver issue where the change is simply not detected.

Offline

#2014 2016-05-26 16:01:21

Loose_Control
Member
From: Germany
Registered: 2011-01-11
Posts: 136

Re: KF 5 & Plasma

mabl wrote:
Tromzy wrote:

Thanks. I installed the patched version, but it did not fix the problem that if I unplug my external monitor, and then plug it back in, Plasma does not detect the monitor. So, it's kind of a disappointment.

If kscreen does not detect that change properly, the fix will indeed not help. It helps that plasma does not mess up once the screen change happens. Does it detect the monitor change once you just run "xrandr"? If so, this bug should probably be reported to the kscreen developers. It might also be a driver issue where the change is simply not detected.

There is a bug report for that issue https://bugs.kde.org/show_bug.cgi?id=346535

Last edited by Loose_Control (2016-05-26 16:01:32)

Offline

#2015 2016-05-27 12:50:08

Tromzy
Member
Registered: 2015-02-15
Posts: 162

Re: KF 5 & Plasma

mabl wrote:
Tromzy wrote:

Thanks. I installed the patched version, but it did not fix the problem that if I unplug my external monitor, and then plug it back in, Plasma does not detect the monitor. So, it's kind of a disappointment.

If kscreen does not detect that change properly, the fix will indeed not help. It helps that plasma does not mess up once the screen change happens. Does it detect the monitor change once you just run "xrandr"? If so, this bug should probably be reported to the kscreen developers. It might also be a driver issue where the change is simply not detected.

Also, the patch did not make anything better. Now at every session start, my 2nd monitor wallpaper is on the 1st monitor, and 2nd monitor is all black. I have to kill and restart plasmashell to make everything back to normal. So, no improvement since the patch, it's probably even worse.

Offline

#2016 2016-05-27 13:52:46

diesel1
Arch Linux f@h Team Member
From: Leeds, UK.
Registered: 2007-07-19
Posts: 263

Re: KF 5 & Plasma

Hi all,

I cannot start KDE/Plasma via a display manager and cannot use any KDE/Plasma applications. When I start a  KDE/Plasma application in a terminal I get the following error;

dolphin: error while loading shared libraries: libQt5PrintSupport.so.5: cannot open shared object file: No such file or directory

I have located a file, libQt5PrintSupport.so, in /usr/lib.

Are there any steps I can take to remedy the error and run my KDE/Plasma applications again?

Thanks in advance,

Diesel1.


Registered GNU/Linux user #140607.

Offline

#2017 2016-05-27 14:21:11

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 701

Re: KF 5 & Plasma

Sure your qt5-base is at the latest version? libQt5PrintSupport.so.5 is a symlink to libQt5PrintSupport.so.5.6.0.

What does

ldd /usr/bin/dolphin

say?

Offline

#2018 2016-05-27 15:54:45

diesel1
Arch Linux f@h Team Member
From: Leeds, UK.
Registered: 2007-07-19
Posts: 263

Re: KF 5 & Plasma

Hi Xabre,

 ldd /usr/bin/dolphin

says nothing at all.

I did a quick

 sudo pacman -S qt5-base

and my KDE/Plasma started working again.

Thanks for the pointer.  I have no idea why my qt5 libraries would have changed though.

Diesel1.

Last edited by diesel1 (2016-05-27 15:59:14)


Registered GNU/Linux user #140607.

Offline

#2019 2016-05-27 15:58:33

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 701

Re: KF 5 & Plasma

That's very strange, you should get a list of shared objects that given executable uses.
Something like this:

% ldd /usr/bin/dolphin                 
        linux-vdso.so.1 (0x00007fffafbf6000)
        libkdeinit5_dolphin.so => /usr/lib/libkdeinit5_dolphin.so (0x00007facabf6b000)
        libc.so.6 => /usr/lib/libc.so.6 (0x00007facabbca000)
        libdolphinprivate.so.5 => /usr/lib/libdolphinprivate.so.5 (0x00007facab883000)
        libKF5Parts.so.5 => /usr/lib/libKF5Parts.so.5 (0x00007facab617000)
        libKF5KCMUtils.so.5 => /usr/lib/libKF5KCMUtils.so.5 (0x00007facab3bf000)
        libKF5Notifications.so.5 => /usr/lib/libKF5Notifications.so.5 (0x00007facab16b000)
        libKF5Crash.so.5 => /usr/lib/libKF5Crash.so.5 (0x00007facaaf63000)
        libKF5KIOFileWidgets.so.5 => /usr/lib/libKF5KIOFileWidgets.so.5 (0x00007facaac85000)
        libKF5Bookmarks.so.5 => /usr/lib/libKF5Bookmarks.so.5 (0x00007facaaa33000)
        libKF5NewStuff.so.5 => /usr/lib/libKF5NewStuff.so.5 (0x00007facaa76d000)
        libKF5KIOWidgets.so.5 => /usr/lib/libKF5KIOWidgets.so.5 (0x00007facaa42a000)
        libKF5JobWidgets.so.5 => /usr/lib/libKF5JobWidgets.so.5 (0x00007facaa1fc000)
        libKF5BalooWidgets.so.5 => /usr/lib/libKF5BalooWidgets.so.5 (0x00007faca9fbc000)
        libKF5KIOCore.so.5 => /usr/lib/libKF5KIOCore.so.5 (0x00007faca9c1d000)
        libKF5Baloo.so.5 => /usr/lib/libKF5Baloo.so.5 (0x00007faca99e6000)
        libKF5Solid.so.5 => /usr/lib/libKF5Solid.so.5 (0x00007faca96f7000)
        libKF5XmlGui.so.5 => /usr/lib/libKF5XmlGui.so.5 (0x00007faca93d7000)
        libKF5IconThemes.so.5 => /usr/lib/libKF5IconThemes.so.5 (0x00007faca9198000)
        libKF5Completion.so.5 => /usr/lib/libKF5Completion.so.5 (0x00007faca8f57000)
        libKF5ConfigWidgets.so.5 => /usr/lib/libKF5ConfigWidgets.so.5 (0x00007faca8cfd000)
        libKF5WidgetsAddons.so.5 => /usr/lib/libKF5WidgetsAddons.so.5 (0x00007faca899a000)
        libKF5ConfigGui.so.5 => /usr/lib/libKF5ConfigGui.so.5 (0x00007faca8777000)
        libKF5Service.so.5 => /usr/lib/libKF5Service.so.5 (0x00007faca84bd000)
        libKF5DBusAddons.so.5 => /usr/lib/libKF5DBusAddons.so.5 (0x00007faca82a9000)
        libKF5I18n.so.5 => /usr/lib/libKF5I18n.so.5 (0x00007faca8058000)
        libQt5Xml.so.5 => /usr/lib/libQt5Xml.so.5 (0x00007faca7e1d000)
        libKF5ItemViews.so.5 => /usr/lib/libKF5ItemViews.so.5 (0x00007faca7be0000)
        libKF5CoreAddons.so.5 => /usr/lib/libKF5CoreAddons.so.5 (0x00007faca7947000)
        libKF5ConfigCore.so.5 => /usr/lib/libKF5ConfigCore.so.5 (0x00007faca76de000)
        libphonon4qt5.so.4 => /usr/lib/libphonon4qt5.so.4 (0x00007faca7454000)
        libQt5Widgets.so.5 => /usr/lib/libQt5Widgets.so.5 (0x00007faca6bd7000)
        libQt5Gui.so.5 => /usr/lib/libQt5Gui.so.5 (0x00007faca6452000)
        libQt5DBus.so.5 => /usr/lib/libQt5DBus.so.5 (0x00007faca61c8000)
        libQt5Core.so.5 => /usr/lib/libQt5Core.so.5 (0x00007faca5af9000)
        libstdc++.so.6 => /usr/lib/libstdc++.so.6 (0x00007faca5772000)
        /lib64/ld-linux-x86-64.so.2 (0x00007facac24d000)
        libdolphinvcs.so.5 => /usr/lib/libdolphinvcs.so.5 (0x00007faca556f000)
        libKF5TextWidgets.so.5 => /usr/lib/libKF5TextWidgets.so.5 (0x00007faca5327000)
        libKF5WindowSystem.so.5 => /usr/lib/libKF5WindowSystem.so.5 (0x00007faca50d5000)
        libKF5Codecs.so.5 => /usr/lib/libKF5Codecs.so.5 (0x00007faca4e93000)
        libKF5FileMetaData.so.3 => /usr/lib/libKF5FileMetaData.so.3 (0x00007faca4c71000)
        libKF5QuickAddons.so.5 => /usr/lib/libKF5QuickAddons.so.5 (0x00007faca4a61000)
        libQt5Quick.so.5 => /usr/lib/libQt5Quick.so.5 (0x00007faca4479000)
        libQt5Qml.so.5 => /usr/lib/libQt5Qml.so.5 (0x00007faca3e88000)
        libKF5Auth.so.5 => /usr/lib/libKF5Auth.so.5 (0x00007faca3c6e000)
        libX11.so.6 => /usr/lib/libX11.so.6 (0x00007faca392c000)
        libQt5X11Extras.so.5 => /usr/lib/libQt5X11Extras.so.5 (0x00007faca3728000)
        libXtst.so.6 => /usr/lib/libXtst.so.6 (0x00007faca3522000)
        libdbusmenu-qt5.so.2 => /usr/lib/libdbusmenu-qt5.so.2 (0x00007faca32ea000)
        libQt5Network.so.5 => /usr/lib/libQt5Network.so.5 (0x00007faca2f7c000)
        libKF5Archive.so.5 => /usr/lib/libKF5Archive.so.5 (0x00007faca2d44000)
        libKF5Attica.so.5 => /usr/lib/libKF5Attica.so.5 (0x00007faca2a94000)
        libattr.so.1 => /usr/lib/libattr.so.1 (0x00007faca288f000)
        libm.so.6 => /usr/lib/libm.so.6 (0x00007faca258b000)
        libacl.so.1 => /usr/lib/libacl.so.1 (0x00007faca2382000)
        libKF5BalooEngine.so.5 => /usr/lib/libKF5BalooEngine.so.5 (0x00007faca2136000)
        libudev.so.1 => /usr/lib/libudev.so.1 (0x00007facac3ee000)
        libQt5PrintSupport.so.5 => /usr/lib/libQt5PrintSupport.so.5 (0x00007faca1ec5000)
        libKF5GlobalAccel.so.5 => /usr/lib/libKF5GlobalAccel.so.5 (0x00007faca1ca4000)
        libQt5Svg.so.5 => /usr/lib/libQt5Svg.so.5 (0x00007faca1a50000)
        libKF5GuiAddons.so.5 => /usr/lib/libKF5GuiAddons.so.5 (0x00007faca1834000)
        libfam.so.0 => /usr/lib/libfam.so.0 (0x00007faca162d000)
        libpthread.so.0 => /usr/lib/libpthread.so.0 (0x00007faca1410000)
        libgcc_s.so.1 => /usr/lib/libgcc_s.so.1 (0x00007faca11fa000)
        libpulse.so.0 => /usr/lib/libpulse.so.0 (0x00007faca0fa9000)
        libpulse-mainloop-glib.so.0 => /usr/lib/libpulse-mainloop-glib.so.0 (0x00007faca0da4000)
        libgobject-2.0.so.0 => /usr/lib/libgobject-2.0.so.0 (0x00007faca0b52000)
        libglib-2.0.so.0 => /usr/lib/libglib-2.0.so.0 (0x00007faca0843000)
        libpng16.so.16 => /usr/lib/libpng16.so.16 (0x00007faca060e000)
        libharfbuzz.so.0 => /usr/lib/libharfbuzz.so.0 (0x00007faca0392000)
        libz.so.1 => /usr/lib/libz.so.1 (0x00007faca017c000)
        libGL.so.1 => /usr/lib/libGL.so.1 (0x00007fac9ff0b000)
        libdbus-1.so.3 => /usr/lib/libdbus-1.so.3 (0x00007fac9fcba000)
        libicui18n.so.57 => /usr/lib/libicui18n.so.57 (0x00007fac9f840000)
        libicuuc.so.57 => /usr/lib/libicuuc.so.57 (0x00007fac9f498000)
        libpcre16.so.0 => /usr/lib/libpcre16.so.0 (0x00007fac9f232000)
        libdl.so.2 => /usr/lib/libdl.so.2 (0x00007fac9f02e000)
        librt.so.1 => /usr/lib/librt.so.1 (0x00007fac9ee26000)
        libsystemd.so.0 => /usr/lib/libsystemd.so.0 (0x00007facac361000)
        libKF5SonnetUi.so.5 => /usr/lib/libKF5SonnetUi.so.5 (0x00007fac9ebfb000)
        libKF5SonnetCore.so.5 => /usr/lib/libKF5SonnetCore.so.5 (0x00007fac9e9cc000)
        libxcb.so.1 => /usr/lib/libxcb.so.1 (0x00007fac9e7a9000)
        libxcb-keysyms.so.1 => /usr/lib/libxcb-keysyms.so.1 (0x00007fac9e5a6000)
        libKF5Declarative.so.5 => /usr/lib/libKF5Declarative.so.5 (0x00007fac9e394000)
        libKF5Package.so.5 => /usr/lib/libKF5Package.so.5 (0x00007fac9e165000)
        libXext.so.6 => /usr/lib/libXext.so.6 (0x00007fac9df53000)
        libXi.so.6 => /usr/lib/libXi.so.6 (0x00007fac9dd43000)
        libssl.so.1.0.0 => /usr/lib/libssl.so.1.0.0 (0x00007fac9dad2000)
        libcrypto.so.1.0.0 => /usr/lib/libcrypto.so.1.0.0 (0x00007fac9d65b000)
        libbz2.so.1.0 => /usr/lib/libbz2.so.1.0 (0x00007fac9d44b000)
        liblzma.so.5 => /usr/lib/liblzma.so.5 (0x00007fac9d225000)
        liblmdb.so => /usr/lib/liblmdb.so (0x00007fac9d010000)
        libcap.so.2 => /usr/lib/libcap.so.2 (0x00007fac9ce0c000)
        libresolv.so.2 => /usr/lib/libresolv.so.2 (0x00007fac9cbf5000)
        libpulsecommon-8.0.so => /usr/lib/pulseaudio/libpulsecommon-8.0.so (0x00007fac9c974000)
        libjson-c.so.2 => /usr/lib/libjson-c.so.2 (0x00007fac9c769000)
        libffi.so.6 => /usr/lib/libffi.so.6 (0x00007fac9c560000)
        libpcre.so.1 => /usr/lib/libpcre.so.1 (0x00007fac9c2f0000)
        libfreetype.so.6 => /usr/lib/libfreetype.so.6 (0x00007fac9c025000)
        libgraphite2.so.3 => /usr/lib/libgraphite2.so.3 (0x00007fac9bdf9000)
        libexpat.so.1 => /usr/lib/libexpat.so.1 (0x00007fac9bbcd000)
        libxcb-dri3.so.0 => /usr/lib/libxcb-dri3.so.0 (0x00007fac9b9ca000)
        libxcb-present.so.0 => /usr/lib/libxcb-present.so.0 (0x00007fac9b7c7000)
        libxcb-randr.so.0 => /usr/lib/libxcb-randr.so.0 (0x00007fac9b5b9000)
        libxcb-xfixes.so.0 => /usr/lib/libxcb-xfixes.so.0 (0x00007fac9b3b1000)
        libxcb-render.so.0 => /usr/lib/libxcb-render.so.0 (0x00007fac9b1a7000)
        libxcb-shape.so.0 => /usr/lib/libxcb-shape.so.0 (0x00007fac9afa3000)
        libxcb-sync.so.1 => /usr/lib/libxcb-sync.so.1 (0x00007fac9ad9c000)
        libxshmfence.so.1 => /usr/lib/libxshmfence.so.1 (0x00007fac9ab99000)
        libglapi.so.0 => /usr/lib/libglapi.so.0 (0x00007fac9a96b000)
        libXdamage.so.1 => /usr/lib/libXdamage.so.1 (0x00007fac9a768000)
        libXfixes.so.3 => /usr/lib/libXfixes.so.3 (0x00007fac9a562000)
        libX11-xcb.so.1 => /usr/lib/libX11-xcb.so.1 (0x00007fac9a360000)
        libxcb-glx.so.0 => /usr/lib/libxcb-glx.so.0 (0x00007fac9a146000)
        libxcb-dri2.so.0 => /usr/lib/libxcb-dri2.so.0 (0x00007fac99f41000)
        libXxf86vm.so.1 => /usr/lib/libXxf86vm.so.1 (0x00007fac99d3b000)
        libdrm.so.2 => /usr/lib/libdrm.so.2 (0x00007fac99b2c000)
        libicudata.so.57 => /usr/lib/libicudata.so.57 (0x00007fac980b0000)
        liblz4.so.1 => /usr/lib/liblz4.so.1 (0x00007fac97e9e000)
        libgcrypt.so.20 => /usr/lib/libgcrypt.so.20 (0x00007fac97b90000)
        libgpg-error.so.0 => /usr/lib/libgpg-error.so.0 (0x00007fac9797c000)
        libXau.so.6 => /usr/lib/libXau.so.6 (0x00007fac97778000)
        libXdmcp.so.6 => /usr/lib/libXdmcp.so.6 (0x00007fac97572000)
        libsndfile.so.1 => /usr/lib/libsndfile.so.1 (0x00007fac972fb000)
        libasyncns.so.0 => /usr/lib/libasyncns.so.0 (0x00007fac970f5000)
        libFLAC.so.8 => /usr/lib/libFLAC.so.8 (0x00007fac96e7f000)
        libogg.so.0 => /usr/lib/libogg.so.0 (0x00007fac96c78000)
        libvorbis.so.0 => /usr/lib/libvorbis.so.0 (0x00007fac96a4b000)
        libvorbisenc.so.2 => /usr/lib/libvorbisenc.so.2 (0x00007fac96798000)
        libnsl.so.1 => /usr/lib/libnsl.so.1 (0x00007fac96580000)

If it doesn't, something is really badly screwed up on your system.

Offline

#2020 2016-05-27 16:00:22

diesel1
Arch Linux f@h Team Member
From: Leeds, UK.
Registered: 2007-07-19
Posts: 263

Re: KF 5 & Plasma

I now get a similar result to yours.  I must have been editing my previous post while you just replied!

Diesel1.


Registered GNU/Linux user #140607.

Offline

#2021 2016-05-27 16:01:53

Xabre
Member
From: Serbia
Registered: 2009-03-19
Posts: 701

Re: KF 5 & Plasma

Well, glad it's solved. smile

Offline

#2022 2016-05-30 14:44:33

eric
Member
From: under heaven
Registered: 2004-02-11
Posts: 116

Re: KF 5 & Plasma

Is there an unofficial user repository that has KDE packages with debug information?

The reason I ask this is because I have a bug that crashes kaddressbook after creating/importing/synchronizing a contact that has a birthday. After this crash, kaddressbook will crash every next time it is executed.

Since the end of last year I (and some others on bugs.kde.org) have been waiting for a newer version that will have this issue solved, but so far no change.

The developer can not confirm the bug, so he asks me to use debug packages.
So, before I start building these packages myself, I hope some one has a repository where I can download these packages.

Last edited by eric (2016-05-30 14:48:05)

Offline

#2023 2016-06-01 11:45:14

Tromzy
Member
Registered: 2015-02-15
Posts: 162

Re: KF 5 & Plasma

mabl wrote:

You are having issues with multiple monitors? You fear to undock your laptop because you just now Plasma will mess up spectacularly? You don't even think of going to standby in the dock and then undock? At work you let others connect their laptop to the projector, because you know they will only make fun of you? The time of constants horrors is over! I present to you:

https://git.reviewboard.kde.org/r/125451/

This little gem applies neatly to plasma-workspace 5.6.4. Just apply and rebuild your plasma-workspace. Your salvation is near!

I must add that the patch added a new bug in Plasmashell on my machine : when I put a window in fullscreen mode, the bottom of the window gets cropped and goes behind the Plasma panel.

Reverting to the regular plasma-workspace package fixed it.

Offline

#2024 2016-06-01 16:51:35

koyote
Member
From: spain
Registered: 2012-10-10
Posts: 45

Re: KF 5 & Plasma

Anybody has a random freezes? I don't see anything in logs when this happens. Yakuake and krunner still works, sometimes killing plasmashell and launch again make it works, others no. This happens more since qt5-base 5.6.0-7 update.

Sorry for my english.

Last edited by koyote (2016-06-01 16:52:35)


Desktop: ASUS P5Q · Intel Core2Duo E7400@2.8 Ghz · nVidia GeForce GT 440 · 8 GB DDR2/667 · WD RE4 500 GB
Laptop: Asus F554L - Intel Core i3 4005U@1.7 Ghz · 8 GB DDR3/1600 · Intel HD Graphics 4400 · Samsung EVO 850 · HL-DT-ST GUE1N
Barebone: Slimbook ONE - Intel Core i5-6200U@2.3 Ghz · 8 GB DDR3/1600 · Intel HD Graphics 520 · WD  120 Gb (SSD) + WD 1 Tb (HDD)

Offline

#2025 2016-06-01 19:34:17

mabl
Member
Registered: 2012-11-20
Posts: 20

Re: KF 5 & Plasma

Tromzy wrote:
mabl wrote:

You are having issues with multiple monitors? You fear to undock your laptop because you just now Plasma will mess up spectacularly? You don't even think of going to standby in the dock and then undock? At work you let others connect their laptop to the projector, because you know they will only make fun of you? The time of constants horrors is over! I present to you:

https://git.reviewboard.kde.org/r/125451/

This little gem applies neatly to plasma-workspace 5.6.4. Just apply and rebuild your plasma-workspace. Your salvation is near!

I must add that the patch added a new bug in Plasmashell on my machine : when I put a window in fullscreen mode, the bottom of the window gets cropped and goes behind the Plasma panel.

Reverting to the regular plasma-workspace package fixed it.

Given the developer's interest in making this patch and multi monitor work, I think you should report this. I cannot reproduce it here.

Offline

Board footer

Powered by FluxBB