You are not logged in.

#1 2016-09-19 17:03:12

Registered: 2013-03-09
Posts: 7

[SOLVED] Printer Brother dcp-7055 not detected anymore by CUPS


I got an issue with multi-function printer/scanner Brother DCP-7055.
Scanner  is working OK but CUPS is not detecting anymore the printer, plugged with USB.
Package from AUR installed correctly.
All was working fine until the last update, made two days ago.
I checked on Brother website if there were a new version of the driver, but no, so the package is up-to-date.

There's a custom rule for the scanner :

cat /etc/udev/rules.d/54-sane.rules 

# Brother scanners rules
ATTRS{idVendor}=="04f9", MODE="0666", GROUP="scanner", ENV{libsane_matched}="yes"

lsub is detecting the printer :


Bus 001 Device 002: ID 04f9:0248 Brother Industries, Ltd DCP-7055 scanner/printer

journactl show me info, it's using usblp as usual :


kernel: usblp 1-1:1.0: usblp3: USB Bidirectional printer dev 2 if 0 alt 0 proto 2 vid 0x04F9 pid 0x0248
kernel: usbcore: registered new interface driver usblp

cups usb backend cli, is detecting the printer :


DEBUG: Loading USB quirks from "/usr/share/cups/usb".
DEBUG: Loaded 79 quirks.
DEBUG: list_devices
DEBUG: libusb_get_device_list=9
DEBUG2: Printer found with device ID: MFG:Brother;CMD:PJL,HBP;MDL:DCP-7055;CLS:PRINTER;CID:Brother Laser Type1; Device URI: usb://Brother/DCP-7055?serial=E69742L2N825401
direct usb://Brother/DCP-7055?serial=E69742L2N825401 "Brother DCP-7055" "Brother DCP-7055" "MFG:Brother;CMD:PJL,HBP;MDL:DCP-7055;CLS:PRINTER;CID:Brother Laser Type1;" ""

but :

lpinfo -v

network beh
file cups-pdf:/
network https
network ipp
network lpd
network ipps
network http
network socket
network smb

I don't understand why


is listing the printer, but

lpinfo -v

is not listing it..
An idea perhaps ?
If anyone have an idea, it could be great smile

Thank you

Last edited by gyan000 (2016-09-21 18:05:01)



#2 2016-09-20 11:02:31

From: Belgium
Registered: 2008-06-22
Posts: 1,490

Re: [SOLVED] Printer Brother dcp-7055 not detected anymore by CUPS

Try to:

chmod u=rwx,og= /usr/lib/cups/backend/usb

This will force cups to access the printer as root (and not as lp). I have experienced problems with some (but not all) printers not detected without this.

Last edited by olive (2016-09-20 11:03:25)


#3 2016-09-21 18:03:52

Registered: 2013-03-09
Posts: 7

Re: [SOLVED] Printer Brother dcp-7055 not detected anymore by CUPS

Yes, it worked this way !
Thanks a lot for the help.



Board footer

Powered by FluxBB