You are not logged in.

#1 2017-01-31 10:40:28

Pyntux
Member
From: Serbia
Registered: 2008-12-21
Posts: 310

[SOLVED]KDE, speech-dispatcher autostart

I have problem with speech-dispatcher autostart. Sound is crcked and everything is good after kill speech-dispatcher.
What starts speech-dispatcher? This starts to be problem after update qt-5.8.

Screenshot_20170131_113835.png

Last edited by Pyntux (2017-01-31 21:18:12)


I do not speak English, but I understand...

Offline

#2 2017-01-31 20:31:36

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,557

Re: [SOLVED]KDE, speech-dispatcher autostart

That would be knotifications, which has text-to-speech support now via qt5-speech. I have made the speech-dispatcher dependency optional in 5.8.0-2, so you can just remove it.

Offline

#3 2017-01-31 21:17:57

Pyntux
Member
From: Serbia
Registered: 2008-12-21
Posts: 310

Re: [SOLVED]KDE, speech-dispatcher autostart

Thank you very much, that solved my problem... smile


I do not speak English, but I understand...

Offline

#4 2017-02-02 18:27:56

an4oud
Member
Registered: 2016-12-17
Posts: 10

Re: [SOLVED]KDE, speech-dispatcher autostart

The package speech-dispatcher is also required by kdeaccessibility-jovie and kdeaccessibility-kaccessible.

[root@ctgx ~]# pacman -Qi speech-dispatcher
Name            : speech-dispatcher
Version         : 0.8.6-1
Description     : High-level device independent layer for speech synthesis interface
Architecture    : x86_64
URL             : [url]http://www.freebsoft.org/speechd[/url]
Licenses        : GPL2  FDL
Groups          : None
Provides        : None
Depends On      : libltdl  python-xdg  dotconf  libpulse  libao
Optional Deps   : festival: Speech output using Festival
                  espeak: Speech output using ESpeak
                  pulseaudio: PulseAudio support [installed]
Required By     : kdeaccessibility-jovie  kdeaccessibility-kaccessible
Optional For    : qt5-speech
Conflicts With  : None
Replaces        : None
Installed Size  : 1414.00 KiB
Packager        : Sven-Hendrik Haase <sh@lutzhaase.com>
Build Date      : Tue 10 Jan 2017 01:55:41 AM MSK
Install Date    : Sun 29 Jan 2017 02:26:44 PM MSK
Install Reason  : Installed as a dependency for another package
Install Script  : No
Validated By    : Signature

[root@ctgx ~]# ps aux | grep 'pulseaudio\|speech'
tm4ig      757 13.3  0.2 1681436 17800 ?       S<sl 21:14   1:15 /usr/bin/pulseaudio --daemonize=no
tm4ig      835  0.0  0.0 413996  4868 ?        Sl   21:14   0:00 /usr/lib/speech-dispatcher-modules/sd_dummy /etc/speech-dispatcher/modules/dummy.conf
tm4ig      839  0.0  0.0 414008  4876 ?        Sl   21:14   0:00 /usr/lib/speech-dispatcher-modules/sd_generic /etc/speech-dispatcher/modules/generic.conf
tm4ig      842  0.0  0.0 168776  2156 ?        Ssl  21:14   0:00 /usr/bin/speech-dispatcher --spawn --communication-method unix_socket --socket-path /run/user/1000/speech-dispatcher/speechd.sock
root      1528  0.0  0.0  11976  2236 pts/1    R+   21:23   0:00 grep pulseaudio\|speech

Because speech-dispatcher is running,  pulseaudio loads my CPU by 10-15%

Howto disable speech-dispatcher (autostart) or remove him?

Last edited by an4oud (2017-02-02 18:30:21)

Offline

#5 2017-02-03 12:25:13

traviscthall
Member
Registered: 2014-04-14
Posts: 9

Re: [SOLVED]KDE, speech-dispatcher autostart

I too have been having crackling problems for a short while, I've been driving myself insane trying to roll back packages and figure this out!

Removed and all seems well now.

Offline

#6 2017-02-03 13:32:33

arojas
Developer
From: Spain
Registered: 2011-10-09
Posts: 1,557

Re: [SOLVED]KDE, speech-dispatcher autostart

an4oud wrote:

Howto disable speech-dispatcher (autostart) or remove him?

$ mkdir -p ~/.config/speech-dispatcher && echo "DisableAutoSpawn" >> ~/.config/speech-dispatcher/speechd.conf

Offline

#7 2017-02-03 17:14:16

an4oud
Member
Registered: 2016-12-17
Posts: 10

Re: [SOLVED]KDE, speech-dispatcher autostart

arojas wrote:
an4oud wrote:

Howto disable speech-dispatcher (autostart) or remove him?

$ mkdir -p ~/.config/speech-dispatcher && echo "DisableAutoSpawn" >> ~/.config/speech-dispatcher/speechd.conf

Thank you

Offline

#8 2017-02-07 10:44:11

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 839

Re: [SOLVED]KDE, speech-dispatcher autostart

arojas wrote:
an4oud wrote:

Howto disable speech-dispatcher (autostart) or remove him?

$ mkdir -p ~/.config/speech-dispatcher && echo "DisableAutoSpawn" >> ~/.config/speech-dispatcher/speechd.conf

I guess that if there is a need to disable it for all users rather than on a per user basis as in the suggested fix that the last line in one or other of the two files at

/usr/share/speech-dispatcher/conf/speechd.conf
/etc/speech-dispatcher/speechd.conf

could be commented out. I guess that it would be the one in /etc/ that would do it? I came to this thread from a problem related to pulseaudio using cpu in plasma referenced at

https://bbs.archlinux.org/viewtopic.php?id=222857

Edit: The solution suggested by Arojas does fix my issue with pulseaudio cpu usage.

Last edited by mcloaked (2017-02-07 21:04:06)


Mike C

Offline

#9 2017-02-07 16:43:40

mcloaked
Member
From: Yorkshire, UK
Registered: 2012-02-02
Posts: 839

Re: [SOLVED]KDE, speech-dispatcher autostart

The dependency on speech-dispatcher for google-chrome in AUR has been removed a few days ago, so in my case I can also now remove the speech-dispatcher package after re-installing google-chrome using the changed PKGBUILD.

Last edited by mcloaked (2017-02-07 21:05:08)


Mike C

Offline

Board footer

Powered by FluxBB