You are not logged in.

#1 2017-10-10 18:45:00

lolop
Member
Registered: 2015-02-19
Posts: 26

deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

Hello,

I am faced with a recurring problem on several wifi cards of which I do not know the cause. My current map uses the rtl8723be module on a thinkpad e330.

When I establish the connection with NetworkManager I find myself systematic with this message deauth:

[  101.225517] wlan0: deauthenticating from mac:adress by local choice (Reason: 3=DEAUTH_LEAVING)

I specify that this product when connecting to my wifi network and every connection.


I use a tplink modem router.

  • This poses a problem in establishing the vpn connection.
    I have set /etc/conf.d/wireless-regdom on my region FR.

  • I also fixed this file as follows:

    [vic lolop] # file /etc/systemd/network/99-default.link
    /etc/systemd/network/99-default.link: symbolic link to /dev/null
  • I also tried to disable power management on the bios as explained for this thinkpad model
    https://wiki.archlinux.org/index.php/Le … ion_issues

  • I also try to sort networkmanger of the daemon TLP as I was able to read on the forum

    # cat /usr/lib/systemd/system/tlp.service
    Wants=bluetooth.service

This is what I read on the forum. But it has no effect.
Do you have any idea about this very painful problem?

Thank you!

Last edited by lolop (2017-10-10 19:38:08)

Offline

#2 2017-10-10 19:07:27

seth
Member
Registered: 2012-09-03
Posts: 4,269

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

please post the output of

systemctl list-units| grep -iE '(net|wicd|dhcp|conn)'

and provide your complete journal ("sudo journalctl -b")

The message itself is pretty meaningless by its own.

Offline

#3 2017-10-10 19:31:41

lolop
Member
Registered: 2015-02-19
Posts: 26

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

Thank you for taking the time.

The result of the commands:

systemctl list-units| grep -iE '(net|wicd|dhcp|conn)'

[lolop@vic ~]$ systemctl list-units| grep -iE '(net|wicd|dhcp|conn)'
  sys-devices-pci0000:00-0000:00:1c.1-0000:02:00.0-net-wlan0.device                           loaded active plugged   RTL8723BE PCIe Wireless Network Adapter                                     
  sys-devices-pci0000:00-0000:00:1c.3-0000:08:00.0-net-eth0.device                            loaded active plugged   RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller                   
  sys-subsystem-net-devices-eth0.device                                                       loaded active plugged   RTL8111/8168/8411 PCI Express Gigabit Ethernet Controller                   
  sys-subsystem-net-devices-wlan0.device                                                      loaded active plugged   RTL8723BE PCIe Wireless Network Adapter                                     
  sys-fs-fuse-connections.mount                                                               loaded active mounted   FUSE Control File System                                                    
  NetworkManager.service                                                                      loaded active running   Network Manager                                                             
  network.target                                                                              loaded active active    Network 

journalctl -b afet connexion:

-- Logs begin at Thu 2017-01-19 22:43:58 CET, end at Tue 2017-10-10 21:25:47 CEST. --
oct. 10 21:23:09 vic mailnag[1232]: INFO (2017-10-10 21:23:09): Checking 2 email account(s).
oct. 10 21:23:15 vic NetworkManager[1948]: <info>  [1507663395.5760] wifi-nl80211: (wlan0): using nl80211 for WiFi device control
oct. 10 21:23:15 vic NetworkManager[1948]: <info>  [1507663395.5763] device (wlan0): driver supports Access Point (AP) mode
oct. 10 21:23:15 vic NetworkManager[1948]: <info>  [1507663395.5771] manager: (wlan0): new 802.11 WiFi device (/org/freedesktop/NetworkManager/Devices/3)
oct. 10 21:23:15 vic NetworkManager[1948]: <info>  [1507663395.5780] device (wlan0): state change: unmanaged -> unavailable (reason 'managed', internal state 'external')
oct. 10 21:23:16 vic NetworkManager[1948]: <info>  [1507663396.1336] ModemManager available in the bus
oct. 10 21:23:16 vic NetworkManager[1948]: <info>  [1507663396.1341] bluez: use BlueZ version 5
oct. 10 21:23:16 vic NetworkManager[1948]: <info>  [1507663396.1641] supplicant: wpa_supplicant running
oct. 10 21:23:16 vic NetworkManager[1948]: <info>  [1507663396.1642] device (wlan0): supplicant interface state: init -> starting
oct. 10 21:23:16 vic NetworkManager[1948]: <info>  [1507663396.2068] sup-iface[0x563a3c725520,wlan0]: supports 4 scan SSIDs
oct. 10 21:23:16 vic NetworkManager[1948]: <info>  [1507663396.2078] device (wlan0): supplicant interface state: starting -> ready
oct. 10 21:23:16 vic NetworkManager[1948]: <info>  [1507663396.2079] device (wlan0): state change: unavailable -> disconnected (reason 'supplicant-available', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7309] device (wlan0): supplicant interface state: ready -> inactive
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7341] policy: auto-activating connection 'Auto ginestet-network'
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7361] device (wlan0): Activation: starting connection 'Auto ginestet-network' (d1ecb7cd-472c-49ef-8a31-568fc16ba079)
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7363] device (wlan0): state change: disconnected -> prepare (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7365] manager: NetworkManager state is now CONNECTING
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7370] device (wlan0): state change: prepare -> config (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7375] device (wlan0): Activation: (wifi) access point 'Auto ginestet-network' has security, but secrets are required.
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7375] device (wlan0): state change: config -> need-auth (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7632] device (wlan0): state change: need-auth -> prepare (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7636] device (wlan0): state change: prepare -> config (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7638] device (wlan0): Activation: (wifi) connection 'Auto ginestet-network' has security, and secrets exist.  No new secrets needed.
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7638] Config: added 'ssid' value 'ginestet-network'
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7639] Config: added 'scan_ssid' value '1'
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7639] Config: added 'key_mgmt' value 'WPA-PSK'
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.7639] Config: added 'psk' value '<hidden>'
oct. 10 21:23:17 vic wpa_supplicant[1680]: wlan0: SME: Trying to authenticate with 98:de:d0:c3:35:66 (SSID='ginestet-network' freq=2447 MHz)
oct. 10 21:23:17 vic kernel: wlan0: authenticate with 98:de:d0:c3:35:66
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8007] device (wlan0): supplicant interface state: inactive -> authenticating
oct. 10 21:23:17 vic kernel: wlan0: send auth to 98:de:d0:c3:35:66 (try 1/3)
oct. 10 21:23:17 vic wpa_supplicant[1680]: wlan0: Trying to associate with 98:de:d0:c3:35:66 (SSID='ginestet-network' freq=2447 MHz)
oct. 10 21:23:17 vic kernel: wlan0: authenticated
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8086] device (wlan0): supplicant interface state: authenticating -> associating
oct. 10 21:23:17 vic kernel: wlan0: associate with 98:de:d0:c3:35:66 (try 1/3)
oct. 10 21:23:17 vic wpa_supplicant[1680]: wlan0: Associated with 98:de:d0:c3:35:66
oct. 10 21:23:17 vic wpa_supplicant[1680]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
oct. 10 21:23:17 vic kernel: wlan0: RX AssocResp from 98:de:d0:c3:35:66 (capab=0x431 status=0 aid=2)
oct. 10 21:23:17 vic kernel: wlan0: associated
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8197] device (wlan0): supplicant interface state: associating -> associated
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8318] device (wlan0): supplicant interface state: associated -> 4-way handshake
oct. 10 21:23:17 vic wpa_supplicant[1680]: wlan0: WPA: Key negotiation completed with 98:de:d0:c3:35:66 [PTK=CCMP GTK=CCMP]
oct. 10 21:23:17 vic wpa_supplicant[1680]: wlan0: CTRL-EVENT-CONNECTED - Connection to 98:de:d0:c3:35:66 completed [id=0 id_str=]
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8509] device (wlan0): supplicant interface state: 4-way handshake -> completed
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8510] device (wlan0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'ginestet-network'.
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8511] device (wlan0): state change: config -> ip-config (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8579] device (wlan0): state change: ip-config -> ip-check (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8592] device (wlan0): state change: ip-check -> secondaries (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8596] device (wlan0): state change: secondaries -> activated (reason 'none', internal state 'managed')
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8598] manager: NetworkManager state is now CONNECTED_LOCAL
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8739] manager: NetworkManager state is now CONNECTED_SITE
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8740] policy: set 'Auto ginestet-network' (wlan0) as default for IPv4 routing and DNS
oct. 10 21:23:17 vic NetworkManager[1948]: <info>  [1507663397.8741] device (wlan0): Activation: successful, device activated.
oct. 10 21:23:17 vic nm-dispatcher[1953]: req:2 'up' [wlan0]: new request (0 scripts)
oct. 10 21:23:17 vic nm-dispatcher[1953]: req:2 'up' [wlan0]: completed: no scripts
oct. 10 21:23:20 vic NetworkManager[1948]: <info>  [1507663400.2670] manager: NetworkManager state is now CONNECTED_GLOBAL
oct. 10 21:23:20 vic nm-dispatcher[1953]: req:3 'connectivity-change': new request (0 scripts)
oct. 10 21:23:20 vic nm-dispatcher[1953]: req:3 'connectivity-change': completed: no scripts
oct. 10 21:23:20 vic NetworkManager[1948]: <info>  [1507663400.3314] manager: startup complete
oct. 10 21:23:27 vic gnome-keyring-daemon[981]: asked to register item /org/freedesktop/secrets/collection/Trousseau_5fde_5fcl_c3_a9s_5fpar_5fd_c3_a9faut/656, but it's already registered
oct. 10 21:23:27 vic gnome-keyring-daemon[981]: asked to register item /org/freedesktop/secrets/collection/Trousseau_5fde_5fcl_c3_a9s_5fpar_5fd_c3_a9faut/656, but it's already registered
oct. 10 21:23:58 vic kernel: [drm:intel_pipe_update_end [i915]] *ERROR* Atomic update failure on pipe A (start=9271 end=9272) time 359 us, min 763, max 767, scanline start 751, end 768
oct. 10 21:24:11 vic sudo[2739]:     root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/journalctl -b
oct. 10 21:24:11 vic sudo[2739]: pam_unix(sudo:session): session opened for user root by (uid=0)
oct. 10 21:24:19 vic sudo[2739]: pam_unix(sudo:session): session closed for user root
oct. 10 21:24:25 vic sudo[2743]:     root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/journalctl -b
oct. 10 21:24:25 vic sudo[2743]: pam_unix(sudo:session): session opened for user root by (uid=0)
oct. 10 21:24:25 vic sudo[2743]: pam_unix(sudo:session): session closed for user root
oct. 10 21:25:00 vic fcron[2751]: Job 'vnstat -u' started for user root (pid 2752)
oct. 10 21:25:00 vic fcron[2751]: Job 'vnstat -u' completed (mailing output)
oct. 10 21:25:00 vic fcron[2751]: Couldn't exec '/usr/bin/sendmail': Aucun fichier ou dossier de ce type
oct. 10 21:25:00 vic fcron[2751]: fcron child aborted: this does not affect the main fcron daemon, but this may prevent a job from being run or an email from being sent.
oct. 10 21:25:21 vic sudo[2757]:     root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/journalctl -b
oct. 10 21:25:21 vic sudo[2757]: pam_unix(sudo:session): session opened for user root by (uid=0)
oct. 10 21:25:25 vic sudo[2757]: pam_unix(sudo:session): session closed for user root
oct. 10 21:25:32 vic kernel: wlan0: deauthenticating from 98:de:d0:c3:35:66 by local choice (Reason: 3=DEAUTH_LEAVING)
oct. 10 21:25:32 vic wpa_supplicant[1680]: wlan0: CTRL-EVENT-DISCONNECTED bssid=98:de:d0:c3:35:66 reason=3 locally_generated=1
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to open /proc/sys/net/ipv6/conf/wlan0/drop_unicast_in_l2_multicast: No such file or directory
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to set IPv6 unicast in multicast filter
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to open /proc/sys/net/ipv6/conf/wlan0/drop_unicast_in_l2_multicast: No such file or directory
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to set IPv6 unicast in multicast filter
oct. 10 21:25:32 vic wpa_supplicant[1680]: rfkill: WLAN soft blocked
oct. 10 21:25:32 vic systemd[1]: Starting Load/Save RF Kill Switch Status...
oct. 10 21:25:32 vic NetworkManager[1948]: <info>  [1507663532.3908] manager: rfkill: WiFi hardware radio set disabled
oct. 10 21:25:32 vic NetworkManager[1948]: <info>  [1507663532.3908] device (wlan0): state change: activated -> unavailable (reason 'none', internal state 'managed')
oct. 10 21:25:32 vic NetworkManager[1948]: <info>  [1507663532.3930] manager: NetworkManager state is now CONNECTED_LOCAL
oct. 10 21:25:32 vic NetworkManager[1948]: <info>  [1507663532.3933] manager: NetworkManager state is now DISCONNECTED
oct. 10 21:25:32 vic dbus[714]: [system] Activating via systemd: service name='org.freedesktop.nm_dispatcher' unit='dbus-org.freedesktop.nm-dispatcher.service'
oct. 10 21:25:32 vic systemd[1]: Starting Network Manager Script Dispatcher Service...
oct. 10 21:25:32 vic systemd[1]: Started Load/Save RF Kill Switch Status.
oct. 10 21:25:32 vic dbus[714]: [system] Successfully activated service 'org.freedesktop.nm_dispatcher'
oct. 10 21:25:32 vic systemd[1]: Started Network Manager Script Dispatcher Service.
oct. 10 21:25:32 vic nm-dispatcher[2771]: req:1 'connectivity-change': new request (0 scripts)
oct. 10 21:25:32 vic nm-dispatcher[2771]: req:1 'connectivity-change': completed: no scripts
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to open /proc/sys/net/ipv6/conf/wlan0/drop_unicast_in_l2_multicast: No such file or directory
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to set IPv6 unicast in multicast filter
oct. 10 21:25:32 vic NetworkManager[1948]: <info>  [1507663532.4073] audit: op="radio-control" arg="wireless-enabled:0" pid=1215 uid=1000 result="success"
oct. 10 21:25:32 vic NetworkManager[1948]: <info>  [1507663532.4077] manager: rfkill: WiFi now disabled by radio killswitch
oct. 10 21:25:32 vic nm-dispatcher[2771]: req:2 'down' [wlan0]: new request (0 scripts)
oct. 10 21:25:32 vic nm-dispatcher[2771]: req:2 'down' [wlan0]: completed: no scripts
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to open /proc/sys/net/ipv6/conf/wlan0/drop_unicast_in_l2_multicast: No such file or directory
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: Failed to set IPv6 unicast in multicast filter
oct. 10 21:25:32 vic wpa_supplicant[1680]: nl80211: deinit ifname=wlan0 disabled_11b_rates=0
oct. 10 21:25:33 vic NetworkManager[1948]: <info>  [1507663533.7939] manager: rfkill: WiFi hardware radio set enabled
oct. 10 21:25:34 vic NetworkManager[1948]: <info>  [1507663534.3275] audit: op="radio-control" arg="wireless-enabled:1" pid=1215 uid=1000 result="success"
oct. 10 21:25:34 vic NetworkManager[1948]: <info>  [1507663534.3277] manager: rfkill: WiFi now enabled by radio killswitch
oct. 10 21:25:34 vic NetworkManager[1948]: <info>  [1507663534.3704] sup-iface[0x563a3c6f6520,wlan0]: supports 4 scan SSIDs
oct. 10 21:25:34 vic NetworkManager[1948]: <info>  [1507663534.3713] device (wlan0): supplicant interface state: starting -> ready
oct. 10 21:25:34 vic NetworkManager[1948]: <info>  [1507663534.3714] device (wlan0): state change: unavailable -> disconnected (reason 'supplicant-available', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3796] device (wlan0): supplicant interface state: ready -> inactive
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3840] policy: auto-activating connection 'Auto ginestet-network'
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3855] device (wlan0): Activation: starting connection 'Auto ginestet-network' (d1ecb7cd-472c-49ef-8a31-568fc16ba079)
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3867] device (wlan0): state change: disconnected -> prepare (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3871] manager: NetworkManager state is now CONNECTING
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3881] device (wlan0): state change: prepare -> config (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3886] device (wlan0): Activation: (wifi) access point 'Auto ginestet-network' has security, but secrets are required.
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.3888] device (wlan0): state change: config -> need-auth (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4077] device (wlan0): state change: need-auth -> prepare (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4081] device (wlan0): state change: prepare -> config (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4083] device (wlan0): Activation: (wifi) connection 'Auto ginestet-network' has security, and secrets exist.  No new secrets needed.
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4083] Config: added 'ssid' value 'ginestet-network'
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4083] Config: added 'scan_ssid' value '1'
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4083] Config: added 'key_mgmt' value 'WPA-PSK'
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4084] Config: added 'psk' value '<hidden>'
oct. 10 21:25:35 vic wpa_supplicant[1680]: wlan0: SME: Trying to authenticate with 98:de:d0:c3:35:66 (SSID='ginestet-network' freq=2447 MHz)
oct. 10 21:25:35 vic kernel: wlan0: authenticate with 98:de:d0:c3:35:66
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4454] device (wlan0): supplicant interface state: inactive -> authenticating
oct. 10 21:25:35 vic kernel: wlan0: send auth to 98:de:d0:c3:35:66 (try 1/3)
oct. 10 21:25:35 vic kernel: wlan0: authenticated
oct. 10 21:25:35 vic wpa_supplicant[1680]: wlan0: Trying to associate with 98:de:d0:c3:35:66 (SSID='ginestet-network' freq=2447 MHz)
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4536] device (wlan0): supplicant interface state: authenticating -> associating
oct. 10 21:25:35 vic kernel: wlan0: associate with 98:de:d0:c3:35:66 (try 1/3)
oct. 10 21:25:35 vic kernel: wlan0: RX AssocResp from 98:de:d0:c3:35:66 (capab=0x431 status=0 aid=2)
oct. 10 21:25:35 vic wpa_supplicant[1680]: wlan0: Associated with 98:de:d0:c3:35:66
oct. 10 21:25:35 vic wpa_supplicant[1680]: wlan0: CTRL-EVENT-SUBNET-STATUS-UPDATE status=0
oct. 10 21:25:35 vic kernel: wlan0: associated
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4645] device (wlan0): supplicant interface state: associating -> associated
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4754] device (wlan0): supplicant interface state: associated -> 4-way handshake
oct. 10 21:25:35 vic wpa_supplicant[1680]: wlan0: WPA: Key negotiation completed with 98:de:d0:c3:35:66 [PTK=CCMP GTK=CCMP]
oct. 10 21:25:35 vic wpa_supplicant[1680]: wlan0: CTRL-EVENT-CONNECTED - Connection to 98:de:d0:c3:35:66 completed [id=0 id_str=]
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4959] device (wlan0): supplicant interface state: 4-way handshake -> completed
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4959] device (wlan0): Activation: (wifi) Stage 2 of 5 (Device Configure) successful.  Connected to wireless network 'ginestet-network'.
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.4961] device (wlan0): state change: config -> ip-config (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.5019] device (wlan0): state change: ip-config -> ip-check (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.5049] device (wlan0): state change: ip-check -> secondaries (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.5054] device (wlan0): state change: secondaries -> activated (reason 'none', internal state 'managed')
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.5058] manager: NetworkManager state is now CONNECTED_LOCAL
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.5303] manager: NetworkManager state is now CONNECTED_GLOBAL
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.5304] policy: set 'Auto ginestet-network' (wlan0) as default for IPv4 routing and DNS
oct. 10 21:25:35 vic NetworkManager[1948]: <info>  [1507663535.5305] device (wlan0): Activation: successful, device activated.
oct. 10 21:25:35 vic nm-dispatcher[2771]: req:3 'up' [wlan0]: new request (0 scripts)
oct. 10 21:25:35 vic nm-dispatcher[2771]: req:3 'up' [wlan0]: completed: no scripts
oct. 10 21:25:36 vic nm-dispatcher[2771]: req:4 'connectivity-change': new request (0 scripts)
oct. 10 21:25:36 vic nm-dispatcher[2771]: req:4 'connectivity-change': completed: no scripts
oct. 10 21:25:40 vic sudo[2811]:     root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/journalctl -b
oct. 10 21:25:40 vic sudo[2811]: pam_unix(sudo:session): session opened for user root by (uid=0)
oct. 10 21:25:44 vic sudo[2811]: pam_unix(sudo:session): session closed for user root
oct. 10 21:25:47 vic sudo[2814]:     root : TTY=pts/0 ; PWD=/root ; USER=root ; COMMAND=/usr/bin/journalctl -b
oct. 10 21:25:47 vic sudo[2814]: pam_unix(sudo:session): session opened for user root by (uid=0)

Last edited by lolop (2017-10-10 19:32:14)

Offline

#4 2017-10-11 10:28:17

lolop
Member
Registered: 2015-02-19
Posts: 26

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

For now I solved the problem with the wicd connection manager ..

Offline

#5 2017-10-11 14:28:15

seth
Member
Registered: 2012-09-03
Posts: 4,269

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

Sorry for the delay. Fits, since there's no hint of any actual issue

Is this back?
https://bugs.archlinux.org/task/43601#comment131948

Does downgrading networkmanager change anything?

Offline

#6 2017-10-12 13:59:36

fasolens
Member
Registered: 2014-01-25
Posts: 2

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

lolop wrote:

For now I solved the problem with the wicd connection manager ..

Could you write how to resolve the problem? I have the same.
Installing Kernel 4.13 over 4.9 helped for me.

Last edited by fasolens (2017-10-12 14:11:51)

Offline

#7 2017-10-12 19:52:04

lolop
Member
Registered: 2015-02-19
Posts: 26

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

Otherwise, you would have a reference of a wifi / bluetooth card that poses no problem?
In mini pcie card

Last edited by lolop (2017-10-12 19:52:41)

Offline

#8 2017-10-12 20:49:37

seth
Member
Registered: 2012-09-03
Posts: 4,269

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

If installing/using wicd "fixes" it for you, this is less of a hardware issue and just a networkmanager bug.

Offline

#9 2017-10-13 04:38:08

lolop
Member
Registered: 2015-02-19
Posts: 26

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

Yes, but I still have the loss of throughput if I am in bluetooth and wifi ..

Offline

#10 2017-10-13 07:15:33

seth
Member
Registered: 2012-09-03
Posts: 4,269

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

The only good solution to BT/WiFi interference is to use the 5GHz band - otherwise this is a physical problem which can only to a certain degree can be mitigated by the chip/driver (temporal slotting - causing thoughput loss ...)

Other ways to *maybe* improve this is are antenna mangement or informing the driver about the problem (what requires to mention it)
Also there might be firmware bugs (in case of significant regression unrelated to the kernel, but driven by updates to the linux-firmware package)

See also this thread: https://bbs.archlinux.org/viewtopic.php?id=228477

Offline

#11 2017-10-20 18:27:19

sm-Fifteen
Member
Registered: 2017-10-20
Posts: 3

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

I'm having the same issue, it's not bluetooth. The full logs show this :

Oct 20 14:07:26 MISERICORDE systemd[1]: wpa_supplicant.service: Start operation timed out. Terminating.
Oct 20 14:07:26 MISERICORDE kernel: wlp3s0: deauthenticating from 6c:f3:7f:6b:11:34 by local choice (Reason: 3=DEAUTH_LEAVING)
Oct 20 14:07:26 MISERICORDE wpa_supplicant[12110]: wlp3s0: CTRL-EVENT-DISCONNECTED bssid=6c:f3:7f:6b:11:34 reason=3 locally_generated=1
Oct 20 14:07:26 MISERICORDE NetworkManager[12096]: <warn>  [1508522846.7113] sup-iface[0x7f1b18007820,wlp3s0]: connection disconnected (reason -3)
Oct 20 14:07:26 MISERICORDE wpa_supplicant[12110]: nl80211: deinit ifname=wlp3s0 disabled_11b_rates=0
Oct 20 14:07:26 MISERICORDE wpa_supplicant[12110]: wlp3s0: CTRL-EVENT-TERMINATING
Oct 20 14:07:26 MISERICORDE systemd[1]: wpa_supplicant.service: Failed with result 'timeout'.
Oct 20 14:07:26 MISERICORDE systemd[1]: Failed to start WPA supplicant.
Oct 20 14:07:26 MISERICORDE NetworkManager[12096]: <info>  [1508522846.7915] supplicant: wpa_supplicant stopped

It's wpa-supplicant not registering with systemd as having completed its activation process and getting killed once it times out (after 1m30s). Periodically restarting wpa-supplicant indeed reestablishes network connection, but only for another minute or so (give or take however long it takes to authenticate).

Since wpa-supplicate is listed as a dbus service unit, I'm guessing that it's a bus name mismatch issue.

Offline

#12 2017-10-20 18:43:37

seth
Member
Registered: 2012-09-03
Posts: 4,269

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

I'm having the same issue

Let's see:

systemctl list-unit-files --state=enabled

Offline

#13 2017-10-20 19:03:29

sm-Fifteen
Member
Registered: 2017-10-20
Posts: 3

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

seth wrote:

I'm having the same issue

Let's see:

systemctl list-unit-files --state=enabled
UNIT FILE                                   STATE  
autovt@.service                             enabled
bluetooth.service                           enabled
cpupower.service                            enabled
dbus-org.bluez.service                      enabled
dbus-org.freedesktop.NetworkManager.service enabled
dbus-org.freedesktop.nm-dispatcher.service  enabled
dbus-org.freedesktop.resolve1.service       enabled
display-manager.service                     enabled
gdm.service                                 enabled
getty@.service                              enabled
libvirtd.service                            enabled
lm_sensors.service                          enabled
NetworkManager-dispatcher.service           enabled
NetworkManager.service                      enabled
systemd-resolved.service                    enabled
systemd-timesyncd.service                   enabled
virtlockd.socket                            enabled
virtlogd.socket                             enabled
remote-fs.target                            enabled

It stays the same whether or not the wi-fi is still available, since wpa-supplicant never gets past the "activating" phase.

Offline

#14 2017-10-20 19:11:24

seth
Member
Registered: 2012-09-03
Posts: 4,269

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

Why is "systemd-resolved.service" enabled?

Offline

#15 2017-10-20 19:35:21

sm-Fifteen
Member
Registered: 2017-10-20
Posts: 3

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

I used to run systemd-networkd on that laptop, but that's from over 2 years ago and systemd-resolvd has been working fine under NetworkManager.

Looking into it further, it seems I had a duplicate wpa_supplicant unit in /etc/systemd masking the one in /usr/lib/systemd, and that a recent update to wpa_supplicant changed the bus name from dbus-fi.epitest.hostap.WPASupplicant.service to dbus-fi.w1.wpa_supplicant1.service, so that's why it wouldn't register for me.

OP's logs don't seem to show what happens during a disconnection, so I can only make guesses, but the logs show that wpa_supplicant seems to be working properly in his case. Considering the timeframe, it might also be due to the bus name change.

Last edited by sm-Fifteen (2017-10-20 19:35:49)

Offline

#16 Yesterday 04:30:02

lolop
Member
Registered: 2015-02-19
Posts: 26

Re: deauthenticating wlan0 (Reason: 3=DEAUTH_LEAVING)

You have targeted right!

This came from the file /etc/dbus-1/system.d/wpa_supplicant.conf that was not pointing to fi.w1.wpa_supplicant1.service but on lines with epitest.

Thanks a lot, now more bug with NetworkManager

Offline

Board footer

Powered by FluxBB