You are not logged in.

#1 2018-01-31 21:25:49

erickwill
Member
Registered: 2013-11-05
Posts: 123

Can't update to kernel 4.15-1 due to nvidia-340xx

Dear fellas,

I wonder if there is any workaround to upgrade to the latest 4.15-1 kernel using the current nvidia-340xx..

error: failed to prepare transaction (could not satisfy dependencies)
:: nvidia-340xx: installing linux (4.15-1) breaks dependency 'linux<4.15'

While I was flagging nvidia-340xx as outdated, I learned that the package is "Orphan" regarding maintainers.

Any clue on this matter is appreciated.

Thanks

Offline

#2 2018-01-31 21:32:07

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,628
Website

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

Mod note: moved to [testing] Repo Forum.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#3 2018-01-31 21:33:36

progandy
Member
Registered: 2012-05-17
Posts: 4,233

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

See this thread on the mailing list: https://lists.archlinux.org/pipermail/a … 29127.html


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#4 2018-01-31 22:03:31

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

progandy wrote:

See this thread on the mailing list: https://lists.archlinux.org/pipermail/a … 29127.html


Thanks for sharing this info..
Do you have any clue if Giancarlo Razzolini adopted the nvidia-340xx package or not?

Offline

#5 2018-01-31 22:34:11

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

Does Nouveau could be an option to Nvidia-340xx?

Offline

#6 2018-01-31 22:34:47

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,239
Website

Re: Can't update to kernel 4.15-1 due to nvidia-340xx


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#7 2018-01-31 22:37:26

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

WorMzy wrote:

Sorry, I missed the point. To check myself regarding Nouveau on https://www.archlinux.org/packages/extr … dia-340xx/?

Offline

#8 2018-01-31 22:40:26

WorMzy
Forum Moderator
From: Scotland
Registered: 2010-06-16
Posts: 10,239
Website

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

That was a reply to your query regarding the 340xx package ownership. Your nouveau question makes no sense. You either use nouveau, or you use nvidia's driver -- you can't use both.


Sakura:-
Mobo: MSI X299 TOMAHAWK ARCTIC // Processor: Intel Core i7-7820X 3.6GHz // GFX: AMD Radeon RX 5700 XT // RAM: 32GB (4x 8GB) Corsair DDR4 (@ 3000MHz) // Storage: 1x 3TB HDD, 6x 1TB SSD, 2x 120GB SSD, 1x 275GB M2 SSD

Making lemonade from lemons since 2015.

Offline

#9 2018-01-31 22:46:49

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

WorMzy wrote:

That was a reply to your query regarding the 340xx package ownership. Your nouveau question makes no sense. You either use nouveau, or you use nvidia's driver -- you can't use both.

I didn't say to use both together, I don't know where did you read this. Anyway, let me make myself clear this time..  I was asking people for sharing their experiences on the subject of dropping nvidia and got started to use nouveau.

Offline

#10 2018-01-31 23:10:08

Xyne
Moderator/TU
Registered: 2008-08-03
Posts: 6,628
Website

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

If you are asking if nouveau supports the same cards as nvidia-340xx and can be used as an alternative, then have a look here and here. Click the chipset name in the column header to get a list of cards with that chipset.


My Arch Linux StuffForum EtiquetteCommunity Ethos - Arch is not for everyone

Offline

#11 2018-01-31 23:10:09

jasonwryan
Anarchist
From: .nz
Registered: 2009-05-09
Posts: 29,260
Website

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

erickwill wrote:

I was asking people for sharing their experiences on the subject of dropping nvidia and got started to use nouveau.

Install it yourself and see. No-one else can hold your hand for this.


Arch + dwm   •   Mercurial repos  •   Surfraw

Registered Linux User #482438

Offline

#12 2018-01-31 23:28:46

Slithery
Forum Moderator
From: Norfolk, UK
Registered: 2013-12-01
Posts: 4,236

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

If you have an 800 series or higher then 3D performance with nouveau will be about 5-10% of what you get with the nvidia driver - if you're lucky.


No, it didn't "fix" anything. It just shifted the brokeness one space to the right. - jasonwryan
Closing -- for deletion; Banning -- for muppetry. - jasonwryan

aur - dotfiles

Offline

#13 2018-01-31 23:39:54

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

slithery wrote:

If you have an 800 series or higher then 3D performance with nouveau will be about 5-10% of what you get with the nvidia driver - if you're lucky.

Thanks for your kind reply and feedback. Appreciated.

Offline

#14 2018-02-01 00:37:21

loqs
Member
Registered: 2014-03-06
Posts: 13,179

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

Or update the nvidia-340xx package locally

diff --git a/trunk/PKGBUILD b/trunk/PKGBUILD
index 8fc9e8c..8233451 100644
--- a/trunk/PKGBUILD
+++ b/trunk/PKGBUILD
@@ -5,12 +5,12 @@
 pkgbase=nvidia-340xx
 pkgname=(nvidia-340xx nvidia-340xx-dkms)
 pkgver=340.106
-_extramodules=extramodules-4.14-ARCH
-pkgrel=3
+_extramodules=extramodules-4.15-ARCH
+pkgrel=4
 pkgdesc="NVIDIA drivers for linux, 340xx legacy branch"
 arch=('x86_64')
 url="http://www.nvidia.com/"
-makedepends=("nvidia-340xx-utils=${pkgver}" 'linux' 'linux-headers>=4.14' 'linux-headers<4.15')
+makedepends=("nvidia-340xx-utils=${pkgver}" 'linux' 'linux-headers>=4.15' 'linux-headers<4.16')
 conflicts=('nvidia')
 license=('custom')
 options=('!strip')

Offline

#15 2018-02-01 00:50:44

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

loqs wrote:

Or update the nvidia-340xx package locally

diff --git a/trunk/PKGBUILD b/trunk/PKGBUILD
index 8fc9e8c..8233451 100644
--- a/trunk/PKGBUILD
+++ b/trunk/PKGBUILD
@@ -5,12 +5,12 @@
 pkgbase=nvidia-340xx
 pkgname=(nvidia-340xx nvidia-340xx-dkms)
 pkgver=340.106
-_extramodules=extramodules-4.14-ARCH
-pkgrel=3
+_extramodules=extramodules-4.15-ARCH
+pkgrel=4
 pkgdesc="NVIDIA drivers for linux, 340xx legacy branch"
 arch=('x86_64')
 url="http://www.nvidia.com/"
-makedepends=("nvidia-340xx-utils=${pkgver}" 'linux' 'linux-headers>=4.14' 'linux-headers<4.15')
+makedepends=("nvidia-340xx-utils=${pkgver}" 'linux' 'linux-headers>=4.15' 'linux-headers<4.16')
 conflicts=('nvidia')
 license=('custom')
 options=('!strip')

It's getting still better! Thanks for the insight wink
PS. May I drop you a PM (email)?

Last edited by erickwill (2018-02-01 00:52:43)

Offline

#16 2018-02-01 00:55:26

progandy
Member
Registered: 2012-05-17
Posts: 4,233

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

@loqs: That is most likely not enough, the mailing list thread mentions a new patch is needed as well, maybe this:
https://devtalk.nvidia.com/default/topi … 9/#5229739


| alias CUTF='LANG=en_XX.UTF-8@POSIX ' |

Offline

#17 2018-02-01 00:58:22

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

progandy wrote:

@loqs: That is most likely not enough, the mailing list thread mentions a new patch is needed as well, maybe this:
https://devtalk.nvidia.com/default/topi … 9/#5229739

It's so exciting to see the solution coming up right in front of my screen! smile Thanks fella for your collaboration.

Offline

#18 2018-02-01 00:59:58

2ManyDogs
Forum Moderator
Registered: 2012-01-15
Posts: 3,575

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

May I ask why you need the 4.15 kernel? I am always curious when people want to use a kernel that causes other problems.

Offline

#19 2018-02-01 01:03:09

erickwill
Member
Registered: 2013-11-05
Posts: 123

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

2ManyDogs wrote:

May I ask why you need the 4.15 kernel? I am always curious when people want to use a kernel that causes other problems.

Well, I think that the bleeding cutting edge is, ALSO, one of the faces of Arch Linux.. so makes sense that as an Arch Linux user, I wish to be at the edge as to the others big_smile

Offline

#20 2018-02-01 01:23:21

loqs
Member
Registered: 2014-03-06
Posts: 13,179

Re: Can't update to kernel 4.15-1 due to nvidia-340xx

@progandy It gained 4.15 compatibility with the update from 104 to 106 it still needs the 4.11 patch as the conftests are not executed fortunately the timer test defaults to being 4.15 compatible.
Edit:
makepkg output too many warnings to post in code but it does build successfully.

Last edited by loqs (2018-02-01 01:28:08)

Offline

Board footer

Powered by FluxBB